wiki:Nl:VersionHistory

Ouder nieuws van JOSM

  • 31-07-2020 (stabiele versie 16812)
  • 02-07-2020 (stabiele versie 16731)
    • Mogelijkheid "Geselecteerde tags herstellen" in venster Geschiedenis (via contextmenu)
    • Links toegevoegd naar taghistory.raifer.tech
    • Actie "Selectie omdraaien" toegevoegd (alleen modus Expert)
  • 02-06-2020 (stabiele versie 16538)
    • Talen Perzisch en IJslands toegevoegd
    • Overgeschakeld naar syntaxis van JOSM in Overpass Query Wizard
    • Verbeterd renderen van cursor op schermen HiDPI
    • Kleurenkiezer toegevoegd aan voorkeuzen, weergeven van de kleur in het dialoogvenster Eigenschappen
    • Spring naar positie: springen naar plaatsnaam toegevoegd
  • 06-04-2020 (stabiele versie 16239)
    • Taal Arabisch toegevoegd
    • Ondersteuning toegevoegd voor Oost-Arabische(-Indic) en Khmer numerieken
  • 26-02-2020 (stabiele versie 15937)
    • Afbeeldingen van Maxar zijn weer beschikbaar
    • Links toegevoegd naar regionale/nationale Taginfo-instanties van Geofabrik - met heel veel dank aan Geofabrik!
    • Autofilters verbeterd
    • De dialoogvensters "Tag toevoegen" en "Waarde wijzigen" geven de gerelateerde pictogrammen voor voorkeuze/kaarttekenstijl weer op de knop OK
  • 01-02-2020 (stabiele versie 15806)
    • Plug-in Tag2Link geïntegreerd in de bron van JOSM en verbeterd
    • Dubbelklikken op schuifbalken voor herstellen doorzichtbaarheid/kleurdiepte/gamma/scherpte
    • Slimmere functie Weg splitsen
  • 02-01-2020 (stabiele versie 15628)
    • Nieuwe link naar nationale instanties van Taginfo beschikbaar
    • Optie om de brontag voor de wijzigingenset automatisch in te vullen in het dialoogvenster Uploaden

2019

  • 02-12-2019 (stabiele versie 15553)
    • Nieuwe taal Marathi
    • Verscheidene verbeteringen voor GPX-lagen
  • 02-11-2019 (stabiele versie 15492)
    • Importeren van GeoJSON toegevoegd
  • 30-09-2019 (stabiele versie 15390)
    • Weergeven van het laagnummer in de Lagenlijst voor gemakkelijker gebruik sneltoetsen lagen
  • 26-08-2019 (stabiele versie 15322)
    • Nieuw logo
    • Tags voor wijzigingensets toevoegen via Afstandsbediening
  • 10-07-2019 (stabiele versie 15238)
    • Lijst met afbeeldingen filteren op naam land
  • 02-06-2019 (stabiele versie 15155)
    • Pictogrammen voor categorieën in de voorkeuren voor afbeeldingen toegevoegd en een val om de lijst te filteren. De categorieën zijn: photo, historicphoto, map, historicmap, osmbasedmap en other.
    • Dynamische items voor afbeeldingen weergeven voor het menu Afbeeldingen in submenu's als zij niet behoren tot de categorie photo.
  • 29-04-2019 (stabiele versie 15031)
    • De plug-in download_along is geïntegreerd in de bron van JOSM, het menuitem "Download along..." verschijnt nu in het menu Bestand.
  • 31-03-2019 (stabiele versie 14945)
  • 02-03-2019 (stabiele versie 14824)
    • Nieuwe taal: Canadees Engels
  • 05-02-2019 (stabiele versie 14760)
    • Onze sponsor van de server is nu FOSSGIS e.V. - Heel veel dank aan Hetzner voor de ondersteuning tot op heden en aan FOSSGIS voor de nieuwe krachtige hardware.

2018

  • 31-12-2018 (stabiele versie 14620)
    • Automatische kolombreedte van de tabel met tags om de inhoud te laten passen
  • 28-11-2018 (stabiele versie 14460)
    • Gegevens downloaden: "Als nieuwe laag downloaden" gewijzigd van keuzevak naar een eigen knop
    • De hoogte van elk venster aan de rechterzijde wordt opgeslagen als JOSM wordt afgesloten
  • 18-11-2018
  • 28-10-2018 (stabiele versie 14382)
    • Optie om in lijsten de versie van het object weer te geven
  • 02-10-2018 (stabiele versie 14289)
    • Verscheidene verbeteringen voor de correlatie van afbeeldingen naar GPX-sporen
  • 22-08-2018 (stabiele versie 14178)
  • 18-08-2018 (stabiele versie 14163)
    • Ondersteuning indeling JSON voor Overpass API
    • Ondersteuning Opmerkingen in bestanden osmChange (.osc) gemaakt door OSMAnd
    • Opties voor conversies van GPX- naar OSM-tags
  • 29-07-2018 (stabiele versie 14066)
    • Ondersteuning voor gegevens van OSM die geschikt voor GDPR zijn
  • 09-07-2018 (stabiele versie 14026)
  • 01-07-2018 (stabiele versie 13996)
  • 31-05-2018 (stabiele versie 13878)
  • 27-05-2018 (stabiele versie 13860)
    • Koreaanse vertaling toegevoegd
    • Belangrijke verbeteringen aan ondersteuning voor WMS/WMTS
  • 07-05-2018 (stabiele versie 13710)
    • 724 nieuwe projecties toegevoegd (JOSM ondersteunt nu in totaal 6135 projecties)
    • Het pictogram source:trunk/resources/images/dialogs/layerlist/offset.svg markeert achtergrondlagen die waren verschoven (uitgelijnd)
    • Dubbelklikken op een element in het venster Uploaden zoomt naar het element
  • 26-03-2018 (stabiele versie 13576)
    • Ondersteuning toegevoegd voor private en vergrendelde OSM gegevenslagen
    • Contextmenu toegevoegd in de tagtabel van het venster Geschiedenis
    • Ondersteuning toegevoegd voor vertalingen met .lang-bestanden voor externe gegevens (kaarttekenstijlen, regels, voorkeuzen)
  • 04-03-2018 (stabiele versie 13500)
  • 01-03-2018 (stabiele versie 13478)
  • 28-01-2018 (stabiele versie 13367)
    • Ondersteuning toegevoegd voor gecomprimeerde XZ-bestanden
    • Betere ondersteuning voor WMS 1.3.0

2017

  • 31-12-2017 (stabiele versie 13265)
    • Contextmenu items om een routerelatie te exporteren naar een GPX-bestand en te converteren naar een nieuwe GPX-laag
    • Contextmenu items "Status tegel ophalen" (/status) en "Renderen van tegel forceren" (/dirty) voor tegels vanaf *.tile.openstreetmap.org (alleen modus Expert)
  • 26-11-2017 (stabiele versie 13170)
    • Tekst van opmerkingen is nu te selecteren en te kopiëren; links zijn nu aan te klikken
    • Mogelijkheid voor uploaden van gegevens in de achtergrond
    • Niet alle tekens uit een tekstvak selecteren bij schakelen tussen JOSM en een andere toepassing
  • 29-10-2017 (stabiele versie 13053)
    • Al gedownloade gebieden worden weergegeven in het venster Downloaden en in de minikaart en de knop voor het sluiten van de laag werd verbeterd
    • Nieuwe knop in de Relatiebewerker die de relatie zelf selecteert
  • 06-10-2017 (laatste versie 12926)
    • JOSM gebruikt nu een nieuw certificaat voor het ondertekenen van code, gesponsord door FOSSGIS e.V. (vereist voor WebStart)
  • 03-10-2017 (stabiele versie 12921)
    • Links toegevoegd naar externe viewers voor wijzigingensets aan de vensters Geschiedenis en Beheer wijzigingenset
    • Keuzevak voor verzoeken om terugkoppeling toegevoegd aan het venster Uploaden
    • De functie Cirkels maken gebruikt automatisch een juiste telling voor de knopen, afhankelijk van de diameter van de cirkel
    • Nieuwe parameters voor de opdrachtregel om bepaalde taken zonder grafische gebruikersinterface uit te voeren:
      • Renderen van gegevens van OSM met behulp van een stijl van MapCSS
      • Coördinaten converteren van de ene projectie naar een andere
  • 02-09-2017 (stabiele versie 12712)
  • 30-07-2017 (stabiele versie 12542)
    • Zoeken op voorkeuze in het venster Zoeken.
    • Nieuwe bladwijzer "home location" (indien ingesteld in de gebruikersinstellingen van OSM) en bladwijzers voor de laatste 15 wijzigingensets.
  • 02-07-2017 (stabiele versie 12450)
  • 29-05-2017 (stabiele versie 12275)
  • 02-05-2017 (stabiele versie 12039)
    • Opnieuw projecteren (warping) van afbeeldingslagen: maakt het mogelijk bronnen van verschillende projecties te combineren.
  • 02-04-2017 (stabiele versie 11826)
    • Volledig voorkomen van uploaden van een laag met "upload=never" in het bestand van OSM
    • Een optie werd toegevoegd om niet te zoomen naar de nieuw gedownloade gegevens. (alleen in modus Expert)
  • 27-02-2017 (stabiele versie 11639)
    • De modus GPS HeatMap heeft nu enkele instellingen om zijn uiterlijk aan te passen.
    • Mirrorservers voor afbeeldingen kunnen nu worden geselecteerd in de voorkeuren voor de afbeeldingen.
  • 02-02-2017 (stabiele versie 11526)
    • GPS-sporen kunnen nu worden weergegeven in de nieuwe modus Heatmap.

2016

  • 31-12-2016 (stabiele versie 11427)
    • Interne database met grenzen van alle landen. Enkele regels voor validatie en kaarttekenstijlen kunnen nu bijv. worden begrensd tot een specifiek land.
    • Een door het dialoogvenster Locatie openen ondersteunde URL neerzetten of plakken zal een download activeren voor de gegevens die die URL vertegenwoordigt.
    • Dialoogvenster Tags toegevoegd: vooraf ingevulde tekstvakken voor sleutel en waarden met tweede tag van de lijst eronder als de eerste sleutel al is gebruikt
  • 06-11-2016 (stabiele versie 11223)
  • 05-09-2016 (stabiele versie 10966)
  • 12-08-2016 (stabiele versie 10786)
  • 12-07-2016 (stabiele versie 10526)
    • Bron van JOSM in grote mate bijgewerkt
  • 28-04-2016 (stabiele versie 10161)
    • Nieuwe laagfilters (transparantie/volheid van kleur/gamma/scherpte)
  • 13-03-2016 (stabiele versie 9979)
    • OAuth is nu de standaard methode voor autorisatie.
    • Ondersteuning voor slepen & neerzetten voor de relatiebewerker (meer info)
    • Nieuwe knop in relatiebewerker om de relatie te vernieuwen (bijv. na splitsen van een weg)
    • Het dialoogvenster Geschiedenis geeft de oude en nieuwe coördinaten van een verplaatste knoop weer op de kaart
    • Automatisch vastzetten van zoom op de standaard resolutie van de achtergrond
    • Uitgebreide ondersteuning van verschillende projecties

2015

  • 31-12-2015 (stabiele versie 9229)
    • Gebieden worden alleen gevuld rondom hun binnenste randen. Dit en andere instellingen zijn aan te passen bij de instellingen voor Stijl van de standaard kaarttekenstijl voor JOSM. Meer info over instellingen voor Stijl
  • 23-11-2015 (stabiele versie 9060)
    • Ondersteuning voor taal Noors Bokmål
  • 30-10-2015 (stabiele versie 8969)
    • Weg splitsen: opnieuw gebruiken van ID/geschiedenis van bestaande weg voor langste segment om te splitsen (gebruikers Expert kunnen een ander segment kiezen)
    • Weergaven van pictogrammen voor kaartweergave ook in lijsten (bijv. in dialoogvenster Selectie, Relatiebewerker of dialoogvenster Uploaden)
  • 28-09-2015 (stabiele versie 8800)
    • Integratie van downloaden vanaf Overpass en Overpass Turbo Wizard (alleen in modus Expert)
    • Minikaart toegevoegd
    • Link naar Taginfo toegevoegd
    • Gamma-waarde voor achtergrondafbeeldingen kan worden geselecteerd
  • 2015-08-22 (stabiele versie 8677)
  • 2015-06-17 (stabiele versie 8491)
    • Ondersteuning voor Wit-Russische taal
    • Ondersteuning voor Vietnamese taal
  • 2015-04-18 (8227)
    • Ondersteuning voor de Valenciaanse taal
  • 2015-03-31 (8160)
    • Ondersteuning voor Litouwse taal
  • 2015-03-02 (8109)
    • Meer lettertypen om meer talen te ondersteunen op Windows
    • Sommige plug-ins kunnen nu worden geïnstalleerd en gebruikt zonder JOSM opnieuw op te starten.
    • Nieuw zoekvak voor hoofdmenu (rechtsboven)
    • De bronondersteuning voor Opmerkingen is nu standaard ingeschakeld (de plug-in is vervallen).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Twee nieuwe talen: Asturiaans en Khmer.
    • Voorkeuren, gebruikersgegevens en mappen voor cache gewijzigd voor OS X en Windows.
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
    • Belangrijke problemen opgelost in sneltoetsen voor toetsenbord en afhandelen van conflicten in Wegen combineren.
  • 2014-09-30 (7588)
    • Betere integratie in OS X (bekijk #10455 voor de details).
    • Weergave van tags van OSM in voorkeuze UI.
  • 2014-09-20 (7569)
    • JOSM geeft nu waarschuwingen voor multipolygonen oude stijl die kunnen worden opgelost door de relevante tags van buitenste wegen te verplaatsen naar de relatie.
  • 2014-08-31 (7480)
    • Verbeteringen van standaard kaartstijl:
      • Symbolen voor knopen en pictogrammen worden verborgen bij laag inzoomen (dit kan worden geconfigureerd in de instellingen voor stijl).
      • Betere plaatsing label binnen gebieden
      • Naam van een snelweg wordt langs de weg weergegeven
    • Modus Offline met nieuw argument opdrachtregel argument --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • We houden tot 30 september een wedstrijd voor grafische afbeeldingen om een nieuw logo te krijgen! Bekijk wiki voor details.
  • 2014-07-04 (7287)
    • Nieuwe duale modus uitlijnen voor de actie Extrude
    • Automatisch opnieuw laden van lokale kaarttekenstijlen en regels voor Validator
    • Automatisch bijwerken van items van afbeeldingen
  • 2014-05-18 (7139)
    • JOSM's standaard kaarttekenstijl is geconverteerd van XML naar MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Overgegaan naar Java versie 7, veel code opgeruimd
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • HTTPS-toegang tot OSM API toegestaan
  • 2014-01-29 (6767)
    • Nieuwe, op MapCSS-gebaseerde, tagcontrole, uit te breiden via aangepaste regels
    • Toegevoegde actie "Zoeken naar objecten op voorkeuze" Shift-F3
    • Verbeteringen in Voorkeuzen/MapCSS/Validator

2013

  • 2013-12-20 (6502)
    • Vragen naar tag source voor wijzigingenset in dialoogvenster Uploaden
    • Dialoogvenster Historie: opmerking wijzigingenset laden en weergeven
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg Nauwkeurigheid weg verbeteren ingeschakeld voor normale gebruikers
    • Vele andere verbeteringen en oplossingen van problemen (changelog)
  • 2013-11-17 (6388)
    • Bijgewerkte taalbestanden
  • 2013-11-12 (6383)
    • Nieuwe opdracht om knoop van weg te ontkoppelen
    • Notificatie van nieuw ontvangen berichten van OSM
    • Vele kleine verbeteringen van voorkeuren. stijlen en validator plus andere gedeelten
  • 2013-09-20 (6238)
    • Nieuwe niet opdringerige berichten voor notificaties
    • Nieuw item "Sessie" zichtbaar in menu Bestand in modus Expert
    • Volledige ondersteuning voor GPX-routes
    • Vele kleine verbeteringen voor voorkeuren, opnieuw starten, stijlen en Validator plus verbeteringen voor de uitvoering
  • 2013-08-07 (6115)
    • Verzoek toestemming van OAuth om de nieuwe plug-in voor notities volledig te ondersteunen
    • Opnieuw inrichten van het menu Invoegtoepassingen voor beter groeperen en integratie
    • Voorkeur voor de kind-knoop van de (laatste) geselecteerde objecten bij het selecteren van knopen met duplicaten
    • Vele andere verbeteringen en oplossingen van problemen (changelog)
  • 2013-07-09 (6060)
    • Accentueren geselecteeerde relaties en objecten in schakelvenster relatie, selectie of eigenschappen
    • modus Gebieden maken door te verlengen: Aanpassingstoets Ctrl geïntroduceerd voor "slepen van knopen langs segmenten" (eerdere instelling kan hersteld worden onder Uitgebreide voorkeuren)
    • Downloaden van GPX-gegevens langs een spoor, instellen van profielen voor sneltoetsen etc. (Uitgebreide voorkeuren - Meer) en vele kleine verbeteringen
  • 2013-06-05 (5990)
    • mogelijkheid om sneltoetsen in te stellen voor voorkeuren en andere knoppen op werkbalken plus nieuw item voor contextmenu "Sneltoets bewerken" om ze te definiëren
    • automatisch in-/uitzoomen voor WMS-lagen
    • nieuwe actie "Schakel panelen" met TAB om dialoogvensters te verbergen/weer te geven
  • 2013-05-08 (5939)
    • integreren van de invoegtoepassing om opnieuw te starten in de bron
    • menu rechtsklikken "ongedaan maken, knippen, kopiëren, plakken, verwijderen, alles selecteren" voor elke tekstcomponent
    • verbeterde uitvoering van opdracht Afvoeren
  • 2013-04-08 (5836)
    • belangrijke vernieuwingen in contextmenu's
    • plakken van tags vanuit tekst: knop "Clear buffer" toegevoegd aan de berichten die worden weergegeven bij een onjuiste buffer
    • verwijderen van [vervallen] ondersteuning voor server van verschuiving voor afbeeldingen
  • 2013-03-07 (5759)
    • Ctrl-Shift-V kan nu tags vanuit de tekstbuffer plakken, bijv. a=2,c=3 en a 2 c 3
    • meerdere verbeteringen in renderen van MapCSS
    • slepen van knopen in modus Extrude toegestaan
    • contextmenu's in dialoogvenster voor eigenschappen Toevoegen/bewerken, optie om weergave van toetsenbord te repareren
    • basaal filteren van datum van GPS-sporen
    • afstandsbediening: toestaan van verwijderen van tags en het maken van objecten met tags
    • vele kleine verbeteringen en reparaties van problemen
  • 2013-02-06 (5697)
    • rollen worden als suggestie gegeven in de Relatiebewerker en bij het maken van een nieuwe relatie
    • mogelijkheid om te filteren in het schakelvenster van de relatielijst
    • verschillende verbeteringen van het dialoogvenster "Waarde toevoegen", inclusief een knop Help, onthouden van de positie en de mogelijkheid om verschillende in een rij toe te voegen zonder het dialoogvenster te sluiten
    • nieuw item afbeeldingen wms_endpoint en opnieuw bewerken van dialoogvenster WMS/TMS
    • nieuwe test voor validatie van adressen en tags van wikipedia en verbeterde uitvoering in de tekenlaag en repareren van fouten
    • vele kleine verbeteringen

2012

  • 2012-12-08 (5608)
    • nieuwe operatoren nth: en nth% maken het mogelijk te zoeken naar positie in wegen
    • enkele kleine verbeteringen in afstandsbediening en interne voorkeuren
  • 2012-11-10 (5576)
    • "nautische mijl" (NM) wordt ondersteund als maateenheid
  • 2012-10-08 (5531)
    • bijwerken van het bouwen van de test voor de validator
    • nog wat meer tags worden automatisch genegeerd bij het uploaden (TIGER, odbl, yh)
    • code met betrekking tot de wijziging van de licentie werd verwijderd
  • 2012-08-29 (5482, 5485)
    • leveranciers van luchtfoto's worden, overeenkomstig de gedownloade regio, voorgesteld
    • bij het toevoegen van tags aan knopen, wegen of relaties, worden de laatste vijf gebruikte tags weergegeven om sneller te kunnen selecteren
    • het programma voor filteren heeft beter ondersteuning voor multipolygonen
    • U kunt niet langer een map openen in het dialoogvenster 'Bestand > Openen...' en alle daarin opgenomen foto's automatisch laden. Selecteer, in plaats daarvan, direct de afbeeldingsbestanden (met behulp van Ctrl-A of Shift-klik). Het programma 'Afbeeldingen importeren' uit het contextmenu van een GPX-laag werkt nog steeds op de oude manier, dus kunt u recursief foto's laden door een map op een hoger niveau te laden.
  • 2012-07-23 (5353, 5356)
    • Belangrijke bugs opgelost in de afhandeling van gegevens die zijn gewijzigd door de bot voor het wijzigen van de Licentie
    • Kleine verbeteringen in kaarttekenstijlen en validatortests, inclusief de rendering van inactieve lagen en het weergeven van namen in het Validator-dialoogvenster.
  • 2012-07-03 (5315)
    • Belangrijke bugs opgelost in validator, conflictdialoog en bij samenvoegen van lagen
    • Diverse verbeteringen in de conflict dialoog, inclusief optie om te selecteren (dubbelklik) en zoomen op objecten (context menu)
    • Diverse verbeteringen in validator-tests
  • 2012-06-04 (5267)
    • Nieuwe talen: Portugees (Europees) (pt), Catalaans (ca)
    • Ondersteuning voor aangepaste projecties
    • Tags verplaatsen naar relatie bij het maken van een multipolygoon
  • 2012-05-02 (5210)
    • Enkele kleine verbeteringen
      • maak het alternatieve zoekvenster de standaard
      • argument voor de opdrachtregel --load-preferences= om instellingen toe te passen bij het starten van JOSM
      • Sta MapCSS toe om de zijkanten links en rechts verschillend op te maken
  • 2012-04-14 (5181)
    • De startpagina josm.openstreetmap.de is vereenvoudigd en gereorganiseerd
    • Een testversie (5181) is uitgegeven met vele wijzigingen/verbeteringen, deze omvatten onder meer
      • source:trunk/resources/images/mapmode/rope.svg lasso selectiemodus (modus Expert)
      • informatie-dialoogvensters voor beginners: waarschuwing tegen verschoven luchtfoto's, bij het combineren van wegen met conflicterende tags of wegen die deel uitmaken van relaties
      • nieuwe mogelijkheden voor het bewerken van relaties: "Voeg selectie toe aan relatie" (bij klikken met rechts op een relatie), "Selecteer vorig/volgend gat" (in relatiebewerker)
      • verbeteringen in de gebruikersinterface in menu Beeld: "Kaarttekenstijlen", mogelijkheid om de werkbalk Bewerken te verbergen
      • diverse verbeteringen om sneller op te starten
  • 2012-02-07 (4905)
    • Sneltoetsen voor de Relatie-bewerker zijn toegevoegd: Alt-Up, Alt-Down (verplaats geselecteerd lid naar boven/beneden), Alt-Del (verwijder lid) en Alt-Home (download incomplete leden)
    • Een opsomming van het log met wijzigingen, dat de relevante wijzigingen tussen de uitgaven bevat, is beschikbaar.
  • 2012-02-02 (4897 ...)
    • Conflicterende sneltoetsen in JOSM en invoegtoepassingen worden gerepareerd. Veel sneltoetsen voor functies zullen wijzigen!
  • 2012-01-22 (4846)
    • De invoegtoepassing ImproveWayAccuracy is toegevoegd aan de kern. Selecteer een weg, klik op source:trunk/resources/images/mapmode/improvewayaccuracy.svg, en verbeter de nauwkeurigheid ervan. Bekijk de hulppagina voor gedetailleerd gebruik.
  • 2012-01-21 (4791, 4796, 4833)
    • Verschillende uitbreidingen voor de mogelijkheid Afstandsbediening: nieuwe opdracht '/load_object' om objecten per id te downloaden; opdracht '/add_way' om een nieuwe weg te maken met bepaalde coördinaten; parameter 'new_layer' voor de opdracht '/load_and_zoom' om de gegevens in een nieuwe laag te laden.
  • 2012-01-12 (4789)
    • Nieuwe optie voor de opdrachtregel om een willekeurige voorkeurswaarde bij het opstarten in te stellen. (bijv. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Accentueren voor knopen en wegen onder de muiscursor kan worden uitgeschakeld: 'Voorkeuren' > 'Beeldscherminstellingen' > 'OSM-gegevens' (Alleen in Modus Expert)
    • De actie Tekening source:trunk/resources/images/mapmode/node/autonode.svg maakt het mogelijk om segmenten te tekenen met discrete hoeken (bijv. 30/45°). Druk op de toets Tab om door de verschillende modi te gaan.
  • 2012-01-04 (4765)
    • Het automatisch verbergen van knoppen voor de dialoogvensters aan de rechterkant kan worden uitgeschakeld voor elk individueel venster. (Symbool Oog in de rechter bovenhoek)

2011

  • 2011-12-29 (4745)
    • Nieuwe opdracht om WMS achtergrondafbeeldingen langs een gpx-track op voorhand te laden en te cachen. (In menu met rechts klikken van GPX-Layer)
  • 2011-12-20 (4673)
    • Projectie Lambert 93 (EPSG:2154) is beschikbaar voor Frankrijk.
  • 2011-12-20 (4670)
    • De talen Arabisch, IJslands en Hebreeuws zijn verwijderd omdat te veel vertaalde bijdragen ontbreken.
  • 2011-12-05 (4621-4636)
    • Uitvoering met grote multipolygonen verbeterd.
  • 2011-11-26 (4609, 4611)
    • De knoppen van de werkbalk Bewerken (gebied linksboven) kunnen worden verborgen.
    • Bij het tekenen van wegen maakt de toets Backspace de laatste actie ongedaan.
  • 2011-11-20 (4601)
    • De versiegeschiedenis geeft nu de licentiestatus weer voor elke deelnemende gebruiker.
  • 2011-11-15 (4595)
    • Ondersteuning voor sneltoetsen die bestaan uit meerdere delen. Bijvoorbeeld: Ctrl+Alt+S, 1 schakelt met de zichtbaarheid van de eerste laag.
  • 2011-11-14 (4593)
    • Op kleine schermen worden lange menu's niet langer afgebroken, maar kan er in worden gescrold, naar boven en beneden.
  • 2011-11-07 (4587)
    • Nieuwe optie in het zoekvenster om een knop van een werkbalk toe te voegen aan de zoekactie. De knop kan later worden verwijderd met het contextmenu (rechts klikken) van de knop. (Alleen in Expertmodus.)
  • 2011-11-02 (4558)
    • Het gereedschap Knopen uitlijnen werkt met een selectie van één enkele wegknoop.
  • 2011-10-31 (4553)
    • De interne indeling voor het opslaan van de gegevens van de voorkeuren van de gebruiker is gewijzigd naar XML.
  • 2011-10-29 (4546)
    • De tekstweergave van knopen, wegen en relaties kan worden aangepast met naam sjabloon.
  • 2011-10-20 (4530)
    • De indeling OsmChange (*.osc) wordt nu officieel ondersteund.
  • 2011-10-10 (4512)
    • De Expertmodus is geïntroduceerd om het voor beginnende gebruikers gemakkelijker te maken. Om compatibiliteitsredenen worden al bestaande JOSM-installaties standaard op expert ingesteld.
  • 2011-10-07 (4497, 4498, 4500)
    • Meer opties in het 'Bestand > Object downloaden'-dialoogvenster.
    • Geschiedenisdialoogvenster: toegevoegde en verwijderde wegknopen (en leden van relaties) worden beter weergegeven.
    • Nieuwe snelkoppelingen in het eigenschappendialoogvenster: Alt+A, Alt+S en Alt+D staan voor toevoegen, bewerken en verwijderen.
  • 2011-09-23 (4454)
    • Kopieer sleutel en waarde naar het klembord door rechts te klikken in het eigenschappenvenster.
  • 2011-09-12 (4416, 4423)
    • De grenzen voor afbeeldingsservices worden weergegeven op een voorbeeldkaart in 'Voorkeuren > Afbeeldingen'.
  • 2011-09-08 (4408)
    • Het menuelement 'Inspecteren' in het contextmenu van het selectievenster is verplaatst naar 'Beeld > Advanced Info'.
  • 2011-09-07 (4405)
    • De lijst in 'Voorkeuren > Afbeeldingen' wordt gesorteerd op landcode.
  • 2011-08-29 (4380)
    • Nieuwe functie 'Bewerken > Coördinaten kopiëren'.
  • 2011-08-28 (4371)
    • De lijst van recent geopende bestanden toont niet alleen geopende, maar ook opgeslagen bestanden.
  • 2011-08-27 (4355)
    • Dynamische zichtbaarheid van de knoppenrij in de dialogen rechts (optioneel, zet in de geavanceerde voorkeuren 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Sneltoetsen om de zichtbaarheid van een laag aan- of uit te zetten (Alt-1 tot Alt-9)
  • 2011-08-21 (4332)
    • Selectie van zichtbare tracks, voor iedere GPX-laag (gebruik het contextmenu van de laag)
  • 2011-08-21 (4327)
    • Modi selecteren en verwijderen hebben nu een betere visuele indicatie over wat de volgende actie zal doen (accentueren, wijzigen van cursor).
  • 2011-07-18 (4256)
    • Ondersteuning voor het afbeeldingsformaat SVG.
  • 2011-07-14 (4241)
    • Houdt rekening met Orientation in de kop EXIF van JPEG-afbeeldingen.
  • 2011-07-07 (4207)
    • GPStraces kunnen afhankelijk van de richting worden gekleurd.
  • 2011-06-18 (4142)
    • Extrude Modus: Een dubbele klik op een lijnsegment voegt een nieuw punt in.
  • 2011-06-11 (4126, 4129, 4134)
    • Geheugenoptimalisaties en snellere GPS-tracks-tekening
    • Nieuwe tekenmodus: Voeg een parallelle weg naast een bestaande toe. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • Nieuwe Lijnvolg functie om het tekenen van aanliggende vlakken te vergemakkelijken. (vergelijkbaar met sneltoets "F" in Potlatch 2)
    • Zoek (en Filter) kan nu gesloten wegen opvragen en kan daarbij beperken tot een bepaalde minimum en maximum oppervlakte. (Sleutelwoorden: closed; areasize:MIN-MAX of areasize:MAX, in m²)
    • De download Object... functie accepteert nu id-lijsten.
  • 2011-04-18 (4032)
    • Voeg meerdere aangepaste zoekopdrachten of achtergrondlagen toe aan de werkbalk met hun eigen symbool.
    • Herlicensiëringsstatus wordt weer in de gebruikerslijst weergegeven (groen V'tje - ingestemd, grijs V'tje - automatisch ingestemd, rood V'tje - afgewezen).
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Nieuwe Kijkvenster Volgen functie - verplaatst het kijkvenster zodat de laatst geplaatste knoop gecentreerd blijft. (Hoofdmenu > Beeld; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • De imagery,wms,slippymap en remotecontrol Plugins zijn geïntegreerd in de JOSM-kernel.
  • 2010-12-07 (3705)
    • Lagen kunnen nu transparant weergegeven worden. (nieuwe knop in Lagenpaneel)
  • 2010-12-07 (3702)
    • Het schalen van objecten wordt ondersteund. (Ctrl+Alt in selecteermodus)
    • info Om een object te draaien kan Ctrl+Shift gebruikt worden.
  • 2010-11-25 (3669)
    • De Validator-plugin is geïntegreerd in het hoofdprogramma.
  • 2010-09-23 (3557, #5427)
    • Wijziging in de “Gebieden aanmaken”-modus (X): Wanneer men meerdere keren in dezelfde richting beweegt, blijven er geen overbodige knopen bestaan. (Shift-toets forceert het oude gedrag.)
  • 2010-09-14 (3529)
    • Bij de tags in het eigenschappenpaneel kunt u nu direct doorklikken naar de bijbehorende wiki-pagina in een webbrowser.
  • 2010-09-03 (o22964)
    • De WMS-plugin ondersteunt nu GetCapabilities-verzoeken.
  • 2010-08-13 (3431)
    • Het nieuwe Purge commando kan gegevenslagen opschonen.
  • 2010-07-27 (3388)
    • Nieuwe zoekfunctie voor voorkeuzes.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Zoekfunctie ondersteunt zoeken naar rol in relaties.
    • Het eigenschappenvenster geeft positie van relatielidmaatschap weer.
  • 2010-06-01 (3291)
    • Rollen gedefiniëerd in voorkeuzes zijn nu in gebruik. Dit leiden tot onverwachte validator waarschuwingen voor onbekende relaties.
    • Leden van geselecteerde relaties worden in een andere kleur weergegeven dan direct geselecteerde elementen.
  • 2010-04-16 (3189)
    • Met de nieuwe Filterfunctie kunt u bepaalde objecten tijdelijk verbergen.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
  • 2010-01-28 (2901)
    • Nieuw: Maak een duplicaat van de geselecteerde gegevenslaag zonder een bestandsassociatie.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Opmerking voor voormalige gebruikers van AgPifoJ: U kunt nu afbeeldingen openen vanuit het hoofdmenu (Bestand > Openen...) of vanuit het rechtsklik-menu van de corresponderende GPX-laag.
  • 2009-12-27 (2689)
    • Nieuw Changeset Manager om queries te maken, te downloaden, te bladeren en wijzingingensets te beheren.
  • 2009-12-12 (2616)
    • Nieuw Changeset List Dialog geeft informatie weer over wijzigingensets. Wijzigingensets kunnen worden gedownload, gesloten en weergegeven.
  • 2009-12-05 (2575)
    • De plugins utilsplugin en AgPifoJ zijn geïntegreerd in de basis van JOSM.
  • 2009-11-24 (2513)
    • Projecties ondersteunen parameters en geven projectiecode en wereldgrenzen weer voor de gebruiker.
  • 2009-10-25 (2313)
    • Weergave van de gekoppelde status in de relatiebewerker is nu grafisch en beter te begrijpen.
    • Gebiedsnamen worden nu ook weergegeven (in lichtgrijs) als zij in het gebied passen.
  • 2009-09-16 (2147)
    • Het plug-invenster in voorkeuren heeft nu een zoekfunctie. U kunt zoeken in namen van plug-ins, omschrijvingen en versies door met spaties gescheiden zoektermen op te geven in elke willekeurige volgorde.
  • 2009-09-14 (2133)
    • Veel sneltoetsen zijn toegevoegd aan het vooraf ingestelde menu Voorkeuze op de werkbalk.
  • 2009-09-13 (2124)
    • JOSM ondersteunt nu het tegelijkertijd op de server openhouden van meerdere wijzigingensets. Indien u iets wilt wijzigen dat u opmerkt bij het maken van een niet-gerelateerde wijziging kunt u nu die wijziging correct taggen.
  • 2009-09-13 (2118)
    • Het menu Voorkeuze heeft nu minder niveaus op het bovenste niveau in plaats van de vorige lange lijst. Dat zou moeten helpen met het gebruiken van JOSM op smallere schermen en makkelijker zoeken.
  • 2009-09-12 (2109)
    • Nieuwe klik met middelste knop maakt het mogelijk om de selectie te schakelen tussen elementen onder de cursor. Dit maakt het selecteren van overlappende elementen veel eenvoudiger.
  • 2009-09-02 (2026)
    • Indien in modus Verwijderen zal de muisaanwijzer wijzigen afhankelijk van het type object dat moet worden verwijderd.
  • 2009-07-15 (1790)
    • Compleet opnieuw bewerkte relatiebewerker.
  • 2009-07-11 (1767)
    • Plug-ins voor JOSM ondersteunt nu verschillende versies (ten minste de in SVN beheerde plug-ins). Bijwerken van de plug-in veroorzaakt niet langer het verstoren van het werken van de plug-in.
  • 2009-07-07 (1743)
    • JOSM heeft nu eenvoudig te gebruiken ondersteuning voor externe voorkeuzes en tekenopmaakprofielen. Bekijk de Presets- en Styles-pagina's eens.
  • 2009-06-28 (1709)
    • Ondersteuning voor geschiedenis van elementen weergegeven binnen JOSM.
  • 2009-06-07 (1652)
    • Nieuw dialoogvenster om conflicten op te lossen (indien gewijzigde objecten ergens anders zijn aangepast).
  • 2009-05-30 (1628)
    • Instellingen wordne nu opgeslagen in UTF-8. Gebruikers met een niet-Latijnse GUI moeten misschien hun eigen teksten repareren of hun configuratie opnieuw instellen.
  • 2009-05-19 (1605)
    • JOSM's standaard projectie is nu Mercator in plaats van EPSG:4326 wat daarvoor de standaard was.
  • 2009-05-19 (1603)
    • Nieuwe parent en child zoekoperatoren maken het mogelijk om te zoeken naar parent- en childobjecten van die objecten doe overeenkomen met een opgegeven zoekactie.
  • 2009-02-14 (1405)
    • Veel verbeteringen in modus Tekenen (dubbelklikken beëindigt tekenen). Ook het schakelen naar de stijl Alles-In-Eén-Potlatch is mogelijk in de voorkeuren.
  • 2009-01-31 (1358)
    • Beperkingen voor omkeren worden op de kaart weergegeven, een asterisk naast de relatie geeft een probleem aan
    • Eerste stap van voorkeuze voor relaties is geïmplementeerd
  • 2009-01-10 (1231)
    • Bestanden kunnen nu ook worden geopend door op het venster van JOSM neer te zetten (Drag-n-Drop).
  • 2009-01-08 (1213)
    • De zoekfunctie ondersteunt nu zoeken met behulp van reguliere uitdrukkingen.
  • 2009-01-03 (1208)
    • Het weergeven van namen van knopen op de kaart is verbeterd. Indien er geen naam voor een knoop is opgegeven, wordt een ref, operator of brand in plaats daarvan weergegeven. Namen voor onbekende items (zonder pictogram) worden nu ook weergegeven.
  • 2009-01-02 (1203)
    • Renderen van multipolygone relaties wordt nu ondersteund. De optie "mappaint.multipolygon=true" moet zijn ingesteld om dat te kunnen doen (zal later de standaard zijn). Als er een * voor de naam van de relatie staat, dan vond JOSM een fout. Gebruik de huidige plug-in Validator om die fout weer te geven.

2008

  • 2008-12-25 (1180)
    • Deze uitgave verwijdert veel overbodige ballast uit JOSM. Oude plug-ins zullen zeer waarschijnlijk niet meer werken. Werk alles bij.
  • 2008-11-28 (1078)
    • Indien u de optie "display boundaries of downloaded data" hebt ingeschakeld (en u tot nu gele rechthoeken voor elke download zag), zult u nu het niet gedownloade gebied gearceerd en het gedownloade gebied helder weergegeven. Dit zou een betere ervaring voor het bewerken moeten geven omdat het eigenlijke gebied om te bewerken niet is voorzien van gele kris-krasstrepen.
  • 2008-11-14 (1076)
    • De functie "align nodes in rectangle" is vervangen door een meer algemene functie die het u mogelijk maakt om een vorm of lijn loodrecht te zetten die al "bijna" rechthoekig zijn.
  • 2008-10-29 (1058)
    • Vertalingen van JOSM zijn opnieuw gestructureerd. Taalplug-ins zijn nu overbodig en vertalingen zijn gebundeld met JOSM. De taa wordt bepaald door de standaard systeemlocale of de parameter --language.
  • 2008-10-05 (1023)
    • WAARSCHUWING: JOSM ondersteunt nu configuratie van het toetsenbord. Echter, sommige van de standaarden zijn gewijzigd. Controleer (en configureer) de sneltoetsen voor het toetsenbord zorgvuldig om onverwacht en onbedoeld verlies van uw werk te voorkomen.
  • 2008-08-24 (858)
    • De actie "losmaken" is geïntegreerd. De plug-in UnGlue is niet langer vereist.
  • 2008-08-19 (805)
    • Deze versie heeft een nieuwe modus Tekenen. Kleine kruisjes worden op het midden van de weg weergegeven bij het gebruiken van het gereedschap Selectie. Als op deze kruisjes wordt geklikt, worden zijn echte knopen. Dit reduceert de wijzigingen van de modus behoorlijk. Indien niet gewenst, schakel de virtuele knopen uit in voorkeuren.
  • 2008-05-20 (643)
    • Deze versie heeft een kleine wijzigingen de modus Knopen tekenen: SHIFT+CLICK selecteert nu altijd een knoop als men er boven staat (eerder selecteerde het de knoop als er al niets anders was geselecteerd). Dit is meer consistent en reduceert het aantal keren dat u moet schakelen naar de modus Selectie.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Een elastieken hulplijn verbindt het laatste punt met het vermoedelijke volgende punt. Zet de voorkeur "draw.helper-line" op "false" om deze mogelijkheid uit te schakelen.
  • 2008-05-08 (608)
    • Statusbalk geeft informatie over positie, hoek en lengte van het lijnsegment dat zal worden toegevoegd.
  • 2008-05-08 (547)
    • Is nu inclusief ingebouwde ondersteuning voor Kaarten met geluid met doorlopend opgenomen geluiden

Last modified 8 years ago Last modified on 2013-06-25T23:19:20+02:00