wiki:Uk:VersionHistory

Архів новин JOSM

  • 31.12.2017 (стабільна версія 13265)
  • 26.11.2017 (стабільна версія 13170)
    • Текст нотаток тепер можна виділяти та копіювати; можна також переходити за посиланнями
    • Можливість надсилання даних на сервер у фоновому режимі
    • Більше не виділяється текст у текстовому полі під час переходу між JOSM та іншим застосунком
  • 29.10.2017 (стабільна версія 13053)
    • У вікні завантаження та на міні-мапі показуються вже заватажені ділянки. Покращено функціонування кнопки вибору шару у вікні завантаження даних
    • Нова кнопка в Редакторі зв'язків, що виділяє сам зв'язок
  • 06.10.2017 (остання версія 12926])
    • Тепер JOSM використовує нових сертіфікат для підписування коду, отриманий за підтримки FOSSGIS e.V. (потрібен для WebStart)
  • 03.10.2017 (стабільна версія 12921)
    • Додано посилання на зовнішні інструменти перегляду наборів змін у вікні Історії та Менеджері наборів змін
    • Додано прапорець на запит перевірки змін у вікні надсилання даних на сервер
    • Функція додавання кіл автоматично обирає оптимальну кількість точок в залежності від діаметра кола
    • Нові параметри командного рядка для виконання деяких завдань без графічного інтерфейса
    • Рендерінг даних OSM з використанням стилів MapCSS
    • Перетворення координат з однієї проекції в іншу
  • 02.09.2017 (стабільна версія 12712)
  • 30.07.2017 (стабільна версія 12542)
    • Пошук по заготовках у вікні пошуку.
    • Нова закладка "Домівка" (якщо цей параметр встановлено в налаштуванях користувача в OSM) та заклдаки для 15-и останіх наборів змін.
  • 02.07.2017 (стабільна версія 12450)
  • 29.05.2017 (стабільна версія 12275)
  • 02.05.2017 (стабільна версія 12039)
    • Перепроеціювання (деформування) фонових шарів: дозволяє поєднувати джерела фонових зображень з різними проекціями.
  • 02.04.2017 (стабільна версія 11826)
    • Запобігання надсиланню на сервер шару, який містить "upload=never" в файлі даних osm
    • Додано параметр, який дозволяє не масштабуватись до нових завантажених даних. (тільки в експертному режимі)
  • 27.02.2017 (стабільна версія 11639)
    • Тепер в режимі Теплової мапи для GPS-треків є кілька варіантів для їх показу.
    • В Налаштуваннях фону можна обрати сервер-дзеркало для фонових зображень
  • 02.02.2017 (стабільна версія 11526)
    • GPS-треки тепер можна показувати в новому режимі Теплової мапи.

2016

  • 31.12.2016 (стабільна версія 11427)
    • Вбудована база даних з кордонами всіх країн. Тепер правила валідації та стилі розфарбовування даних також можуть бути обмежені територією певної країни.
    • Просто перетягніть посилання або вставте його в JOSM, щоб завантажити дані. Підтримуються всі доступні типи посилань з діалогу Відкрити адресу
    • Поля ключ та значення у діалозі додавання властивостей мають значення останнього використаного теґу.
  • 06.11.2016 (стабільна версія 11223)
  • 05.09.2016 (стабільна версія 10966)
  • 12.08.2016 (стабільна версія 10786)
  • 12.07.2016 (стабільна версія 10526)
    • Велика переробка ядра JOSM
  • 28.04.2016 (стабільна версія 10161)
  • 13.03.2016 (стабільна версія 9979)
    • OAuth – тепер є типовим методом авторизації.
    • Підтримка Тягни-Кидай (Drag & Drop) в реадкторі зв'язків – більш докладно
    • Нова кнопка в редакторі зв'язків для оновлення стану зв'язку (наприклад після розділення лінії)
    • У вікні Історії показуються старі та нові координати точок на мапі
    • Автоматичне встановлення рівнів масштабування в залежності від роздільної здатності фону
    • Розшірено перелік підтримуваних проекцій

2015

  • 31.12.2015 (стабільна версія 9229)
  • 23.11.2015 (стабільна версія 9060)
    • Підтримка норвезької (Букмол)
  • 30.10.2015 (стабільна версія 8969)
    • Розрізання ліній: перенесення історії на найдовшу частину (в експертному режимі можна обрати на яку частину переносити історію)
    • Показ значків не тільки на мапі, а й у списках (напр. на панелі вибору, редакторі зв’язків чи вікні надсилання даних)
  • 28.09.2015 (стабільна версія 8800)
    • Інтеграція завантаження з Overpass та Помічника Overpass Turbo (в експертному режимі)
    • Додано міні-мапу
    • Додано посилання на taginfo
    • Гама-корекція фонових зображень
  • 22.08.2015 (стабільна версія 8677)
  • 17.06.2015 (стабільна версія 8491)
    • Підтримка білоруської мови
    • Підтримка в’єтнамської мови
  • 2015-04-18 (8227)
    • Підтримка валенсійської мови
  • 2015-03-31 (8160)
    • Підтримка литовської мови
  • 2015-03-02 (8109)
    • Більше шрифтів для підтримки більшої кількості мов в Windows
    • Деякі втулки тепер можна встановлювати та використовувати без перезапуску JOSM
    • Нове поле пошуку для головного мені (вгорі праворуч)
    • Підтримка нотаток тепер типово увімкнена (більше не потрібно встановлювати втулок для цього)
  • 2015-02-18
    • Веб-інтерфейс Launchpad, який використовується для перекладу JOSM, знов працює нормально, без постійних помилок "Timeout error".

2014

  • 2014-12-29 (7906)
    • Дві нових мови: астурійська та кхмерська.
    • Змінено теки для налаштувань, даних користувача та кешу в OS X та Windows.
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
    • Виправлено серйозні помилки в роботі клавішних комбінації та інструмент З’єднати лінії, що спричиняли конфлікти.
  • 2014-09-30 (7588)
    • Покращено інтеграцію з OS X (докладніше #10455).
    • Показ теґів OSM в Заготовках.
  • 2014-09-20 (7569)
    • JOSM відтепер попереджує про застарілий стиль мультиполігонів, який можна виправити переносом відповідних теґів із зовнішньої лінії на зв’язок.
  • 2014-08-31 (7480)
    • Суттєве вдосконалення типового стилю мапи:
      • Точки та значки на малих масштабах приховуються (цей режим налаштовується через налаштування стилів)
      • Краще розташування підписів в середині полігонів
      • На дорогах показуються їх назви, назви вулиць, вдовж всієї їх довжини
    • Автономний режим роботи з новим аргументом командного рядка --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Ми проводимо конкурс на створення нового логотипу, роботи приймаються до 30 вересня 2014 року! Див вікі, щоб дізнатись подробиці
  • 2014-07-04 (7287)
    • Новий режим подвійного вирівнювання для Видавлювання
    • Автоматичне перезавантаження стилів показу елементів мапи та правил валідації
    • Автоматичне оновлення елементів меню Фон
  • 2014-05-18 (7139)
    • Типовий стиль мапи перетворений з XML на MapCSS
  • 2014-05-15 (7131)
    • Додано дію Move Node onto Way (Перемістити точку до найближчого сегмента лінії)
  • 2014-04-25 (7001)
    • Перехід до використання Java 7, велика переробка коду
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Доступ до OSM API через HTTPS
  • 2014-01-29 (6767)
    • Нова, на основі MapCSS перевірка теґів, розширювана за допомогою правил
    • Додано "Пошук по об’єктах в заготовках" Shift-F3
    • Покращення Заготовок/MapCSS/Валідатора

2013

  • 2013-12-20 (6502)
    • Пропонується заповнити теґ source для набору змін в діалозі надсилання даних
    • Діалог історії: тепер завантажуються та показуються описи наборів змін
    • source:trunk/images/mapmode/improvewayaccuracy.png Покращення точності ліній доступне також і по за експертним режимом
    • Багато інших покращень та виправлення помилок (перелік змін)
  • 2013-11-17 (6388)
    • Оновлення перекладів
  • 2013-11-12 (6383)
    • Нова команда для від’єднання точки від лінії
    • Сповіщення про отримані нові повідомлення в ОСМ
    • Багато незначних покращень в шаблонах, стилях, валідаторі та інших місцях
  • 2013-09-20 (6238)
    • Нові ненав’язливі сповіщення
    • Новий пункт «сесія» в меню Файл, доступний в режимі експерта
    • Всебічна підтримка GPX маршрутів
    • Багато невеличких покращень в заготовках, перезапуску, стилях та валідаторі, також поліпшення продуктивності
  • 2013-08-07 (6115)
    • Для повної підтримки нового втулка нотаток запитуються дозволи через OAuth
    • Перероблені меню, які утворюються втулками, для кращої інтеграції та гуртування
    • Надається перевага дочірній (останній) точці із виділених об’єктів з дублікатами
    • Багато інших покращень та виправлення помилок (перелік змін)
  • 2013-07-09 (6060)
    • Підсвічування виділених зв’язків та об’єктів на панелі Зв’язки, Виділення? чи Параметри/Членство та в редакторі зв’язків.
    • В режимі Видавлювання: додано модифікатор Ctrl для «перетягування точок вздовж відрізків» (попередні параметри можуть бути відновленні через розширені налаштування)
    • Завантаження даних GPX вздовж треку, профілі налаштувань, (Розширені налаштування - Ще…), купа невеличких покращень
  • 2013-06-05 (5990)
    • Можливість призначити клавіші для шаблонів та інших кнопок панелі інструментів, плюс новий пункт контекстного меню "Змінити сполучення клавіш", для цього.
    • Автоматичне змінення масштабу для шарів WMS
    • Нова дія для приховування панелі діалогів за допомоги клавіші TAB
  • 2013-05-08 (5939)
    • Втулок «Restart» включений до складу ядра
    • Контекстне меню «відмінити, вирізати, копіювати, вилучити, виділити все» доступне для кожного текстового поля
    • Покращено продуктивність команди Очищення
  • 2013-04-08 (5836)
    • Переробка контекстних меню
    • Додано кнопку «очищення буферу» для вилучення некоректних даних для функції «вставити теґи з тексту»
    • Вилучено підтримку (застарілого) сервера зсуву фону
  • 2013-03-07 (5759)
    • Ctrl-Shift-V — вставляє з буферу теґи, скопійовані як текст, наприклад, a=2,c=3 або a 2 c 3
    • Численні покращення рендерингу MapCSS
    • Можливість перетягування точок в режимі Видавлювання
    • Контекстне меню Діалога редагуваня теґів, опції для фіксації мови теґів
    • Основи фільтрування даних треків GPS
    • Віддалене керування: можливість вилучення теґів та створення об’єктів з теґами
    • Багато незначних покращень та усунення помилок
  • 2013-02-06 (5697)
    • Під час редагування та створення зв’язків пропонуються певні ролі
    • Можливість фільтрування зв’язків на панелі зв’язків
    • Кілька покращень в діалозі «Додати значення», включаючи кнопку виклику довідки, запам’ятовування положення та можливість додавання кількох теґів підряд без закриття діалогу
    • Новий елемент фону wms_endpoint та перероблений діалог WMS/TMS
    • Нові правила для перевірки адрес та теґів вікіпедії, збільшення продуктивності у розфарбовування шарів та виправлення помилок
    • Багато незначних поліпшень

2012

  • 2012-12-08 (5608)
    • Нові оператори nth: та nth% дозволяють шукати по місцю знаходження в лініях
    • Кілька невеликих покращень в службі віддаленого керування та у вбудованих шаблонах
  • 2012-11-10 (5576)
    • Доступне вимірювання у «морських милях» (NM)
  • 2012-10-08 (5531)
    • Перероблено перевірку будівель у валідаторі
    • Деякі теґи (TIGER, odbl, yh) автоматично відкидаються під час надсилання даних на сервер
    • Код, що стосується процесу переліцензування, був вилучений
  • 2012-08-29 (5482, 5485)
    • Постачальники фонових зображень пропонуються відповідно до завантаженої території
    • Під час додавання теґів точкам, лініям та зв’язкам, для пришвидшення вибору, показуються п’ять останніх використаних теґів
    • Покращено підтримку роботи з полігонами під час фільтрування об’єктів за допомогою інструменту «Фільтр»
    • Відтепер ви не зможете відкрити теку та завантажити всі фотографії з неї за допомоги діалогу «Відкрити» 'Файл > Відкрити…'. Замість цього вибирайте файли зображень напряму (використовуючи Ctrl-A чи Shift-Ліва кнопка миші). Інструмент 'Імпортування зображень' із контекстного меню Шару GPX все ще працює у звичний спосіб і ви можете завантажити фотографії рекурсивно, відкриваючи теку рівнем вище.
  • 2012-07-23 (5353, 5356)
    • В основному виправлення помилок пов’язаних з обробкою даних, внесених ботом перевірки умовам нової Ліцензії
    • Невеличкі покращення в стилях мапи та механізмі перевірки даних, включаючи відтворення неактивних шарів та показ назв у діалозі перевірки даних
  • 2012-07-03 (5315)
    • Виправлені основні помилки валідатора, діалогу конфліктів та процедури об’єднання шарів
    • Кілька покращень діалогу виправлення конфліктів, включаючи параметри вибору (подвійним клацанням) та наближення до елемента (через контекстне меню)
    • Деякі покращення процесу перевірки на помилки
  • 2012-06-04 (5267)
    • Нові мови: Португальська (Європа) (pt), Каталонська (ca)
    • Підтримка власних проекцій користувачів
    • Під час створення мультиполігону теґи переносяться на зв’язок
  • 2012-05-02 (5210)
    • Кілька незначних покращень
      • Альтернативний діалог пошуку тепер став типовим
      • Використовуйте аргумент командного рядка --load-preferences= для завантаження налаштувань під час запуску JOSM
      • MapCSS тепер може по-різному стилізувати ліву і праву кромки (casings) ліній
  • 2012-04-14 (5181)
    • Стартова сторінка josm.openstreetmap.de була спрощена і реорганізована
    • Стабільна версія (5181) випущена із великою кількістю змін та покращень, серед яких:
      • source:trunk/images/mapmode/rope.png Режим виділення «Ласо» (в режимі експерта)
      • Інформаційні діалоги для початківців: попередження про зсув фону, при об’єднанні ліній з конфліктуючими теґами або ліній - учасників відносин
      • Нові можливості редактора зв’язків: «Додати виділення до зв’язка» (в контекстному меню), «Перейти до попереднього/наступного розриву» в редакторі
      • Покращення в меню «Вид»: «Стиль кольорів мапи», з можливістю сховати панель редагування
      • Ряд поліпшень процесу запуску
  • 2012-02-07 (4905)
    • Були додані комбінації клавіш для Редактора зв’язків: Alt-Up, Alt-Down (перемістити членів зв’язку вгору/вниз), Alt-Del (вилучити члена зв’язку) та Alt-Home (завантажити неповних членів)
    • Доступний Підсумковий огляд змін, який містить перелік змін, що відбулись між випусками стабільних версій.
  • 2012-02-02 (4897 ...)
    • Виправлено конфлікти комбінацій клавіш для JOSM і втулків. Було змінено велику кількість комбінацій клавіш!
  • 2012-01-22 (4846)
    • Втулок ImproveWayAccuracy для уточнення вигляду ліній додано до ядра програми. Виберіть лінію, натисніть source:trunk/images/mapmode/improvewayaccuracy.png та уточніть вигляд лінії. Додаткову інформація дивіться у довідці
  • 2012-01-21 (4791, 4796, 4833)
    • Багато поліпшень у Дистанційному керуванні: нова команда '/load_object' для завантаження об’єктів по ID; команда '/add_way' для додаванні нової лінії із вказаними координатами; параметр 'new_layer' для команди '/load_and_zoom', дозволяє завантажити дані до нового шару.
  • 2012-01-12 (4789)
    • Новий параметр командного рядка, який дозволяє встановити значення довільного параметра налаштувань під час запуску. (наприклад: --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Підсвічування точок та ліній під вказівником миші можна відключити: 'Налаштування' > 'Налаштування екрану' > 'Дані OSM' (тільки в експертному режимі)
    • Інструмент Креслення source:trunk/images/mapmode/node/autonode.png дозволяє креслити відрізки ліній під фіксованими кутами (наприклад 30°, 45°). Натискання TAB перемикає режими.
  • 2012-01-04 (4765)
    • Автоматичне приховування кнопок на панелі діалогів можна відключити для кожного діалогу окремо (Значок у вигляді ока праворуч в заголовку діалогу)

2011

  • 2011-12-29 (4745)
    • Нова команда для завантаження та збереження у кеші фонових зображень WMS вздовж GPX-треку. (В контекстному меню шару GPX)
  • 2011-12-20 (4673)
    • Для Франції доступна проекція Lambert 93 (EPSG:2154)
  • 2011-12-20 (4670)
    • Арабська, ісландський мова та іврит були вилучені у зв’язку з відсутністю оновлень перекладу.
  • 2011-12-05 (4621-4636)
    • Покращено роботу з великими мультиполігонами.
  • 2011-11-26 (4609, 4611)
    • Кнопки на панелі інструментів (зверху ліворуч) можна приховувати.
    • Під час креслення лінії натискання на BackSpace скасовує останню дію.
  • 2011-11-20 (4601)
    • В діалозі Історії тепер показується чи прийняв користувач нову ліцензію чи ні.
  • 2011-11-15 (4595)
    • Підтримка багато-ступеневих комбінацій клавіш. Наприклад: натисніть Ctrl+Alt+S, а потім 1 для перемикання видимості першого шару.
  • 2011-11-14 (4593)
    • На малих екрана довгі меню тепер більше не обрізаються, а прогортаються.
  • 2011-11-07 (4587)
    • Новий параметр у вікні пошуку для додавання кнопки з пошуковим запитом на панель інструментів. Потім кнопку можливо вилучити за допомоги контекстного меню, що з’являється при натисканні правої кнопкою миші на цій кнопці. (Тільки в режимі експерта)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Внутрішній формат для збереження налаштувань користувача був змінений на XML.
  • 2011-10-29 (4546)
    • Показ тексту над точками, лініями та зв’язками може бути налаштований через заготовки імен.
  • 2011-10-20 (4530)
    • Формат OsmChange (*.osc) тепер підтримується офіційно.
  • 2011-10-10 (4512)
    • Режим експерта був введений, щоб зменшити складності для нових користувачів. Для забезпечення сумісності із вже встановленим JOSM режим експерта є типово увімкненим.
  • 2011-10-07 (4497, 4498, 4500)
    • Додаткові параметри в діалозі 'Файл > Завантажити об’єкт…'.
    • Вікно історії: Покращений показ вставлених/вилучених точок ліній (а також членів зв’язків).
    • Нові скорочення у вікні властивостей: Alt+A, Alt+S, Alt+D для Додавання, Редагування, Вилучення.
  • 2011-09-23 (4454)
    • Копіювання ключів та їх значень до буферу обміну за допомоги правої клавіші миші у вікні властивостей.
  • 2011-09-12 (4416, 4423)
    • Межі покриття сервісів фонових зображень показуються у попередньому перегляді мапи у меню 'Налаштування > Фон'.
  • 2011-09-08 (4408)
    • Елемент контекстного меню 'Перевірити' з вікна виділених елементів переміщено до меню 'Вигляд > Додаткова інформація'.
  • 2011-09-07 (4405)
    • Перелік в меню 'Налаштування > Фон' тепер відсортований за кодами країн.
  • 2011-08-29 (4380)
    • Нова функція 'Правка > Копіювати координати'.
  • 2011-08-28 (4371)
    • У переліку нещодавно відкритих файлів показуються тепер не тільки відкриті, а й збережені файли.
  • 2011-08-27 (4355)
    • Динамічний показ рядка кнопок у панелі діалогів праворуч (додатково, розширені налаштування 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Скорочення для приховування/показу шарів (Alt-1 до Alt-9)
  • 2011-08-21 (4332)
    • Виділення видимих треків у кожному шарі gpx (за допомоги правої кнопки миші)
  • 2011-08-21 (4327)
    • Режими Виділення та Вилучення тепер мають кращу візуальну індикацію (підсвічування, змінення курсору).
  • 2011-07-18 (4256)
    • Підтримка зображень формату SVG.
  • 2011-07-14 (4241)
    • Приймається до уваги орієнтація зображення JPEG з EXIF-заголовка.
  • 2011-07-07 (4207)
    • Розфарбовування треків GPS відповідно до їх напрямку
  • 2011-06-18 (4142)
    • В режимі Видавлювання подвійне клацання на відрізку додає нову точку.
  • 2011-06-11 (4126, 4129, 4134)
    • Оптимізовано використання пам’яті та підвищено швидкість показу треків GPX
    • Новий режим креслення: Додання паралельної лінії поруч з існуючою. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • Нова функція Йти за лінією для спрощення креслення суміжних ділянок. (схожа на скорочення "F" у Потлатч 2)
    • Пошук (та Фільтр) підтримують запити по замкнених лініях, а також лініях що входять до певної мінімальної чи максимальної ділянки (Ключові слова: closed; areasize:MIN-MAX або areasize:MAX, у м²)
    • Діалог заватажити об’єкт… тепер приймає списки ідентифікаторів.
  • 2011-04-18 (4032)
    • Додавайте кілька персональних пошукових запитів чи фонових шарів із їх власними значками на панель інструментів.
    • Оновлення показу стану переліцензування для кожного учасника (зелений — погодився, сірий — автоматичне переліцензування [для нових користувачів], червоний хрест — не погодився.)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Нова функція переміщення вікна мапи — центрує мапу по останній розміщеній точці. (Меню > Вид; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Втулки imagery,wmsplugin,slippymap та remotecontrol включені до ядра JOSM.
  • 2010-12-07 (3705)
    • Шари тепер можуть бути прозорими. (нова кнопка у вікні переліку шарів)
  • 2010-12-07 (3702)
    • Підтримується масштабуваня об’єктів (Ctrl+Alt в режимі виділення)
    • інформація Щоб обертати об’єкти натисніть Ctrl+Shift та потягніть мишею.
  • 2010-11-25 (3669)
    • Втулок Validator включено до складу основної програми.
  • 2010-09-23 (3557, #5427)
    • Зміни в режимі “Видавлювання” (X): Коли ви здійснюєте видавлювання в одному напрямку кілька разів, не створюються зайві проміжні точки. (Разом із Shift можливо отримання проміжних точок після кожного руху.)
  • 2010-09-14 (3529)
    • Для теґів у вікні властивостей присутні прямі посилання на сторінки у вікі (відкриваються у інтернет оглядачі).
  • 2010-09-03 (o22964)
    • Втулок WMS підтримує запити GetCapabilities.
  • 2010-08-13 (3431)
    • Нова команда Очистити очищає шари з даними.
  • 2010-07-27 (3388)
    • Новий діалог пошуку заготовок теґів.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Тепер можливо шукати елементи за роллю у зв’язках.
    • Діалогове вікно властивостей показує позицію членів зв’язків.
  • 2010-06-01 (3291)
    • Зараз використовуються ролі зазначені у заготовках. Це може призвести до появи попереджень під час перевірки зв’язків, які невідомі JOSM.
    • Члени виділених зв’язків показуються іншим кольором, ніж безпосередньо виділені елементи.
  • 2010-04-16 (3189)
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • Новий діалог завантаження об'єкта по ID і можливість завантаження всіх ліній і відносин, що використовують даний об’єкт.
  • 2010-01-28 (2901)
    • З’явилася можливість створити дублікат вибраного шару даних без прив’язки до файлу.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • The plugins utilsplugin and AgPifoJ have been integrated in JOSM core.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 5 years ago Last modified on 2013-06-25T23:20:19+02:00