wiki:Pt_BR:VersionHistory

Antigas nóticias do JOSM

  • 2020-07-31 (versão estável 16812)
  • 2020-07-02 (versão estável 16731)
    • Add feature "restore selected tags" in the history window (via context menu)
    • Add links to taghistory.raifer.tech
    • Add "Invert selection" action (expert mode only)
  • 2020-06-02 (versão estável 16538)
    • Add Persian and Icelandic language
    • Switch to JOSM search syntax in Overpass Query Wizard
    • Improve cursor rendering on HiDPI screens
    • Add color chooser to presets, display the color in the properties dialog
    • Jump to Position: add jump to place name
  • 2020-04-06 (versão estável 16239)
    • Add Arabic language
    • Add support for Eastern Arabic(-Indic) and Khmer numerals
  • 2020-02-26 (versão estável 15937)
    • Maxar imageries are available again
    • Add links to regional/national taginfo instances of the Geofabrik - big thanks to the Geofabrik!
    • Improve Autofilters
    • The "Add tag" and "Change value" dialogs display the related preset/mappaint style icons on the okay button
  • 2020-02-01 (versão estável 15806)
    • Tag2Link plugin integrated in the JOSM core and improved
    • Double click sliders to reset opacity/colorfulness/gamma/sharpness
    • Smarter Split way function
  • 2020-01-02 (versão estável 15628)
    • New link to national taginfo instances if available
    • Option to automatically fill the changeset source tag in the upload dialog

2019

  • 2019-12-02 (versão estável 15553)
    • New language Marathi
    • Various improvements for gpx layers
  • 2019-11-02 (versão estável 15492 (en))
    • Add GeoJSON import
  • 2019-09-30 (versão estável 15390 (en))
  • 2019-08-26 (versão estável 15322 (en))
    • New logo
    • Add changeset tags via remote control
  • 2019-07-10 (versão estável 15238 (en))
    • Filter Imagery list by country name
  • 2019-06-02 (versão estável 15155 (en))
    • Add category icons in the imagery preferences and a box to filter the list. The categories are: photo, historicphoto, map, historicmap, osmbasedmap and other.
    • Display dynamic imagery entries of the Imagery menu (en) in sub menus when they don't belong to the category photo.
  • 2019-04-29 (versão estável 15031 (en))
    • O plugin download_along foi integrado no código do JOSM, a opção "Baixar ao longo..." aparece no menu Arquivo (en).
  • 2019-03-31 (versão estável 14945 (en))
  • 2019-03-02 (versão estável 14824 (en))
    • Novo idioma: ingles canadense
  • 2019-02-05 (versão estável 14760 (en))
    • Our server sponsor is now FOSSGIS e.V. - Thanks a lot to Hetzner for the support till now and to FOSSGIS for the new powerful hardware.

2018

  • 2018-12-31 (versão estável 14620)
    • Automatic column width of the tags table to fit content
  • 2018-11-28 (versão estável 14460)
    • Data download: "Download as new layer" changed from a checkbox to an own button
    • The height of each panel on the right side is saved when JOSM is closed
  • 2018-11-18
  • 2018-10-28 (versão estável 14382)
    • Option to display object version in lists
  • 2018-10-02 (versão estável 14289)
    • Various enhancements for the correlation of images to gpx tracks
  • 2018-08-22 (versão estável 14178)
  • 2018-08-18 (versão estável 14163)
    • Support Overpass API JSON format
    • Support Notes (en) in osmChange files (.osc) created by OSMAnd
    • Options (en) for conversions of GPX to OSM tags
  • 2018-07-29 (versão estável 14066)
    • Support GDPR-compliant OSM data
  • 2018-07-09 (versão estável 14026)
  • 2018-07-01 (versão estável 13996)
  • 2018-05-31 (versão estável 13878)
  • 2018-05-27 (versão estável 13860)
    • Add Korean translation
    • Major improvements to WMS/WMTS support
  • 2018-05-07 (versão estável 13710)
    • Add 724 new projections (JOSM supports now 6135 projections in total)
    • The source:trunk/resources/images/dialogs/layerlist/offset.svg icon marks background layers which were shifted (aligned)
    • Double-clicking on an element in the upload window zooms to the element
  • 2018-03-26 (versão estável 13576)
    • Add support for private and locked OSM data layers (en)
    • Add context menu in the tag table of the history window (en)
    • Add support for translations with .lang files for external data (mappaint styles, rules, presets)
  • 2018-03-04 (versão estável 13500)
  • 2018-03-01 (versão estável 13478)
  • 2018-01-28 (versão estável 13367)
    • Add support for XZ compressed files
    • Better support for WMS 1.3.0

2017

  • 2017-12-31 (versão estável 13265)
  • 2017-11-26 (versão estável 13170)
    • Text of notes is now selectable and copyable; links are now clickable
    • Ability to upload data in background
    • Don't select all characters from a text box when switching between JOSM and another application
  • 2017-10-29 (versão estável 13053)
    • Already downloaded areas are displayed in the download window and in the minimap and the layer chooser button was improved
    • New button in the relation editor that selects the relation itself
  • 2017-10-06 (latest version 12926)
    • JOSM now uses a new code signing certificate sponsored by FOSSGIS e.V. (required for WebStart)
  • 2017-10-03 (versão estável 12921)
    • Added links to external changeset viewers to the History and Changeset Manager windows
    • Added feedback request checkbox to the upload window
    • The creating circles function automatically uses a proper node count depending on the circle diameter
    • New command-line parameters to execute certain tasks without graphical user interface:
      • Rendering of osm data using a MapCSS style
      • Converting coordinates from one projection to another
  • 2017-09-02 (versão estável 12712)
  • 2017-07-30 (versão estável 12542)
    • Search by preset in the Search window.
    • New "home location" bookmark (if set in the OSM user settings) and bookmarks of the last 15 changesets.
  • 2017-07-02 (versão estável 12450)
  • 2017-05-29 (versão estável 12275)
  • 2017-05-02 (versão estável 12039)
    • Reprojection (warping) of imagery layers: allows to combine sources of different projections.
  • 2017-04-02 (versão estável 11826)
    • Completely prevent the upload of a layer by "upload=never" in the osm file
    • An option was added to not zoom to the new downloaded data. (expert mode only)
  • 2017-02-27 (versão estável 11639)
    • The GPS Heat Map mode has now some settings to adjust its appearance.
    • Mirror servers of imageries can now be selected in the Imagery Preferences.
  • 2017-02-02 (versão estável 11526)
    • GPS traces can now be displayed in the new Heat Map mode.

2016

  • 2016-12-31 (versão estável #11427)
    • Internal database with boundaries of all countries. Single validator rules and mappaint styles can now e.g. be limited to a specific country.
    • Simply dropping or pasting URLs to download data supports now all URL types from the Open Location window.
    • The key and value text boxes in the add value window are prefilled with the next tag of the list below if the first key is already used.
  • 2016-11-06 (versão estável #11223)
  • 2016-09-05 (versão estável 10966)
  • 2016-08-12 (versão estável 10786)
  • 2016-07-12 (versão estável 10526)
    • Big rework of the JOSM core
  • 2016-04-28 (versão estável 10161)
  • 2016-03-13 (versão estável 9979)
    • OAuth is now the default authorisation method.
    • Drag & Drop support for the relation editor (more info)
    • New button in relation editor to refresh the relation (e.g. after splitting a way)
    • The History dialog shows the old and new coordinates of a moved node on a map
    • Automatic snap zoom to default resolution of background
    • Extended support of different projections

2015

  • 2015-12-31 (versão estável 9229)
  • 2015-11-23 (versão estável 9060)
    • Suporte a língua norueguesa Bokmål
  • 2015-10-30 (versão estável 8969)
    • Divisão de vias: reutiliza id/história da via existente para divisão de segmentos maiores (usuários experientes podem escolher um outro segmento)
    • Ícones do mapview são exibidos em listas também (por exemplo, na seleção, no editor de relação ou no upload)
  • 2015-09-28 (versão estável 8800)
    • Integração do Overpass e Overpass Turbo Wizard (apenas no modo avançado)
    • Adicionado minimapa
    • Adicionado link para o taginfo
    • Valor de gama selecionável para imagens de fundo
  • 2015-08-22 (stable version 8677)
  • 2015-06-17 (stable version 8491)
    • Suporte do idioma Bielorusso
    • Suporte do idioma Vietnamita
  • 2015-04-18 (8227)
    • Suporte do idioma Valenciano
  • 2015-03-31 (8160)
    • Suporte do idioma Lituano
  • 2015-03-02 (8109)
    • Mais fontes para suportar mais línguas em Windows
    • Alguns módulos podem agora ser instalados e usados sem ser necessário reiniciar o JOSM.
    • Adicionada uma caixa de pesquisa no menu do lado direito para pesquisar por itens nos menus.
    • As funcionalidades de Erros reportados no mapa foram integradas no JOSM (o módulo foi desativado).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Duas linguagens novas: Asturiano e Khmer.
    • Configurações, dados de usuário e diretórios de cache foram alterados no OS X e no Windows.
  • 2014-12-10 (7777)
    • Logotipo novo, cujo design foi feito por Diamond00744.
    • Habilidade de baixar/carregar Notas do OSM.
    • Removido diálogo de histórico da barra lateral em favor de um novo botão de histórico no diálogo de seleção.
  • 2014-10-21 (7643)
    • Conserto de erros importantes de atalhos de teclado e do gerenciamento de conflitos da ação Combinar linhas/vias.
  • 2014-09-30 (7588)
    • Melhor integração com o OS X (para mais detalhes o bilhete #10455).
    • Visualização de etiquetas OSM na interface de predefinições.
  • 2014-09-20 (7569)
    • O JOSM agora exibe avisos para multipolígonos mapeados no estilo antigo, que podem ser atualizados transferindo as etiquetas relevantes das linhas externas para a relação.
  • 2014-08-31 (7480)
    • Melhorias importantes no estilo padrão do mapa:
      • Os símbolos dos pontos e ícones são ocultados em níveis de zoom menores (isto pode ser configurado nas configurações de estilo).
      • Melhoria na colocação de rótulos dentro das áreas
      • O nome das rodovias é exibido ao longo das linhas
    • O modo offline com um argumento novo na linha de comando --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Nós estamos fazendo um concurso gráfico até o dia 30 de setembro para escolher um novo logotipo! Veja o wiki para mais detalhes.
  • 2014-07-04 (7287)
    • Novo modo de alinhamento duplo para ação de Extrusão
    • Recarregamento automático dos estilos de pintura do mapa e das regras de validação
    • Atualização automática para as camadas padrão
  • 2014-05-18 (7139)
    • Estilo padrão do mapa JOSM convertido de XML para MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Mudado para versão 7 do Java, muitas limpezas no código
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Permitido acesso HTTPS a API do OSM
  • 2014-01-29 (6767)
    • Novo MapCSS- verificador baseado em tag, expansível via personalização de regras
  • Adicionada ação "Procurar por objetos utilizando predefinições" Shift + F3
    • Melhorias em predefinições/MapCSS/Verificador

2013

  • 2013-12-20 (6502)
    • Ask for changeset source tag in upload dialog
    • History dialog: load and display changeset comment
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg Improve way accuracy enabled for non-experts
    • Many other enhancements and bug fixes (changelog)
  • 2013-11-17 (6388)
    • Up-to-date language files
  • 2013-11-12 (6383)
    • New command to disconnect node from way
    • Notification of newly received OSM messages
    • Many minor enhancements of presets, styles and validator plus other parts
  • 2013-09-20 (6238)
    • New non-intrusive notification messages
    • New "session" item in file menu visible in expert mode
    • Complete support of GPX routes
    • Lots of minor enhancement of presets, restart, styles and validator plus performance improvements
  • 2013-08-07 (6115)
    • Request OAuth permission to fully support the new notes plugin
    • Refactoring of the plugin menus to support better grouping and integration
    • Prefer the child node of (last) selected objects when selecting nodes with duplicates
    • Many other enhancements and bug fixes (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • possibility to set keyboard shortcuts for presets and other toolbar buttons plus new context menu item "Edit shortcut" to define them
    • automatic zoom for WMS layers
    • new "Toggle panels" action on TAB to hide/unhide toggle dialog panel
  • 2013-05-08 (5939)
    • integrate restart plugin into core
    • right click menu "undo, cut, copy, paste, delete, select all" for each text component
    • improve performance of purge command
  • 2013-04-08 (5836)
    • major rework of context menus
    • add "clear buffer" button to remove incorrect buffer from "paste tag from text" action
    • remove support for the (deprecated) imagery offset server
  • 2013-03-07 (5759)
    • Ctrl-Shift-V now can paste tags from text buffer, e.g., a=2,c=3 and a 2 c 3
    • multiple MapCSS rendering improvements
    • allow dragging nodes in Extrude mode
    • context menus in Add/Edit property dialogs, option to fix keyboard layout
    • basic date-filtering of GPS traces
    • remote control: allow deleting tags and creating objects with tags
    • lots of minor enhancements and bug fixes
  • 2013-02-06 (5697)
    • roles are suggested in the relation editor and upon creating a relation
    • possibility to filter in the relation list toggle dialog
    • several enhancements of the "Add Value" dialog including a help button, remembering position and the possibility to add several tags in a row without closing the dialog
    • new imagery entry wms_endpoint and rework of WMS/TMS Dialog
    • new validator test for addresses and wikipedia tags and performance improvement in layer painting and error fixing
    • lots of minor enhancements

2012

  • 2012-12-08 (5608)
    • new operators nth: and nth% allow to search for position in ways
    • some minor enhancement of remote control and internal presets
  • 2012-11-10 (5576)
    • "nautical mile" (NM) is supported as system of measurement
  • 2012-10-08 (5531)
    • remodelação do teste de validação "Edifício dentro de Edifício" para detetar mais ocorrências e remover algumas falsas
    • são eliminadas mais algumas etiquetas automaticamente ao enviar dados para o OpenStreetMap (TIGER, odbl, yh)
    • removido o código referente à alteração da licença do OpenStreetMap por esta já ter terminado
  • 2012-08-29 (5482, 5485)
    • são sugeridas imagens de fundo caso estejam disponíveis para a região descarregada
    • ao adicionar etiquetas a nós, linhas ou relações, são mostradas as últimas 5 etiquetas adicionadas para facilitar a introdução de etiquetas semelhantes
    • a ferramenta de filtragem suporta melhor os multipolígonos
    • já não se pode abrir um diretório em 'Ficheiro > Abrir...' e carregar todas as fotografias automaticamente. Em vez disso, selecione os ficheiros das fotografias diretamente (utilizando CTRL-A ou SHIFT-clique). A ferramenta 'Importar imagens' disponível no menu de contexto de uma camada GPX continua disponível, por isso pode-se carregar fotografias recursivamente abrindo um diretório acima.
  • 2012-07-23 (5353, 5356)
    • correções importantes de erros nos dados alterados pelo robô que realiza as alterações da licença
    • pequenos melhoramentos nos estilos de mapas e no verificador de erros, incluindo a renderização de camadas inativas e a visualização de nomes na janela do verificador de erros
  • 2012-07-03 (5315)
    • correções no verificador de erros, na janela de conflitos e ao fundir camadas
    • vários melhoramentos na janela de conflitos, incluindo a opção para selecionar (clique duplo) e enquadrar objetos (menu de contexto)
    • vários melhoramentos no verificador de erros
  • 2012-06-04 (5267)
    • novas línguas disponíveis: Português (europeu) (pt), Catalão (ca). A versão em português europeu é muito recente e pode conter erros. Deve-se verificar as etiquetas adicionadas.
    • suporte para projeções personalizadas
    • mover as etiquetas para a relação ao criar um multi-polígono
  • 2012-05-02 (5210)
    • alguns melhoramentos
      • diálogo de pesquisa alternativo definido como principal
      • argumento --load-preferences= da linha de comandos para aplicar configurações no início do JOSM
      • Permitir MapCSS para definir estilos do lado direito e esquerdo de modo diferente
  • 2012-04-14 (5181)
    • A página inicial de josm.openstreetmap.de foi simplificada e reorganizada
    • A versão testada (5181) foi lançada com muitas alterações/melhoramentos, que incluem
      • source:trunk/resources/images/mapmode/rope.svg modo de seleção com laço (modo avançado)
      • informações em diálogos para iniciados: aviso sobre imagens aéreas desalinhadas, ao combinar linhas com etiquetas em conflito ou linhas pertencentes a relações
      • novas funcionalidades em edição de relações: "Adicionar seleção à relação" (ao clicar com botão direito numa relação), "Selecionar extremo anterior/seguinte" (no editor de relações)
      • melhoramentos na interface no menu Ver: "Estilos de Visualização do Mapa", possibilidade de esconder a barra de ferramentas de edição
      • várias melhorias no tempo de inicio do JOSM
  • 2012-02-07 (4905)
    • Foram adicionados Atalhos para o Editor de Relações: ALT-CIMA, ALT-BAIXO (move o item selecionado para cima ou para baixo), ALT-DEL (remove o item) e ALT-HOME (descarrega os objetos incompletos)
    • Agora está disponível uma lista de alterações resumida que contém mudanças importantes entre as versões estáveis.
  • 2012-02-02 (4897 ...)
    • Os atalhos com conflitos entre o JOSM e os módulos (plugins) foram corrigidos. Foram alterados muitos atalhos de funções!
  • 2012-01-22 (4846)
    • O plugin Melhorar Acurácia foi incorporado ao JOSM. Selecione um caminho, clique em source:trunk/resources/images/mapmode/improvewayaccuracy.svg, e melhore sua acurácia. Dê uma olhada na ajuda para uma explicação detalhada.
  • 2012-01-21 (4791, 4796, 4833)
    • Various extensions for the RemoteControl feature: new command '/load_object' to download objects by id; '/add_way' command to create a new way with certain coordinates; parameter 'new_layer' for the '/load_and_zoom' command to load the data into a new layer.
  • 2012-01-12 (4789)
    • New command line option to set an arbitrary preference value on start. (e.g. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Highlight for nodes and ways under the mouse cursor can be turned off: 'Preferences' > 'Display Settings' > 'OSM Data' (Only in Expert mode)
    • The drawing action source:trunk/resources/images/mapmode/node/autonode.svg allows to draw segments with discrete angles (e.g., 30/45°). Press the tabulator key to cycle through different modes.
  • 2012-01-04 (4765)
    • The automatic hiding of buttons for the right hand side dialogs can be disabled for each window individually. (Eye-symbol in the upper right corner)

2011

  • 2011-12-29 (4745)
    • New command to load and cache WMS background images along a gpx track in advance. (In right click menu of GPX-Layer)
  • 2011-12-20 (4673)
    • Lambert 93 projection (EPSG:2154) is available for France.
  • 2011-12-20 (4670)
    • Languages Arabic, Icelandic and Hebrew have been removed due to missing translation efforts.
  • 2011-12-05 (4621-4636)
    • Performance with large multipolygons improved.
  • 2011-11-26 (4609, 4611)
    • The buttons of the edit toolbar (upper left area) can be hidden.
    • When drawing ways, the backspace key takes back the last action.
  • 2011-11-20 (4601)
    • The version history display now shows the license status for each contributing user.
  • 2011-11-15 (4595)
    • Support for multipart shortcuts. For example Ctrl+Alt+S, 1 toggles the visibility of the first layer.
  • 2011-11-14 (4593)
    • On small screens, long menus are no longer clipped, but can be scrolled up and down.
  • 2011-11-07 (4587)
    • New option in the search dialog to add a toolbar button for the search. The button can be removed later from the right click menu of the button. (Only in expert mode.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • The internal format for saving user preference data has been changed to XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • Expert mode introduced to reduce complexity for new users. For compatibility existing installations are experts by default.
  • 2011-10-07 (4497, 4498, 4500)
    • More options in 'File > Download Object...' dialog.
    • History dialog: Better display of inserted / deleted way nodes (and relation members).
    • New shortcuts in properties dialog: Alt+A, Alt+S, Alt+D for Add, Edit, Delete.
  • 2011-09-23 (4454)
    • Copy key and value to clipboard by right click in the properties dialog.
  • 2011-09-12 (4416, 4423)
    • Bounds of imagery services are displayed on a preview map in 'Preferences > Imagery'.
  • 2011-09-08 (4408)
    • Menu item 'Inspect' in context menu of the selection dialog has moved to 'View > Advanced Info'.
  • 2011-09-07 (4405)
    • List in 'Preferences > Imagery' is sorted by country code.
  • 2011-08-29 (4380)
    • New feature 'Edit > Copy Coordinates'.
  • 2011-08-28 (4371)
    • The list of recently opened files shows not just opened, but also saved files.
  • 2011-08-27 (4355)
    • Dynamic visibility of button row in toggle dialogs to the right (optional, advanced preferences 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Shortcuts to toggle layer visibility (Alt-1 to Alt-9)
  • 2011-08-21 (4332)
    • Selection of visible tracks, for each gpx layer (from the right click menu of the layer)
  • 2011-08-21 (4327)
    • Select and delete mode now have better visual indication what the next action will do (highlighting, cursor changes).
  • 2011-07-18 (4256)
    • Suporte para o formato SVG.
  • 2011-07-14 (4241)
    • Tem em conta a orientação nos cabeçalhos EXIF das imagens JPEG.
  • 2011-07-07 (4207)
    • Traços GPS podem ser coloridos em função da sua direção.
  • 2011-06-18 (4142)
    • Modo Extrude: um duplo clique num segmento de linha insere um novo ponto.
  • 2011-06-11 (4126, 4129, 4134)
    • Memory optimizations and faster drawing of GPX tracks
    • New drawing mode: Add a parallel way next to an existing one. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • New Follow Line feature to ease drawing of adjacent areas. (similar to Potlatch 2's "F" shortcut)
    • Search (and Filter) can query closed ways now, and those enclosing a certain minimum and maximum area. (Keywords: closed; areasize:MIN-MAX or areasize:MAX, in m²)
    • The download Object... feature now accepts a list of ids.
  • 2011-04-18 (4032)
    • Add multiple customized search strings or background layers with its own icon to the toolbar.
    • Update of re-licensing status display in the user list (green check - agreed, gray check - agreed automatically, red cross - disagreed)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • New Viewport Following function - moves the viewport so that the last placed node is in the center. (Main Menu > View; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Os plugins imagery,wmsplugin,slippymap e remotecontrol foram integrados ao núcleo do JOSM.
  • 2010-12-07 (3705)
    • As camadas agora podem ser exibidas com transparência. (novo botão no diálogo Lista de Camadas)
  • 2010-12-07 (3702)
    • Suporte para escalonamento de objetos. (Ctrl+Alt no modo de seleção)
    • dica Para girar um objeto, clique pressionando Ctrl+Shift.
  • 2010-11-25 (3669)
    • O plugin Validator foi integrado ao programa principal.
  • 2010-09-23 (3557, #5427)
    • Mudança no modo de Criar Áreas (atalho = X) (também conhecido como extrusão): Quando movendo em uma mesma direção várias vezes, não são mais criados nós inúteis. (Segurando Shift força o comportamento antigo de criar nós a cada aplicação).
  • 2010-09-14 (3529)
    • Agora você pode clicar com o botão direito do mouse nas tags na janela de propriedades para abrir a janela correspondente do wiki no navegador web.
  • 2010-09-03 (o22964)
    • O plugin WMS suporta requisições GetCapabilities.
  • 2010-08-13 (3431)
    • O novo comando Purge pode ser usado para limpar camadas de dados.
  • 2010-07-27 (3388)
    • Nova janela de Busca de etiquetas.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • A Busca agora suporta localizar por papéis nos membros de uma relação.
    • A janela de Propriedades agora mostra a posição de um membro da relação.
  • 2010-06-01 (3291)
    • Papéis definidos na pré-configuração agora são usados. isto pode resultar em avisos inesperados do validados para relações não editadas pelo JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • Novo diálogo para baixar um objeto pelo id e opcionalmente todas as vias e relações que o usam.
  • 2010-01-28 (2901)
    • Novo: Crie uma cópia da camada de dados selecionada sem associar a um arquivo.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Nota aos utilizadores do AgPifoJ: Agora você pode abrir imagens através do menu principal (Arquivo > Abrir...) ou pelo menu de contexto (clique direito) da camada GPX correspondente.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • A nova Janela de conjunto de mudanças mostra informações sobre conjuntos de mudanças. Conjuntos de mudanças podem ser baixados, fechados ou visualizados.
  • 2009-12-05 (2575)
    • Os plugins utilsplugin e AgPifoJ foram integrados ao núcleo do JOSM.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 6 years ago Last modified on 2015-03-31T12:07:09+02:00