wiki:Ja:VersionHistory

過去のJOSMニュース

  • 2020-07-31 (安定したバージョン 16812)
  • 2020-07-02 (安定したバージョン 16731)
    • 履歴ウィンドウに「選択したタグを復元」機能を追加しました(コンテキストメニュー経由)
    • taghistory.raifer.tech のリンクを追加
    • 「選択と反転」の動きを追加(上級者モードのみ)
  • 2020-06-02 (安定したバージョン 16538)
    • ペルシア語とアイスランド語に対応しました
    • OverpassクエリウィザードがJOSM検索構文に切り替わりました
    • HiDPI画面でのカーソルレンダリングが改善されました
    • プロパティダイアログで色を表示するために、プリセットメニューに色選択ツールを追加しました
    • Jump to Position: add jump to place name
  • 2020-04-06 (安定したバージョン 16239)
    • アラビア語に対応しました。
    • Add support for Eastern Arabic(-Indic) and Khmer numerals
  • 2020-02-26 (安定したバージョン 15937)
    • Maxar画像が再び使えるようになりました
    • Geofabrikの地域/国別taginfoサイトへのリンクを追加-感謝しますGeofabrik
    • 自動フィルタリングの改善
    • 「タグの追加」および「値の変更」ダイアログで、OKボタンに関連するプリセット/地図表示スタイルアイコンが表示されるようになりました。
  • 2020-02-01 (安定したバージョン 15806)
    • Tag2LinkプラグインがJOSM基本機能に含まれました。Tag2Linkプラグイン機能の改善
    • スライダーをダブルクリックすると、透明度/彩度/ガンマ値/シャープネスを初期化することができます
    • よりスマートな線分割機能
  • 2020-01-02 (安定したバージョン 15628)
    • 国別taginfoサイトへのリンクを追加(サイトがある場合のみ)
    • アップロード画面で変更セットソースタグの自動的に入力するオプションを追加

2019

  • 2019-12-02 (安定したバージョン 15553)
    • New language Marathi
    • Various improvements for gpx layers
  • 2019-11-02 (安定したバージョン 15492 (en))
    • Add GeoJSON import
  • 2019-09-30 (安定したバージョン 15390 (en))
  • 2019-08-26 (安定したバージョン 15322 (en))
    • 新しいロゴ
    • Add changeset tags via remote control
  • 2019-07-10 (安定したバージョン 15238 (en))
    • Filter Imagery list by country name
  • 2019-06-02 (安定したバージョン 15155 (en))
    • Add category icons in the imagery preferences and a box to filter the list. The categories are: photo, historicphoto, map, historicmap, osmbasedmap and other.
    • Display dynamic imagery entries of the Imagery menu in sub menus when they don't belong to the category photo.
  • 2019-04-29 (安定したバージョン 15031 (en))
    • download_along プラグインがJOSMコアに統合され、メニュー項目「ウェイに沿ってダウンロード...」がファイルメニューに表示されます。
  • 2019-03-31 (安定したバージョン 14945 (en))
    • Various improvements of the validator panel: "Manage ignore list", "Ignore for now", etc.
  • 2019-03-02 (安定したバージョン 14824 (en))
    • New language: Canadian English
  • 2019-02-05 (安定したバージョン 14760 (en))
    • 私たちのサーバーのスポンサーは現在FOSSGIS e.V.になりました - Hetznerの今までのサポートに、そしてFOSSGISの新しい強力なハードウェアに感謝します

2018

  • 2018-12-31 (安定したバージョン 14620)
    • タグテーブルのカラムの幅は自動的に中身に合わされる様になりました
  • 2018-11-28 (安定したバージョン 14460)
    • データダウンロード:「新しいレイヤーとしてダウンロード」はチェックボックスからボタンに変更されました
    • 右側のそれぞれのパネルの高さはJOSM終了時に保存される様になりました
  • 2018-11-18
    • buildings_toolsプラグインはエッジにもスナップする様になりました
  • 2018-10-28 (安定したバージョン 14382)
    • リストにオブジェクトのバージョンを表示するオプション
  • 2018-10-02 (安定したバージョン 14289)
    • GPXトラックと画像との相互関係についての様々な改善
  • 2018-08-22 (安定したバージョン 14178)
  • 2018-08-18 (安定したバージョン 14163)
    • Overpass API JSONフォーマットをサポート
    • OSMAndによって作成されたosmChangeファイル (.osc) の Notes (en)のサポート
    • GPXからOSMタグへの変換のオプション
  • 2018-07-29 (安定したバージョン 14066)
    • GDPR に準拠した OSM データのサポート
  • 2018-07-09 (安定したバージョン 14026)
  • 2018-07-01 (安定したバージョン 13996)
  • 2018-05-31 (安定したバージョン 13878)
  • 2018-05-27 (安定したバージョン 13860)
    • 韓国語の翻訳を追加
    • WMS/WMTSサポートの全面的な改善
  • 2018-05-07 (安定したバージョン 13710)
    • 724個の新しい画像を追加(JOSMは現在6135個の画像をサポート)
    • この source:trunk/resources/images/dialogs/layerlist/offset.svg アイコンは、移動(配置)された背景レイヤーをマークする
    • アップロードウィンドウ内の要素をダブルクリックすると、要素がズームされる
  • 2018-03-26 (安定したバージョン 13576)
    • プライベートおよびロックされたOSMデータレイヤーのサポートの追加
    • 履歴ウィンドウのタグテーブルにコンテキストメニューを追加
    • 外部データ用の.langファイルによる翻訳のサポートを追加(mappaintスタイル、ルール、プリセット)
  • 2018-03-04 (安定したバージョン 13500)
  • 2018-03-01 (安定したバージョン 13478)
  • 2018-01-28 (安定したバージョン 13367)
    • XZ ファイル圧縮形式のサポートを追加
    • WMS 1.3.0サポートの改善

2017

  • 2017-12-31 (安定したバージョン 13265)
  • 2017-11-26 (安定したバージョン 13170)
    • Text of notes is now selectable and copyable; links are now clickable
    • Ability to upload data in background
    • Don't select all characters from a text box when switching between JOSM and another application
  • 2017-10-29 (安定したバージョン 13053)
    • Already downloaded areas are displayed in the download window and in the minimap and the layer chooser button was improved
    • New button in the relation editor that selects the relation itself
  • 2017-10-06 (latest version 12926)
    • JOSM now uses a new code signing certificate sponsored by FOSSGIS e.V. (required for WebStart)
  • 2017-10-03 (安定したバージョン 12921)
    • Added links to external changeset viewers to the History and Changeset Manager windows
    • Added feedback request checkbox to the upload window
    • The creating circles function automatically uses a proper node count depending on the circle diameter
    • New command-line parameters to execute certain tasks without graphical user interface:
      • Rendering of osm data using a MapCSS style
      • Converting coordinates from one projection to another
  • 2017-09-02 (安定したバージョン 12712)
  • 2017-07-30 (安定したバージョン 12542)
    • Search by preset in the Search window.
    • New "home location" bookmark (if set in the OSM user settings) and bookmarks of the last 15 changesets.
  • 2017-07-02 (安定したバージョン 12450)
  • 2017-05-29 (安定したバージョン 12275)
  • 2017-05-02 (安定したバージョン 12039)
    • Reprojection (warping) of imagery layers: allows to combine sources of different projections.
  • 2017-04-02 (安定したバージョン 11826)
    • Completely prevent the upload of a layer by "upload=never" in the osm file
    • An option was added to not zoom to the new downloaded data. (expert mode only)
  • 2017-02-27 (安定したバージョン 11639)
    • The GPS Heat Map mode has now some settings to adjust its appearance.
    • Mirror servers of imageries can now be selected in the Imagery Preferences.
  • 2017-02-02 (安定したバージョン 11526)
    • ヒートマップモードでGPSトレースを表示できるようになりました。

2016

  • 2016-12-31 (安定したバージョン 11427)
    • Internal database with boundaries of all countries. Single validator rules and mappaint styles can now e.g. be limited to a specific country.
    • Simply dropping or pasting URLs to download data supports now all URL types from the Open Location window.
    • The key and value text boxes in the add value window are prefilled with the next tag of the list below if the first key is already used.
  • 2016-11-06 (安定したバージョン 11223)
  • 2016-09-05 (安定したバージョン 10966)
  • 2016-08-12 (安定したバージョン 10786)
    • JOSMコアの再構築でJava 8に切り替えました。
    • New function "Paste at source position" in the Edit menu (Ctrl+Alt+V, expert mode only)
    • Support of geo: URLs
  • 2016-07-12 (安定したバージョン 10526)
    • Big rework of the JOSM core
  • 2016-04-28 (安定したバージョン 10161)
  • 2016-03-13 (安定したバージョン 9979)
    • OAuth is now the default authorisation method.
    • Drag & Drop support for the relation editor (more info)
    • New button in relation editor to refresh the relation (e.g. after splitting a way)
    • The History dialog shows the old and new coordinates of a moved node on a map
    • Automatic snap zoom to default resolution of background
    • Extended support of different projections

2015

  • 2015-12-31 (安定したバージョン 9229)
    • Areas are filled only around their inner edges. This and other settings are adjustable in the Style settings of the JOSM Standard mappaint style. More info about Style settings
  • 2015-11-23 (安定したバージョン 9060)
    • ノルウェー語(ブークモール)をサポートしました、
  • 2015-10-30 (安定したバージョン 8969)
    • ウェイの分割: 分割された最長セグメントが既存ウェイの id/history を継承 (上級者モードで別セグメントを選択可)
    • mapview のリスト中でもノードのアイコンを表示 (例 セレクションダイアログ, リレーションエディタ, アップロードダイアログ)
  • 2015-09-28 (安定したバージョン 8800)
    • Overpass ダウンロードの統合と Overpass Turbo ウィザード (上級者モードのみ)
    • Minimap の追加
    • taginfo へのリンクを追加
    • 背景画像のGamma 値が選択可
  • 2015-08-22 (安定したバージョン 8677)
  • 2015-06-17 (安定したバージョン 8491)
    • ベラルーシ語をサポートしました。
    • ベトナム語をサポートしました。
  • 2015-04-18 (8227)
    • バレンシア語をサポートしました。
  • 2015-03-31 (8160)
    • リトアニア語をサポートしました。
  • 2015-03-02 (8109)
    • Windowsでより多くの言語をサポートするためフォントを追加しました。
    • 一部のプラグインについて、インストール後に再起動せずに利用できるようになりました。
    • 右上に検索ボックスを追加しました。
    • Notes(メモ機能) は標準でコアによりサポートされるようになりました(Notesプラグインは廃止予定です)。
  • 2015-02-18
    • JOSMを翻訳するために使用されているLaunchpad web interfaceは、タイムアウトエラーなしで再び動作します。

2014

  • 2014-12-29 (7906)
    • アストゥリアス語とクメール語が追加されました。
    • OS XとWindowsで環境設定、ユーザーデータ、キャッシュのディレクトリが変更されました。
  • 2014-12-10 (7777)
    • 新しいロゴはDiamond00744さんがデザインしました。→ Logo.
    • ダウンロード/アップロードする機能 Note OSMNotes Dialog.
    • サイドメニューの履歴ダイアログを削除し、代わりに選択ダイアログに新しく履歴ボタンを追加しました。
  • 2014-10-21 (7643)
    • キーボードショートカットとCombine Wayの競合の扱いについて、大きいバグを修正しました。
  • 2014-09-30 (7588)
    • Better integration in OS X (see #10455 for details).
    • Display of OSM tags in preset UI.
  • 2014-09-20 (7569)
    • JOSMは、関連する外側のウェイのタグをリレーションに移動すれば解決するような、古い形のマルチポリゴンに警告を報告するようになりました。
  • 2014-08-31 (7480)
    • Improvements of default map style:
      • Node symbols and icons are hidden at low zoom (this can be configured in the style settings).
      • Better label placement inside areas
      • Name of highway is displayed along the way
    • Offline mode with new command line argument --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • 新しいロゴのためのグラフィックコンテストを9/30まで開催しています! 詳しくは wiki を参照してください
  • 2014-07-04 (7287)
    • 押し出し操作に新しくDual alignmentモードを追加しました
    • ローカルのマップスタイルと妥当性検査ルールを自動で再読み込みするようにしました
    • マップ画像(英)を自動更新するようになりました
  • 2014-05-18 (7139)
    • JOSMの標準のマップスタイルをXMLからMapCSS(英)に変更しました
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Javaバージョン7に切り替えました。コードのクリーンナップを行ないました
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • OSM APIにHTTPSでアクセスできるようになりました
  • 2014-01-29 (6767)
    • MapCSSベースでルールによって拡張可能なタグチェッカーを追加しました
    • "オブジェクトをプリセットで検索"を追加しました Shift-F3
    • Presets/MapCSS/Validator を改善しました

2013

  • 2013-12-20 (6502)
    • アップロードダイアログに変更セットのsourceタグの入力欄を追加しました
    • 履歴ダイアログ: 変更セットのコメントを読み込んで表示するようにしました
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg ウェイ精度の改善機能を上級者モード以外でも利用できるようにしました
    • その他多数の機能拡張とバグ修正を行ないました (changelog)
  • 2013-11-17 (6388)
    • 翻訳情報を最新化しました
  • 2013-11-12 (6383)
    • 新しいコマンド「ウェイからノードを切り離す」を追加しました
    • OSMメッセージの新着通知機能を追加しました
    • プリセット、スタイル、妥当性検査やその他の部分に多数の細かい機能拡張を加えました
  • 2013-09-20 (6238)
    • 新たに控え目なメッセージ通知を導入しました
    • 上級者モードのときファイルメニューで"セッション"の項目を使えるようになりました
    • GPXルートの完全なサポートを追加しました
    • プリセット、再起動、スタイル、妥当性検査について多数の細かい機能拡張を加えました。 パフォーマンスの改善を行ないました
  • 2013-08-07 (6115)
    • OAuthの許可要求を変更し、新しいnotes pluginをサポートできるようにしました
    • プラグインメニューをリファクタリングしてグループ化と統合の機能を改善しました
    • 重複したノードがある場合、(最後に)選択したオブジェクトに属するノードを優先して選択するようにしました
    • その他多数の機能拡張とバグ修正を行ないました (changelog)
  • 2013-07-09 (6060)
    • リレーションエディタリレーション選択プロパティの各トグルダイアログで選択したリレーションやオブジェクトをハイライト表示するようにしました
    • 押し出しモード: 修飾キーCtrl で "セグメントに沿ってノードを移動" するようになりました (詳細設定で以前の挙動に戻すことができます)
    • 軌跡に沿ってGPXデータをダウンロードする機能や、ショートカットキー用のプロファイルを設定する機能など(詳細設定を参照)、マイナーな機能拡張を多数行いました
  • 2013-06-05 (5990)
    • プリセットとツールバーのボタンに対してショートカットキーを設定できるようになりました。 設定用のコンテキストメニューの項目として"ショートカットの編集"を追加しました
    • WMSレイヤーを自動的にズームするようにしました
    • ダイアログパネルの表示/非表示を切り替えるアクションをTABキーに割り当てました
  • 2013-05-08 (5939)
    • 再起動プラグインをコアに統合しました
    • テキスト入力欄の右クリックメニューに"取り消し、切り取り、コピー、貼り付け、削除、すべて選択"を追加しました
    • 消去コマンドのパフォーマンスを改善しました
  • 2013-04-08 (5836)
    • コンテキストメニューを作り直しました
    • "文字列からタグを貼り付け"の際、適切な文字列がバッファに含まれていない場合に"バッファをクリア"するボタンを表示するようにしました
    • (非推奨の)画像オフセットサーバのサポートを削除しました
  • 2013-03-07 (5759)
    • Ctrl-Shift-V でコピーした文字列をもとにタグを貼り付けられるようになりました。文字列の例: a=2,c=3a 2 c 3
    • 複数のMapCSSの描画を改善しました
    • 押し出しモードでノードをドラッグできるようになりました
    • プロパティの追加/編集ダイアログのコンテキストメニューにキーボードレイアウトの選択オプションを追加しました
    • GPSトレースを日付でフィルタできるようになりました
    • リモート制御機能: タグの削除とタグ付きのオブジェクト作成ができるようになりました
    • その他、多数の機能拡張とバグ修正を行ないました
  • 2013-02-06 (5697)
    • リレーションの作成時と編集時、リレーションエディタでロールが提案されるようになりました
    • リレーション一覧ダイアログにフィルタ機能を追加しました
    • タグの"値を追加"ダイアログにいくつかの機能を追加しました。 ヘルプボタン、ダイアログ表示位置の記憶、ダイアログを閉じずに複数のタグを続けて追加する機能が含まれています
    • 新しい画像ソース wms_endpoint を追加しました。 WMS/TMSダイアログを作り直しました
    • 住所とwikipediaタグに関する妥当性のチェックを加えました。 レイヤー描画とエラー修正のパフォーマンスを改善しました
    • その他、細かい機能拡張を行ないました

2012

  • 2012-12-08 (5608)
    • 新しい演算子 nth:nth% でウェイ上の位置を検索できるようになりました
    • リモート制御と内部プリセットの細かい機能拡張を行ないました
  • 2012-11-10 (5576)
    • 測定系として "海里" (NM) をサポートしました
  • 2012-10-08 (5531)
    • 建物の妥当性確認機能を再構成しました
    • アップロード時にいくつかのタグを自動的に削除するようにしました(TIGER, odbl, yh)
    • ライセンス変更に関連するコードを削除しました
  • 2012-08-29 (5482, 5485)
    • ダウンロードする領域に応じた画像プロバイダを提示するようにしました
    • タグをノードやウェイ、リレーションに追加するとき、素早く選択できるように最近使った5個のタグを表示するようにしました
    • フィルタツールのマルチポリゴンのサポートを改善しました
    • ’ファイル > 開く...' ダイアログでディレクトリを選択して配下の全ての写真を自動的に読み込むことはできなくなりました。 その代わりに複数の画像ファイルを直接(Ctrl-A や Shift-クリックで)選択することができます。 GPXレイヤのコンテキストメニュー '画像のインポート'ツールでは以前からの方法を使えるので、上位のフォルダを指定することで再帰的に写真を読み込むことができます。
  • 2012-07-23 (5353, 5356)
    • ライセンス変更に伴うデータ修正ボットによって変更されたデータの扱いに関する大きなバグを修正しました
    • マップスタイルと妥当性検査について、非アクティブなレイヤのレンダリングと妥当性検査ダイアログでの名称表示を含む細かい拡張を行ないました
  • 2012-07-03 (5315)
    • 妥当性検査とレイヤをマージする際の競合ダイアログに関する大きなバグを修正しました
    • 競合ダイアログにおいて、ダブルクリックによる選択と(コンテキストメニューから)要素へのズームを含むいくつかの拡張を行ないました
    • 妥当性検査にいくつかの拡張を行ないました
  • 2012-06-04 (5267)
    • 新しい言語をサポートしました: ポルトガル語(ヨーロッパ)(pt), カタロニア語(ca)
    • 投影法のカスタマイズをサポートしました
    • マルチポリゴンを作成するときにタグをリレーションに移動するようにしました
  • 2012-05-02 (5210)
    • 軽微な機能拡張
      • 別の検索ダイアログをデフォルトに変更
      • コマンドライン引数 --load-preferences= を追加。JOSM起動時に設定を適用できます
      • MapCSSでケーシング(外枠線)の左側と右側で別のスタイルを指定できるように変更
  • 2012-04-14 (5181)
    • josm.openstreetmap.de のエントリーページを簡素化して再構成しました。
    • テスト済みバージョン(5181)をリリースしました。 多くの変更と機能拡張が行なわれています。 次のような項目が含まれています。
      • source:trunk/resources/images/mapmode/rope.svg 投げ縄選択モード (上級者モード)
      • 初心者向けの情報ダイアログ: 画像の位置ずれ、リレーションの一部のウェイやタグが衝突するウェイの結合に対する警告
      • リレーション編集時の新機能: "リレーションに選択を追加" (リレーションの右クリックより)、 "前の/次のギャップを選択" (リレーションエディタ内より)
      • 表示メニューのユーザインタフェース拡張: "Map Paint Styles"、 編集ツールバーの非表示機能
      • 起動時間に関するいくつかの改善
  • 2012-02-07 (4905)
    • リレーションエディタ(英)のショートカットキーを追加しました。Alt-Up, Alt-Down (選択したメンバーを上下に移動), Alt-Del (メンバーを削除) , Alt-Home (不完全なメンバーをダウンロード)
    • Changelog概要(英) で安定版リリースの主な変更点を参照できるようになりました。
  • 2012-02-02 (4897 ...)
    • JOSMとプラグインのショートカットキーの衝突を修正しました。 多くの機能のショートカットキーが変更されています!
  • 2012-01-22 (4846)
    • ウェイ精度改善プラグインをコアに取り込みました。 ウェイを選択してsource:trunk/resources/images/mapmode/improvewayaccuracy.svgをクリックし、精度を上げることができます。 詳細な使い方はヘルプページを参照してください。
  • 2012-01-21 (4791, 4796, 4833)
    • RemoteControl機能を拡張しました。 '/load_object' コマンド: IDを指定してオブジェクトをダウンロード。 '/add_way' コマンド: 座標を指定して新しいウェイを作成。 '/load_and_zoom' コマンドの 'new_layer' パラメタ: データを新しいレイヤーに読み込む。
  • 2012-01-12 (4789)
    • 起動時に任意の設定値を指定する新しいコマンドラインオプションを追加しました。 (例: --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • マウスカーソルの下のノードとウェイを強調表示する機能をオフにできるようになりました: '設定' > '表示設定' > 'OSMデータ' (上級者モードのときのみ)
    • ノード描画 source:trunk/resources/images/mapmode/node/autonode.svg ツールで特定の角度(30度/45度など)をもたせた線分を引けるようになりました。 タブキーを押すことでモードを変更できます。
  • 2012-01-04 (4765)
    • 右側のダイアログで自動的にボタンを隠す機能をウィンドウごとに無効化できるようになりました。 (ウィンドウ右上の目のマークを使います)

2011

  • 2011-12-29 (4745)
    • GPXトラックに沿ってWMS背景画像を読み込んでキャッシュするコマンドを追加しました。 (GPXレイヤーの右クリックメニュー)
  • 2011-12-20 (4673)
    • フランスで用いられるランベルト93投影法(EPSG:2154)に対応しました。
  • 2011-12-20 (4670)
    • 翻訳が不足していたため、アラビア語、アイスランド語、ヘブライ語のサポートを削除しました。
  • 2011-12-05 (4621-4636)
    • 大量のマルチポリゴンを扱うときのパフォーマンスを改善しました。
  • 2011-11-26 (4609, 4611)
    • 編集ツールバー(左上部分)を非表示にできるようになりました。
    • ウェイを描いているとき、バックスペースキーで取り消しできるようになりました。
  • 2011-11-20 (4601)
    • 履歴表示画面で各ユーザのライセンス承認状態を表示するようになりました。
  • 2011-11-15 (4595)
    • 複数のキーストロークによるショートカットをサポートします。 例: Ctrl+Alt+S と 1 で一番上のレイヤーの表示/非表示を切り替えます。
  • 2011-11-14 (4593)
    • 小さな画面でメニュー項目を全て表示できない場合でも、上下にスクロールできるようになりました。
  • 2011-11-07 (4587)
    • 検索ダイアログにツールバーボタンとして検索を追加するオプションが加わりました。 このボタンは右クリックメニューから削除できます。 (上級者モードのみ)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • ユーザ設定データを格納する内部フォーマットをXMLに変更しました。
  • 2011-10-29 (4546)
    • ノード、ウェイ、リレーションのテキスト表示をname templatesでカスタマイズできるようになりました。
  • 2011-10-20 (4530)
    • OsmChangeフォーマット(*.osc)を正式にサポートするようになりました。
  • 2011-10-10 (4512)
    • 新規ユーザへの複雑さを軽減するためエキスパートモードを導入しました。 互換性のためインストール済みの環境ではデフォルトでエキスパートモードになっています。
  • 2011-10-07 (4497, 4498, 4500)
    • 'ファイル > オブジェクトをダウンロード...' ダイアログのオプションを追加しました。
    • 履歴ダイアログ: 追加/削除されたウェイやノード、リレーションメンバーの表示を改善しました。
    • プロパティダイアログに新しいショートカットを追加: Alt+A、Alt+S、Alt+Dでそれぞれ追加、編集、削除です。
  • 2011-09-23 (4454)
    • プロパティダイアログで右クリックからタグのキーと値をクリップボードにコピーできるようになりました。
  • 2011-09-12 (4416, 4423)
    • 画像サービスの境界が'設定 > 画像の設定'のプレビューマップに表示されるようになりました。
  • 2011-09-08 (4408)
    • 選択ダイアログのコンテキストメニュー項目'Inspect' は '表示 > 詳細な情報' に移動しました。
  • 2011-09-07 (4405)
    • '設定 > 画像の設定' の一覧は国コードでソートされるようになりました。
  • 2011-08-29 (4380)
    • '編集 > 座標をコピー' の機能を追加しました。
  • 2011-08-28 (4371)
    • 最近使用したファイルを開く機能の一覧に、開いただけではなく保存したファイルも表示するようにしました。
  • 2011-08-27 (4355)
    • 右側のトグルダイアログのボタンについてマウスカーソルをかざすと表示するモードを追加しました(オプションで、高度な設定の'dialog.dynamic.buttons=true'を設定します)。
  • 2011-08-22 (4333)
    • レイヤー表示を切り替えるショートカットキーを追加しました(Alt-1 から Alt-9まで)。
  • 2011-08-21 (4332)
    • 各GPXレイヤーごとに(レイヤーの右クリックメニューから)GPS軌跡の表示を選択できるようになりました。
  • 2011-08-21 (4327)
    • 選択モードと削除モードで、次にどんなアクションが行われるのかがより分かりやすく(強調表示とカーソルの変化で)表現されるようになりました。
  • 2011-07-18 (4256)
    • SVGフォーマットをサポートしました。
  • 2011-07-14 (4241)
    • JPEG画像のEXIFヘッダに含まれるOrientationタグを考慮するようにしました。
  • 2011-07-07 (4207)
    • GPSトレースを方向に基づいて色分けできるようになりました。
  • 2011-06-18 (4142)
    • 押し出しモード: モード選択中(ショートカット x)に線分上でダブルクリックすると新しいノードを追加できます。
  • 2011-06-11 (4126, 4129, 4134)
    • メモリ利用方法の最適化と、GPXトラック表示の高速化を行いました。
    • 新しい描画モード: 既存のウェイに平行するウェイを追加できます。 (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • 新しく Follow Line(ラインをたどる) 機能が追加され、隣接するエリアを楽に書くことができるようになりました。(Potlatch 2のショートカット"F"に似ています)
    • 検索(とフィルター)機能で閉じたウェイを調べることができるようになりました。囲まれたエリアの面積の最小・最大を指定することもできます。 (キーワード: closed; areasize:MIN-MAX または areasize:MAX, 単位はm²)
    • オブジェクトをダウンロード...機能でIDのリストを指定できるようになりました。
  • 2011-04-18 (4032)
    • カスタマイズした検索文字列や背景レイヤをアイコン付きでツールバーに追加できるようになりました。
    • 作者ダイアログのユーザ一覧で再ライセンス承認状態の表示を更新しました。(緑色のチェック - 同意、灰色のチェック - 自動的に同意、赤の× - 拒否)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • 新しいビューポート追随機能 - 追加したノードが常に画面の中心になるモードを追加しました。(メニュー > 表示 > Viewport Following; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • プラグイン imagery,wmsplugin,slippymap,remotecontrol はJOSMのコアに統合されました。
  • 2010-12-07 (3705)
    • レイヤを透過表示できるようになりました。 (レイヤ一覧ダイアログの新しいボタンを使います)
  • 2010-12-07 (3702)
    • オブジェクトの拡大・縮小がサポートされました。 (選択モードでCtrl+Alt)
    • info オブジェクトを回転させるには Ctrl+Shift を押しながらドラッグします。
  • 2010-11-25 (3669)
    • プラグイン Validator はJOSMに統合されました。
  • 2010-09-23 (3557, #5427)
    • Change in “Extrude” mode (X): When moving in one direction multiple times, no superfluous nodes remain. (Shift key forces the old behaviour.)
  • 2010-09-14 (3529)
    • For the tags in the properties dialogue, you can directly open the corresponding wiki-page in a browser.
  • 2010-09-03 (o22964)
    • The WMS plugin supports GetCapabilities requests.
  • 2010-08-13 (3431)
    • The new Purge command can clean up data layers.
  • 2010-07-27 (3388)
    • New tagging preset search dialog.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Search supports searching for role in relation membership.
    • The properties dialog shows position of relation membership.
  • 2010-06-01 (3291)
    • Roles defined in presets are now used. This may result in unexpected validator warnings for relations not yet know to JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
    • With the new Filter feature you can temporarily hide certain kinds of objects.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • New dialog to download an object by id and optionally all ways and relations that use this object.
  • 2010-01-28 (2901)
    • New: Create a duplicate of the selected data layer without a file association.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • プラグインutilsplugin、AgPifoJをJOSMコアに統合しました。
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • 削除モードでのマウスポインターを、削除するオブジェクトの種類に応じて変更するようにしました。
  • 2009-07-15 (1790)
    • リレーションエディターの作り直しが完了。
  • 2009-07-11 (1767)
    • JOSM プラグインは、違うバージョンもサポートするようになりました。 (少なくとも SVN で管理されている plugins である必要があります。) Plugin のアップデートは、plugin が変更されるまで、必要ありません。
  • 2009-07-07 (1743)
    • JOSM は、外部プリセットや、外部線引きのスタイルを簡単に使えるようになりました。Presets 詳しくは、Styles ページを見てください。
  • 2009-06-28 (1709)
    • JOSM上でのエレメントの履歴表示に対応しました。
  • 2009-06-07 (1652)
    • 競合解決のための新しいダイアログが導入されました。(同じノードやウェイが他で変更されたときのためのものです)
  • 2009-05-30 (1628)
    • 設定をUTF-8で保存するよう変更しました。ラテン文字以外のGUIを使っていたユーザーは一度設定を初期化してください。
  • 2009-05-19 (1605)
    • JOSM のデフォルトの投影法が EPSG:4326からメルカトル法に変更されました。
  • 2009-05-19 (1603)
    • parentchildを使った検索をサポートしました。親オブジェクトや子ノードを検索できます。
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • JOSMの翻訳を再構築しました。Languageプラグインを廃止して、翻訳をJOSMに同梱しています。言語は、既定のシステムロケールまたは--languageパラメーターをもとに決定されます。
  • 2008-10-05 (1023)
    • 警告: JOSMがキーボード設定に対応しました。しかし、既定値の一部が変更されました。作業内容を失ってしまう事故を避けるため、キーボードショートカットを確認(およびその設定を)してください。
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • ステータスバーで、追加する線の位置、角度、長さについての情報を表示するようにしました。
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 8 years ago Last modified on 2013-06-25T23:19:10+02:00