wiki:Sk:VersionHistory

Staršie novinky v JOSM

  • 31.07.2020 (stabilná verzia 16812)
  • 02.07.2020 (stabilná verzia 16731)
    • Pridaná funkcia "obnoviť vybrané značky" v okne histórie (cez kontextové menu)
    • Pridané linky na taghistory.raifer.tech
    • Pridaná akcia "Invertovať výber" (len v režime pre expertov)
  • 02.06.2020 (stabilná verzia 16538)
    • Pridaný Perzský a Islandský jazyk
    • Zmena na vyhľadávacie výrazy JOSM v Pomocníkovi pre vyhľadávanie Overpass
    • Vylepšené vykresľovanie kurzora na obrazovkách s vysokou hustotou bodov (HiDPI)
    • Pridaný nástroj na výber farieb v predvoľbách, farba je zobrazená v dialógu vlastností
    • Skok na pozíciu: pridaná možnosť skoku na miesto podľa názvu
  • 06.04.2020 (stabilná verzia 16239)
    • Pridaný arabský jazyk
    • Pridaná podpora pre východoarabské a Khmérske číslice
  • 26.02.2020 (stabilná verzia 15937)
    • Podkladové snímky Maxar sú opäť dostupné
    • Pridané odkazy na regionálne/národné inštancie Taginfo z Geofabriku - veľká vďaka Geofabriku!
    • Vylepšené automatické filtre
    • Okná "Pridať značku" a "Zmeniť hodnotu" zobrazujú ikonu súvisiacej predvoľby/mapového štýlu na tlačidle OK
  • 01.02.2020 (stabilná verzia 15806)
    • Plugin Tag2Link bol vylepšený a integrovaný do jadra JOSM
    • Dvojklikom na posuvníky je možné resetovať prehľadnosť/farebnosť/jas/ostrosť
    • Funkcia Rozdeliť cestu je inteligentnejšia
  • 02.01.2020 (stabilná verzia 15628)
    • Nový odkaz na národné verzie taginfo, ak sú dostupné
    • Možnosť automatického vyplnenia zdroja údajov pre sadu zmien v okne odosielania zmien

2019

  • 02.12.2019 (stabilná verzia 15553)
  • 02.11.2019 (stabilná verzia 15492 (en))
    • Pridaný import formátu GeoJSON
  • 30.09.2019 (stabilná verzia 15390 (en))
  • 26.08.2019 (stabilná verzia 15322 (en))
    • Nové logo
    • Pridávanie značiek sady zmien cez diaľkové ovládanie
  • 10.07.2019 (stabilná verzia 15238 (en))
    • Filtrovanie Mapových podkladov podľa názvu krajiny
  • 02.06.2019 (stabilná verzia 15155 (en))
    • V predvoľbách mapových podkladov boli pridané ikony kategórie a pole pre filtrovanie zoznamu. Kategórie sú: photo (fotografie), historicphoto (historické fotografie), map (mapy), historicmap (historické mapy), osmbasedmap (mapy založené na OSM) a iné.
    • Zobrazenie dynamických položiek mapových podkladov v Menu mapových podkladov (en) v podmenu ak nepatria do kategórie fotografií.
  • 29.04.2019 (stabilná verzia 15031 (en))
    • Plugin 'download_along' (Stiahnuť pozdĺž) bol začlenený do jadra JOSM, v menu Súbor (en) je teraz položka "Stiahnuť pozdĺž..." .
  • 31.03.2019 (stabilná verzia 14945 (en))
  • 02.03.2019 (stabilná verzia 14824 (en))
    • Nový jazyk: Kanadská angličtina
  • 05.02.2019 (stabilná verzia 14760 (en))
    • Naším sponzorom servera je odteraz FOSSGIS e.V. - Ďakujeme firme Hetzner za doterajšiu podporu a firme FOSSGIS za nový výkonný hardvér.

2018

  • 31.12.2018 (stabilná verzia 14620)
    • Automatická šírka stĺpcov tabuľky značiek podľa šírky obsahu
  • 28.11.2018 (stabilná verzia 14460)
    • Sťahovanie údajov: Možnosť "Načítať na novú vrstvu" sa zmenila na samostatné tlačidlo
    • Výška panelov na pravej strane sa pri ukončení JOSM uloží
  • 18.11.2018
  • 28.10.2018 (stabilná verzia 14382)
    • Voľba pre zobrazenie verzií objektov v zoznamoch
  • 02.10.2018 (stabilná verzia 14289)
    • Vylepšenia priradenia obrázkov k stopám gpx
  • 22.08.2018 (stabilná verzia 14178)
  • 18.08.2018 (stabilná verzia 14163)
    • Podpora formátu Overpass API JSON
    • Podpora OSM poznámok (en) v súboroch osmChange (.osc) vytvorených aplikáciou OsmAnd
    • Nastavenie (en) pre konverziu GPX na značky OSM
  • 29.07.2018 (stabilná verzia 14066)
    • Podpora pre OSM dáta spĺňajúce GDPR
  • 09.07.2018 (stabilná verzia 14026)
  • 01.07.2018 (stabilná verzia 13996)
  • 31.05.2018 (stabilná verzia 13878)
  • 27.05.2018 (stabilná verzia 13860)
    • Pridaný Kórejský preklad
    • Výrazné vylepšenia podpory WMS/WMTS
  • 07.05.2018 (stabilná verzia 13710)
    • Pridaných 724 nových projekcií (JOSM teraz podporuje spolu 6135 projekcií)
    • Ikona source:trunk/resources/images/dialogs/layerlist/offset.svg označuje vrstvy v pozadí, ktoré boli posunuté
    • Dvojklik na objekt v okne nahrávania priblíži na daný objekt
  • 26.03.2018 (stabilná verzia 13576)
    • Pridaná podpora pre súkromné a zamknuté dátové vrstvy OSM (en)
    • Pridané kontextové menu do tabuľky značiek v okne histórie (en)
    • Pridaná podpora pre preklady pomocou súborov .lang pre externé dátové zdroje (mapové štýly, pravidlá kontroly, predvoľby)
  • 04.03.2018 (stabilná verzia 13500)
  • 01.03.2018 (stabilná verzia 13478)
  • 28.01.2018 (stabilná verzia 13367)
    • Pridaná podpora pre súbory skomprimované pomocou XZ
    • Lepšia podpora pre WMS 1.3.0

2017

  • 31.12.2017 (stabilná verzia 13265)
  • 26.11.2017 (stabilná verzia 13170)
    • Text poznámok je možné označiť a skopírovať; na odkazy je možné kliknúť
    • Možnosť odosielať dáta na pozadí
    • Pri prepínaní medzi JOSM a inou aplikáciou sa neoznačia všetky znaky v textovom poli
  • 29.10.2017 (stabilná verzia 13053)
    • Stiahnuté oblasti sú zobrazené v okne sťahovania a v minimape a bolo vylepšené tlačidlo na výber vrstiev
    • Nové tlačidlo v editore relácií, ktoré zvolí samotnú reláciu
  • 06.10.2017 (verzia 12926)
    • JOSM odteraz používa nový certifikát na podpisovanie kódu, sponzorovaný FOSSGIS e.V. (vyžadované pre WebStart)
  • 03.10.2017 (stabilná verzia 12921)
    • Linky na externé zobrazovače sád zmien boli pridané do okien Histórie a Manažéra zmenových súborov
    • Do okna odosielania bola pridaná možnosť požiadať o spätnú väzbu
    • Funkcia na vytváranie kružníc automaticky použije počet bodov vhodný k priemeru kružnice
    • Nové parametre pre príkazový riadok na spustenie úloh bez grafického rozhrania:
      • Vykreslenie OSM dát pomocou štýlu MapCSS
      • Konverziu súradníc z jednej projekcie do inej
  • 02.09.2017 (stabilná verzia 12712)
  • 30.07.2017 (stabilná verzia 12542)
    • Vyhľadávanie podľa predvolieb v Okne vyhľadávania.
    • Nová záložka "domovská poloha" (ak je zadaná v používateľských nastaveniach v OSM) a záložky pre 15 posledných sád zmien.
  • 02.07.2017 (stabilná verzia 12450)
  • 29.05.2017 (stabilná verzia 12275)
  • 02.05.2017 (stabilná verzia 12039)
    • Reprojekcia (deformácia) podkladových vrstiev: umožňuje spojiť zdroje z rôznych projekcií.
  • 02.04.2017 (stabilná verzia 11826)
    • Pomocou "upload=never" v osm súbore je možné úplne zabrániť odoslaniu vrstvy
    • Bola pridaná možnosť nepribližovať pohľad na stiahnuté dáta. (len v režime pre expertov)
  • 27.02.2017 (stabilná verzia 11639)
    • Režim teplotnej mapy GPS má nové nastavenia pre úpravu vzhľadu.
    • Zrkadliace servery mapových podkladov je možné vybrať v Nastavení mapových podkladov.
  • 02.02.2017 (stabilná verzia 11526)
    • GPS stopy sa dajú zobraziť v režime teplotnej mapy (heat map) na zvýraznenie hustoty stôp.

2016

  • 31.12.2016 (stabilná verzia 11427)
    • Interná databáza hraníc všetkých krajín. Pravidlá kontroly značiek a mapové štýly môžu byť obmedzené na konkrétne krajiny.
    • Vkladanie URL adries na stiahnutie dát teraz podporuje všetky formáty URL z okna Otvoriť z URL.
    • Textové polia na vkladanie kľúčov a hodnôt v okne "Pridať hodnotu" sú predvyplnené nasledujúcou značkou zo zoznamu, ak je prvý kľúč už použitý.
  • 06.11.2016 (stabilná verzia 11223)
  • 05.09.2016 (stabilná verzia 10966)
  • 12.08.2016 (stabilná verzia 10786)
    • Veľké prepracovanie jadra JOSM a prechod na Java 8
    • Nová funkcia "Prilepiť na pozíciu zdroja" v menu Upraviť (Ctrl+Alt+V, len v režime pre expertov)
    • Podpora pre odkazy geo:
  • 12.07.2016 (stabilná verzia 10526)
    • Veľké prepracovanie jadra JOSM
  • 28.04.2016 (stabilná verzia 10161)
  • 13.03.2016 (stabilná verzia 9979)
    • OAuth je teraz predvolenou metódou prihlasovania.
    • Podpora pre drag&drop v editore relácií (viac informácií)
    • Nové tlačidlo v editore relácií na aktualizáciu relácie (napr. po rozdelení cesty)
    • Okno histórie zobrazuje na mape starú a novú polohu posunutého bodu
    • Automatické naviazanie priblíženia na rozlíšenie vrstvy pozadia
    • Rozšírená podpora pre ďalšie projekcie

2015

  • 31.12.2015 (stabilná verzia 9229)
    • Oblasti sú vyplnené farbou len pozdĺž ich vnútorných okrajov. Toto a podobné nastavenia sú meniteľné v Nastavení štandardného štýlu JOSM. Viac informácií o Nastavení štýlu
  • 23.11.2015 (stabilná verzia 9060)
    • Podpora pre jazyk Nórsky Bokmål
  • 30.10.2015 (stabilná verzia 8969)
    • Rozdelenie cesty: id/história cesty sa použije na najdlhší úsek (experti môžu vybrať iný úsek)
    • Ikony objektov z mapy sa zobrazujú aj v zoznamoch (napr. okno výberu, editor relácií, okno odosielania)
  • 28.09.2015 (stabilná verzia 8800)
    • Začlenenie priameho sťahovania zo služby Overpass a pomocníka Overpass Turbo (len v režime pre expertov)
    • Pridaná minimapa
    • Pridaná linka na službu Taginfo
    • Voliteľná hodnota Gamma pre mapové podklady
  • 22.08.2015 (stabilná verzia 8677)
  • 17.06.2015 (stabilná verzia 8491)
    • Podpora pre Bieloruský jazyk
    • Podpora pre Vietnamský jazyk
  • 2015-04-18 (8227)
    • Podpora pre Katalánsky jazyk
  • 2015-03-31 (8160)
    • Podpora pre Litovský jazyk
  • 2015-03-02 (8109)
    • Doplnené písma na podporu ďalších jazykov vo Windows
    • Niektoré pluginy môžu byť nainštalované a použité bez reštartu JOSM.
    • Nové pole pre hľadanie v hlavnom menu (vpravo hore)
    • Integrovaná podpora pre Poznámky je teraz štandardne zapnutá (plugin je označený ako zastaralý).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Dva nové jazyky: astúrčina a kmérčina.
    • Zmenené priečinky pre nastavenia, používateľské údaje a dočasné údaje na OS X a Windows.
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
    • Opravené vážne chyby v klávesových skratkách a riešení konfliktov v nástroji Spojiť cesty.
  • 2014-09-30 (7588)
    • Lepšia integrácia s OS X (pozri #10455 pre viac detailov).
    • V dialógoch predvolieb sa zobrazujú kľúče príslušných OSM značiek.
  • 2014-09-20 (7569)
    • JOSM odteraz zobrazuje varovania o multipolygónoch so zastaralým štýlom značkovania, ktoré môžu byť opravené presunutím značiek z vonkajších ciest do relácie.
  • 2014-08-31 (7480)
    • Vylepšenia základného štýlu mapy:
      • Symboly bodov a ikony sú pri nízkom priblížení skryté (toto je možné zmeniť v nastaveniach štýlu).
      • Lepšie umiestňovanie nápisov vovnútri oblastí
      • Názov cesty je zobrazený pozdĺž nej
    • Režim offline s novými parametrami pre príkazový riadok --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Do 30. septembra prebieha súťaž o nové logo! Podrobnosti na wiki.
  • 2014-07-04 (7287)
    • Nový režim duálneho zarovnávania pre akciu Vyťahovania
    • Automatické znovunačítanie lokálnych štýlov a pravidiel validátora pri ich zmene
    • Automatické aktualizáce zdrojov mapových podkladov
  • 2014-05-18 (7139)
    • Základný mapový štýl JOSM prekonvertovaný z XML do MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Prechod na Java 7, veľa zlepšení zdrojového kódu
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Prístup na OSM API cez HTTPS
  • 2014-01-29 (6767)
    • Nový systém kontroly značiek založený na MapCSS, rozšíriteľný vlastnými pravidlami
    • Nová funkcia "Hľadať objekty podľa predvoľby" Shift-F3
    • Vylepšenia predvolieb, kontroly chýb, MapCSS

2013

  • 2013-12-20 (6502)
    • Pri odosielaní je vyžadovaná značka o zdroji ("source") pre súbor zmien
    • Okno histórie: zobrazuje komentár zo súboru zmien
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg Nástroj pre zvýšenie presnosti ciest dostupný aj mimo režimu pre expertov
    • Mnoho ďalších vylepšení a opráv chýb (zoznam zmien)
  • 2013-11-17 (6388)
    • Aktualizácia prekladov
  • 2013-11-12 (6383)
    • Nový príkaz na odpojenie bodu od cesty
    • Oznamovanie nových správ na OSM
    • Mnohé vylepšenia predvolieb, štýlov a validátora
  • 2013-09-20 (6238)
    • Nové nerušivé oznámenia
    • Nová skupina "Sedenie" v menu na správu sedení dostupná v režime pre expertov
    • Plná podpora pre GPX trasy
    • Mnoho drobných vylepšení predvolieb, reštartu, štýlov a kontroly chýb a vylepšenia výkonu
  • 2013-08-07 (6115)
    • OAuth autorizácia požadovaná pre plnú podporu nového pluginu notes plugin
    • Prepracovanie menu pluginov pre lepšiu podporu zoskupovania a integrácie
    • Potomok (naposledy) vybraného objektu je uprednostnený keď sú vyberané body s duplicitami
    • Mnoho ďalších vylepšení a opráv chýb (zoznam zmien)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • possibility to set keyboard shortcuts for presets and other toolbar buttons plus new context menu item "Edit shortcut" to define them
    • automatic zoom for WMS layers
    • new "Toggle panels" action on TAB to hide/unhide toggle dialog panel
  • 2013-05-08 (5939)
    • integrate restart plugin into core
    • right click menu "undo, cut, copy, paste, delete, select all" for each text component
    • improve performance of purge command
  • 2013-04-08 (5836)
    • major rework of context menus
    • add "clear buffer" button to remove incorrect buffer from "paste tag from text" action
    • remove support for the (deprecated) imagery offset server
  • 2013-03-07 (5759)
    • Ctrl-Shift-V now can paste tags from text buffer, e.g., a=2,c=3 and a 2 c 3
    • multiple MapCSS rendering improvements
    • allow dragging nodes in Extrude mode
    • context menus in Add/Edit property dialogs, option to fix keyboard layout
    • basic date-filtering of GPS traces
    • remote control: allow deleting tags and creating objects with tags
    • lots of minor enhancements and bug fixes
  • 2013-02-06 (5697)
    • roles are suggested in the relation editor and upon creating a relation
    • possibility to filter in the relation list toggle dialog
    • several enhancements of the "Add Value" dialog including a help button, remembering position and the possibility to add several tags in a row without closing the dialog
    • new imagery entry wms_endpoint and rework of WMS/TMS Dialog
    • new validator test for addresses and wikipedia tags and performance improvement in layer painting and error fixing
    • lots of minor enhancements

2012

  • 2012-12-08 (5608)
    • new operators nth: and nth% allow to search for position in ways
    • some minor enhancement of remote control and internal presets
  • 2012-11-10 (5576)
    • "nautical mile" (NM) is supported as system of measurement
  • 2012-10-08 (5531)
    • rework of validator building test
    • some more tags are automatically discarded on upload (TIGER, odbl, yh)
    • code regarding license change was removed
  • 2012-08-29 (5482, 5485)
    • imagery providers are suggested, according to the downloaded region
    • when adding tags to nodes, ways or relations, the five last used tags are displayed for quicker selection
    • filter tool has better support for multipolygons
    • You can no longer open a directory in the 'File > Open...'-dialog and load all containing photos automatically. Instead, select the image files directly (using Ctrl-A or Shift-Click). The 'Import images' tool from the context menu of a GPX-layer still works in the old way, so you can recursively load photos by opening a higher-level directory.
  • 2012-07-23 (5353, 5356)
    • major bug fixes in handling of data modified by the License change redaction bot
    • small enhancements in map styles and validator tests, including the rendering of inactive layers and the display of names in validator dialog
  • 2012-07-03 (5315)
    • major bug fixes in validator, conflict dialog and when merging layers
    • several enhancements in conflict dialog including option to select (double click) and zoom on elements (context menu)
    • several enhancements in validator tests
  • 2012-06-04 (5267)
    • nové preklady: Portugalčina (Európska) (pt), Katalánčina (ca)
    • podpora pre špeciálne projekcie
    • presunie tagy do relácie pri vytvorení multipolygónu
  • 2012-05-02 (5210)
    • Rôzne drobné vylepšenia
      • alternatívne vyhľadávacie okno je nastavené ako východzie
      • parameter príkazového riadku --load-preferences= pre načítanie konfigurácie JOSM
      • MapCSS umožňuje rozdielne štýly pre pravú a ľavú stranu
  • 2012-04-14 (5181)
    • Úvodná stránka josm.openstreetmap.de bola zjednodušená a reorganizovaná
    • Testovaná verzia (5181) bola vydaná s mnohými zmenamy a vylepšeniami, zahrňujúcimi)
      • source:trunk/resources/images/mapmode/rope.svg režim výberu lasom (v expertnom režime)
      • informačné dialógy pre začiatočníkov: varovanie pred nesprávne zarovnaným podkladom, pri spájaní ciest s konfliktnými tagmi alebo ciest ktoré sú súčasťou relácie
      • nová funkcia pri úprave relácie: "Pridať výber do relácie" (pravým kliknutím na reláciu), "Vybrať predchádzajúcu/nasledujúcu medzeru " (v editore relácie)
      • vylepšenie užívateľského rozhrania v menu Zobraziť: "Farebné štýly mapy", možnosť schovať editačnú nástrojovú lištu
      • niekoľko zlepšení pre zrýchlenie štartu
  • 2012-02-07 (4905)
    • Pribudli klávesové skratky pre editor relácií: Alt-Up, Alt-Down (posun vybraného člena hore/dole), Alt-Del (zmazanie vybraného člena) a Alt-Home (stiahnutie nekompletných členov)
    • Je dostupná súhrnná história zmien v stabilných verziách.
  • 2012-02-02 (4897 ...)
    • Oprava konfliktných klávesových skratiek medzi JOSM a pluginmi. Veľa skratiek bolo zmenených!
  • 2012-01-22 (4846)
    • Plugin ImproveWayAccuracy bol integrovaný do jadra. Vyberte cestu, kliknite na source:trunk/resources/images/mapmode/improvewayaccuracy.svg a zlepšite presnosť. Viac informácií nájdete v nápovede.
  • 2012-01-21 (4791, 4796, 4833)
    • Rôzne rozšírenia funkcionality vzdialeného ovládania: nový príkaz '/load_object' pre stiahnutie objektu podľa id; príkaz '/add_way' pre vytvorenie novej cesty so zadanými koordinátmi; parameter 'new_layer' pre príkaz '/load_and_zoom' spôsobí načítanie dát do novej vrstvy.
  • 2012-01-12 (4789)
    • Nový parameter príkazového riadku pre nastavenie ľubovolnej predvoľby pri štarte. (napr. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Zvýrazňovanie bodov a ciest pod kurzorom sa dá vypnúť: 'Nastavenia...' > 'Nastavenie zobrazenia' > 'OSM Údaje' (iba v režime expert)
    • V režime kreslenia source:trunk/resources/images/mapmode/node/autonode.svg je možné kresliť čiaru pod celočíselným uhlom (30°, 45°,...). Režim kreslenia čiar sa prepína klávesou TAB.
  • 2012-01-04 (4765)
    • Automatické skrývanie tlačítok dialógov na pravej strane sa môže deaktivovať zvlášť pre každé okno. (Symbol oka v pravom hornom rohu)

2011

  • 2011-12-29 (4745)
    • Pribudol nový príkaz pre načítanie a cachovanie WMS podkladov pozdĺž gpx trasy. (V kontextovej ponuke GPX vrstvy)
  • 2011-12-20 (4673)
    • Pre Francúzsko je dostupná projekcia Lambert 93 (EPSG:2154).
  • 2011-12-20 (4670)
    • Z dôvodu nedostatočnej podpory boli odstránené Arabské, Islandské a Hebrejské predklady.
  • 2011-12-05 (4621-4636)
    • Zlepšený výkon pri práci s rozsiahlymi multipolygónmi.
  • 2011-11-26 (4609, 4611)
    • Tlačítka na nástrojovej lište (vľavo hore) sa dajú schovať.
    • Pri kreslení klávesa backspace vráti späť poslednú akciu.
  • 2011-11-20 (4601)
    • História verzií zobrazuje stav akceptácie novej licencie u každého prispievateľa.
  • 2011-11-15 (4595)
    • Podpora pre viac-dielne klávesové skratky, napr. Ctrl+Alt+S a 1 prepne viditeľnosť prvej vrstvy.
  • 2011-11-14 (4593)
    • Menu na malých obrazovkách už nie je orezané ale dá sa posúvať.
  • 2011-11-07 (4587)
    • Vo vyhľadávacom dialógu pribudla možnosť pridať tlačítko na panel nástrojov. Odstrániť sa dá pravým kliknutím na tlačítko. (Iba v režime expert mód.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Interný formát pre ukladanie používateľských dát sa zmenil na XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • Expert mode introduced to reduce complexity for new users. For compatibility existing installations are experts by default.
  • 2011-10-07 (4497, 4498, 4500)
    • More options in 'File > Download Object...' dialog.
    • History dialog: Better display of inserted / deleted way nodes (and relation members).
    • New shortcuts in properties dialog: Alt+A, Alt+S, Alt+D for Add, Edit, Delete.
  • 2011-09-23 (4454)
    • Copy key and value to clipboard by right click in the properties dialog.
  • 2011-09-12 (4416, 4423)
    • Bounds of imagery services are displayed on a preview map in 'Preferences > Imagery'.
  • 2011-09-08 (4408)
    • Menu item 'Inspect' in context menu of the selection dialog has moved to 'View > Advanced Info'.
  • 2011-09-07 (4405)
    • List in 'Preferences > Imagery' is sorted by country code.
  • 2011-08-29 (4380)
    • New feature 'Edit > Copy Coordinates'.
  • 2011-08-28 (4371)
    • The list of recently opened files shows not just opened, but also saved files.
  • 2011-08-27 (4355)
    • Dynamic visibility of button row in toggle dialogs to the right (optional, advanced preferences 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Shortcuts to toggle layer visibility (Alt-1 to Alt-9)
  • 2011-08-21 (4332)
    • Selection of visible tracks, for each gpx layer (from the right click menu of the layer)
  • 2011-08-21 (4327)
    • Select and delete mode now have better visual indication what the next action will do (highlighting, cursor changes).
  • 2011-07-18 (4256)
    • Support for the SVG image format.
  • 2011-07-14 (4241)
    • Takes Orientation in EXIF header of JPEG images into account.
  • 2011-07-07 (4207)
    • GPS traces can be coloured with respect to the direction.
  • 2011-06-18 (4142)
    • Extrude Mode: A double click at a line segment inserts a new point.
  • 2011-06-11 (4126, 4129, 4134)
    • Memory optimizations and faster drawing of GPX tracks
    • New drawing mode: Add a parallel way next to an existing one. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • New Follow Line feature to ease drawing of adjacent areas. (similar to Potlatch 2's "F" shortcut)
    • Search (and Filter) can query closed ways now, and those enclosing a certain minimum and maximum area. (Keywords: closed; areasize:MIN-MAX or areasize:MAX, in m²)
    • The download Object... feature now accepts a list of ids.
  • 2011-04-18 (4032)
    • Add multiple customized search strings or background layers with its own icon to the toolbar.
    • Update of re-licensing status display in the user list (green check - agreed, gray check - agreed automatically, red cross - disagreed)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • New Viewport Following function - moves the viewport so that the last placed node is in the center. (Main Menu > View; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Plugins imagery,wmsplugin,slippymap and remotecontrol are integrated into JOSM core.
  • 2010-12-07 (3705)
    • Layers can be displayed transparently. (new button in layer list dialog)
  • 2010-12-07 (3702)
    • Scaling of objects is supported. (Ctrl+Alt in select mode)
    • info To rotate an object click Ctrl+Shift.
  • 2010-11-25 (3669)
    • The Validator plugin has been integrated into the main program.
  • 2010-09-23 (3557, #5427)
    • Change in “Extrude” mode (X): When moving in one direction multiple times, no superfluous nodes remain. (Shift key forces the old behaviour.)
  • 2010-09-14 (3529)
    • For the tags in the properties dialogue, you can directly open the corresponding wiki-page in a browser.
  • 2010-09-03 (o22964)
    • The WMS plugin supports GetCapabilities requests.
  • 2010-08-13 (3431)
    • The new Purge command can clean up data layers.
  • 2010-07-27 (3388)
    • New tagging preset search dialog.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Search supports searching for role in relation membership.
    • The properties dialog shows position of relation membership.
  • 2010-06-01 (3291)
    • Roles defined in presets are now used. This may result in unexpected validator warnings for relations not yet know to JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
    • With the new Filter feature you can temporarily hide certain kinds of objects.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • New dialog to download an object by id and optionally all ways and relations that use this object.
  • 2010-01-28 (2901)
    • New: Create a duplicate of the selected data layer without a file association.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • The plugins utilsplugin and AgPifoJ have been integrated in JOSM core.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 8 years ago Last modified on 2013-06-25T23:20:00+02:00