wiki:Ko:VersionHistory

Older JOSM News

  • 2020-07-31 (안정적인 버전 16812)
  • 2020-07-02 (안정적인 버전 16731)
    • 역사 창에 "선택한 태그 복구" 버튼 추가
    • taghistory.raifer.tech로 연결되는 링크 추가
    • "선택한 지물 반전" 기능 추가(전문가 모드를 활성화해야 함)
  • 2020-06-02 (안정적인 버전 16538)
    • 페르시아어, 아이슬란드어 추가
    • Overpass 쿼리 마법사에 적용되는 JOSM 검색 문법 변경
    • HiDPI 화면에서 마우스 커서가 흐리게 보이는 문제 수정
    • 사전 설정(프리셋)의 속성 창에 색상을 적용하는 기능 추가
    • 이제 장소명을 이용해 원하는 위치로 이동할 수 있음('특정 위치로 이동' 기능 이용)
  • 2020-04-06 (안정적인 버전 16239)
    • 아랍어 추가
    • 동부 아랍어 숫자와 크메르 숫자 지원
  • 2020-02-26 (안정적인 버전 15937)
    • Maxar 이미지가 다시 돌아옴
    • Geofabrik 지역별/국가별 taginfo 사이트와 연결되는 링크 추가 - Geofabrik에게 감사드립니다!
    • 자동 필터링 개선
    • "태그 추가" 창과 "값 변경" 창의 확인 버튼 위에 관련 프리셋/지도 표시 스타일 아이콘이 뜸
  • 2020-02-01 (안정적인 버전 15806)
    • Tag2Link 플러그인이 JOSM 기본 기능으로 포함됨 + Tag2Link 플러그인 기능 개선
    • 슬라이더를 더블 클릭하면 투명도/채도/감마 값/선명도를 초기화할 수 있음
    • 선 분할 기능이 더 똑똑해짐
  • 2020-01-02 (안정적인 버전 15628)
    • 국가별 taginfo 인스턴스로 이동하는 링크 추가(인스턴스가 있을 경우에만)
    • 업로드 화면에서 자동으로 바뀜집합 출처 태그를 채워주는 옵션 추가

2019

  • 2019-12-02 (안정적인 버전 15553)
    • 마라티어 추가
    • GPX 레이어 개선
  • 2019-11-02 (안정적인 버전 15492 (en))
    • GeoJSON 가져오기 기능 추가
  • 2019-09-30 (안정적인 버전 15390 (en))
    • 이제 레이어 목록에서 각 레이어의 번호를 볼 수 있음. 참고로 alt+(레이어 번호)를 누르면 해당 레이어를 켜고 끌 수 있습니다(레이어 단축키 (en) 참고).
  • 2019-08-26 (안정적인 버전 15322 (en))
    • 새로운 로고
    • 원격 조종으로 바뀜집합 태그를 추가할 수 있음
  • 2019-07-10 (안정적인 버전 15238 (en))
    • 이미지를 국가명으로 필터링하는 기능 추가
  • 2019-06-02 (안정적인 버전 15155 (en))
    • 이미지 설정 창에 분류 아이콘 및 필터 추가(사진, 과거 사진, 지도, 과거 지도, 오픈스트리트맵 기반 지도, 기타)
    • 사진 카테고리에 속해 있지 않은 이미지들은 이미지 메뉴 (en)의 하위 메뉴에서 볼 수 있음
  • 2019-04-29 (안정적인 버전 15031 (en))
    • download_along 플러그인을 기본 기능으로 추가, 파일 메뉴 (en)에 "Download along..." 버튼 추가
  • 2019-03-31 (안정적인 버전 14945 (en))
  • 2019-03-02 (안정적인 버전 14824 (en))
    • 캐나다 영어 추가
  • 2019-02-05 (안정적인 버전 14760 (en))
    • JOSM 서버를 FOSSGIS e.V.에서 제공하는 서버로 옮김 - 장소를 지원해 주신 Hetzner에게, 그리고 강력한 하드웨어를 지원해 주신 FOSSGIS에게 감사드립니다.

2018

  • 2018-12-31 (안정적인 버전 14620)
    • 태그 표에 들어가 있는 값에 따라 폭을 자동으로 조정
  • 2018-11-28 (안정적인 버전 14460)
    • 데이터 다운로드: "새 레이어로 다운로드"가 체크박스에서 버튼으로 변경
    • JOSM을 닫을 때 오른쪽에 있는 창(패널)들의 높이를 저장함
  • 2018-11-18
  • 2018-10-28 (안정적인 버전 14382)
    • 설정을 통해 목록에서 개체의 버전을 띄울 수 있음
  • 2018-10-02 (안정적인 버전 14289)
    • GPX 궤적을 이용한 이미지 교정 기능을 강화
  • 2018-08-22 (안정적인 버전 14178)
  • 2018-08-18 (안정적인 버전 14163)
    • Overpass API JSON 포맷 지원
    • OSMAnd에서 생성된 osmChange 파일(.osc)의 참고 (en) 지원
    • GPX를 OSM 태그로 변환하는 옵션 (en) 추가
  • 2018-07-29 (안정적인 버전 14066)
    • GDPR을 준수하는 OSM 데이터 지원
  • 2018-07-09 (안정적인 버전 14026)
  • 2018-07-01 (안정적인 버전 13996)
  • 2018-05-31 (안정적인 버전 13878)
  • 2018-05-27 (안정적인 버전 13860)
    • 한국어 번역 추가
    • WMS/WMTS 지원에서 주요한 개선
  • 2018-05-07 (안정적인 버전 13710)
    • 새로운 화상 724개 추가 (JOSM은 현재 총 6135개의 화상을 지원합니다)
    • source:trunk/resources/images/dialogs/layerlist/offset.svg 아이콘을 이동(정렬)한 배경 레이어에 표시
    • 업로드 창에서 요소를 더블 클릭하면 그 요소로 확대됩니다
  • 2018-03-26 (안정적인 버전 13576)
    • 보안과 잠긴 OSM 데이터 레이어 (en) 관련한 지원 추가
    • 역사 창 (en)의 태그 표에서 콘텍스트 메뉴 추가
    • 외부 데이터(지도 스타일, 규칙, 사전 설정)에 대해 .lang 파일의 변환에 대한 지원 추가
  • 2018-03-04 (안정적인 버전 13500)
  • 2018-03-01 (안정적인 버전 13478)
  • 2018-01-28 (안정적인 버전 13367)
    • XZ 압축 파일 지원 추가
    • WMS 1.3.0에 대한 기존보다 더 나아진 지원

2017

  • 2017-12-31 (안정적인 버전 13265)
  • 2017-11-26 (stable version 13170)
    • Text of notes is now selectable and copyable; links are now clickable
    • Ability to upload data in background
    • Don't select all characters from a text box when switching between JOSM and another application
  • 2017-10-29 (stable version 13053)
    • Already downloaded areas are displayed in the download window and in the minimap and the layer chooser button was improved
    • New button in the relation editor that selects the relation itself
  • 2017-10-06 (latest version 12926)
    • JOSM now uses a new code signing certificate sponsored by FOSSGIS e.V. (required for WebStart)
  • 2017-10-03 (stable version 12921)
    • Added links to external changeset viewers to the History and Changeset Manager windows
    • Added feedback request checkbox to the upload window
    • The creating circles function automatically uses a proper node count depending on the circle diameter
    • New command-line parameters to execute certain tasks without graphical user interface:
      • Rendering of osm data using a MapCSS style
      • Converting coordinates from one projection to another
  • 2017-09-02 (stable version 12712)
  • 2017-07-30 (stable version 12542)
    • Search by preset in the Search window.
    • New "home location" bookmark (if set in the OSM user settings) and bookmarks of the last 15 changesets.
  • 2017-07-02 (stable version 12450)
  • 2017-05-29 (stable version 12275)
  • 2017-05-02 (stable version 12039)
    • Reprojection (warping) of imagery layers: allows to combine sources of different projections.
  • 2017-04-02 (stable version 11826)
    • Completely prevent the upload of a layer by "upload=never" in the osm file
    • An option was added to not zoom to the new downloaded data. (expert mode only)
  • 2017-02-27 (stable version 11639)
    • The GPS Heat Map mode has now some settings to adjust its appearance.
    • Mirror servers of imageries can now be selected in the Imagery Preferences.
  • 2017-02-02 (stable version 11526)
    • GPS traces can now be displayed in the new Heat Map mode.

2016

  • 2016-12-31 (stable version 11427)
    • Internal database with boundaries of all countries. Single validator rules and mappaint styles can now e.g. be limited to a specific country.
    • Simply dropping or pasting URLs to download data supports now all URL types from the Open Location window.
    • The key and value text boxes in the add value window are prefilled with the next tag of the list below if the first key is already used.
  • 2016-11-06 (stable version 11223)
  • 2016-09-05 (stable version 10966)
  • 2016-08-12 (stable version 10786)
  • 2016-07-12 (stable version 10526)
    • Big rework of the JOSM core
  • 2016-04-28 (stable version 10161)
  • 2016-03-13 (stable version 9979)
    • OAuth is now the default authorisation method.
    • Drag & Drop support for the relation editor (more info)
    • New button in relation editor to refresh the relation (e.g. after splitting a way)
    • The History dialog shows the old and new coordinates of a moved node on a map
    • Automatic snap zoom to default resolution of background
    • Extended support of different projections

2015

  • 2015-12-31 (stable version 9229)
    • Areas are filled only around their inner edges. This and other settings are adjustable in the Style settings of the JOSM Standard mappaint style. More info about Style settings
  • 2015-11-23 (stable version 9060)
    • Support Norwegian Bokmål language
  • 2015-10-30 (stable version 8969)
    • Way splitting: reuse id/history of existing way for longest split segment (expert users can choose another segment)
    • Display node icons from mapview also in lists (e.g. in selection dialog, relation editor or upload dialog)
  • 2015-09-28 (stable version 8800)
    • Integration of Overpass download and Overpass Turbo Wizard (Expert mode only)
    • Added Minimap
    • Added link to taginfo
    • Selectable Gamma value for background imagery
  • 2015-08-22 (stable version 8677)
  • 2015-06-17 (stable version 8491)
    • Support Belarusian language
    • Support Vietnamese language
  • 2015-04-18 (8227)
    • Support Valencian language
  • 2015-03-31 (8160)
    • Support Lithuanian language
  • 2015-03-02 (8109)
    • More fonts to support more languages on Windows
    • Some plugins can now be installed and used without a restart of JOSM.
    • New search box for main menu (top right)
    • The core Notes support is now enabled by default (the plugin is deprecated).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Two new languages: Asturian and Khmer.
    • Preferences, user data, and cache directories changed on OS X and Windows.
  • 2014-12-10 (7777)
    • New logo designed by Diamond00744.
    • Ability to download/upload OSM Notes.
    • Removed history dialog in side menus in favour of a new history button in selection dialog.
  • 2014-10-21 (7643)
    • Fixed major bugs in keyboard shortcuts and Combine Way conflicts handling.
  • 2014-09-30 (7588)
    • Better integration in OS X (see #10455 for details).
    • Display of OSM tags in preset UI.
  • 2014-09-20 (7569)
    • JOSM now issues warnings for old style multipolygons which can be solved by transferring the relevant tags from outer ways to the relation.
  • 2014-08-31 (7480)
    • Improvements of default map style:
      • Node symbols and icons are hidden at low zoom (this can be configured in the style settings).
      • Better label placement inside areas
      • Name of highway is displayed along the way
    • Offline mode with new command line argument --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • We're holding a graphics contest until 30th of September to get a new logo! See wiki for details.
  • 2014-07-04 (7287)
    • New dual alignment mode for Extrude action
    • Automatic reloading of local map paint styles and validator rules
    • Automatic update for imagery entries
  • 2014-05-18 (7139)
    • JOSM's default map style converted from XML to MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Switch to Java version 7, many code cleanups
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Allow HTTPS access to OSM API
  • 2014-01-29 (6767)
    • New MapCSS-based tag checker, extensible via custom rules
    • Add "Search for objects by preset" action Shift-F3
    • Presets/MapCSS/Validator improvements

2013

  • 2013-12-20 (6502)
    • Ask for changeset source tag in upload dialog
    • History dialog: load and display changeset comment
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg Improve way accuracy enabled for non-experts
    • Many other enhancements and bug fixes (changelog)
  • 2013-11-17 (6388)
    • Up-to-date language files
  • 2013-11-12 (6383)
    • New command to disconnect node from way
    • Notification of newly received OSM messages
    • Many minor enhancements of presets, styles and validator plus other parts
  • 2013-09-20 (6238)
    • New non-intrusive notification messages
    • New "session" item in file menu visible in expert mode
    • Complete support of GPX routes
    • Lots of minor enhancement of presets, restart, styles and validator plus performance improvements
  • 2013-08-07 (6115)
    • Request OAuth permission to fully support the new notes plugin
    • Refactoring of the plugin menus to support better grouping and integration
    • Prefer the child node of (last) selected objects when selecting nodes with duplicates
    • Many other enhancements and bug fixes (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • possibility to set keyboard shortcuts for presets and other toolbar buttons plus new context menu item "Edit shortcut" to define them
    • automatic zoom for WMS layers
    • new "Toggle panels" action on TAB to hide/unhide toggle dialog panel
  • 2013-05-08 (5939)
    • integrate restart plugin into core
    • right click menu "undo, cut, copy, paste, delete, select all" for each text component
    • improve performance of purge command
  • 2013-04-08 (5836)
    • major rework of context menus
    • add "clear buffer" button to remove incorrect buffer from "paste tag from text" action
    • remove support for the (deprecated) imagery offset server
  • 2013-03-07 (5759)
    • Ctrl-Shift-V now can paste tags from text buffer, e.g., a=2,c=3 and a 2 c 3
    • multiple MapCSS rendering improvements
    • allow dragging nodes in Extrude mode
    • context menus in Add/Edit property dialogs, option to fix keyboard layout
    • basic date-filtering of GPS traces
    • remote control: allow deleting tags and creating objects with tags
    • lots of minor enhancements and bug fixes
  • 2013-02-06 (5697)
    • roles are suggested in the relation editor and upon creating a relation
    • possibility to filter in the relation list toggle dialog
    • several enhancements of the "Add Value" dialog including a help button, remembering position and the possibility to add several tags in a row without closing the dialog
    • new imagery entry wms_endpoint and rework of WMS/TMS Dialog
    • new validator test for addresses and wikipedia tags and performance improvement in layer painting and error fixing
    • lots of minor enhancements

2012

  • 2012-12-08 (5608)
    • new operators nth: and nth% allow to search for position in ways
    • some minor enhancement of remote control and internal presets
  • 2012-11-10 (5576)
    • "nautical mile" (NM) is supported as system of measurement
  • 2012-10-08 (5531)
    • rework of validator building test
    • some more tags are automatically discarded on upload (TIGER, odbl, yh)
    • code regarding license change was removed
  • 2012-08-29 (5482, 5485)
    • imagery providers are suggested, according to the downloaded region
    • when adding tags to nodes, ways or relations, the five last used tags are displayed for quicker selection
    • filter tool has better support for multipolygons
    • You can no longer open a directory in the 'File > Open...'-dialog and load all containing photos automatically. Instead, select the image files directly (using Ctrl-A or Shift-Click). The 'Import images' tool from the context menu of a GPX-layer still works in the old way, so you can recursively load photos by opening a higher-level directory.
  • 2012-07-23 (5353, 5356)
    • major bug fixes in handling of data modified by the License change redaction bot
    • small enhancements in map styles and validator tests, including the rendering of inactive layers and the display of names in validator dialog
  • 2012-07-03 (5315)
    • major bug fixes in validator, conflict dialog and when merging layers
    • several enhancements in conflict dialog including option to select (double click) and zoom on elements (context menu)
    • several enhancements in validator tests
  • 2012-06-04 (5267)
    • new languages: Portuguese (European) (pt), Catalan (ca)
    • support for custom projections
    • move tags to relation when creating a multipolygon
  • 2012-05-02 (5210)
    • Some minor enhancements
      • make alternative search dialog default
      • command line argument --load-preferences= to apply settings on JOSM start
      • Allow MapCSS to style right and left side casings differently
  • 2012-04-14 (5181)
    • The entry page of josm.openstreetmap.de has been simplified and re-organized
    • A tested version (5181) has been released with many changes/enhancements, these include
      • source:trunk/resources/images/mapmode/rope.svg lasso selection mode (expert mode)
      • information dialogs for beginners: warning against misaligned imagery, when combining ways with conflicting tags or ways being part of relations
      • new features for relation editing: "Add selection to relation" (when right-clicking a relation), "Select previous/next Gap" (in relation editor)
      • user interface enhancements in View menu: "Map Paint Styles", ability to hide edit toolbar
      • several improvements in startup time
  • 2012-02-07 (4905)
    • Shortcuts for the Relation Editor have been added: Alt-Up, Alt-Down (move selected member up/down), Alt-Del (delete member) and Alt-Home (download incomplete members)
    • A summarized change log is available which contains relevant changes between stable releases.
  • 2012-02-02 (4897 ...)
    • Conflicting shortcuts in JOSM and plugins get fixed. All lot of function shortcuts will change!
  • 2012-01-22 (4846)
    • The ImproveWayAccuracy plugin has been added to core. Select a way, click source:trunk/resources/images/mapmode/improvewayaccuracy.svg, and improve its accuracy. Check the help page for a detailed usage.
  • 2012-01-21 (4791, 4796, 4833)
    • Various extensions for the RemoteControl feature: new command '/load_object' to download objects by id; '/add_way' command to create a new way with certain coordinates; parameter 'new_layer' for the '/load_and_zoom' command to load the data into a new layer.
  • 2012-01-12 (4789)
    • New command line option to set an arbitrary preference value on start. (e.g. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Highlight for nodes and ways under the mouse cursor can be turned off: 'Preferences' > 'Display Settings' > 'OSM Data' (Only in Expert mode)
    • The drawing action source:trunk/resources/images/mapmode/node/autonode.svg allows to draw segments with discrete angles (e.g., 30/45°). Press the tabulator key to cycle through different modes.
  • 2012-01-04 (4765)
    • The automatic hiding of buttons for the right hand side dialogs can be disabled for each window individually. (Eye-symbol in the upper right corner)

2011

  • 2011-12-29 (4745)
    • New command to load and cache WMS background images along a gpx track in advance. (In right click menu of GPX-Layer)
  • 2011-12-20 (4673)
    • Lambert 93 projection (EPSG:2154) is available for France.
  • 2011-12-20 (4670)
    • Languages Arabic, Icelandic and Hebrew have been removed due to missing translation efforts.
  • 2011-12-05 (4621-4636)
    • Performance with large multipolygons improved.
  • 2011-11-26 (4609, 4611)
    • The buttons of the edit toolbar (upper left area) can be hidden.
    • When drawing ways, the backspace key takes back the last action.
  • 2011-11-20 (4601)
    • The version history display now shows the license status for each contributing user.
  • 2011-11-15 (4595)
    • Support for multipart shortcuts. For example Ctrl+Alt+S, 1 toggles the visibility of the first layer.
  • 2011-11-14 (4593)
    • On small screens, long menus are no longer clipped, but can be scrolled up and down.
  • 2011-11-07 (4587)
    • New option in the search dialog to add a toolbar button for the search. The button can be removed later from the right click menu of the button. (Only in expert mode.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • The internal format for saving user preference data has been changed to XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • Expert mode introduced to reduce complexity for new users. For compatibility existing installations are experts by default.
  • 2011-10-07 (4497, 4498, 4500)
    • More options in 'File > Download Object...' dialog.
    • History dialog: Better display of inserted / deleted way nodes (and relation members).
    • New shortcuts in properties dialog: Alt+A, Alt+S, Alt+D for Add, Edit, Delete.
  • 2011-09-23 (4454)
    • Copy key and value to clipboard by right click in the properties dialog.
  • 2011-09-12 (4416, 4423)
    • Bounds of imagery services are displayed on a preview map in 'Preferences > Imagery'.
  • 2011-09-08 (4408)
    • Menu item 'Inspect' in context menu of the selection dialog has moved to 'View > Advanced Info'.
  • 2011-09-07 (4405)
    • List in 'Preferences > Imagery' is sorted by country code.
  • 2011-08-29 (4380)
    • New feature 'Edit > Copy Coordinates'.
  • 2011-08-28 (4371)
    • The list of recently opened files shows not just opened, but also saved files.
  • 2011-08-27 (4355)
    • Dynamic visibility of button row in toggle dialogs to the right (optional, advanced preferences 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Shortcuts to toggle layer visibility (Alt-1 to Alt-9)
  • 2011-08-21 (4332)
    • Selection of visible tracks, for each gpx layer (from the right click menu of the layer)
  • 2011-08-21 (4327)
    • Select and delete mode now have better visual indication what the next action will do (highlighting, cursor changes).
  • 2011-07-18 (4256)
    • Support for the SVG image format.
  • 2011-07-14 (4241)
    • Takes Orientation in EXIF header of JPEG images into account.
  • 2011-07-07 (4207)
    • GPS traces can be coloured with respect to the direction.
  • 2011-06-18 (4142)
    • Extrude Mode: A double click at a line segment inserts a new point.
  • 2011-06-11 (4126, 4129, 4134)
    • Memory optimizations and faster drawing of GPX tracks
    • New drawing mode: Add a parallel way next to an existing one. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • New Follow Line feature to ease drawing of adjacent areas. (similar to Potlatch 2's "F" shortcut)
    • Search (and Filter) can query closed ways now, and those enclosing a certain minimum and maximum area. (Keywords: closed; areasize:MIN-MAX or areasize:MAX, in m²)
    • The download Object... feature now accepts a list of ids.
  • 2011-04-18 (4032)
    • Add multiple customized search strings or background layers with its own icon to the toolbar.
    • Update of re-licensing status display in the user list (green check - agreed, gray check - agreed automatically, red cross - disagreed)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • New Viewport Following function - moves the viewport so that the last placed node is in the center. (Main Menu > View; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Plugins imagery,wmsplugin,slippymap and remotecontrol are integrated into JOSM core.
  • 2010-12-07 (3705)
    • Layers can be displayed transparently. (new button in layer list dialog)
  • 2010-12-07 (3702)
    • Scaling of objects is supported. (Ctrl+Alt in select mode)
    • info To rotate an object click Ctrl+Shift.
  • 2010-11-25 (3669)
    • The Validator plugin has been integrated into the main program.
  • 2010-09-23 (3557, #5427)
    • Change in “Extrude” mode (X): When moving in one direction multiple times, no superfluous nodes remain. (Shift key forces the old behaviour.)
  • 2010-09-14 (3529)
    • For the tags in the properties dialogue, you can directly open the corresponding wiki-page in a browser.
  • 2010-09-03 (o22964)
    • The WMS plugin supports GetCapabilities requests.
  • 2010-08-13 (3431)
    • The new Purge command can clean up data layers.
  • 2010-07-27 (3388)
    • New tagging preset search dialog.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Search supports searching for role in relation membership.
    • The properties dialog shows position of relation membership.
  • 2010-06-01 (3291)
    • Roles defined in presets are now used. This may result in unexpected validator warnings for relations not yet know to JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
    • With the new Filter feature you can temporarily hide certain kinds of objects.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • New dialog to download an object by id and optionally all ways and relations that use this object.
  • 2010-01-28 (2901)
    • New: Create a duplicate of the selected data layer without a file association.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • The plugins utilsplugin and AgPifoJ have been integrated in JOSM core.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 16 months ago Last modified on 2019-11-03T15:08:36+01:00