wiki:Ru:VersionHistory

Архив новостей JOSM

  • 02.10.2018 (стабильная версия 14289)
    • Различные улучшения для привязки изображений к gpx-трекам
  • 22.08.2018 (стабильная версия 14178)
    • Показ названия языка, обозначаемого аббревиатурой в ключах name:xx, в диалоговой панели Теги/Участие
  • 18.08.2018 (стабильная версия 14163)
    • Поддержка JSON-формата для Overpass API
    • Поддержка Заметок в файлах osmChange (.osc), созданных в OSMAnd
    • Настройки для преобразования тегов GPX в теги OSM
  • 29.07.2018 (стабильная версия 14066)
    • Поддержка данных OSM, соответствующих требованиям GDPR
  • 09.07.2018 (стабильная версия 14026)
  • 01.07.2018 (стабильная версия 13996)
  • 31.05.2018 (стабильная версия 13878)
  • 27.05.2018 (стабильная версия 13860)
    • Добавлен перевод на корейский язык
    • Значительные улучшения в поддержке WMS/WMTS
  • 07.05.2018 (стабильная версия 13710)
    • Добавлены 724 новые проекции (теперь JOSM поддерживает 6135 проекций)
    • Значком source:trunk/images/dialogs/layerlist/offset.png обозначаются подложки, для которых было выполнено смещение (выравнивание по трекам)
    • Двойной щелчок на элементе в окне передачи данных на сервер масштабирует до этого элемента
  • 26.03.2018 (стабильная версия 13576)
    • Добавлена поддержка приватных и заблокированных слоёв данных OSM
    • Добавлено контекстное меню для таблицы тегов окна журнала
    • Добавлена поддержка переводов с помощью файлов .lang для внешних данных (стилей отрисовки карты, правил проверки, заготовок тегов)
  • 04.03.2018 (стабильная версия 13500)
  • 01.03.2018 (стабильная версия 13478)
  • 28.01.2018 (стабильная версия 13367)
    • Добавлена поддержка сжатых XZ файлов
    • Улучшена поддержка WMS 1.3.0

2017

  • 31.12.2017 (стабильная версия 13265)
  • 26.11.2017 (стабильная версия 13170)
    • Текст заметок теперь можно выделять и копировать; на ссылках можно щёлкать
    • Возможность отправки данных на сервер в фоновом режиме
    • Больше не выделяются все символы в текстовом поле при переключении между JOSM и другим приложением
  • 29.10.2017 (стабильная версия 13053)
    • Уже загруженные области отображаются в окне скачивания данных и на мини-карте. Улучшена кнопка выбора слоя в окне скачивания данных
    • Новая кнопка в редакторе отношений для выделения самого отношения
  • 06.10.2017 (последняя разрабатываемая версия 12926)
    • JOSM теперь использует новый сертификат подписи кода, спонсируемый FOSSGIS e.V. (требуется для WebStart)
  • 03.10.2017 (стабильная версия 12921)
    • Добавлены ссылки на внешние средства просмотра пакетов правок в окнах Журнал и Менеджер пакетов правок
    • Добавлен флажок "Я хочу, чтобы кто-нибудь проверил мои правки" в окне отправки данных на сервер
    • Функция создания окружностей автоматически использует подходящее количество точек в зависимости от диаметра окружности
    • Новые параметры командной строки для выполнения некоторых задач без графического интерфейса:
      • Отрисовка данных OSM с использованием стиля MapCSS
      • Преобразование координат из одной проекции в другую
  • 02.09.2017 (стабильная версия 12712)
  • 30.07.2017 (стабильная версия 12542)
    • Поиск по заготовке в окне поиска.
    • Новая закладка «домашнее местоположение» (если задано в настройках пользователя OSM) и закладки для последних 15 пакетов правок.
  • 02.07.2017 (стабильная версия 12450)
  • 29.05.2017 (стабильная версия 12275)
  • 02.05.2017 (стабильная версия 12039)
    • Изменение проекции (деформирование) слоёв подложек: позволяет комбинировать источники снимков с разными проекциями.
  • 02.04.2017 (стабильная версия 11826)
    • Полное предотвращение отправки слоя на сервер с помощью "upload=never" в файле osm
    • Добавлена опция, препятствующая масштабированию до новых скачанных данных. (только в режиме эксперта)
  • 27.02.2017 (стабильная версия 11639)
    • Теперь у режима тепловой карты GPS-треков есть несколько настроек для изменения внешнего вида.
    • У подложек есть сервера-зеркала, доступны из меню настроек.
  • 02.02.2017 (стабильная версия 11526)
    • GPS-треки теперь могут быть отображены в новом режиме «тепловой карты» (разными цветами в зависимости от количества треков в данном месте).

2016

  • 31.12.2016 (стабильная версия 11427)
    • Внутренняя база данных с границами всех стран. Теперь правила валидатора и стили mappaint могут быть, например, ограничены отдельной страной.
    • Перетаскивание или вставка URL для загрузки данных теперь поддерживает все типы URL из окна Открыть адрес.
    • Текстовые поля ключ/значение в окне добавления значения автоматичски заполняются следующим тегом из списка ниже, если первый ключ уже использован.
  • 06.11.2016 (стабильная версия 11223)
  • 05.09.2016 (стабильная версия 10966)
  • 12.08.2016 (стабильная версия 10786)
  • 12.07.2016 (стабильная версия 10526)
    • Большая переработка ядра JOSM
  • 28.04.2016 (стабильная версия 10161)
    • Новые фильтры слоёв (прозрачность/цветность/гамма/зернистость) (на англ.)
  • 13.03.2016 (стабильная версия 9979)
    • Используемым по умолчанию методом авторизации теперь является OAuth.
    • Поддержка перетаскивания (Drag & Drop) в редакторе отношений (подробнее)
    • Новая кнопка в редакторе отношений для обновления отношения (например, после разделения линии)
    • Диалог истории показывает старые и новые координаты точки, перемещённой на карте
    • Автоматическая привязка масштаба к разрешению по умолчанию фонового изображения
    • Расширенная поддержка различных проекций

2015

  • 31.12.2015 (стабильная версия 9229)
    • Заливка областей отображается не сплошной, а только вдоль их краёв. Это и кое-что ещё можно изменить в настройках стандартного стиля отрисовки JOSM. См. подробнее о настройках стилей
  • 23.11.2015 (стабильная версия 9060)
    • Поддержка норвежского языка букмол
  • 30.10.2015 (стабильная версия 8969)
    • Разделение линий: id/история линии при разделении наследуется самым длинным её сегментом (в экспертном режиме можно выбрать другой сегмент)
    • Показ значков точек с карты также и в списках (например, в панели выделения, редакторе отношений и диалоге передачи данных)
  • 28.09.2015 (стабильная версия 8800)
    • Интеграция загрузки с Overpass и мастера Overpass Turbo (только в экспертном режиме)
    • Добавлена мини-карта
    • Добавлена ссылка на taginfo
    • Настраиваемая гамма-коррекция подложек
  • 22.08.2015 (стабильная версия 8677)
  • 17.06.2015 (стабильная версия 8491)
    • Поддержка белорусского языка
    • Поддержка вьетнамского языка
  • 2015-04-18 (8227)
    • Поддержка валенсийского языка
  • 2015-03-31 (8160)
    • Поддержка литовского языка
  • 2015-03-02 (8109)
    • Дополнительные шрифты для поддержки большего количества языков в Windows
    • Некоторые модули теперь можно устанавливать и использовать без перезапуска JOSM.
    • Новое поле поиска для главного меню (вверху справа)
    • Поддержка заметок теперь включена по умолчанию (модуль больше не нужен).
  • 2015-02-18
    • Веб-интерфейс Launchpad, используемый для перевода JOSM, снова работает нормально, без постоянно повторявшихся ошибок "Timeout error".

2014

  • 2014-12-29 (7906)
    • Два новых языка: астурийский и кхмерский.
    • Каталоги настроек, пользовательских данных и кэша изменены в OS X и Windows.
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
  • 2014-09-30 (7588)
    • Улучшена интеграция с OS X (подробнее см. #10455).
    • Показ тегов OSM в пользовательском интерфейсе "Заготовки".
  • 2014-09-20 (7569)
    • JOSM теперь предупреждает об устаревшем стиле мультиполигонов, который можно исправить переносом соответствующих тегов с внешних линий на отношение.
  • 2014-08-31 (7480)
    • Улучшения в стандартном стиле карты:
      • Символы точек и значки скрываются при малых масштабах (это можно изменить в настройках отрисовки карты).
      • Улучшено размещение подписей внутри областей
      • Название дороги отображается вдоль дороги
    • Автономный режим с новым аргументом командной строки --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Мы проводим конкурс на создание нового логотипа до 30-го сентября! Подробнее смотрите в wiki.
  • 2014-07-04 (7287)
    • Новый режим двойного выравнивания для действия Выдавливание
    • Автоматическая перезагрузка стилей отрисовки карты и правил проверки данных
    • Автоматическое обновление подложек
  • 2014-05-18 (7139)
    • Стиль карты по-умолчанию переведен из XML в MapCSS
  • 2014-05-15 (7131)
    • Добавлено действие Move Node onto Way (Переместить точку к ближайшему сегменту линии)
  • 2014-04-25 (7001)
    • Переход на Java 7й версии, много подчисток кода
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Разрешен доступ к OSM API через HTTPS
  • 2014-01-29 (6767)
    • New MapCSS-based tag checker, extensible via custom rules
    • Add "Search for objects by preset" action Shift-F3
    • Presets/MapCSS/Validator improvements

2013

  • 2013-12-20 (6502)
    • Предлагает заполнить тег 'source' для пакета правок в диалоге передачи данных на сервер
    • Диалоговое окно Журнал: загружает и отображает комментарий пакета правок
    • source:trunk/images/mapmode/improvewayaccuracy.png Режим улучшения точности линий активирован в режиме для начинающих
    • много других улучшений и исправлений (changelog)
  • 2013-11-17 (6388)
    • Обновление переводов
  • 2013-11-12 (6383)
    • Новая команда для отсоединения точки от линии
    • Оповещения о получении новых сообщений в ОСМ
    • Много незначительных улучшений в шаблонах, стилях, валидаторе и др.
  • 2013-09-20 (6238)
    • Новые ненавязчивые оповещения
    • Новый пункт «сессия» в меню Файл, доступный в экспертном режиме?
    • Полная поддержка GPX маршрутов
    • Много незначительных улучшений в заготовках, процедуре перезапуска, стилях и валидаторе, улучшение производительности
  • 2013-08-07 (6115)
    • необходим OAuth для полной поддержки notes plugin
    • переработаны меню модулей для лучшей интеграции и группировки
    • при щелчке на дублирующихся точках, выделяется точка, принадлежащая выделенной до этого линии
    • много других улучшений и исправлений (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • возможность назначить горячие клавиши для заготовок тегов и кнопок панели инструментов, плюс пункт контекстного меню "Свойства горячей клавиши" для этого
    • автоматическое масштабирование для слоев WMS
    • новый экшн "Показать/скрыть панели" на клавише TAB для переключения видимости диалоговых панелей
  • 2013-05-08 (5939)
    • модуль restart интегрирован в ядро
    • контекстное меню "Отмена, Вырезать, Копировать, Вставить, Удалить, Выделить всё" у каждого текстового компонента
    • увеличена производительность команды Очистить
  • 2013-04-08 (5836)
    • переработаны контекстные меню
    • добавлена кнопка "Очистить буфер" для удаления неверных данных в диалоге "Вставить теги"
    • убрана поддержка (устаревшего) сервера смещений подложки
  • 2013-03-07 (5759)
    • Ctrl-Shift-V - вставить из буфера теги, скопированные как текст, например, a=2,c=3 или a 2 c 3
    • многочисленные улучшения рендеринга MapCSS
    • возможно перетаскивание точек в Extrude mode
    • контекстное меню в Диалоге редактирования тегов, выбор языка по умолчанию для тегов
    • элементарная фильтрация GPS-треков по дате
    • Удалённое управление: возможность удаления тегов и создания объектов с тегами
    • множество небольших улучшений и исправлений ошибок
  • 2013-02-06 (5697)
    • "intellisence" для роли в Редакторе отношений
    • возможность фильтрации в списке отношений
    • несколько усовершенствований диалога "Добавить значение" (кнопка Помощь, запоминание позиции, возможность добавить несколько тегов без закрытия диалога)
    • новая опция подложки wms_endpoint, переработан диалог WMS/TMS
    • новые тесты валидатора проверки адресов и тегов Википедии, увеличение производительности рисования слоев, исправления ошибок
    • множество незначительных улучшений

2012

  • 2012-12-08 (5608)
    • новые операторы nth: and nth% позволяют искать n-го участника отношения или n-ю точку в линии
    • незначительные улучшения дистанционного управления и внутренних заготовок тегов
  • 2012-11-10 (5576)
    • в Системах измерения поддерживается Морская миля (NM)
  • 2012-10-08 (5531)
    • переписан тест валидатора "здание внутри здания"
    • некоторые теги (TIGER, odbl, yh) автоматически очищаются при передаче на сервер
    • убран код, относящийся перелицензированию данных ОСМ
  • 2012-08-29 (5482, 5485)
    • спутниковые подложки изображений предлагаются, исходя из загруженной области
    • при добавлении тегов на точки, линии или отношения, для быстрого выбора предлагаются пять последних добавленных тегов
    • инструмент "Фильтр" теперь лучше обрабатывает мультиполигоны
    • теперь нельзя, выбрав каталог в окне 'Файл > Открыть...', загрузить все фотографии из него. Вместо этого, выберите файлы изображения напрямую (с помощью Ctrl-A или Shift-Click). Инструмент 'Импорт изображений" из контекстного меню GPX-слоя работает по-прежнему, так что вы можете загрузить фотографии рекурсивно, открыв каталог верхнего уровня.
  • 2012-07-23 (5353, 5356)
    • исправлены основные ошибки в обработке данных, изменённых ботом в связи со сменой лицензии OSM
    • мелкие улучшения в стилях карты и тестах валидатора, в том числе отображение неактивных слоёв и названий в диалоге валидатора
  • 2012-07-03 (5315)
    • исправлены основные ошибки в валидаторе, диалоге исправления конфликтов и слиянии слоёв
    • улучшен диалог исправления конфликтов: добавлены опции выбора (двойной клик) и просмотра элемента (контекстное меню)
    • некоторые улучшения в тестах валидатора
  • 2012-06-04 (5267)
    • Добавлены новые языки: португальский (европейский) (pt), каталонский (ca)
    • Поддержка пользовательских проекций
    • Перенос тегов на отношение при создании мультиполигона
  • 2012-05-02 (5210)
    • Несколько незначительных улучшений
      • по умолчанию - альтернативный диалог поиска
      • аргумент командной строки --load-preferences= для загрузки настроек при старте JOSM
      • MapCSS теперь может по-разному стилизовать левую и правую обводки (casings) линий
  • 2012-04-14 (5181)
    • Стартовая страница josm.openstreetmap.de была упрощена и реорганизована
    • Стабильная версия (5181) выпущена с большим количеством изменений/улучшений, такими как:
      • source:trunk/images/mapmode/rope.png Режим выделения "Лассо" (Экспертный режим)
      • информационные диалоги для начинающих: предупреждение о сдвиге подложки, при объединении линий с конфликтующими тегами или линий - участников отношений
      • новые возможности редактора отношений: "Добавить выделение к отношению" (правый щелчок по отношению), "Выбрать предыдущий/следующий разрыв" (в редакторе отношений)
      • улучшения в меню "Вид": "Стили отрисовки карты", возможность скрыть панель правки
      • ряд улучшений во время запуска
  • 2012-02-07 (4905)
    • Были добавлены сочетания клавиш для Редактора отношений: Alt-Вверх, Alt-Вниз (переместить участников отношения вверх/вниз), Alt-Del (удалить участника отношения) и Alt-Home (докачать неполных участников)
    • Доступен Обобщёный список изменений, который содержит важные изменения, внесённые в каждой стабильной версии.
  • 2012-02-02 (4897 ...)
    • Происходит исправление конфликтов в комбинациях клавиш подключаемых модулей. Многие сочетания будут изменены!
  • 2012-01-22 (4846)
    • Модуль уточнения линий включён в ядро программы. Выберите линию, нажмите на инструмент source:trunk/images/mapmode/improvewayaccuracy.png и уточните линию. Дополнительная информация доступна на справочной странице.
  • 2012-01-21 (4791, 4796, 4833)
    • Множественные улучшения возможности удалённого управления: новая команда '/load_object' для скачивания объектов по ID; команда '/add_way' для добавления новой линии с заданными координатами; параметр 'new_layer' для команды '/load_and_zoom', позволяющий загрузить данные на новый слой.
  • 2012-01-12 (4789)
    • Новый параметр командной строки, позволяющий установить значение произвольного параметра конфигурации при запуске. (например --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Подсвечивание точек и линий под курсором мыши можно отключить: 'Настройки' > 'Настройки отображения' > 'Данные OSM' (только в экспертном режиме)
    • Инструмент рисования source:trunk/images/mapmode/node/autonode.png позволяет создавать сегменты под фиксированными углами друг к другу (например 30°, 45°). Нажатие клавиши TAB переключает режимы.
  • 2012-01-04 (4765)
    • Автоматическое скрытие кнопок на панелях диалогов можно выключить отдельно для каждой панели (Значок глаза справа-вверху)

2011

  • 2011-12-29 (4745)
    • Новая команда для загрузки и кэширования подложек WMS вдоль GPX-треков (контекстное меню GPX-слоя)
  • 2011-12-20 (4673)
    • Для Франции доступна проекция Lambert 93 (EPSG:2154)
  • 2011-12-20 (4670)
    • Арабский, исландский язык и иврит были удалены в связи с отсутствием обновлений перевода.
  • 2011-12-05 (4621-4636)
    • Увеличена скорость работы с большими мультиполигонами.
  • 2011-11-26 (4609, 4611)
    • Кнопки панели инструментов "правка" (вверху слева) можно скрывать.
    • При рисовании линий нажатие клавиши BackSpace отменяет последнее действие.
  • 2011-11-20 (4601)
    • В панели истории теперь показывается принятие или непринятие новой лицензии пользователем.
  • 2011-11-15 (4595)
    • Поддержка многошаговых сочетаний клавиш. Например, нажав Ctrl+Alt+S а затем 1 можно переключить видимость первого слоя.
  • 2011-11-14 (4593)
    • На маленьких экранах длинные меню больше не обрезаются, а прокручиваются.
  • 2011-11-07 (4587)
    • Новая опция в диалоговом окне поиска: добавить кнопку с поисковым запросом на панель. Впоследствии добавленную кнопку можно убрать через меню, выводимое при нажатии на эту кнопку правой кнопкой мыши. (Только в экспертном режиме)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Формат файла настроек пользователя изменен на XML.
  • 2011-10-29 (4546)
    • Отображение текста над точками, линиями и отношениями может быть настроено через заготовки имён.
  • 2011-10-20 (4530)
    • Формат OsmChange (*.osc) теперь поддерживается официально.
  • 2011-10-10 (4512)
    • Добавлен режим эксперта, чтобы упростить работу новых пользователей с программой. В целях обратной совместимости, существующие установки по умолчанию переходят в экспертный режим.
  • 2011-10-07 (4497, 4498, 4500)
    • Новые опции в диалоге 'Файл > Скачать объект…'.
    • Окно истории: Улучшено отображение добавленных / удалённых точек в линиях (и в составе отношений).
    • Новые сочетания клавиш для редактирования свойств: Alt+A, Alt+S и Alt+D для Добавления, Правки и Удаления соответственно.
  • 2011-09-23 (4454)
    • Название тега и его значение копируются в буфер обмена при правом щелчке по ним в диалоговом окне свойств объекта.
  • 2011-09-12 (4416, 4423)
    • Границы покрытия служб фоновых снимков отображается на карте в меню 'Настройки > Подложки'.
  • 2011-09-08 (4408)
    • Пункт меню 'Проверить' контекстного меню выделения перемещён в меню 'Вид > Подробная информация'.
  • 2011-09-07 (4405)
    • Список в меню 'Настройки > Подложки' сортируется по коду страны.
  • 2011-08-29 (4380)
    • Новая функция 'Правка > Скопировать координаты'.
  • 2011-08-28 (4371)
    • Список недавних файлов содержит не только открывавшиеся, но и сохранявшиеся файлы.
  • 2011-08-27 (4355)
    • Динамический показ ряда кнопок в диалоговых окнах справа (опционально, расширенные настройки 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Сочетания клавиш для настройки видимости слоёв (Alt-1 до Alt-9)
  • 2011-08-21 (4332)
    • Выделение видимых треков на каждом слое GPX (в меню свойств слоя, по правому щелчку мыши)
  • 2011-08-21 (4327)
    • В режимах выделения и удаления теперь лучше заметно, над каким объектом производится действие (подсветка, изменение вида курсора).
  • 2011-07-18 (4256)
    • Поддержка изображений в формате SVG.
  • 2011-07-14 (4241)
    • Принимается во внимание ориентация изображения JPEG из EXIF-заголовка.
  • 2011-07-07 (4207)
    • Треки GPS могут окрашиваться в разные цвета в зависимости от их направления.
  • 2011-06-18 (4142)
    • В режиме Выдавливания теперь возможно добавить новую точку, дважды щелкнув мышью по линии.
  • 2011-06-11 (4126, 4129, 4134)
    • Оптимизировано использование памяти и ускорена отрисовка GPX треков.
    • Новый режим рисования: Добавление линии, параллельной существующей. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • Новая функция Следовать за линией упрощает рисование смежных объектов. (аналогично клавише "F" в Potlatch 2)
    • Поиск (и фильтрация) теперь могут обрабатывать замкнутые линии, в том числе согласно их минимальной и максимальной площади. (Ключевые слова: closed; areasize:МИН-МАКС либо areasize:МАКС, в м²)
    • Диалог Скачать объект… теперь принимает списки идентификаторов.
  • 2011-04-18 (4032)
    • Добавление нескольких персональных поисковых запросов и слоёв подложек с собственными иконками на панель инструментов.
    • Обновлена индикация перехода на новую лицензию в списке пользователей. (зелёная галочка - согласился, серая галочка - автоматически согласился, красный крестик - не согласился)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Новая функция слежения: двигает карту вслед за добавляемыми точками (Меню > Вид > Viewport Following; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Модули imagery,wmsplugin,slippymap и remotecontrol встроены в ядро JOSM.
  • 2010-12-07 (3705)
    • Прозрачность слоя теперь можно регулировать. (новая кнопка в списке слоёв)
  • 2010-12-07 (3702)
    • Появилась возможность масштабировать объекты. (Ctrl+Alt в режиме выделения)
    • информация Чтобы вращать объект, зажмите клавиши Ctrl+Shift.
  • 2010-11-25 (3669)
    • Модуль Validator встроен в ядро JOSM.
  • 2010-09-23 (3557, #5427)
    • Изменения в режиме "Выдавливание" (X): При растягивании несколько раз в одном направлении не остаётся промежуточных точек. (старое поведение включается клавишей Shift)
  • 2010-09-14 (3529)
    • Для тегов в диалоге свойств теперь можно сразу открыть соответствующую wiki-страницу в браузере.
  • 2010-09-03 (o22964)
    • Модуль WMS теперь поддерживает запросы GetCapabilities.
  • 2010-08-13 (3431)
    • Новое действие Очистить позволяет удалить данные со слоя без последующего их удаления с сервера.
  • 2010-07-27 (3388)
    • Новый диалог поиска заготовок тегов.
  • 2010-07-20 (3378)
    • JOSM теперь может recover an intermediate state of your editing после незапланированного завершения работы программы.
    • Для работы JOSM теперь необходимо иметь Java версии не ниже 6. Пользователи, у которых установлена Java 5, должны пользоваться старыми версиями JOSM.
  • 2010-06-03 (3306)
    • Поиск теперь поддерживает обнаружение роли участника отношения.
    • Диалог свойств теперь показывает положение участника отношения.
  • 2010-06-01 (3291)
    • Роли, задаваемые в предустановках теперь работают. Из-за этого могут возникать неожиданные предупреждения модуля validator, в случае неизвестных для JOSM отношений.
    • Участники выделенных отношений отображаются в цвете, отличном от цвета элементов, выделенных напрямую.
  • 2010-04-16 (3189)
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • Новый диалог загрузки объекта по id и возможность загрузки всех линий и отношений, использующих данный объект.
  • 2010-01-28 (2901)
    • Появилась возможность создать дубликат выбранного слоя данных без привязки к файлу.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Примечание для тех, кто ранее пользовался AgPifoJ: Теперь изображения можно открывать из главного меню (Файл > Открыть...), либо через контекстное меню соответствующего GPX слоя.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • Новый диалог для отображения информации о списках пакетов правок. Списки пакетов правок можно удалять, закрывать и отображать.
  • 2009-12-05 (2575)
    • В ядро JOSM были встроены модули utilsplugin и AgPifoJ.
  • 2009-11-24 (2513)
    • Тип проекции настраивается в параметрах и там же пользователь видит код проекции и границы.
  • 2009-10-25 (2313)
    • Отображение состояния принадлежности в редакторе отношений теперь в графическом виде и лучше воспринимается.
    • Названия полигонов теперь также видны (в светло-сером цвете), когда они вмещаются в полигон.
  • 2009-09-16 (2147)
    • В панели модулей появилась возможность поиска. Теперь можно искать модули по названию, описанию, версии, указывая параметры поиска через пробел в любом порядке.
  • 2009-09-14 (2133)
    • В панель инструментов добавлено множество ссылок на меню шаблонов.
  • 2009-09-13 (2124)
    • Теперь JOSM может поддерживать одновременно несколько открытых пакетов правок. Если нужно изменить объект, не связанный с текущим пакетом правок, теперь можно обозначить это изменение правильным тегом.
  • 2009-09-13 (2118)
    • Меню шаблонов теперь состоит из нескольких категорий верхнего уровня, вместо длинного списка. Это облегчит использование программы на маленьких экранах, и упростит поиск.
  • 2009-09-12 (2109)
    • Новая функция средней клавиши мышки переключает выбор между элементами под курсором. Это позволяет намного быстрее выбирать один из перекрывающихся элементов.
  • 2009-09-02 (2026)
    • В режиме удаления курсор мыши меняется в зависимости от типа объекта, который будет удалён.
  • 2009-07-15 (1790)
    • Полностью переделан редактор отношений.
  • 2009-07-11 (1767)
    • Модули JOSM теперь могут иметь разные версии (по крайней мере модули из SVN). Обновление модулей больше не вызывает ошибок в их работе.
  • 2009-07-07 (1743)
    • В JOSM теперь можно легко использовать внешние шаблоны и стили отрисовки. Больше информации - на страницах Presets и Styles.
  • 2009-06-28 (1709)
    • Появилась возможность просмотра истории правок объектов прямо в JOSM.
  • 2009-06-07 (1652)
    • Новый диалог разрешения конфликтов (когда редактируемый объект изменяется кем-то другим)
  • 2009-05-30 (1628)
    • Настройки теперь хранятся в кодировке UTF-8. Пользователям нелатинских локалей, возможно, потребуется исправить сбившиеся строки в настройках, либо полностью сбросить конфигурацию.
  • 2009-05-19 (1605)
    • Проекция по умолчанию теперь Mercator вместо EPSG:4326, которая была по умолчанию до сих пор.
  • 2009-05-19 (1603)
    • Новые операторы поиска parent и child позволяют искать соответственно среди родительских и дочерних объектов, соответствующих поисковому запросу.
  • 2009-02-14 (1405)
    • Множество улучшений в режиме рисования (двойной щелчок завершает рисование). Также в настройках появилась возможность переключения в "безрежимный" режим (как в Potlatch).
  • 2009-01-31 (1358)
    • Ограничения на повороты отображаются на карте и проверяются на ошибки, как и мультиполигональные отношения (звёздочка указывает на ошибки)
    • Сделаны первые шаги ко внедрению шаблонов для отношений
  • 2009-01-10 (1231)
    • Файлы теперь можно открывать, просто перетащив их на окно JOSM (Drag-n-Drop).
  • 2009-01-08 (1213)
    • Функция поиска теперь поддерживает регулярные выражения.
  • 2009-01-03 (1208)
    • Изменился способ отображения названий точек. Если не указано название точки, отображается значение параметра ref, operator или brand. Названия для неизвестных объектов (без иконки) теперь тоже отображаются.
  • 2009-01-02 (1203)
    • Появилась поддержка отрисовки многополигональных отношений (multipolygon relations). Для включения данного режима, необходимо выставить параметр "mappaint.multipolygon=true" (позже, будет включено по умолчанию). Если перед названием отношения есть звёздочка, значит JOSM обнаружил ошибку. Используйте модуль validator, чтобы просмотреть подробности об ошибке.

2008

  • 2008-12-25 (1180)
    • В этой версии из JOSM удалено много устаревшего кода. Старые версии модулей, скорее всего, откажутся работать. Необходимо их обновить.
  • 2008-11-28 (1078)
    • Если у Вас включена опция "отображать границы скачанной области" (ранее для каждой области отображался жёлтый прямоугольник), то теперь области, которые не скачивались, будут заштрихованы. Это должно облегчить редактирование, так как рабочая область не пересекается жёлтыми линиями.
  • 2008-11-14 (1076)
    • Инструмент "выстроить точки прямоугольником" был заменён более универсальным инструментом, позволяющим сделать все углы какой-нибудь фигуры прямыми, если все они близки к прямым углам.
  • 2008-10-29 (1058)
    • Изменена структура переводов JOSM. Все переводы вошли в стандартную поставку JOSM, поэтому модули переводов больше не нужны. Язык программы определяется языком системы, либо параметром --language.
  • 2008-10-05 (1023)
    • ВНИМАНИЕ: JOSM теперь поддерживает настройку горячих клавиш. Также изменились некоторые стандартные значения. Пожалуйста, проверьте (и настройте) сочетания клавиш, чтобы избежать случайной потери данных.
  • 2008-08-24 (858)
    • Команда разъединения теперь встроена. Плагин UnGlue более не требуется.
  • 2008-08-19 (805)
    • Данная версия включает в себя новый режим рисования. При использовании инстумента выделения, в середине линии показываются крестики. При щелчке мышью по крестику, он превращается в точку. Это значительно уменьшает необходимость в переключении режимов рисования. Если такое поведение не требуется, отключите "виртуальные точки" в настойках.
  • 2008-05-20 (643)
    • Эта версия содержит небольшое изменение в режиме рисования точек: SHIFT+щелчок мышью теперь всегда выбирает точку, когда курсор находится над ней (ранее точка выбиралась только если не было уже выбранных объектов). Это более логично, и сокращает количество переключений в режим Выбора.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • "Резиновая" вспомогательная линия соединяет последнюю точку с перспективной следующей точкой. Для выключения этой возможности установите значение настройки "draw.helper-line" в "false".
  • 2008-05-08 (608)
    • Строка статуса показывает информацию о координатах, угле и длине сегмента линии, которая будет добавлена.
  • 2008-05-08 (547)
    • Теперь есть встроенная поддержка Audio Mapping, включая аудио-ролики, записанные без перерывов.

Last modified 6 years ago Last modified on 2013-06-25T23:19:50+02:00