wiki:Ru:Help/SystemRequirements

Требования к программному обеспечению

Для JOSM необходимо, чтобы на вашем компьютере была установлена среда выполнения Java 8 или более поздней версии.

В случае, если у вас есть только более старая версия Java и нет возможности обновить её, доступны старые версии JOSM:

  • Версия 3377 для Java 5.
  • Версия 7000 для Java 6.
  • Версия 10526 для Java 7.

Старые версии JOSM, включая инсталляторы для Mac и Windows, доступны в архиве загрузки. Тем не менее, настоятельно рекомендуется всегда использовать свежую стабильную версию.

Если у вас только старая версия 7 (до update 25, выпущенной в июне 2013 г.), можно запустить JOSM версии 10526, но вы можете столкнуться со следующей ошибкой Java. Для её устранения выполните соответствующие действия по обновлению.

  • #8182: Mac OS: Cannot open files in directories with swedish characters in them -> Выполните обновление до Java 7 update 10 или более поздней (см. Java bug 7193966)

Решение проблем

  • При запуске JOSM выводит в командной строке
    Exception in thread "main" java.lang.UnsupportedClassVersionError: JOSM : Unsupported major.minor version 52.0
    
    → Убедитесь, что установлена Java 8 или более поздняя версия, как описано выше.
Last modified 3 years ago Last modified on 2017-10-20T15:07:25+02:00