wiki:Nl:Help/SystemRequirements

Softwarevereisten

JOSM vereist dat een recente versie van Java 8 of latere runtime environment is geïnstalleerd op uw computer.

Indien u een oudere versie van Java heeft en niet kan bijwerken, zijn er oudere versies van JOSM beschikbaar:

  • Versie 3377 voor Java 5.
  • Versie 7000 voor Java 6.
  • Versie 10526 voor Java 7.

Oude versies van JOSM, inclusief installatieprogramma's voor Mac en Windows, zijn beschikbaar in het archief voor downloads. Dringend aanbevolen wordt echter om altijd de laatste stabiele versie te gebruiken

Indien u alleen een oude versie van Java 7 (ouder dan update 25, uitgegeven in juni 2013) heeft, kunt u de versie 10526 van JOSM uitvoeren, maar u zou het volgende probleem kunnen tegenkomen in Java. Voer de overeenkomende acties voor updaten uit om er vanaf te komen.

  • #8182: Mac OS: Kan geen bestanden openen in mappen met Zweedse tekens in de naam -> Update naar Java 7 update 10 of later (zie Java bug 7193966)

Probleemoplossing

  • Uitvoer voor starten van JOSM op de opdrachtregel
    Exception in thread "main" java.lang.UnsupportedClassVersionError: JOSM : Unsupported major.minor version 52.0
    
    → Zorg er voor Java 8 of later te installeren zoals hierboven beschreven.
Last modified 5 years ago Last modified on 2016-08-22T18:44:32+02:00