wiki:De:VersionHistory

Ältere JOSM Neuigkeiten

  • 03.10.2017 (stabile Version 12921)
    • Links zu externen Änderungssatzanalysewerkzeugen zu den Chronik- und Änderungssatzverwaltungsfenstern hinzugefügt
    • Rückmeldungscheckbox zum Hochladenfenster hinzugefügt
    • Die Funktion Kreis erstellen nutzt automatisch eine sinnvolle Punktanzahl in Abhängigkeit vom Kreisdurchmesser
    • Neue Kommandozeilenparameter zur Ausführung bestimmter Aufgaben ohne grafische Benutzeroberfläche:
      • Rendern von osm-Daten anhand eines MapCSS-Stils
      • Umrechnen von Koordinaten von einer Projektion in eine andere
  • 02.09.2017 (stabile Version 12712)
  • 30.07.2017 (stabile Version 12542)
    • Suche mittels Vorlage im Suchen-Fenster.
    • Neues "Heimat-Standort"-Lesezeichen (falls in den OSM-Nutzereinstellungen festgelegt) und Lesezeichen der letzten 15 Änderungssätze.
  • 02.07.2017 (stabile Version 12450)
  • 29.05.2017 (stabile Version 12275)
  • 02.05.2017 (stabile Version 12039)
    • Reprojizieren (Verzerren) von Hintergrundbildern: erlaubt das Kombinieren von Quellen unterschiedlicher Projektion.
  • 02.04.2017 (stabile Version 11826)
    • Verhindere komplett das Hochladen einer Ebene mithilfe von "upload=never" in der osm-Datei
    • Eine Option wurde hinzugefügt, um nicht zu neu heruntergeladenen Daten zu zoomen. (nur im Expertenmodus)
  • 27.02.2017 (stabile Version 11639)
    • Der GPS-Heatmap-Modus besitzt nun einige Einstellungen, um sein Aussehen anzupassen.
    • Spiegelserver von Hintergrundbildern können nun in den Hintergrundbild-Einstellungen ausgewählt werden.
  • 02.02.2017 (stabile Version 11526)
    • GPS-Spuren können jetzt im neuen Heatmap-Modus angezeigt werden.

2016

  • 31.12.2016 (stabile Version 11427)
    • Interne Datenbank mit Grenzen aller Länder. Einzelne Datenprüfregeln oder Kartenstile können nun bspw. auf ein bestimmtes Land begrenzt werden.
    • Einfaches Ablegen oder Einfügen von URLs um Daten herunterzuladen unterstützt nun alle URL-Typen des Fensters Adresse öffnen.
    • Die Textfelder Schlüssel und Wert im Fenster "Wert hinzufügen" werden mit dem nächsten Merkmal der darunter befindlichen Liste vorausgefüllt, wenn der erste Schlüssel bereits in Benutzung ist.
  • 06.11.2016 (stabile Version 11223)
  • 05.09.2016 (stabile Version 10966)
  • 12.08.2016 (stabile Version 10786)
    • Umstellung auf Java 8 mit großer Überarbeitung des JOSM-Kerns
    • Neue Funktion "Bei Quellposition einfügen" im Menü Bearbeiten (Strg+Alt+V, nur im Expertenmodus)
    • Unterstützung von geo: URLs
  • 12.07.2016 (stabile Version 10526)
    • Große Überarbeitung des JOSM-Kerns
  • 28.04.2016 (stabile Version 10161)
    • Neue Ebenen-Filter (Transparenz/Farbsättigung/Gamma/Schärfe)
  • 13.03.2016 (stabile Version 9979)
    • OAuth ist jetzt die standardmäßige Methode zur Anmeldung.
    • Drag & Drop-Unterstützung für den Relationseditor (mehr Infos (en))
    • Neue Schaltfläche im Relationseditor um die Relation zu aktualisieren (z.B. nach dem Aufspalten einer Linie)
    • Das Versionsprotokoll zeigt die alten und neuen Koordinaten eines verschobenen Punktes auf einer Karte an
    • Der Zoom rastet automatisch auf die Standardauflösung des Hintergrundes ein
    • Erweiterte Unterstützung von verschiedenen Projektionen

2015

  • 31.12.2015 (stabile Version 9229)
  • 23.11.2015 (stabile Version 9060)
    • Unterstützung der norwegischen Sprachvariante Bokmål
  • 30.10.2015 (stabile Version 8969)
    • Linie aufspalten: Wiederverwenden der Kennung/Versionsgeschichte der vorhandenen Linie für das längste Teilsegment (Expertennutzer können ein anderes Segment wählen)
    • Punktsymbole der Kartenansicht werden auch in Listen angezeigt (z.B. im Auswahldialog, Relationseditor oder Hochladendialog)
  • 28.09.2015 (stabile Version 8800)
    • Integration von Overpass download und des Overpass-Turbo-Assistenten (Nur im Expertenmodus)
    • Minikarte hinzugefügt
    • Link zu taginfo hinzugefügt
    • Veränderbarer Gamma-Wert bei Hintergrundbildern
  • 22.08.2015 (stabile Version 8677)
  • 17.06.2015 (stabile Version 8491)
    • Unterstützung der weißrussischen Sprache
    • Unterstützung der vietnamesischen Sprache
  • 2015-04-18 (8227)
    • Unterstützung der valencianischen Sprache
  • 2015-03-31 (8160)
    • Unterstützung der litauischen Sprache
  • 2015-03-02 (8109)
    • Mehr Schriftarten, um in Windows mehr Sprachen zu unterstützen
    • Manche Plugins können jetzt ohne einen Neustart von JOSM installiert und genutzt werden.
    • Neue Suchbox für das Hauptmenü (oben rechts)
    • Die integrierte OSM-Hinweis-Funktion ist jetzt standardmäßig aktiviert (das Plugin ist veraltet).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Zwei neue Sprachen: Asturisch und Khmer.
    • Verzeichnisse der Einstellungen, Nutzerdaten und des Caches bei OS X und Windows geändert.
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
    • Größere Fehler in der Verwendung von Tastaturkürzeln und der Konfliktbehandlung von Linien verbinden behoben.
  • 2014-09-30 (7588)
    • Bessere Integration in OS X (für Einzelheiten siehe #10455).
    • Anzeige von OSM-Merkmalen in der Vorlagen-GUI.
  • 2014-09-20 (7569)
    • JOSM erzeugt ab sofort Warnungen für alte Multipolygone, welche durch Verschieben der relevanten Merkmale von den Außenlinien auf die Relation behoben werden können.
  • 2014-08-31 (7480)
    • Verbesserungen des Standard-Kartenstils:
      • Punktsymbole und Symbole werden auf niedrigen Zoomstufen versteckt (dies kann in den Stileinstellungen geändert werden).
      • Bessere Positionierung von Beschriftungen innerhalb von Bereichen
      • Name von Straßen wird entlang des Weges angezeigt
    • Offline-Modus mit dem neuen Befehlszeilenargument --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Wir haben einen Grafik-Wettbewerb für ein neues Logo gestartet (Laufzeit bis zum 30. September)! Siehe Wiki (en) für Einzelheiten.
  • 2014-07-04 (7287)
  • 2014-05-18 (7139)
    • Der Standardkartenstil von JOSM wurde von XML nach MapCSS (en) konvertiert
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Wechsel auf Java-Version 7, viele Aufräumarbeiten im Quelltext
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • HTTPS-Zugriff auf die OSM-API.
  • 2014-01-29 (6767)
    • Neuer, auf MapCSS basierender, Merkmalsprüfer, erweiterbar mit eigenen Regeln
    • Funktion "Suche nach Objekten mittels Vorlage" Umschalt-F3 hinzugefügt
    • Verbesserungen bei Vorlagen, Kartenstilen und Validator

2013

  • 2013-12-20 (6502)
    • Quelle für Änderungssatz (source) wird im Hochladen-Dialog abgefragt
    • Änderungssatzkommentar wird im Versionsprotokoll angezeigt
    • source:trunk/images/mapmode/improvewayaccuracy.png Liniengenauigkeit verbessern auch im Nicht-Expertenmodus
    • Viele weitere Erweiterungen und Fehlerbereinigungen (Änderungshistorie (en))
  • 2013-11-17 (6388)
    • Aktuelle Sprachdateien
  • 2013-11-12 (6383)
    • Neuer Werkzeuge-Befehl Punkt von Linie trennen
    • Benachrichtigungen über neu erhaltene OSM-Nachrichten
    • Viele kleine Verbesserungen der Vorlagen, Kartenstile, der Fehlerprüfung sowie anderer Teile
  • 2013-09-20 (6238)
    • Nicht aufdringliche Hinweismeldungen
    • Neuer Menüpunkt Sitzung im Datei-Menü im Expertenmodus
    • Vollständige Unterstützung von GPS-Routen
    • Viele kleiner Verbesserungen der Vorlagen, von Neustarten, der Kartenstile und von Validator plus Leistungsverbesserungen
  • 2013-08-07 (6115)
    • OAuth (en) Berechtigungen werden abgefragt um das neue Notes-Plugin (en) vollständig zu unterstützen
    • Überarbeitung der Plugin-Menüs um eine bessere Gruppierung und Einbindung zu erreichen
    • Kindpunkte der (zuletzt) ausgewählten Objekte werden beim Auswählen von übereinander liegenden Punkten bevorzugt
    • Viele weiter Erweiterungen und Fehlerbereinigungen (Änderungshistorie (en))
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • Möglichkeit Tastenkürzel für Vorlagen und andere Werkzeugleistenschaltflächen zu vergeben und neuer Kontextmenüeintrag "Tastenkürzel bearbeiten", um diese zu definieren.
    • Automatischer Zoom für WMS-Ebenen
    • Neue "Leistenumschalt"-Aktion auf TAB um die Dialogfelderleiste aus-/einzublenden.
  • 2013-05-08 (5939)
    • Restart-Erweiterung wurde ins Hauptprogramm integriert
    • Rechtsklick-Menü mit "zurück, ausschneiden, kopieren, einfügen, löschen, alles auswählen" für jede Textkomponente
    • Effizienzverbesserung des Befehls "Bereinigen" (en)
  • 2013-04-08 (5836)
    • Größere Überarbeitung der Kontextmenüs
    • Schaltfläche "Zwischenspeicher löschen", um inkorrekten Zwischenspeicher der Aktion "Einfügen von Merkmale aus Text" zu löschen, wurde hinzugefügt
    • Unterstützung für den veralteten Hintergrundversatzserver wurde entfernt
  • 2013-03-07 (5759)
    • Strg+Shift+V kann jetzt Merkmale aus der Zwischenablage einfügen, z.B. a=2,c=3 und a 2 c 3
    • Viele Verbesserungen der Kartendarstellung mittels MapCSS
    • Das Verschieben von Punkten im Extruder-Modus ist möglich
    • Kontextmenüs in den Dialogen zum Hinzufügen/Ändern von Merkmalen, Option das Tastuturlayout zu korrigieren
    • Einfacher Datumsfilter für GPS-Spuren
    • Die Fernsteuerung erlaubt das Löschen von Merkmalen und das Erstellen von Objekten mit Merkmalen
    • viele kleinere Verbesserungen und Fehlerbehebungen
  • 2013-02-06 (5697)
    • Rollen werden im Relationeditor und beim Erstellen von Relationen vorgeschlagen
    • Filtermöglichkeit im Relationslistendialog
    • Einige Erweiterungen des "Wert hinzufügen"-Dialogs, dazu gehören eine Hilfe-Schaltfläche, das Merken der Position und die Möglichkeit mehrere Merkmale hintereinander hinzuzufügen ohne das Dialogfenster zu schließen
    • Neuer Hintergrundeintrag wms_endpoint und Überarbeitung des WMS/TMS-Dialogs
    • Neue Validierungstest für Adressen- und Wikipediamerkmale und Effizienzverbesserung beim Ebenezeichnen und Fehlerbeheben
    • viele kleinere Verbesserungen

2012

  • 2012-12-08 (5608)
    • Die neuen Operatoren nth: und nth% ermöglichen es nach der Position in Linien zu suchen
    • Einige kleinere Verbesserungen der Fernsteuerung (remote control) und der internen Vorlagen
  • 2012-11-10 (5576)
    • Die Seemeile wird als Maßeinheit unterstützt
  • 2012-10-08 (5531)
    • Validatorgebäudetest wurde überarbeitet
    • Ein paar weitere Eigenschaften werden beim Hochladen automatisch entfernt (TIGER, odbl, yh)
    • Quellcode, der den Lizenzwechsel betraf, wurde entfernt
  • 2012-08-29 (5482, 5485)
    • Hintergrundbilder werden entsprechend der heruntergeladenen Region vorgeschlagen.
    • Beim Hinzufügen von Merkmalen zu Punkten, Wegen oder Relationen werden die fünf zuletzt benutzten Eigenschaften als Schnellauswahl angezeigt.
    • Bessere Unterstützung von Multipolygonen durch das Filter-Werkzeug
    • Das automatische Laden aller enthaltenen Fotos bei Auswahl eines Verzeichnisses im 'Datei > Öffnen...'-Dialog wurde deaktiviert. Stattdessen müssen die zu öffnenden Bilddateien nun direkt ausgewählt werden (Über Strg-A oder Shift-Klick). Alternativ lassen sich mit dem Werkzeug 'Bilder importieren' im Kontextmenü einer GPX-Ebene Fotos auf die gewohnte Weise rekursiv über das Öffnen eines übergeordneten Verzeichnisses laden.
  • 2012-07-23 (5353, 5356)
    • Wichtige Fehlerkorrekturen in der Behandlung durch den Lizenzroboter bearbeiteter Daten
    • Kleinere Verbesserungen in den Kartenstilen und Validatorprüfungen (z.B. Korrektur der Anzeige inaktiver Ebenen und Darstellung der Namen im Validatordialog)
  • 2012-07-03 (5315)
    • Größere Fehler in Validator, im Konfliktdialog und beim Zusammenführen von Ebenen behoben
    • Einige Verbesserungen des Konfliktdialogs inklusive der Möglichkeit Elemente auszuwählen (Doppelklick) und sie zu fokusieren (Kontextmenü)
    • Einige Verbesserungen der Validator-Tests
  • 2012-06-04 (5267)
    • Neue Sprachen: Portugiesisch (Portugal) (pt), Katalanisch (ca)
    • Unterstützung von benutzerdefinierten Projektionen
    • Beim Erstellen eines Multipolygons werden die Merkmale der Relation übergeben
  • 2012-05-02 (5210)
    • Einige kleinere Erweiterungen
      • Alternativer Suchdialog wurde als Standard gesetzt
      • Kommandozeilenargument --load-preferences= um Einstellungen beim Starten von JOSM zu setzten
      • Unterschiedliche Gestaltung der rechten und linken Seitenummantelungen in MapCSS ermöglicht
  • 2012-04-14 (5181)
    • Die Startseite von josm.openstreetmap.de wurde neu strukturiert und vereinfacht
    • Eine neue, stabile Version (5181) wurde freigegeben. Es wurden viele Änderungen und Verbesserungen vorgenommen, u.A.:
      • source:trunk/images/mapmode/rope.png Lasso-Auswahl - Werkzeug (im Expertenmodus verfügbar)
      • Informationsdialoge für Anfänger: Warnungen bei fehlausgerichteten Hintergrundbildern und bei der Kombination von widersprüchlichen Tags oder Wegen in Relationen
      • Neue Funktionen zur Bearbeitung von Relation: "Füge Auswahl zur Relation hinzu" (Verfügbar bei Rechtsklick auf die Relation), "Wähle nächste/vorherige Lücke" (im Relationen-Editor)
      • Verbesserungen der Benutzerpberfläche im Ansicht-Menü: "Map Paint Styles" und die Möglichkeit die Werkzeugleiste auszublenden
      • Einige Verbesserungen bei der Startzeit
  • 2012-02-07 (4905)
    • Tastenkombinationen für den Relationeditor wurden hinzugefügt: Alt-Up, Alt-Down (ausgewählte Elemente nach oben/unten schieben), Alt-Del (Element löschen) und Alt-Home (unvollständige Elemente herunterladen)
    • Eine Zusammenfassung der Änderungshistorie ist verfügbar, welche die maßgeblichen Änderungen zwischen stabilen Versionen auflistet.
  • 2012-02-02 (4897 ...)
    • Widersprüchliche Tastaturkürzel in JOSM und den Plugins werden behoben. Eine größere Anzahl von Tastenkürzeln für Funktionen werden sich ändern!
  • 2012-01-22 (4846)
    • Das ImproveWayAccuracy-Plugin wurde in JOSM integriert. Selektiere einen Weg, aktiviere source:trunk/images/mapmode/improvewayaccuracy.png und verbessere die Lage des Weges. Auf der Hilfeseite wird die Verwendung genauer erklärt.
  • 2012-01-21 (4791, 4796, 4833)
    • Verschiedene Erweiterungen der Fernsteuerung (RemoteControl): Neues Kommando '/load_object', um Objekte anhand ihrer Id herunterzuladen; '/add_way' Kommando, um einen neuen Weg mit bestimmten Koordinaten zu erzeugen; Parameter 'new_layer' für das '/load_and_zoom' Kommando, um Daten in eine neue Ebene zu laden.
  • 2012-01-12 (4789)
    • Neue Kommandozeilenoption, um den Wert einer beliebigen erweiterten Einstellung beim Start zu setzen. (z.B. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Hervorhebung von Knoten und Wegen unter dem Mauscursor kann abgestellt werden: 'Einstellungen' > 'Anzeige' > 'OSM-Daten' (Nur im Expertenmodus)
    • Mit dem Zeichenwerkzeug source:trunk/images/mapmode/node/autonode.png können Wegsegmente mit diskreten Winkeln (z.B. 30/45°) gezeichnet werden. Mit der Tabulatortaste können verschiedene Arbeitsweisen aktiviert werden.
  • 2012-01-04 (4765)
    • Das automatische Ausblenden der Buttons in den Dialogen auf der rechten Seite kann für jedes Fenster einzeln unterbunden werden. (Auge-Symbol in der oberen rechten Ecke)

2011

  • 2011-12-29 (4745)
    • Neuer Befehl um WMS Hintergrundbilder entlang einer GPX Spur im Voraus zu laden und zu cachen. (Per Rechtsklick auf GPX-Ebene)
  • 2011-12-20 (4673)
    • Für Frankreich ist die Projektion Lambert 93 (EPSG:2154) verfügbar.
  • 2011-12-20 (4670)
  • 2011-12-05 (4621-4636)
    • Anzeige großer Multipolygone wurde beschleunigt.
  • 2011-11-26 (4609, 4611)
    • Die Schalter der Arbeitswerkzeugleiste im linken oberen Bereich können einzeln verborgen werden.
    • Beim Zeichnen von Wegen kann mit der Rückschritttaste die letzte Aktion zurück genommen werden.
  • 2011-11-20 (4601)
    • In der Anzeige des Versionsprotokolls ist jetzt auch der Lizenzstatus der beteiligten Nutzer aufgeschlüsselt.
  • 2011-11-15 (4595)
    • Unterstützung für mehrteilige Tastenkombinationen. Beispielsweise wechselt Strg+Alt+S, 1 die Sichtbarkeit der ersten Ebene.
  • 2011-11-14 (4593)
    • Auf kleinen Bildschirmen werden lange Menüs nicht mehr abgeschnitten, sondern lassen sich hoch und runter scrollen.
  • 2011-11-07 (4587)
    • Vom Suchdialog aus kann ein Toolbar-Button für die entsprechende Suche hinzugefügt werden. Per Rechtsklick auf den Button kann dieser wieder entfernt werden. (Nur im Expertenmodus.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Das interne Format für die Speicherung von Benutzereinstellungen wurde auf XML umgestellt.
  • 2011-10-29 (4546)
    • Mit Namens-Templates kann die Schriftanzeige von Punkten, Linien und Relationen angepasst werden.
  • 2011-10-20 (4530)
    • Das OsmChange Format (*.osc) wird jetzt offiziell unterstützt.
  • 2011-10-10 (4512)
    • Expertenmodus zur Reduzierung der Komplexizität für neue Nutzer eingeführt. Aus Kompatibilitätsgründen nutzen bestehende Installationen den Expertenmodus standardmäßig.
  • 2011-10-07 (4497, 4498, 4500)
    • Mehr Optionen im Dialog 'Datei > Objekt herunterladen...'.
    • Versionsprotokoll: Intelligentere Darstellung für entfernte / hinzugefügte Punkte von Wegen (sowie Relationsmitgliedern).
    • Neue Tastenkombinationen im Eigenschaftendialog: Alt+A, Alt+S, Alt+D für Hinzufügen, Bearbeiten, Entfernen.
  • 2011-09-23 (4454)
    • Per Rechtsklick können im Eigenschaftendialog Schlüssel und Wert in die Zwischanablage kopiert werden.
  • 2011-09-12 (4416, 4423)
    • In 'Einstellungen > Hintergrundebenen' werden die Ausmaße der WMS/TMS-Angebote in einer Vorschaukarte angezeigt.
  • 2011-09-08 (4408)
    • Der Menüpunkt 'Inspizieren' im Kontextmenü des Auswahldialogs ist jetzt unter 'Ansicht > Erweiterte Informationen' zu finden.
  • 2011-09-07 (4405)
    • Liste in 'Einstellungen > Hintergrundebenen' ist nach Länderkürzel sortiert.
  • 2011-08-29 (4380)
    • Neue Funktion 'Bearbeiten > Koordinaten kopieren'.
  • 2011-08-28 (4371)
    • In der Liste der zuletzt geöffneten Dateien werden nicht nur geöffnete, sondern auch gespeicherte Dateien angezeigt.
  • 2011-08-27 (4355)
    • Dynamische Sichtbarkeit der Buttonleiste für die Dialoge auf der rechten Seite (optional, erweiterte Einstellung 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Tastenkombination zum Wechseln der Sichtbarkeit von Ebenen (Alt-1 bis Alt-9)
  • 2011-08-21 (4332)
    • Auswahl der Sichtbaren Spuren, für jede gpx-Ebene (per Rechts-Klick auf die Ebene)
  • 2011-08-21 (4327)
    • Der Auswahl- und der Löschmodus haben eine bessere visuelle Darstellung des nächsten Arbeitsschrittes (Hervorhebung, Änderung des Mauszeigers).
  • 2011-07-18 (4256)
    • Unterstützung für das SVG Bildformat.
  • 2011-07-14 (4241)
    • Orientierungsangabe in den EXIF-Daten von JPEG Bildern wird berücksichtigt.
  • 2011-07-07 (4207)
    • GPS Spuren können anhand ihrer Richtung eingefärbt werden.
  • 2011-06-18 (4142)
  • 2011-06-11 (4126, 4129, 4134)
    • Speicherverbrauch minimiert und Darstellung von GPX-Dateien beschleunigt
    • Neuer Zeichenmodus: Fügt parallel zu einem existierenden Weg einen neuen ein. (Umschalt + P)
  • 2011-05-16 (4081, 4085, 4086)
    • Neue Linie verfolgen-Funktion zum leichteren Zeichnen von aneinandergrenzenden Flächen. (ähnlich der Kurzwahl "F" in Potlatch 2)
    • Die Suche (und der Filter) unterstützt nun auch die Abfrage nach geschlossenen Linien und solchen, welche eine gewisse Minimal- und Maximalfläche umschließen. (Schlüsselworte: closed; areasize:MIN-MAX oder areasize:MAX, in m²)
    • Die Objekt Herunterladen...-Funktion verarbeitet nun auch eine Liste von IDs.
  • 2011-04-18 (4032)
    • Mehrere angepasste Suchanfragen oder Hintergrundebenen können mit einem eigenen Symbol in die Werkzeugleiste eingefügt werden.
    • Die Ansicht der Zustimmung zum Lizenzwechsel wurde aktualisiert. (grüner Haken - zugestimmt, grauer Haken - automatisch zugestimmt, rotes Kreuz - abgelehnt)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Neue "Automatisch nachführen"-Funktion - Ansicht wird automatisch auf den zuletzt gesetzten Punkt zentriert (Hauptmenü > Ansicht; Strg+Umschalt+F)

2010

  • 2010-12-12 (3715)
    • Die Plugins imagery, wmsplugin, slippymap und remotecontrol sind jetzt Bestandteil des JOSM-Hauptprogramms.
  • 2010-12-07 (3705)
    • Ebenen können transparent dargestellt werden. (neue Schaltfläche im Ebenendialog)
  • 2010-12-07 (3702)
    • Objekte können mittels Strg+Alt (im Auswahl-Modus) skaliert werden.
    • info Mit Strg+Umschalt können Objekte auch gedreht werden.
  • 2010-11-25 (3669)
    • Das Validator-Plugin wurde ins Hauptprogramm integriert.
  • 2010-09-23 (3557, #5427)
    • Änderung im „Gebiete erstellen“ Modus (X): Bei mehrfachem Verschieben in eine Richtung bleiben keine überflüssigen Nodes mehr stehen. (Shift-Taste erzwingt das alte Verhalten.)
  • 2010-09-14 (3529)
    • Zu den Merkmalen im Eigenschaftendialog kann direkt die entsprechende Wiki-Seite im Browser geöffnet werden.
  • 2010-09-03 (o22964)
    • Das WMS-Plugin unterstützt GetCapabilities-Anfragen.
  • 2010-08-13 (3431)
    • Der neue Bereinigen-Befehl kann Daten-Ebenen bereinigen.
  • 2010-07-27 (3388)
    • Neuer Dialog zum Suchen in Objektvorlagen.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Die Suche unterstützt das Suchen der Rollen eines Relationselementes.
    • Der Eigenschaftsdialog zeigt die Position von Relationselementen.
  • 2010-06-01 (3291)
    • Die Rollendefinition in den Vorlagen werden jetzt genutzt. Das kann bei JOSM noch unbekannten Relationen zu Warnungen im Validator führen.
    • Elemente von ausgewählten Relationen werden farblich anders dargestellt, als direkt gewählte Objete.
  • 2010-04-16 (3189)
    • Mit der neuen Filter-Funktion können bestimmte Arten von Objekten vorübergehend ausgeblendet werden.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
  • 2010-01-28 (2901)
    • Neu: Erstellen eines Duplikats der gewählten Datenebene ohne eine Dateizuordnung.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Hinweis an frühere AgPifoJ Nutzer: Bilder können jetzt über das Hauptmenü (Datei > Öffnen...) oder über das Rechts-Klick-Menü der zugehörigen GPX-Ebene geöffnet werden.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • Neuer Änderungssatzdialog zeigt im heruntergeladenen Bereich die Zugehörigkeit zu den verschiedenen Änderungssätzen an.
  • 2009-12-05 (2575)
    • Die Plugins utilsplugin und AgPifoJ wurden direkt in JOSM integriert.
  • 2009-11-24 (2513)
    • Die Projektionen unterstützen Parameter und zeigen dem Anwender die Projektionsbezeichnung und die Weltgrenzen.
  • 2009-10-25 (2313)
    • Die Anzeige des Verbunden-Status im Relationseditor ist jetzt grafisch und besser verständlich.
    • Namen von Flächen werden (in hellem Grau) angezeigt, sofern sie in das Gebiet hineinpassen.
  • 2009-09-16 (2147)
    • Das Plugin-Menü besitzt jetzt eine Suchfunktion. Während der Eingabe wird nach Übereinstimmungen im Namen, in der Version oder dem Beschreibungsbereich gesucht. Mehrere Suchwörter können durch ein Leerzeichen getrennt werden.
  • 2009-09-14 (2133)
    • Der Standard-Werkzeugleiste wurden einige ausgewählte Vorlagen hinzugefügt.
  • 2009-09-13 (2124)
    • JOSM unterstützt jetzt die Bearbeitung mehrere Änderungssätze. Das heißt, dass man Änderungssätze nach dem Hochladen offen halten kann, danach etwas ganz Anderes bearbeitet und zum Server überträgt, um danach wieder am ersten Änderungssatz weiter zu arbeiten. Beachte das ein Änderungssatz nach einer Stunde ohne Bearbeitung vom Server automatisch geschlossen wird.
  • 2009-09-13 (2118)
    • Im Vorlagenmenü wurden neue Hauptkategorien eingeführt. Mit diesen kann die benötigte Vorlage schneller finden und es macht die große Liste auch auf kleinen Bildschirmen wieder nutzbar.
  • 2009-09-12 (2109)
    • Die neue Behandlung der mittleren Maustaste erlaubt das Umschalten der Auswahl von Elementen unter dem Mauszeiger. Dadurch wird die Auswahl von überlappenden Elementen stark vereinfacht.
  • 2009-09-02 (2026)
    • Im Löschmodus ändert sich der Mauszeiger in Abhängigkeit des zu löschenden Objektes.
  • 2009-07-15 (1790)
    • Komplette Überarbeitung des Relationseditors.
  • 2009-07-11 (1767)
    • JOSM-Plugins unterstützen jetzt verschiedene Versionen (zumindest die im SVN enthaltenen Plugins). Pluginaktualisierungen verursachen jetzt keine Pluginfehlfunktion mehr.
  • 2009-07-07 (1743)
    • JOSM unterstützt nun eine einfache Nutzung von externen Objektvorlagen und Zeichenstilen. Sehen Sie sich auch die Seiten Vorlagen und Stile an.
  • 2009-06-28 (1709)
    • Darstellung der Elementgeschichte innerhalb von JOSM.
  • 2009-06-07 (1652)
    • Neuer Dialog zum Beheben von Konflikten (wenn geänderte Objekte in der Zwischenzeit bearbeitet wurden).
  • 2009-05-30 (1628)
    • Die Einstellungen werden jetzt in UTF-8 gespeichert. Nutzer von Sonderzeichen müssen möglicherweise eigene Texte korrigieren oder die Konfiguration zurücksetzen.
  • 2009-05-19 (1605)
    • Die Standardprojektion wurde von EPSG:4326 auf Mercartor geändert.
  • 2009-05-19 (1603)
    • Neue Suchoperatoren parent und child erlauben es über- und untergeordnete Objekte der Ergebnisse einer Suchanfrage zu finden.
  • 2009-02-14 (1405)
    • Viele Veränderungen im Zeichenmodus (Doppelklick beendet Zeichnen). Auch der Wechsel auf den Alles-In-Einem-Potlatch-Stil ist in den Einstellungen möglich.
  • 2009-01-31 (1358)
    • Abbiegeeinschränkungen werden in der Karte dargestellt, ein Stern an der Relation kennzeichnet Probleme
    • Ein erster Anfang zur Nutzung von Objektvorlagen für Relationen wurde eingebaut
  • 2009-01-10 (1231)
    • Dateien können jetzt auch durch Fallenlassen in das JOSM Fenster geöffnet werden (Drag-n-Drop).
  • 2009-01-08 (1213)
    • Die Suchfunktion unterstützt nun die Suche mit regulären Ausdrücken.
  • 2009-01-03 (1208)
    • Die Anzeige der Punktnamen auf der Karte wurde verbessert. Wenn kein Name vorhanden ist, wird wenn vorhanden jetzt ref, operator oder brand angezeigt. Namen von unbekannten Objekten (also ohne Icon) werden jetzt ebenfalls angezeigt.
  • 2009-01-02 (1203)
    • Die Anzeige von Multipolygon-Relationen wird jetzt unterstützt. Dazu muss die Option "mappaint.multipolygon=true" gesetzt werden (wird später Standard sein). Wenn vor dem Namen einer Relation ein * erscheint, dann hat JOSM einen Fehler gefunden. Nutzen Sie das aktuelle Validator-Plugin, um den Fehler anzuzeigen.

2008

  • 2008-12-25 (1180)
    • Diese Version entfernt alte Bestandteile aus JOSM. Alte Plugins werden sehr wahrscheinlich nicht mehr funktionieren. Aktualisieren Sie alles.
  • 2008-11-28 (1078)
    • Falls die Option zum Anzeigen des heruntergeladenen Gebietes aktiviert ist (wobei bis jetzt gelbe Rechtecke für jedes Herunterladen zu sehen waren), wird jetzt das nicht heruntergeladene Gebiet mit gelben Streifen versehen und das heruntergeladene nicht. Dies sollte das Editieren erleichtern, da die Daten nicht mit gelben Linien zerschnitten werden.
  • 2008-11-14 (1076)
    • Die Funktion "Im Rechteck anordnen" wurde durch eine allgemeinere Funktion ersetzt, die alles orthogonalisieren kann, was "halbwegs rechtwinklig" ist.
  • 2008-10-29 (1058)
    • Die Übersetzungen von JOSM wurden umgestellt. Sprach-Plugins sind nicht mehr nötig. Die Übersetzungen kommen jetzt direkt mit JOSM. Die Sprache wird anhand der Systemeinstellungen oder des --language Parameters ermittelt.
  • 2008-10-05 (1023)
    • WARNUNG: JOSM unterstützt jetzt die Konfiguration der Tastaturkürzel. Dadurch haben sich einige Standardeinstellungen geändert. Bitte prüfen (und konfigurieren) Sie die Tastaturkürzel sorgfältig, um Datenverluste zu vermeiden.
  • 2008-08-24 (858)
    • Die Option zum Teilen von Punkten wurde integriert. Das UnGlue-Plugin ist nicht länger notwendig.
  • 2008-08-19 (805)
    • Diese Version hat einen neuen Zeichenmodus. Bei Nutzung des Auswahlwerkzeuges werden in der Mitte eines Linie kleine Kreuze angezeigt. Werden diese angeklickt, so entsteht ein neuer Punkt. Dadurch werden Zeichenmoduswechsel reduziert. Falls diese Option unerwünscht ist, können die virtuellen Punkte in den Einstellungen deaktiviert werden.
  • 2008-05-20 (643)
    • Diese Version hat eine kleine Änderung zum Zeichnen von Punkten: UMSCHALT+Klick wählt jetzt einen Punkt unter dem Mauszeiger aus (vorher wurde der Punkt nur gewählt, wenn nichts anderes aktiv war). Das ist konsistenter und reduziert die Anzahl der nötigen Wechsel in den Auswahlmodus.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Die Gummibandhilfslinie verbindet den letzten Punkt zum vorraussichtlich nächsten Punkt. Um dies auszuschalten die Einstellung "draw.helper-line" auf "false" setzen.
  • 2008-05-08 (608)
    • Die Statuszeile enthält Informationen über Position, Winkel und Länge des zu erstellenden Linienabschnittes.
  • 2008-05-08 (547)
    • Enthält jetzt Unterstützung für Audio Mapping mit kontinuierlich aufgezeichneten Sprachdateien

Last modified 5 years ago Last modified on 2013-06-25T23:17:25+02:00