wiki:Zh_TW:VersionHistory

舊的JOSM消息

  • 2020-07-31 (穩定版本 16812)
  • 2020-07-02 (穩定版本 16731)
    • 在歷史視窗中新增「恢復選取的標籤」功能 (經由語境選單)
    • 新增連結至 taghistory.raifer.tech
    • 新增「反向選擇」功能 (只有在專家模式)
  • 2020-06-02 (穩定版本 16538)
    • 新增波斯語與冰島語
    • Overpass 檢索精靈模式切換為 JOSM 搜尋語法
    • 改進在 HiDPI 螢幕下的指標渲染狀況
    • 新增預置選單下的色彩選擇器,在屬性對話框顯示色彩
    • 跳至位置:新增跳至位置名稱功能
  • 2020-04-06 (穩定版本 16239)
    • 新增阿拉伯語
    • 新增支援東阿拉伯(印度)和吉蔑數字
  • 2020-02-26 (穩定版本 15937)
    • Maxar 影像又再次可以使用了
    • 增加 Geofabrik 的地區/國家標籤資訊站的連結 - 相當感謝 Geofabrik
    • 改進自動篩選器
    • "新增標籤"和"改變數值"對話框的確認按鈕,會顯示相關標籤/mappaint 樣式圖示
  • 2020-02-01 (穩定版本 15806)
    • Tag2Link 插件已經融入 JOSM 核心並且已經大幅改進
    • 點兩下滑標來重設透明度/彩度/gamma/銳利度
    • 智慧切割路徑功能
  • 2020-01-02 (穩定版本 15628)
    • 新增國家級的 taginfo,如果有則顯示連結
    • 在上傳對話框自動填充變更集的來源標籤選項

2019

  • 2019-12-02 (穩定版本 15553)
    • 新語言馬拉提語
    • gpx 圖層多項改進措施
  • 2019-11-02 (穩定版本 15492 (en))
    • 增加 GeoJSON 匯入功能
  • 2019-09-30 (穩定版本 15390 (en))
  • 2019-08-26 (穩定版本 15322 (en))
    • 新 logo
    • 經由遠端控制新增變動集標籤
  • 2019-07-10 (穩定版本 15238 (en))
    • 用國家名稱篩選影像清單
  • 2019-06-02 (穩定版本 15155 (en))
    • 在影像設定裡加上分類圖示,以及從清單中篩選框。分類有:照片、歷史照片、地圖、歷史地圖、基於osm的地圖和其他。
    • 當不能歸類圖片時,在圖磚選單 (en)的次選單中顯示動態影像說明。
  • 2019-04-29 (穩定版本 15031 (en))
  • 2019-03-31 (穩定版本 14945 (en))
    • 多項驗證器面板改進:「管理忽略清單」,「從現在起忽略」等
  • 2019-03-02 (穩定版本 14824 (en))
    • 新語言:加拿大英語
  • 2019-02-05 (穩定版本 14760 (en))
    • 我們伺服器的贊助者如今是 FOSSGIS e.V. - 十分感謝 Hetzner 的支持,如今能夠使用 FOSSGIS 強大的新硬體。

2018

  • 2018-12-31 (穩定版本 14620)
    • 自動調整標籤表格寬度以符合畫面需求
  • 2018-11-28 (穩定版本 14460)
    • 資料下載:"下載為新圖層"從核取方塊變成單獨的按鈕
    • 右側每個面板的高度在 JOSM 關閉時都會被記下來
  • 2018-11-18
  • 2018-10-28 (穩定版本 14382)
    • 在清單中顯示物件歷史的選項
  • 2018-10-02 (穩定版本 14289)
    • 為了圖片與 gpx 軌跡的關聯而做的各項增強
  • 2018-08-22 (穩定版本 14178)
  • 2018-08-18 (穩定版本 14163)
    • 支援 Overpass API JSON 格式
    • 支援 OSMAnd 產生的 osmChange 檔案 (.osc) 註解 (en)
    • GPX 轉換到 OSM 標籤的選項 (en)
  • 2018-07-29 (穩定版本 14066)
    • 支援 GDPR 相容 OSM 資料
  • 2018-07-09 (穩定版本 14026)
  • 2018-07-01 (穩定版本 13996)
  • 2018-05-31 (穩定版本 13878)
  • 2018-05-27 (穩定版本 13860)
    • 新增韓語翻譯
    • 大幅改進 WMS/WMTS 支援程度
  • 2018-05-07 (穩定版本 13710)
    • 新增 724 個新投影 (JOSM 如今總共支援 6135 個投影)
    • source:trunk/resources/images/dialogs/layerlist/offset.svg 圖示顯示背景圖層是否有移動(偏移)
    • 在上傳視窗裡對物件點兩下會縮放到該物件
  • 2018-03-26 (穩定版本 13576)
  • 2018-03-04 (穩定版本 13500)
  • 2018-03-01 (穩定版本 13478)
  • 2018-01-28 (穩定版本 13367)
    • 增加支援 XZ 壓縮檔案
    • 更好支援 WMS 1.3.0

2017

  • 2017-12-31 (穩定版本 13265)
  • 2017-11-26 (穩定版本 13170)
    • 註解的文字已經可以被選取和複製;連結也可以點了
    • 能夠在背景狀況上傳資料
    • 切換 JOSM 和其他應用程式時,不會全選文字框內文字
  • 2017-10-29 (穩定版本 13053)
    • 下載視窗會顯示已經下載區域,而小地圖和圖層選擇按鈕已經更精進
    • 關係編輯器裡的新按鈕已經能選擇關係本身了
  • 2017-10-06 (最新版本 12926)
    • JOSM 現在使用由 FOSSGIS e.V. 簽署的新程式碼認證 (網頁啟動所需)
  • 2017-10-03 (穩定版本 12921)
    • 增加歷史變更組合管理系統視窗,連結到外部的變更組合瀏覽器
    • 增加上傳視窗的請求覆核核取方框
    • 建立圓形功能自動根據圓形直徑採用合適的節點數量
    • 新的命令列參數,可以無需圖形化界面即可執行某些務:
    • 使用 MapCSS 風格渲染 osm 資料
    • 可以從一種投影法轉換到另一種投影法
  • 2017-09-02 (穩定版本 12712)
  • 2017-07-30 (穩定版本 12542)
    • 搜尋視窗裡用預設組合搜尋
    • 新 "家位置" 書籤 (如果有在 OSM 使用者設定設置),以及最後 15 筆變更組合
  • 2017-07-02 (穩定版本 12450)
  • 2017-05-29 (穩定版本 12275)
  • 2017-05-02 (穩定版本 12039)
    • 圖片圖層重新投影(扭轉):允許整合不同投影來源。
  • 2017-04-02 (穩定版本 11826)
    • 完全防止有 "upload=never" 的 osm 檔案圖層上傳
    • 不要縮放到新下載資料的選項。 (只有專家模式)
  • 2017-02-27 (穩定版本 11639)
    • 現在 GPS 熱力圖模式有設定選項能夠調整外觀。
    • 可以在影像設定選擇影像的鏡像伺服器。
  • 2017-02-02 (穩定版本 11526)
    • 可以用新的熱力圖模式顯示 GPS 軌跡。

2016

  • 2016-12-31 (穩定版本 11427)
    • 內部資料庫已經有所有國家資料。簡單的驗證規則和 mappaint 樣式可以只限制在特定國家。
    • 開啟位置視窗,支援所有型態的簡單拖拉連結的方式下載資料。
    • 增加值視窗的鍵值方格,如果第一個鍵已經使用了,會被清單裡下個標籤預填。
  • 2016-11-06 (穩定版本 11223)
  • 2016-09-05 (穩定版本 10966)
  • 2016-08-12 (穩定版本 10786)
    • JOSM 核心大改寫轉換使用 Java 8
    • 新功能"貼上來源位置"在編輯選單裡 (Ctrl+Alt+V,只有在專家模式)
    • 支援 geo: 網址
  • 2016-07-12 (穩定版本 10526)
    • JOSM 核心重大改寫工作
  • 2016-04-28 (穩定版本 10161)
  • 2016-03-13 (穩定版本 9979)
    • OAuth已經是預設的帳戶認證方式。
    • 關係編輯器支援拖放功能(更多資訊)
    • 關係編輯器裡新增重新整理關係的新按鈕(例如分割路徑之後)
    • 歷史視窗的地圖部分用顯示移動的節點呈現新舊座標
    • 自動縮放放大倍數到背景影像的預設解析度
    • 擴大支援不同的投影座標系統

2015

  • 2015-12-31 (穩定版本 9229)
  • 2015-11-23 (穩定版本 9060)
    • 支援書面挪威語
  • 2015-10-30 (穩定版本 8969)
    • 路徑切割: 分割後最長路徑會重新使用原先路徑的 id/歷史 (專家使用者可以選擇其他片段)
    • 不只在地圖顯示節點圖示,也在清單中顯示 (例如在選取視窗,關係編輯器或是上傳視窗)
  • 2015-09-28 (穩定版本 8800)
    • 整合 Overpass 下載資料和 Overpass Turbo 精靈模式 (使用專家模式啟動)
    • 增加縮圖顯示
    • 增加 taginfo 連結
    • 可調整背景影像的 Gamma 值 
  • 2015-08-22 (穩定版本 8677)
  • 2015-06-17 (穩定版本 8491)
    • 支援白俄羅斯語
    • 支援越南語
  • 2015-04-18 (8227)
    • 支援巴倫西亞語
  • 2015-03-31 (8160)
    • 支援立陶宛語
  • 2015-03-02 (8109)
    • 在 Windows 平臺新增更多種字型以便支援更多種語言
    • 部分外掛可以直接安裝後使用,不必重新啟動 JOSM
    • 新增搜尋欄位(右上角)
    • 原生的備註已經預設啟用 (已經不再支援外掛)。
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • 兩種新語言:阿斯圖里亞斯語和高綿語
    • 在OS X和Windows系統,設定、使用者資料和暫存資料夾改變位置。
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
  • 2014-09-30 (7588)
    • 更好的 OS X 整合 (詳情請見 #10455)。
    • 預設組合選單會顯示 OSM 標籤。
  • 2014-09-20 (7569)
    • JOSM 現在會警告舊式多重多邊形狀況,解決之道為將外圈的相關標籤轉移到整個關係。
  • 2014-08-31 (7480)
    • 改進了預設地圖樣式:
      • 低放大倍率下隱藏節點符號和圖示(可在樣式設定中設定)
      • 更好的區域內標籤標示
      • 公路的名稱沿著道路顯示
    • 離線模式有新的命令列參數 --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • 我們要舉辦新 logo 的設計大賽!報名至 9 月 30 日截止,詳情請看 wiki
  • 2014-07-04 (7287)
    • 拉伸功能新的雙重對齊模式上線。
    • 自動重新載入本地端地圖的繪圖樣式和驗證器規則。
    • 影像清單自動更新功能
  • 2014-05-18 (7139)
    • JOSM 的預設地圖樣式格式從 XML 轉成 MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • 升級至 Java 7,以及清理許多程式碼
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • 允許透過 HTTPS 方式連線至 OSM API
  • 2014-01-29 (6767)
    • 新的基於 MapCSS 標籤檢查器,可以透過自訂規則擴充
    • 新增透過預設組合搜尋功能Shift-F3
    • 增強預設組合/MapCSS/檢查器

2013

  • 2013-12-20 (6502)
    • 上傳視窗會詢問變更集的 source 標籤
    • 歷史視窗:載入和顯示變更集內容
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg 增進路徑正確性為非專家啟用
    • Many other enhancements and bug fixes (changelog)
  • 2013-11-17 (6388)
    • 更新的語言檔案
  • 2013-11-12 (6383)
    • New command to disconnect node from way
    • Notification of newly received OSM messages
    • Many minor enhancements of presets, styles and validator plus other parts
  • 2013-09-20 (6238)
    • New non-intrusive notification messages
    • New "session" item in file menu visible in expert mode
    • 完整支援 GPX 路線
    • Lots of minor enhancement of presets, restart, styles and validator plus performance improvements
  • 2013-08-07 (6115)
    • Request OAuth permission to fully support the new notes plugin
    • Refactoring of the plugin menus to support better grouping and integration
    • Prefer the child node of (last) selected objects when selecting nodes with duplicates
    • Many other enhancements and bug fixes (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • possibility to set keyboard shortcuts for presets and other toolbar buttons plus new context menu item "Edit shortcut" to define them
    • automatic zoom for WMS layers
    • new "Toggle panels" action on TAB to hide/unhide toggle dialog panel
  • 2013-05-08 (5939)
    • integrate restart plugin into core
    • right click menu "undo, cut, copy, paste, delete, select all" for each text component
    • improve performance of purge command
  • 2013-04-08 (5836)
    • major rework of context menus
    • add "clear buffer" button to remove incorrect buffer from "paste tag from text" action
    • remove support for the (deprecated) imagery offset server
  • 2013-03-07 (5759)
    • Ctrl-Shift-V now can paste tags from text buffer, e.g., a=2,c=3 and a 2 c 3
    • multiple MapCSS rendering improvements
    • allow dragging nodes in Extrude mode
    • context menus in Add/Edit property dialogs, option to fix keyboard layout
    • basic date-filtering of GPS traces
    • remote control: allow deleting tags and creating objects with tags
    • lots of minor enhancements and bug fixes
  • 2013-02-06 (5697)
    • roles are suggested in the relation editor and upon creating a relation
    • possibility to filter in the relation list toggle dialog
    • several enhancements of the "Add Value" dialog including a help button, remembering position and the possibility to add several tags in a row without closing the dialog
    • new imagery entry wms_endpoint and rework of WMS/TMS Dialog
    • new validator test for addresses and wikipedia tags and performance improvement in layer painting and error fixing
    • lots of minor enhancements

2012

  • 2012-12-08 (5608)
    • new operators nth: and nth% allow to search for position in ways
    • some minor enhancement of remote control and internal presets
  • 2012-11-10 (5576)
    • "nautical mile" (NM) is supported as system of measurement
  • 2012-10-08 (5531)
    • rework of validator building test
    • some more tags are automatically discarded on upload (TIGER, odbl, yh)
    • code regarding license change was removed
  • 2012-08-29 (5482, 5485)
    • imagery providers are suggested, according to the downloaded region
    • when adding tags to nodes, ways or relations, the five last used tags are displayed for quicker selection
    • filter tool has better support for multipolygons
    • You can no longer open a directory in the 'File > Open...'-dialog and load all containing photos automatically. Instead, select the image files directly (using Ctrl-A or Shift-Click). The 'Import images' tool from the context menu of a GPX-layer still works in the old way, so you can recursively load photos by opening a higher-level directory.
  • 2012-07-23 (5353, 5356)
    • 對於被授權變更節錄機器人所修改資料的程式錯誤修正
    • 對地圖樣式與 validator 測試的小幅增強,包含對未使用圖層的繪製與在 validator 對話盒中名稱的顯示
  • 2012-07-03 (5315)
    • validator 、衝突對話盒以及合併圖層時的主要程式錯誤修正
    • 衝突對話盒的許多強化,包括在元素 (關連選單) 上選擇選項 (雙擊) 和縮放
    • 許多在 validator 測試上的強化
  • 2012-06-04 (5267)
    • 新的語言: Portuguese (European) (pt), Catalan (ca)
    • 支援自訂投影法
    • 建立多重多邊形時會把標籤移至關係上
  • 2012-05-02 (5210)
    • 小幅度的強化
      • 將替代搜尋對話盒設為預設值
      • JOSM 啟動時可使用命令列引數 --load-preferences= 來套用設定值
      • 允許 MapCSS 的樣式左側與右側不同
  • 2012-04-14 (5181)
    • josm.openstreetmap.de 的進入頁面已經簡化並重新組織過了
    • 新釋出的已測試版本 (5181) 釋出,包含許多變更/強化,這些包括
      • source:trunk/resources/images/mapmode/rope.svg 套索式選擇模式 (專家模式)
      • 給初學者用的資訊對話盒:對沒有對齊的圖片、當合併有衝突標籤或其他關係一部分的路徑時提出警告
      • 關係編輯器的新功能:"將選擇區域加入關係" (當在一個關係上按右鍵時), "選擇上一個/下一個" (在關係編輯器中)
      • 檢視選單的使用者介面改良: "地圖繪製樣式",可以隱藏編輯工具列的能力
      • 許多在啟動時間上的改善
  • 2012-02-07 (4905)
    • 關係編輯器 加入捷徑鍵: Alt-Up, Alt-Down (以上/下移動選取的成員),Alt-Del (刪除成員) 和 Alt-Home (下載不完整的成員)
    • 摘要 change log ,包含了穩定釋出版之間的相關變更。
  • 2012-02-02 (4897 ...)
    • 在 JOSM 和外掛程式中的捷徑鍵衝突已修正。許多的功能捷徑鍵都會改變!
  • 2012-01-22 (4846)
    • ImproveWayAccuracy 外掛程式已加入核心程式中。選擇一條路徑,點選 source:trunk/resources/images/mapmode/improvewayaccuracy.svg,並改善它的準確度。請查閱 help page 以了解詳細的使用方法。
  • 2012-01-21 (4791, 4796, 4833)
    • RemoteControl 功能有許多擴充:新的指令 '/load_object' 可以依 id 下載物件;'/add_way' 指令可以由某個坐標建立新的路徑;'/load_and_zoom' 指令的 'new_layer' 參數可以將資料載入到新的圖層。
  • 2012-01-12 (4789)
    • 新的命令列選項可以在啟動時設定任意偏好設定數值。 (例如: --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • 突顯在滑鼠游標下方的節點與路徑可以關閉:'偏好設定' > '顯示設定值' > 'OSM 資料' (只有在 專家模式)
    • 繪製動作 source:trunk/resources/images/mapmode/node/autonode.svg 可以用個別角度繪製區段 (例如, 30/45°)。請按 Tab 鍵來循環不同的模式。
  • 2012-01-04 (4765)
    • 右側對話盒按鈕的自動隱藏可以依每個視窗個別停用。 (使用視窗右上角的眼睛符號)

2011

  • 2011-12-29 (4745)
    • 新的指令可以沿著 gpx 軌跡載入與快取 WMS 背景圖片。 (在 GPX-圖層選單按右鍵)
  • 2011-12-20 (4673)
    • Lambert 93 projection (EPSG:2154) is available for France.
  • 2011-12-20 (4670)
    • Languages Arabic, Icelandic and Hebrew have been removed due to missing translation efforts.
  • 2011-12-05 (4621-4636)
    • Performance with large multipolygons improved.
  • 2011-11-26 (4609, 4611)
    • The buttons of the edit toolbar (upper left area) can be hidden.
    • When drawing ways, the backspace key takes back the last action.
  • 2011-11-20 (4601)
    • The version history display now shows the license status for each contributing user.
  • 2011-11-15 (4595)
    • Support for multipart shortcuts. For example Ctrl+Alt+S, 1 toggles the visibility of the first layer.
  • 2011-11-14 (4593)
    • On small screens, long menus are no longer clipped, but can be scrolled up and down.
  • 2011-11-07 (4587)
    • New option in the search dialog to add a toolbar button for the search. The button can be removed later from the right click menu of the button. (Only in expert mode.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • The internal format for saving user preference data has been changed to XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • Expert mode introduced to reduce complexity for new users. For compatibility existing installations are experts by default.
  • 2011-10-07 (4497, 4498, 4500)
    • More options in 'File > Download Object...' dialog.
    • History dialog: Better display of inserted / deleted way nodes (and relation members).
    • New shortcuts in properties dialog: Alt+A, Alt+S, Alt+D for Add, Edit, Delete.
  • 2011-09-23 (4454)
    • Copy key and value to clipboard by right click in the properties dialog.
  • 2011-09-12 (4416, 4423)
    • Bounds of imagery services are displayed on a preview map in 'Preferences > Imagery'.
  • 2011-09-08 (4408)
    • Menu item 'Inspect' in context menu of the selection dialog has moved to 'View > Advanced Info'.
  • 2011-09-07 (4405)
    • List in 'Preferences > Imagery' is sorted by country code.
  • 2011-08-29 (4380)
    • New feature 'Edit > Copy Coordinates'.
  • 2011-08-28 (4371)
    • The list of recently opened files shows not just opened, but also saved files.
  • 2011-08-27 (4355)
    • Dynamic visibility of button row in toggle dialogs to the right (optional, advanced preferences 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Shortcuts to toggle layer visibility (Alt-1 to Alt-9)
  • 2011-08-21 (4332)
    • Selection of visible tracks, for each gpx layer (from the right click menu of the layer)
  • 2011-08-21 (4327)
    • Select and delete mode now have better visual indication what the next action will do (highlighting, cursor changes).
  • 2011-07-18 (4256)
    • 支持自由開放的可縮放向量圖形 (SVG) 格式
  • 2011-07-14 (4241)
    • 考慮 JEPG 圖像有關導覽(Orientation)的圖片資訊(EXIF)
  • 2011-07-07 (4207)
    • GPS 軌跡可以用不同顏色來區分方向
  • 2011-06-18 (4142)
    • Extrude 模式: 將滑鼠移動到在一個線段上點兩下就可以加入一個新的點。
  • 2011-06-11 (4126, 4129, 4134)
    • 記憶體最佳化,並且對 GPX 軌跡的繪製更加快速
    • 新的繪製模式:在現有路徑旁加上平行的路徑。 (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • 新的跟隨直線功能,方便繪製臨近區域。 (類似 Potlatch 2 的 "F" 捷徑鍵)
    • 搜尋 (與過濾) 現在可以查詢封閉路徑,以及含有最小和最大值的封閉區域。 (關鍵字:closed; areasize:MIN-MAXareasize:MAX,以 m² 為單位)
    • 下載物件...功能現在能使用 id 清單。
  • 2011-04-18 (4032)
    • 在工具列中加入多重自訂搜尋字串或有自己圖示的背景圖層。
    • 更新在使用者清單中顯示重新授權狀態 (綠色勾勾 - 已同意,灰色勾勾 - 自動同意,紅色勾勾 - 不同意)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • 新的檢視跟隨功能 - 移動檢視埠將最後放置的節點保持在中央。(主選單 > 檢視; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • 外掛程式 imagerywmspluginslippymapremotecontrol 已整合到 JOSM 核心。
  • 2010-12-07 (3705)
    • 圖層可用透明的方式顯示。 (在圖層清單對話盒中的新按鈕)
  • 2010-12-07 (3702)
    • 支援縮放物件。 (在選擇模式中按 Ctrl+Alt)
    • 資訊 按 Ctrl+Shift 可旋轉物件。
  • 2010-11-25 (3669)
    • Validator 外掛程式已整合至主程式。
  • 2010-09-23 (3557, #5427)
    • Change in “Extrude” mode (X): When moving in one direction multiple times, no superfluous nodes remain. (Shift key forces the old behaviour.)
  • 2010-09-14 (3529)
    • 在屬性對話盒中的標籤,您都可以直接開啟瀏覽器來觀看對應的 wiki 頁面。
  • 2010-09-03 (o22964)
    • WMS 外掛程式支援 GetCapabilities 要求。
  • 2010-08-13 (3431)
    • 新的清除指令可以清除資料圖層。
  • 2010-07-27 (3388)
    • 新的標籤預設組合搜尋對話盒。
  • 2010-07-20 (3378)
    • JOSM 現在可以回復您上一次編輯時當機前的狀態。
    • JOSM 現在需要 Java 版本 6。Java 版本 5 的使用者需要使用 舊版的 JOSM。
  • 2010-06-03 (3306)
    • Search supports searching for role in relation membership.
    • The properties dialog shows position of relation membership.
  • 2010-06-01 (3291)
    • Roles defined in presets are now used. This may result in unexpected validator warnings for relations not yet know to JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
    • With the new Filter feature you can temporarily hide certain kinds of objects.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • New dialog to download an object by id and optionally all ways and relations that use this object.
  • 2010-01-28 (2901)
    • New: Create a duplicate of the selected data layer without a file association.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • The plugins utilsplugin and AgPifoJ have been integrated in JOSM core.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 8 years ago Last modified on 2013-06-25T23:21:02+02:00