wiki:Zh_CN:VersionHistory

JOSM 历史消息

  • 2020-07-31 (稳定版 16812)
  • 2020-07-02 (稳定版 16731)
    • 在历史视窗中新增「恢复选取的标签」功能 (经由语境选单)
    • 新增连结至 taghistory.raifer.tech
    • 新增「反向选择」功能 (只有在专家模式)
  • 2020-06-02 (稳定版 16538)
    • 新增波斯语与冰岛语
    • Overpass 检索精灵模式切换为 JOSM 搜寻语法
    • 改进在 HiDPI 萤幕下的指标渲染状况
    • 新增预置选单下的色彩选择器,在属性对话框显示色彩
    • 跳至位置:新增跳至位置名称功能
  • 2020-04-06 (稳定版 16239)
    • 新增阿拉伯语
    • 新增支援东阿拉伯(印度)和高棉数字
  • 2020-02-26 (稳定版 15937)
    • Maxar 影像又再次可以使用了
    • 增加 Geofabrik 的地区/国家标签资讯站的连结 - 相当感谢 Geofabrik
    • 改进自动筛选器
    • "新增标签"和"改变数值"对话框的确认按钮,会显示相关标签/mappaint 样式图示
  • 2020-02-01 (稳定版 15806)
    • Tag2Link 插件已经融入 JOSM 核心并且已经大幅改进
    • 点击顶点标来重设基线/彩度/ gamma /锐利度
    • 智能切割路径功能
  • 2020-01-02 (稳定版 15628)
    • 新增国家级的 taginfo,如果有则显示连结
    • 在上传对话框自动填充变更集的来源标签选项

2019

  • 2019-12-02 (稳定版 15553)
    • 新语言马拉提语
    • gpx 图层多项改进措施
  • 2019-11-02 (稳定版 15492 (en))
    • 增加 GeoJSON 汇入功能
  • 2019-09-30 (稳定版 15390 (en))
  • 2019-08-26 (稳定版 15322 (en))
    • 新 logo
    • 经由远端控制新增变动集标签
  • 2019-07-10 (稳定版 15238 (en))
    • 用国家名称筛选影像清单
  • 2019-06-02 (稳定版 15155 (en))
    • 在影像设定里加上分类图示,以及从清单中筛选框。分类有:照片、历史照片、地图、历史地图、基于osm的地图和其他。
    • 当不能归类图片时,在图砖选单 (en)的次选单中显示动态影像说明。
  • 2019-04-29 (稳定版 15031 (en))
  • 2019-03-31 (稳定版 14945 (en))
    • 多项验证器面板改进:"管理忽略清单","从现在起忽略"等
  • 2019-03-02 (稳定版 14824 (en))
    • 新语言:加拿大英语
  • 2019-02-05 (稳定版 14760 (en))
    • 目前我们的服务器赞助者是 FOSSGIS e.V. - 十分感谢 Hetzner 一直以来的支持以及 FOSSGIS 提供强大的新硬件。

2018

  • 2018-12-31 (稳定版 14620)
    • 根据内容自动调整标签表格宽度
  • 2018-11-28 (稳定版 14460)
    • 数据下载:"下载为新图层"从复选框变为单独的按钮
    • 在关闭 JOSM 时保存右侧每个面板的高度
  • 2018-11-18
  • 2018-10-28 (稳定版 14382)
    • 可在对象列表中选择显示对象历史
  • 2018-10-02 (稳定版 14289)
    • 为了图片与 gpx 轨迹的关联而做的各项增强
  • 2018-08-22 (稳定版 14178)
  • 2018-08-18 (稳定版 14163)
    • 支援 Overpass API JSON 格式
    • 支援 OSMAnd 产生的 osmChange 档案 (.osc) 注解 (en)
    • GPX 转换到 OSM 标签的选项 (en)
  • 2018-07-29 (稳定版 14066)
    • 支援 GDPR 相容 OSM 资料
  • 2018-07-09 (稳定版 14026)
  • 2018-07-01 (稳定版 13996)
  • 2018-05-31 (稳定版 13878)
  • 2018-05-27 (稳定版 13860)
    • 新增韩语翻译
    • 大幅改进 WMS/WMTS 支援程度
  • 2018-05-07 (稳定版 13710)
    • 新增 724 个新投影 (JOSM 如今总共支援 6135 个投影)
    • source:trunk/resources/images/dialogs/layerlist/offset.svg 图示显示背景图层是否有移动(偏移)
    • 在上传视窗里对物件点两下会缩放到该物件
  • 2018-03-26 (稳定版 13576)
  • 2018-03-04 (稳定版 13500)
  • 2018-03-01 (稳定版 13478)
  • 2018-01-28 (稳定版 13367)
    • 增加支援 XZ 压缩档案
    • 更好支援 WMS 1.3.0

2017

  • 2017-12-31 (稳定版 13265)
  • 2017-11-26 (稳定版 13170)
    • 笔记 的文本现已可被选择和复制; 链接也可以点击
    • 能够在后台上传数据
    • 在切换JOSM与其他应用时,不全选文本框中的全部字符
  • 2017-10-29 (稳定版 13053)
    • 下载窗口会显示已下载区域,并且改善了小地图和图层选择按钮
    • 关系编辑器里的新按钮已经可以选择关系本身了
  • 2017-10-06 (最新版本 12926)
    • JOSM 现在使用由 FOSSGIS e.V. 支持的新代码签名证书 (需要WebStart)
  • 2017-10-03 (稳定版 12921)
    • 历史修改集合管理器窗口增加外部修改集合浏览器的链接
    • 为上传窗口增加反馈请求复选框
    • 创建圆功能自动根据圆直径使用合适的节点数
    • 新的命令行参数,无需图形用户界面即可执行某些任务
    • 使用MapCSS风格渲染osm数据
    • 可以从一种投影法转换至另一种
  • 2017-09-02 (稳定版 12712)
  • 2017-07-30 (稳定版 12542)
    • 搜寻视窗里用预设组合搜寻
    • 新 "家位置" 书签 (如果有在 OSM 使用者设定设置),以及最后 15 笔变更组合
  • 2017-07-02 (稳定版 12450)
  • 2017-05-29 (稳定版 12275)
  • 2017-05-02 (稳定版 12039)
    • 图片图层重新投影(扭转):允许整合不同投影来源。
  • 2017-04-02 (稳定版 11826)
    • 完全防止有 "upload=never" 的 osm 档案图层上传
    • 不要缩放到新下载资料的选项。 (只有专家模式)
  • 2017-02-27 (稳定版 11639)
    • 现在 GPS 热力图模式有设定选项能够调整外观。
    • 可以在影像设定选择影像的镜像伺服器。
  • 2017-02-02 (稳定版 11526)
    • 可以用新的热力图模式显示 GPS 轨迹。

2016

  • 2016-12-31 (稳定版 11427)
    • 现已自带所有国境线,以便特定的数据检验规则和地图显示样式仅在相应地区生效。
    • 打开位置窗口现已支持所有类型的链接通过拖曳或粘贴的方式下载数据。
    • 添加标签窗口中,如果对象已有最近使用的键,则自动填写最近标签列表中的下一个键。
  • 2016-11-06 (稳定版 11223)
  • 2016-09-05 (稳定版 10966)
  • 2016-08-12 (稳定版 10786)
    • 改用 Java 8 重构 JOSM 核心
    • 编辑菜单内新功能"粘贴至原位置" (Ctrl+Alt+V,仅限专家模式)
    • 支持 geo: 网址
  • 2016-07-12 (稳定版 10526)
    • JOSM 核心重大改写工作
  • 2016-04-28 (稳定版 10161)
  • 2016-03-13 (稳定版 9979)
    • OAuth已经是预设的帐户认证方式。
    • 关系编辑器支持拖放功能(更多资讯)
    • 关系编辑器里新增重新整理关系的新按钮(例如分割路径之后)
    • 历史视窗的地图不能用显示移动的节点呈现新旧座标
    • 自动缩放放大倍数到背景影像的预设解析度
    • 扩大支持不同的投影座标系统

2015

  • 2015-12-31 (稳定版 9229)
    • 区域仅填充内侧边缘附近。相关设置可在 JOSM 标准绘图样式中的样式设置中修改。 更多样式设置信息
  • 2015-11-23 (稳定版 9060)
    • 支持书面挪威语
  • 2015-10-30 (稳定版 8969)
    • 打断路径: 打断后最长路段继承原始路径的 id 和历史 (专家模式可选另一段)
    • 除在地图视图外新增在列表中显示节点符号(如选择对话框、关系编辑器或上传对话框)
  • 2015-09-28 (稳定版 8800)
    • 集成 Overpass 和 Overpass Turbo 向导 (仅限专家模式)
    • 新增缩略图
    • 新增 taginfo 链接
    • 可自定义底图影像的 Gamma 值
  • 2015-08-22 (稳定版 8677)
  • 2015-06-17 (稳定版 8491)
    • 支持白俄罗斯语
    • 支持越南语
  • 2015-04-18 (8227)
    • 支持巴伦西亚语
  • 2015-03-31 (8160)
    • 支持立陶宛语
  • 2015-03-02 (8109)
    • 新增字体以便在 Windows 上支持更多语言
    • 部分插件可无需重启 JOSM 直接安装使用。
    • 右上角新增主菜单搜索框
    • 默认启用核心组件的笔记功能,不再推荐使用笔记插件。
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • 支持两种新语言:阿斯图里亚斯语和高棉语(柬埔寨语)
    • OS X 和 Windows 系统中首选项、用户数据和缓存目录改变。
  • 2014-12-10 (7777)
    • 新 logo 由 Diamond00744 设计。
    • 新增 OSM 笔记上传/下载功能
    • 历史按钮从侧边工具栏移除,建议使用选择对话框中新增的历史按钮。
  • 2014-10-21 (7643)
  • 2014-09-30 (7588)
    • 更好的 OS X 整合(详见 #10455)。
    • 在预设组合界面显示 OSM 标签。
  • 2014-09-20 (7569)
    • JOSM 现在对旧式多重多边形发出警报,可通过将外部路径的相关标签移至整个关系解决。
  • 2014-08-31 (7480)
    • 改进了默认地图样式:
      • 低放大倍数下隐藏节点符号和图标(可在样式设置中配置)。
      • 更好的区域内标签位置
      • 公路的名称沿线划显示
    • 离线模式有新的命令行参数 --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • 我们要举办新 logo 的设计大赛!报名截止至 9 月 30 日,详情请看 wiki
  • 2014-07-04 (7287)
    • 拉伸功能中新的双重对齐模式。
    • 自动重新加载本地地图样式和验证器规则。
    • 图像列表自动更新功能
  • 2014-05-18 (7139)
    • JOSM 默认地图样式格式已从 XML 转换为 MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • 升级至 Java 7,清理代码
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • 允许以 HTTPS 连接访问 OSM API
  • 2014-01-29 (6767)
    • 新增基于 MapCSS 的标签检查器,支持自定义规则扩展
    • 新增搜索预设组合功能 Shift-F3
    • 预设组合/MapCSS/检查器改进

2013

  • 2013-12-20 (6502)
    • 上传视窗会询问变更集的 source 标签
    • 历史视窗:载入和显示变更集内容
    • source:trunk/resources/images/mapmode/improvewayaccuracy.svg 增进路径正确性为非专家启用
    • Many other enhancements and bug fixes (changelog)
  • 2013-11-17 (6388)
    • Up-to-date language files
  • 2013-11-12 (6383)
    • New command to disconnect node from way
    • Notification of newly received OSM messages
    • Many minor enhancements of presets, styles and validator plus other parts
  • 2013-09-20 (6238)
    • New non-intrusive notification messages
    • New "session" item in file menu visible in expert mode
    • 完整支援 GPX 路线
    • Lots of minor enhancement of presets, restart, styles and validator plus performance improvements
  • 2013-08-07 (6115)
    • Request OAuth permission to fully support the new notes plugin
    • Refactoring of the plugin menus to support better grouping and integration
    • Prefer the child node of (last) selected objects when selecting nodes with duplicates
    • Many other enhancements and bug fixes (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • possibility to set keyboard shortcuts for presets and other toolbar buttons plus new context menu item "Edit shortcut" to define them
    • automatic zoom for WMS layers
    • new "Toggle panels" action on TAB to hide/unhide toggle dialog panel
  • 2013-05-08 (5939)
    • integrate restart plugin into core
    • right click menu "undo, cut, copy, paste, delete, select all" for each text component
    • improve performance of purge command
  • 2013-04-08 (5836)
    • major rework of context menus
    • add "clear buffer" button to remove incorrect buffer from "paste tag from text" action
    • remove support for the (deprecated) imagery offset server
  • 2013-03-07 (5759)
    • Ctrl-Shift-V now can paste tags from text buffer, e.g., a=2,c=3 and a 2 c 3
    • multiple MapCSS rendering improvements
    • allow dragging nodes in Extrude mode
    • context menus in Add/Edit property dialogs, option to fix keyboard layout
    • basic date-filtering of GPS traces
    • remote control: allow deleting tags and creating objects with tags
    • lots of minor enhancements and bug fixes
  • 2013-02-06 (5697)
    • roles are suggested in the relation editor and upon creating a relation
    • possibility to filter in the relation list toggle dialog
    • several enhancements of the "Add Value" dialog including a help button, remembering position and the possibility to add several tags in a row without closing the dialog
    • new imagery entry wms_endpoint and rework of WMS/TMS Dialog
    • new validator test for addresses and wikipedia tags and performance improvement in layer painting and error fixing
    • lots of minor enhancements

2012

  • 2012-12-08 (5608)
    • new operators nth: and nth% allow to search for position in ways
    • some minor enhancement of remote control and internal presets
  • 2012-11-10 (5576)
    • "nautical mile" (NM) is supported as system of measurement
  • 2012-10-08 (5531)
    • rework of validator building test
    • some more tags are automatically discarded on upload (TIGER, odbl, yh)
    • code regarding license change was removed
  • 2012-08-29 (5482, 5485)
    • imagery providers are suggested, according to the downloaded region
    • when adding tags to nodes, ways or relations, the five last used tags are displayed for quicker selection
    • filter tool has better support for multipolygons
    • You can no longer open a directory in the 'File > Open...'-dialog and load all containing photos automatically. Instead, select the image files directly (using Ctrl-A or Shift-Click). The 'Import images' tool from the context menu of a GPX-layer still works in the old way, so you can recursively load photos by opening a higher-level directory.
  • 2012-07-23 (5353, 5356)
    • major bug fixes in handling of data modified by the License change redaction bot
    • small enhancements in map styles and validator tests, including the rendering of inactive layers and the display of names in validator dialog
  • 2012-07-03 (5315)
    • major bug fixes in validator, conflict dialog and when merging layers
    • several enhancements in conflict dialog including option to select (double click) and zoom on elements (context menu)
    • several enhancements in validator tests
  • 2012-06-04 (5267)
    • new languages: Portuguese (European) (pt), Catalan (ca)
    • support for custom projections
    • move tags to relation when creating a multipolygon
  • 2012-05-02 (5210)
    • Some minor enhancements
      • make alternative search dialog default
      • command line argument --load-preferences= to apply settings on JOSM start
      • Allow MapCSS to style right and left side casings differently
  • 2012-04-14 (5181)
    • The entry page of josm.openstreetmap.de has been simplified and re-organized
    • A tested version (5181) has been released with many changes/enhancements, these include
      • source:trunk/resources/images/mapmode/rope.svg lasso selection mode (expert mode)
      • information dialogs for beginners: warning against misaligned imagery, when combining ways with conflicting tags or ways being part of relations
      • new features for relation editing: "Add selection to relation" (when right-clicking a relation), "Select previous/next Gap" (in relation editor)
      • user interface enhancements in View menu: "Map Paint Styles", ability to hide edit toolbar
      • several improvements in startup time
  • 2012-02-07 (4905)
    • Shortcuts for the Relation Editor have been added: Alt-Up, Alt-Down (move selected member up/down), Alt-Del (delete member) and Alt-Home (download incomplete members)
    • A summarized change log is available which contains relevant changes between stable releases.
  • 2012-02-02 (4897 ...)
    • Conflicting shortcuts in JOSM and plugins get fixed. All lot of function shortcuts will change!
  • 2012-01-22 (4846)
    • The ImproveWayAccuracy plugin has been added to core. Select a way, click source:trunk/resources/images/mapmode/improvewayaccuracy.svg, and improve its accuracy. Check the help page for a detailed usage.
  • 2012-01-21 (4791, 4796, 4833)
    • Various extensions for the RemoteControl feature: new command '/load_object' to download objects by id; '/add_way' command to create a new way with certain coordinates; parameter 'new_layer' for the '/load_and_zoom' command to load the data into a new layer.
  • 2012-01-12 (4789)
    • New command line option to set an arbitrary preference value on start. (e.g. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Highlight for nodes and ways under the mouse cursor can be turned off: 'Preferences' > 'Display Settings' > 'OSM Data' (Only in Expert mode)
    • The drawing action source:trunk/resources/images/mapmode/node/autonode.svg allows to draw segments with discrete angles (e.g., 30/45°). Press the tabulator key to cycle through different modes.
  • 2012-01-04 (4765)
    • The automatic hiding of buttons for the right hand side dialogs can be disabled for each window individually. (Eye-symbol in the upper right corner)

2011

  • 2011-12-29 (4745)
    • New command to load and cache WMS background images along a gpx track in advance. (In right click menu of GPX-Layer)
  • 2011-12-20 (4673)
    • Lambert 93 projection (EPSG:2154) is available for France.
  • 2011-12-20 (4670)
    • Languages Arabic, Icelandic and Hebrew have been removed due to missing translation efforts.
  • 2011-12-05 (4621-4636)
    • Performance with large multipolygons improved.
  • 2011-11-26 (4609, 4611)
    • The buttons of the edit toolbar (upper left area) can be hidden.
    • When drawing ways, the backspace key takes back the last action.
  • 2011-11-20 (4601)
    • The version history display now shows the license status for each contributing user.
  • 2011-11-15 (4595)
    • Support for multipart shortcuts. For example Ctrl+Alt+S, 1 toggles the visibility of the first layer.
  • 2011-11-14 (4593)
    • On small screens, long menus are no longer clipped, but can be scrolled up and down.
  • 2011-11-07 (4587)
    • New option in the search dialog to add a toolbar button for the search. The button can be removed later from the right click menu of the button. (Only in expert mode.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • The internal format for saving user preference data has been changed to XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • 专家模式减少了对新用户的复杂性。为了兼容现有的安装,默认情况下为专家模式。
  • 2011-10-07 (4497, 4498, 4500)
    • “文件 > 下载对象...”对话框中有了更多的选项。
    • 历史对话框:更好地显示插入/删除的节点(及关系成员)。
    • 属性对话框中的新快捷键:Alt+A、Alt+S、Alt+D 对应添加、编辑、删除。
  • 2011-09-23 (4454)
    • 在属性对话框中右键单击可复制键值和数值到剪贴板。
  • 2011-09-12 (4416, 4423)
    • 图像服务的边界显示在“首选项 > 图像”的预览图上。
  • 2011-09-08 (4408)
    • 在选择对话框上下文菜单中的“检查”菜单项已经移至“查看 > 高级信息”。
  • 2011-09-07 (4405)
    • “首选项 > 图像”中的列表依国家代码排序。
  • 2011-08-29 (4380)
    • 新功能“编辑 > 复制坐标”。
  • 2011-08-28 (4371)
    • 最近打开的文件列表不仅可以显示刚打开的文件,也可以显示已保存的文件。
  • 2011-08-27 (4355)
    • 动态切换对话框按钮行的可见度。(可选,设置高级首选项“dialog.dynamic.buttons=true”)
  • 2011-08-22 (4333)
    • 切换图层可见性的快捷键(Alt-1 至 Alt-9)
  • 2011-08-21 (4332)
    • 可为每个 gpx 图层选择可见轨迹(从图层的右键单击菜单中)
  • 2011-08-21 (4327)
    • 选择和删除模式有了更好的视觉指示,显示下一个动作会做什么(突出显示,光标变化)。
  • 2011-07-18 (4256)
    • 支持 SVG 图像格式。
  • 2011-07-14 (4241)
    • 可采用在 JPEG 图像 EXIF 头中的方位。
  • 2011-07-07 (4207)
    • GPS 轨迹可以依方向着色。
  • 2011-06-18 (4142)
    • 拉伸模式:双击线段以插入一个新的点。
  • 2011-06-11 (4126, 4129, 4134)
    • 优化了内存,并且能更快地绘制 GPX 轨迹
    • 新的绘制模式:在现有路径旁加上平行的路径。 (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • 新的跟随线条功能,方便绘制相邻的区域。(类似于 Potlatch 2 的 "F" 快捷键)
    • 查找(和过滤)现在可以查询封闭路径,和一个指定了最小和最大面积的封闭区域。(关键词: closed; areasize:MIN-MAXareasize:MAX,以 m² 记)
    • 下载对象...功能现在能够接受一个 ID 列表。
  • 2011-04-18 (4032)
    • 在工具栏中加入多重自定义搜索字符串或有自己图标的背景图层。
    • 更新在用户列表中显示的重新授权状态 (绿勾 - 已同意,灰勾 - 自动同意,红勾 - 不同意)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • 新的视图跟随功能 - 移动视图,使最后放置的节点在中央。(主菜单 > 查看; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • 插件 imagerywmspluginslippymapremotecontrol 已整合到 JOSM 核心。
  • 2010-12-07 (3705)
    • 图层可透明。(在图层列表对话框的新按钮)
  • 2010-12-07 (3702)
    • 支持对象缩放。(在选择模式中按 Ctrl+Alt)
    • 信息 按 Ctrl+Shift 可旋转对象。
  • 2010-11-25 (3669)
    • Validator 插件已被集成到主程序。
  • 2010-09-23 (3557, #5427)
    • “拉伸”模式 (X) 中的变化: 当往一个方向移动多次时,不会有多余的节点存在。 (按住 Shift 执行旧的方法。)
  • 2010-09-14 (3529)
    • 对于在属性对话框中的标签,你可以直接在浏览器中打开相应的维基页面。
  • 2010-09-03 (o22964)
    • WMS 插件支持 GetCapabilities 请求。
  • 2010-08-13 (3431)
    • 新的清除命令可以清理图层。
  • 2010-07-27 (3388)
    • 新的预设标签搜索对话框。
  • 2010-07-20 (3378)
    • JOSM 现在可以恢复你在上一次崩溃时编辑的状态。
    • JOSM 现在需要 Java 版本 6。Java 版本 5 的用户需要使用旧的 JOSM。
  • 2010-06-03 (3306)
    • 搜索功能支持搜索关系成员的角色。
    • 属性对话框可显示关系成员的位置。
  • 2010-06-01 (3291)
    • Roles defined in presets are now used. This may result in unexpected validator warnings for relations not yet know to JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
    • With the new Filter feature you can temporarily hide certain kinds of objects.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • New dialog to download an object by id and optionally all ways and relations that use this object.
  • 2010-01-28 (2901)
    • New: Create a duplicate of the selected data layer without a file association.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • The plugins utilsplugin and AgPifoJ have been integrated in JOSM core.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 8 years ago Last modified on 2013-06-25T23:20:34+02:00