wiki:It:VersionHistory

Precedenti notizie su JOSM

  • 26.11.2017 (versione stabile 13170)
    • Text of notes is now selectable and copyable; links are now clickable
    • Ability to upload data in background
    • Don't select all characters from a text box when switching between JOSM and another application
  • 29.10.2017 (versione stabile 13053)
    • Already downloaded areas are displayed in the download window and in the minimap and the layer chooser button was improved
    • New button in the relation editor that selects the relation itself
  • 06-10-2017 (ultima versione 12926)
    • JOSM ora utilizza un nuovo certificato di firma sponsorizzato da FOSSGIS e.V. (necessario per WebStart)
  • 03.10.2017 (versione stabile 12921)
    • Aggiunti collegamenti ai visualizzatori esterni dei changeset alla finestra wiki:Help/Action/ObjectHistory History] and Changeset Manager
    • Aggiunta la casella di selezione per richiesta di feedback nella finestra di caricamento dei dati
    • La funzione di creazione di cerchi utilizza in automatico un appropriato contatore di nodi basato sul diametro
    • Nuovi parametri della riga di comando per eseguire determinate attività senza l'interfaccia utente grafica:
      • Rendering di dati osm con l'utilizzo di uno stile MapCSS
      • Conversione di coordinate da una proiezione all'altra
  • 02.09.2017 (versione stabile 12712)
  • 30.07.2017 (versione stabile 12542)
    • Ricerca per Preimpostazioni nella Finestra di ricerca.
    • Nuovo segnalibro "Posizione Casa" impostato nelle impostazione utente su OSM) e segnalibri degli ultimi 15 changeset.
  • 02.07.2017 (versione stabile 12450)
  • 29.05.2017 (versione stabile 12275)
  • 02.05.2017 (versione stabile 12039)
    • Riproiezione (deformazione) di livelli di immagine: permette di combinare sorgenti con proiezioni differenti.
  • 02.04.2017 (versione stabile 11826)
    • Possibilità di evitare il caricamento di un livello tramite "upload=never" nel file di OSM
    • Aggiunta opzione per non zoomare ai nuovi dati scaricati. (solo in modalità esperto)
  • 27.02.2017 (versione stabile 11639)
    • La modalità Heat Map GPS ora ha le impostazioni circa l'aspetto.
    • Possibilità di impostare i mirror server per le immagini nel menù Preferenze immagini aeree.
  • 02.02.2017 (versione stabile 11526)
    • Le tracce GPS possono essere visualizzate nella nuova modalità "Heat Map".

2016

  • 31.12.2016 (versione stabile 11427)
    • Database interno con i confini di tutti i paesi. Ora è possibile, ad esempio, limitare ad un paese specifico regole singole del validatore e stili di mappa.
    • Semplice copie e incolla degli URL per scaricare i dati per tutti i tipi di URL per la finestraOpen Location?.
    • Le caselle di testo chiave e valore nella finestra valore sono precomplilate con il tag successivo della lista se la prima chiave è già in uso.
  • 06.11.2016 (versione stabile 11223)
  • 05.09.2016 (versione stabile 10966)
  • 12.08.2016 (versione stabile 10786)
    • Passaggio a Java 8 con una grande ricostruzione del nucleo di Josm
    • Nuova funzione "copia e incolla Posizione" nel menu Edit (Ctrl+Alt+V, solo in modalità esperta)
    • Supporto di geo: URL
  • 12.07.2016 (versione stabile 10526)
    • Importante rifacimento del nucleo di JOSM
  • 28.04.2016 (versione stabile 10161)
  • 13.03.2016 (versione stabile 9979)
    • OAuth ora è il metodo predefinito di autenticazione.
    • Supporto Drag & Drop per l'editor delle relazioni (maggiori info)
    • Nuovo bottone nell'editor delle relazioni per aggiornare la relazione (es. dopo una divisione in due tracciati separati)
    • Il dialogo Cronologia, mostra le coordinate nuove e vecchie di un nodo spostato sulla mappa
    • Zoom automatico alla risoluzione predefinita dello sfondo
    • Supporto esteso a differenti proiezioni

2015

  • 31.12.2015 (versione stabile 9229)
  • 23.11.2015 (versione stabile 9060)
    • Supporto alla lingua Bokmål Norvegese
  • 30.10.2015 (Versione stabile 8969)
    • Divisione percorsi (way): riutilizzo id/storia del percorso esistente per suddividere lunghi segmenti (gli utenti esperti possono scegliere un altro segmento)
    • Mostra icone nodo da mapview anche negli elenchi (ad esempio nel dialogo di selezione, editor relazione o finestra di upload)
  • 28.09.2015 (versione stabile 8800)
    • Integrazione di Overpass download e Overpass Turbo Wizard (solo modalità ananzata)
    • Aggiunta Minimappa
    • Aggiunto link a taginfo
    • Selezione del valore Gamma per le immagini di sfondo
  • 22.08.2015 (versione stabile 8677)
    • Migliorata la gestione delle immagini WMS e il supporto al WMTS
    • Nuovi plug-in OpenGL e Filtri per livelli Raster
    • 17.06.2015 (versione stabile 8491)
    • Supporto della lingua bielorussa
    • Supporto della lingua vietnamita
  • 2015-04-18 (8227)
    • Supporto della lingua valenziana
  • 2015-03-31 (8160)
    • Supporto della lingua lituana
  • 2015-03-02 (8109)
    • Maggiore disponibilità di font per supportare più lingue in Windows
    • Ora alcuni plug-in possono essere installati senza il riavvio di Josm
    • Nuova casella di ricerca nel menù principale (in alto a destra)
    • Il supporto principale delle Note ora è abilitato in modo predefinito (il plug-in è deprecato).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Due nuove lingue: Asturiano (Spagna, Portogallo) e Khmer (Vietnam, Cambogia).
    • Preferenze, dati utente e cartelle cache cambiate sotto OS X a Windows.
  • 2014-12-10 (7777)
    • Nuovo logo disegnato da Diamond00744.
    • Possibilità di scaricare/caricare le Note OSM.
    • Rimosso il dialogo nel menu a lato in favore di un nuovo bottone cronologia nel dialogo selezione.
  • 2014-10-21 (7643)
    • Corretti errori importanti nelle scorciatoie da tastiera e nella gestione dei conflitti di Unisci Percorso.
  • 2014-09-30 (7588)
    • Migliore integrazione con OS X (vedere #10455 per i dettagli).
    • Visualizzazione delle etichette di OSM nelle impostazioni dell'interfaccia utente.
  • 2014-09-20 (7569)
    • JOSM ora avverte della presenza di multipoligoni con il vecchio stile che possono essere risolti trasferendo le variabili rilevanti da way esterne alla relazione.
  • 2014-08-31 (7480)
    • Miglioramenti allo stile di mappa predefinito:
      • Simboli dei nodi e icone nascosti a bassi livelli di zoom (configurabile in impostazione stile).
      • Migliore posizionamento delle etichette all'interno delle aree
      • Nome della strada visualizzato lungo il tracciato
    • Modalità offline con un nuovo argomento della command line --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Stiamo organizzando un concorso di grafica fino al 30 settembre per creare un nuovo logo! Per i dettagli vedi: wiki.
  • 2014-07-04 (7287)
    • Nuovo metodo di doppio allineamento per l'azione di Estrusione
    • Ricarico automatico dello stile di mappa locale e delle regole di validazione
    • Aggiornamento automatico delle immagini aeree
  • 2014-05-18 (7139)
    • Stile di mappa predefinito di JOSM convertito da XML a MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Passaggio alla versione 7 di Java, alcune rifiniture del codice
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Permesso di accedere alle API di OSM tramite HTTPS
  • 2014-01-29 (6767)
    • Nuovo controllo etichette basato su MapCSS, estendibile tramite regole personalizzate
    • Aggiunta "Ricerca oggetti tramite preimpostazioni" Shift-F3
    • Miglioramenti delle Preimpostazioni, MapCSS e Validatore

2013

  • 2013-12-20 (6502)
    • Aggiunta la richiesta della 'sorgente' dei dati inseriti nella finestra di dialogo del caricamento su OSM
    • Finestra Cronologia: carica e mostra i commenti alle modifiche
    • L'icona source:trunk/images/mapmode/improvewayaccuracy.png attiva la nuova funzionalità migliora accuratezza del tracciato scorciatoia W disponibile per i meno esperti
    • Molti altri miglioramenti e correzione di bug (changelog)
  • 2013-11-17 (6388)
    • File di lingua aggiornati
  • 2013-11-12 (6383)
    • Nuovo comando per scollegare un nodo dal tracciato
    • Notifica della ricezione di nuovi messaggi OSM
    • Vari miglioramenti delle preimpostazioni, degli stili e del validatore e altri particolari minori
  • 2013-09-20 (6238)
    • Nuove notifiche non-intrusive
    • Nuovo oggetto "sessione" visibile nel menù File in expert mode
    • Completo supporto ai percorsi GPX
    • Vari miglioramenti minori a: preimpostazioni, riavvio, stili e validatore, oltre ad un miglioramento delle prestazioni
  • 2013-08-07 (6115)
    • Richiesti i permessi di OAuth per supportare pienamente il nuovo notes plugin
    • Rifacimento dei menu del plugin per meglio supportare il raggruppamento e l'integrazione
    • Preferenza al nodo figlio nella selezione degli (ultimi) oggetti selezionati durante la selezione dei nodi con i duplicati
    • Molti altri miglioramenti e correzione di bug (changelog)
  • 2013-07-09 (6060)
    • Evidenziando le relazioni e gli oggetti selezionati in relazioni, selezioni o proprietà si passa dalla finestra di dialogo all'editor delle relazioni
    • Modo estrusione: introdotto il modificatore Ctrl per "trascinare i nodi lungo i segmenti" (l'impostazione precedente può essere ripristinata nelle preferenze avanzate)
    • Scarica dati GPX lungo un tracciato, impostati profili per le scorciatoie, ecc (Preferenze avanzate - e altro) e un sacco di migliorie minori
  • 2013-06-05 (5990)
    • possibilità di impostare le scorciatoie da tastiera per le preipostazioni e altri pulsanti della barra degli strumenti, nuova voce di menu contestuale "Modifica scorciatoia" per definirli.
    • zoom automatico per livelli WMS
    • nuova azione "Alterna pannelli" con il tasto TAB per nascondere/mostrare i pannelli di dialogo (sul lato destro)
  • 2013-05-08 (5939)
    • il riavvio dei plug-in è stato integrato nel programma principale
    • per tutti i componenti testo c'è il menù "annulla, taglia, copia, incolla, cancella, seleziona tutti" con il tasto destro del mouse
    • migliorate prestazioni del comando Modifica / Epura
  • 2013-04-08 (5836)
    • modifiche importanti ai menù contestuali
    • nuovo bottone "pulisci buffer" per eliminare errori nel buffer in seguito alla "copia etichetta dal testo"
    • rimosso il supporto dal (deprecato) imagery offset server
  • 2013-03-07 (5759)
    • Ctrl+Shift+V ora può incollare le etichette dal buffer di testo. Es: 'a=2,c=3' e 'a 2 c 3'
    • miglioramenti nel rendering multiplo di MapCSS
    • possibilità di trascinare nodi nella modalità estrusione
    • menù contestuale nel dialogo Aggiungi/Modifica, opzione per la modifica del layout di tastiera
    • filtro delle tracce GPS in base alla data
    • controllo remoto: consentita l'eliminazione di etichette e la creazione di oggetti con etichette
    • numerosi miglioramenti minori e correzione di errori
  • 2013-02-06 (5697)
    • Durante la creazione e modifica delle relazioni, vengono suggeriti i ruoli
    • nella finestra con la lista delle relazioni è possibile inserire un filtro
    • diversi miglioramenti del dialogo "aggiungi valori" tra cui un pulsante di aiuto, che ricordano la posizione e la possibilità di aggiungere più variabili in una riga senza chiudere la finestra di dialogo
    • nuovo wms_endpoint per imagery e rifacimento del dialogo WMS/TMS
    • nuovo test di convalida per gli indirizzi e le etichette wikipedia e il miglioramento delle prestazioni nella colorazione del livello e sistemazioni di errori
    • vari miglioramenti minori

2012

  • 2012-12-08 (5608)
    • nuovi operatori nth: e nth%: permettono la ricerca di un nodo lungo un percorso (way)
    • qualche miglioramento minore del controllo remoto e delle impostazioni interne
  • 2012-11-10 (5576)
    • aggiunte le "miglia nautiche" (NM) tra le unità di misura supportate
  • 2012-10-08 (5531)
    • rifatto il test di validazione edifici
    • qualche altro tag viene eliminato automaticamente durante l'upload (TIGER, ODbL, yh)
    • rimosso il codice che aveva attinenza con il cambio di licenza
  • 2012-08-29 (5482, 5485)
    • suggerimento dei fornitori di immagini a seconda della zona scaricata.
    • quando si aggiungono etichette ai nodi, way o relazioni, vengono visualizzati i cinque ultimi tag utilizzati per una più veloce selezione
    • migliorato il supporto ai multipoligoni nello strumento filtro
    • Non è più possibile aprire una directory nel dialogo 'File> Apri ...' e caricare automaticamente tutte le foto contenute. Selezionare le immagini direttamente (usando Ctrl-A o Maiusc + clic). Lo strumento "Importa immagini" dal menu contestuale di un livello GPX lavora ancora alla vecchia maniera, in modo da poter caricare le foto in modo ricorsivo con l'apertura di una directory di livello superiore.
  • 2012-07-23 (5353, 5356)
    • correzione di bug importanti nella gestione di dati modificati dal sistema automatico (bot) dovuti al cambio di licenza di OSM.
    • piccoli miglioramenti negli stili di mappa e nel test di convalida, tra cui il rendering dei livelli inattivi e nella visualizzazione dei nomi nella finestra di dialogo di convalida
  • 2012-07-03 (5315)
    • correzione di bug più importanti nel validatore, nella finestra di dialogo dei conflitti e nella fusione dei livelli
    • diversi miglioramenti nella finestra di dialogo conflitti compresa l'opzione per selezionare (doppio clic) e zoom sugli elementi (menu contestuale)
    • diversi miglioramenti nel test di validazione (dei dati)
  • 2012-06-04 (5267)
    • nuove lingue: portoghese (europeo) (pt) e catalano (ca)
    • supporto alle proiezioni personalizzate
    • spostamento delle etichette (tag) nella creazione di un multipoligono
  • 2012-05-02 (5210)
    • Alcuni miglioramenti minori
      • Il menu di ricerca alternativo è presentato di default
      • La riga di comando accetta un nuovo parametro --load-preferences= per caricare le proprie preferenze
      • Abilitato MAPCSS nella gestione di differenti stili degli elementi destra e sinistra
  • 2012-04-14 (5181)
    • La pagina iniziale di WikiStart josm.openstreetmap.de è stata semplificata e riorganizzata
    • Una nuova versione stabile (5181) è disponibile e contiene molti cambiamenti / miglioramenti, che comprendono
      • source:trunk/images/mapmode/rope.png modalità di selezione lazo (solo in modalità per esperti, detta anche "avanzata")
      • finestre di dialogo di informazione per principianti: allarme contro le immagini disallineate, quando si combinano tracciati con tag contrastanti o tracciati facenti parte di relazioni
      • nuove funzionalità per l'editing delle relazioni: "Aggiungi selezione alla relazione" (tasto destro del mouse sulla relazione), "Selezionare Gap precedente/successiva" (nell'editor delle relazioni)
      • miglioramenti dell'interfaccia utente nel menu Visualizza: "Stili di disegno della mappa" e l'opzione per nascondere la barra degli strumenti di modifica (la barra verticale sinistra)
      • diversi miglioramenti nel tempo di avvio
  • 2012-02-07 (4905)
    • Aggiunte scorciatoie da tastiera per l'editor delle relazioni: Alt-Freccia su, Alt-Freccia giù (sposta i membri selezionati su/giù), Alt-Canc (elimina membro) e Alt-Inizio (scarica i membri incompleti)
    • È disponibile un riassunto dei change log che contiene importanti cambiamenti tra versioni stabili.
  • 2012-02-02 (4897 ...)
    • Corretti i conflitti dei tasti di scelta rapida tra JOSM e le estensioni. Un gran numero di scorciatoie da tastiera per le funzioni saranno cambiate!
  • 2012-01-22 (4846)
    • Il plugin ImproveWayAccuracy è stato aggiunto all'interno del programma. Selezionare un percorso, fare clic su source:trunk/images/mapmode/improvewayaccuracy.png, e migliorare la sua accuratezza. Controllare la pagina di aiuto per i dettagli sull'utilizzo.
  • 2012-01-21 (4791, 4796, 4833)
    • Varie estensioni per la funzione Controllo remoto: il nuovo comando '/load_object' seleziona gli oggetti da scaricare per ID, il comando '/add_way' crea un nuovo percorso con determinate coordinate, il parametro 'new_layer' per il comando '/load_and_zoom' scaricare i dati in un nuovo livello.
  • 2012-01-12 (4789)
    • Nuova opzione da linea di comando per impostare un valore arbitrario delle preferenze all'avvio. (esempio --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • L'evidenziazione dei nodi e le vie sotto il cursore del mouse può essere disattivata: 'Preferenze' > 'Impostazioni di visualizzazione'> 'Dati OSM' (solo in Modalità avanzata)
    • In modalità disegno source:trunk/images/mapmode/node/autonode.png nodi, è ora possibile creare nuovi segmenti con angoli discreti (es. 30/45 °). Premendo il tasto di tabulazione si attiva o disattiva la funzione.
  • 2012-01-04 (4765)
    • La funzione di occultamento automatico dei pulsanti delle finestre di dialogo (sul lato destro) può essere controllato per ogni finestra (simbolo dell'occhio in alto a destra, in ogni finestra di dialogo).

2011

  • 2011-12-29 (4745)
    • Nuovo comando per caricare e memorizzare nella cache le immagini di sfondo WMS lungo un tracciato gpx in anticipo. (menu contestuale con il tasto destro del mouse sul livello GPX)
  • 2011-12-20 (4673)
    • La proiezione Lambert 93 (EPSG:2154) per la Francia è ora disponibile.
  • 2011-12-20 (4670)
    • L'arabo, l'islandese e l'ebraico sono stati rimossi a causa di traduzioni insufficienti.
  • 2011-12-05 (4621-4636)
    • Migliorate le prestazioni con grandi multipoligoni.
  • 2011-11-26 (4609, 4611)
    • I pulsanti della barra degli strumenti di modifica (area superiore sinistra) possono essere nascosti.
    • Durante l'inserimento di nuovi nodi, il tasto Backspace annulla l'ultima azione.
  • 2011-11-20 (4601)
    • La scheda cronologia ora mostra l'accettazione o meno della licenza per ogni utente che ha contribuito.
  • 2011-11-15 (4595)
    • Supporto per le scorciatoie con una sequenza di tasti. Per esempio Ctrl + Alt + S, 1 commuta la visibilità del primo livello.
  • 2011-11-14 (4593)
    • Su schermi di piccole dimensioni, i menu lunghi non sono più tagliati, ma possono scorrere verticalmente.
  • 2011-11-07 (4587)
    • Nuova opzione nella finestra di dialogo di ricerca per aggiungere un pulsante della barra degli strumenti per la ricerca. Il pulsante può essere rimosso in seguito, dal menu contestuale (clic destro del mouse). (Solo in modalità avanzata.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Il formato interno per il salvataggio dei dati relativi alle preferenze dell'utente è stato cambiato in XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • Introdotta la modalità per Esperti per ridurre le difficoltà per i nuovi utenti. Per compatibilità le installazioni esistenti sono per Esperti come impostazione predefinita.
  • 2011-10-07 (4497, 4498, 4500)
    • Nuove opzioni nella finestra di dialogo File > Scarica oggetto...
    • Cronologia: miglior visualizzazione dei nodi aggiunti e eliminati in un way (e nei membri di relazioni).
    • Nuove scorciatoie nella finestra di dialogo delle proprietà: Alt+A, Alt+S, Alt+D per Aggiungi, Modifica, Elimina.
  • 2011-09-23 (4454)
    • Copia di chiave e valore negli appunti facendo clic con il tasto destro nella finestra di dialogo delle proprietà.
  • 2011-09-12 (4416, 4423)
    • I confini dei servizi d'immagini aeree sono mostrati su una mappa di anteprima in Preferenze > Immagini aeree
  • 2011-09-08 (4408)
    • Menu item 'Inspect' in context menu of the selection dialog has moved to 'View > Advanced Info'.
  • 2011-09-07 (4405)
    • List in 'Preferences > Imagery' is sorted by country code.
  • 2011-08-29 (4380)
    • New feature 'Edit > Copy Coordinates'.
  • 2011-08-28 (4371)
    • The list of recently opened files shows not just opened, but also saved files.
  • 2011-08-27 (4355)
    • Dynamic visibility of button row in toggle dialogs to the right (optional, advanced preferences 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Shortcuts to toggle layer visibility (Alt-1 to Alt-9)
  • 2011-08-21 (4332)
    • Selection of visible tracks, for each gpx layer (from the right click menu of the layer)
  • 2011-08-21 (4327)
    • Le modalità di selezione ed eliminazione ora hanno una migliore indicazione visiva di cosa farà l'azione successiva (evidenziazione, cambiamento del puntatore).
  • 2011-07-18 (4256)
    • Supporto per il formato immagine SVG.
  • 2011-07-14 (4241)
    • Usa l'orientazione nell'intestazione EXIF delle immagini JPEG.
  • 2011-07-07 (4207)
    • Le tracce GPS possono essere colorate in funzione della loro direzione.
  • 2011-06-18 (4142)
    • Modalità estrusione: un doppio clic su un segmento di linea inserisce un nuovo punto.
  • 2011-06-11 (4126, 4129, 4134)
    • Memory optimizations and faster drawing of GPX tracks
    • New drawing mode: Add a parallel way next to an existing one. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • Nuova funzione Segui la linea per disegnare facilmente aree adiacenti (simile alla scorciatoia "F" di Potlatch 2).
    • La ricerca (e il filtro) ora possono richiedere way chiuse e quelle che racchiudono una certa area minima o massima (parole chiave: closed; areasize:MIN-MAX oppure areasize:MAX, in m²).
    • La funzione Scarica oggetto... ora accetta un elenco di id.
  • 2011-04-18 (4032)
    • Aggiungi alla barra degli strumenti più stringhe di ricerca personalizzate o livelli di sfondo con la propria icona.
    • Mostra lo stato del cambio di licenza nella lista utenti (segno verde - accettato, segno grigio - accettato automaticamente, segno rosso - non accettato).
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Nuova funzione "Spostamento automatico area di visualizzazione" - sposta la vista così che l'ultimo nodo posizionato resti al centro. (Menu > Visualizza; Ctrl+Maiusc+F)

2010

  • 2010-12-12 (3715)
    • I plugin imagery, wmsplugin, slippymap e remotecontrol sono stati integrati in JOSM.
  • 2010-12-07 (3705)
    • I livelli possono essere mostrati in trasparenza. (nuovo pulsante nella lista livelli)
  • 2010-12-07 (3702)
    • È possibile il ridimensionamento degli oggetti. (Ctrl+Alt in modalità selezione)
    • info Per ruotare un oggetto, premere Ctrl+Shift.
  • 2010-11-25 (3669)
    • Il plugin Validator è stato integrato nel programma principale.
  • 2010-09-23 (3557, #5427)
    • Cambiamento nella modalità "Estrusione" (X): quando si estrude verso una direzione più volte, non rimangono più nodi superflui. (Il tasto Shift forza il vecchio comportamento.)
  • 2010-09-14 (3529)
    • È possibile aprire direttamente in un browser la pagina del wiki corrispondente ai tag mostrati nella finestra di dialogo delle proprietà.
  • 2010-09-03 (o22964)
    • Il plugin WMS supporta le richieste GetCapabilities.
  • 2010-08-13 (3431)
    • Il nuovo comando Purge permette di non mostrare alcuni dati presenti nei livelli.
  • 2010-07-27 (3388)
    • Nuova finestra di dialogo di ricerca delle preimpostazioni.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • La ricerca permette di cercare un ruolo tra i membri di una relazione.
    • La finestra di dialogo delle proprietà mostra la posizione dei membri di una relazione.
  • 2010-06-01 (3291)
    • I ruoli definiti nei preimpostati ora vengono usati. Ciò può comportare avvisi inattesi del validator per relazioni non ancora conosciute da JOSM.
    • I membri delle relazioni selezionate sono mostrati con un colore diverso rispetto agli elementi selezionati direttamente.
  • 2010-04-16 (3189)
    • Con la nuova funzione di Filtro si possono temporaneamente nascondere certi tipi di oggetti.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • Nuovo dialogo per scaricare un oggetto per id e opzionalmente tutte le way e relazioni che usano questo oggetto.
  • 2010-01-28 (2901)
    • Nuovo: Crea un duplicato del livello dati selezionato senza un file associato.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Nota agli utenti di AgPifoJ: ora puoi aprire le immagini dal menu principale (File > Apri...) o dal menu click destro del livello GPX corrispondente.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • Nuovo Dialogo Lista Changeset, mostra informazioni sui changeset. I changeset possono essere scaricati, chiusi e mostrati.
  • 2009-12-05 (2575)
    • I plugin utilsplugin e AgPifoJ sono stati integrati in JOSM.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • I nomi delle aree vengono mostrate (in grigio chiaro) se rientrano nell'area.
  • 2009-09-16 (2147)
    • Il pannello dei plugin nelle preferenze ha ora una funzione di ricerca. Puoi cercare tra i nomi, descrizioni e versioni fornendo dei termini di ricerca separati da spazi, in qualunque ordine.
  • 2009-09-14 (2133)
    • Molti shortcut al menu dei preset sono stati aggiunti alla barra degli strumenti standard.
  • 2009-09-13 (2124)
    • JOSM ora supporta il mantenimento di diversi changeset aperti in contemporanea sul server. Se ti accorgi di qualcosa da cambiare mentre stai facendo altri cambiamenti, ora puoi taggarlo correttamente.
  • 2009-09-13 (2118)
    • Il menu dei preset ora ha alcune categorie principali invece della precedente lista. Questo dovrebbe essere d'aiuto nell'utilizzare JOSM con schermi piccoli, e dovrebbe facilitare la ricerca.
  • 2009-09-12 (2109)
    • La nuova gestione del click del tasto centrale permette di scegliere i diversi elementi sotto il cursore. Questo permette una migliore selezione di elementi sovrapposti.
  • 2009-09-02 (2026)
    • Quando in modalità cancellazione il puntatore del mouse cambierà in base al tipo di oggetto che si sta per cancellare.
  • 2009-07-15 (1790)
    • Riscrittura completa dell'editor relazioni.
  • 2009-07-11 (1767)
    • I plugin di JOSM ora supportano diverse versioni (almeno i plugin gestiti su SVN). Gli aggiornamenti dei plugin non causano più malfunzionamenti.
  • 2009-07-07 (1743)
    • JOSM ora ha un supporto usabile per preset e stili di disegno esterni. Da' un'occhiata alle pagine Presets e Styles.
  • 2009-06-28 (1709)
    • Supporto per mostrare la cronologia degli elementi in JOSM.
  • 2009-06-07 (1652)
    • Nuovo dialogo per risolvere i conflitti (quando oggetti cambiati sono stati cambiati altrove).
  • 2009-05-30 (1628)
    • Le impostazioni vengono salvate in UTF-8. Gli utenti con una GUI non-latina potrebbero aver bisogno di correggere i propri testi, o resettare la configurazione.
  • 2009-05-19 (1605)
    • La proiezione predefinita di JOSM è ora Mercatore invece di EPSG:4326.
  • 2009-05-19 (1603)
    • Nuovi operatori di ricerca parent e child, che rendono possibile la ricerca di oggetti genitori o figli di quegli oggetti che corrispondono ad uno specifico criterio di ricerca.
  • 2009-02-14 (1405)
    • Molti miglioramenti alla modalità di disegno (doppio click termina il disegno). È anche possibile cambiare ad uno stile Tutto-In-Uno-Potlatch nelle preferenze.
  • 2009-01-31 (1358)
    • Le restrizioni di svolta vengono mostrate nella mappa, un asterisco vicino ad una relazione indica un problema
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • I file possono essere aperti rilasciandoli sulla finestra JOSM (Drag-n-Drop).
  • 2009-01-08 (1213)
    • La funzione di ricerca ora supporta le espressioni regolari.
  • 2009-01-03 (1208)
    • Il posizionamento dei nomi dei nodi sulla mappa è stato migliorato. Se non viene dato un nome, viene mostrato uno tra ref, operator e brand. Vengono anche mostrati i nomi per i tag non conosciuti (senza alcuna icona).
  • 2009-01-02 (1203)
    • È supportato il rendering delle relazioni multipoligono. L'opzione "mappaint.multipolygon=true" dev'essere impostata (sarà default successivamente). Quando c'è un * prima del nome della relazione, JOSM segnala un errore. Utilizza il plugin validator per capire l'errore.

2008

  • 2008-12-25 (1180)
    • Questa release rimuove molto codice obsoleto in JOSM. I vecchi plugin probabilmente non funzioneranno più. Aggiorna tutto.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 5 years ago Last modified on 2013-06-25T23:19:00+02:00