Modify

Opened 6 years ago

Closed 4 days ago

#10759 closed enhancement (fixed)

add preset for man_made=mast

Reported by: aceman Owned by: team
Priority: normal Milestone: 20.06
Component: Internal preset Version: latest
Keywords: mast tower Cc: Klumbumbus, Geozeisig, ma-rt-in

Description (last modified by skyper)

It seems there is no preset for man_made=mast so JOSM does not have an icon for it and it is reported (in warnings) as unknown value.
There is already some usage of it (osmwiki:Tag:man_made=mast), about 10000 times, mostly in Europe.

Attachments (0)

Change History (21)

comment:1 Changed 6 years ago by skyper

Description: modified (diff)
Keywords: mast added
Priority: trivialnormal

Last time I did some work on this, there was quite some confusion about tower, mast and antenna. See #8076.

Still in favour of introducing/updating the presets for all three tags.

comment:2 Changed 6 years ago by Klumbumbus

Cc: Klumbumbus added

comment:3 Changed 4 years ago by Klumbumbus

Ticket #12756 has been marked as a duplicate of this ticket.

comment:5 Changed 2 years ago by Don-vip

Ticket #16121 has been marked as a duplicate of this ticket.

comment:6 Changed 2 years ago by Don-vip

Cc: geozeisig added

comment:7 Changed 2 years ago by geozeisig

Please add man_made=mast in the menu.

with the the options tower:type
tower:type=communication
tower:type=lighting

and with the options tower:construction
tower:construction=freestanding
tower:construction=lattice
tower:construction=guyed_lattice
tower:construction=guyed_tube

and operator
and height

The wiki pages have been updated and symbols added to carto.

comment:8 Changed 2 years ago by Don-vip

Keywords: tower added

comment:9 Changed 4 months ago by skyper

Totally, forgot the issues with man_made=mast

comment:10 Changed 4 months ago by skyper

By the way, it is the last tag without excuse missing from #12135.

comment:11 Changed 4 months ago by Klumbumbus

I think there was never a proper definition for distinction of mast, tower and communications_tower agreed.

comment:12 Changed 3 months ago by skyper

Well it is in use on over 100000 objects. Anyway I created Presets/MastAndTower, so the priority to include man_made=mast in defaultpresets is lowered.

comment:13 Changed 2 months ago by skyper

Ticket #19131 has been marked as a duplicate of this ticket.

comment:14 Changed 2 months ago by skyper

Cc: ma-rt-in added

comment:15 Changed 9 days ago by Klumbumbus

In 16706/josm:

see #10759, see #17818, see #16898 - Add Presets for man_made=mast and man_made=communications_tower, rework preset for man_made=tower, based on patch by skyper, (all icons from https://wiki.openstreetmap.org/, from Geozeisig, all PD and CC0 licensed)

comment:16 Changed 9 days ago by Klumbumbus

still todo:

  • add missing icons
  • observation and watchtower share an icon, find a new one
  • delete 2 old icons before next release (not yet done to not brake external presets/styles now)
  • add man_made=telescope (?)

comment:17 Changed 9 days ago by Klumbumbus

Milestone: 20.06

comment:18 Changed 9 days ago by Klumbumbus

In 16709/josm:

see #10759 - update ignore list

comment:19 Changed 7 days ago by Klumbumbus

Cc: Geozeisig added; geozeisig removed

@Geozeisig: you created the nice tower and mast icons. Would you like to create icons for these combinations too?

man_made=mast + tower:type=monitoring
man_made=mast + tower:type=radar
man_made=mast + tower:type=siren
man_made=tower + tower:type=minaret
man_made=tower + tower:type=radar

man_made=tower + tower:type=observation or tower:type=watchtower (to distinguish between these two)

comment:20 Changed 4 days ago by Klumbumbus

In 16724/josm:

see #15240 - Replace some icons by svg

see #10759 - Remove old unused icons

comment:21 in reply to:  16 Changed 4 days ago by Klumbumbus

Resolution: fixed
Status: newclosed

Replying to Klumbumbus:

still todo:

  • add missing icons

--> can be done later

  • observation and watchtower share an icon, find a new one

--> can be done later

  • delete 2 old icons before next release (not yet done to not brake external presets/styles now)

--> done in r16724

  • add man_made=telescope (?)

--> #19445

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.