Modify

Opened 5 years ago

Closed 5 years ago

#12756 closed enhancement (duplicate)

There is no "man_made=mast" in pre-sets, which renders well on the OSM map, but there's "man_made=tower", which is not renedered at all

Reported by: oleksiy.muzalyev@… Owned by: team
Priority: normal Milestone:
Component: Internal preset Version: tested
Keywords: preset, tower, mast, rendering, icon, safety Cc:

Description

What steps will reproduce the problem?

  1. Add in JOSM man_made=tower;
  2. add tower:type=communication
  3. upload

What is the expected result?

A communication tower is shown on the map with the proper icon.

What happens instead?

man_made=tower is not rendered with any icon at all

Please provide any additional information below. Attach a screenshot if possible.

Due to the power of defaults a lot of communications masts or towers are mapped with "man_made=tower" tag. This tag is not rendered with any icon on the OSM map.

However the "man_made=mast" is absent in the JOSM pre-sets, at the same time it renders well on the map with the proper icon.

This rendering with the icon is useful in numerous cases:

  • knowing location of the communication mast (or tower) in rural or in wilderness areas is beneficial, as it is the place where one can send and receive messages, calls, etc.
  • for RC and manned low altitude aviation, as there is a risk of a collision with the communication mast (or tower) and its strong electromagnetic emissions may interfere with the radio control signal and/or the navigation system (on-board magnetic compass).

I would suggest to add the "man_made=mast" to the presets, with a short text explaining the rendering with the icon issue.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en) Mac OS X 10.11.4
Memory Usage: 646 MB / 910 MB (297 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=/Users/OLeksiy/Library, -DDocumentsDirectory=/Users/OLeksiy/Documents, -DApplicationSupportDirectory=/Users/OLeksiy/Library/Application Support, -DCachesDirectory=/Users/OLeksiy/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
- buildings_tools (31895)

Last errors/warnings:
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed
Type: defectenhancement
Version: latesttested

Closed as duplicate of #10759.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.