Modify

Opened 5 years ago

Closed 5 years ago

#11300 closed defect (fixed)

block by start download - first step after update

Reported by: anonymous Owned by: team
Priority: blocker Milestone: 15.04
Component: Core Version:
Keywords: template_report Cc: Luebeck, bastiK, wiktorn, cschueller, jurecka@…, giscardveloso@…, Atalanttore, sigfrido@…, tomasz@…

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-06 01:31:03
Last Changed Author: bastiK
Revision: 8168
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-06 01:43:03 +0200 (Mon, 06 Apr 2015)
Last Changed Rev: 8168

Identification: JOSM/1.5 (8168 de) Windows 7 64-Bit
Memory Usage: 395 MB / 910 MB (137 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- AddrInterpolation (30892)
- CommandLine (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- Tracer (30997)
- Tracer2 (30984)
- fieldpapers (b49dadd)
- geotools (31068)
- jts (31002)
- measurement (30892)
- mirrored_download (30962)
- opendata (31050)
- public_transport (30892)
- terracer (30892)
- utilsplugin2 (31072)
- wikipedia (31035)

Last errors/warnings:
- E: Defekte Objektvorlage "frequency-Frequency" - Anzahl der Datenworte in 'display_values' und in 'values' müssen gleich sein
- E: Defekte Objektvorlage "frequency-Frequency" - Anzahl der Datenworte in 'display_values' und in 'values' müssen gleich sein
- E: Defekte Objektvorlage "railway:signal:speed_limit:speed-Speed (km/h, in case of light signals separate the possible values (number or 'off') with ';')" - Anzahl der Datenworte in 'display_values' und in 'values' müssen gleich sein
- E: java.lang.ExceptionInInitializerError. Ursache: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl). Ursache: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl
- E: java.lang.NoClassDefFoundError: Could not initialize class org.apache.commons.jcs.engine.control.CompositeCacheManager

java.lang.NoClassDefFoundError: Could not initialize class org.apache.commons.jcs.engine.control.CompositeCacheManager
	at org.openstreetmap.josm.data.cache.JCSCacheManager.initialize(JCSCacheManager.java:86)
	at org.openstreetmap.josm.data.cache.JCSCacheManager.getCache(JCSCacheManager.java:130)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.<init>(TMSCachedTileLoader.java:48)
	at org.openstreetmap.josm.gui.layer.TMSLayer$1.makeTileLoader(TMSLayer.java:139)
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:141)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:109)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:208)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:64)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:41)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (2)

josm.patch (487 bytes) - added by wiktorn 5 years ago.
Corrected build.xml file (Eclipse workspace patch format)
josm-latest (1.6 KB) - added by sigfrido@… 5 years ago.
josm-latest giving error in Ubuntu Linux 14.04

Download all attachments as: .zip

Change History (45)

comment:1 Changed 5 years ago by Don-vip

Cc: bastiK added
Milestone: 15.04

comment:2 Changed 5 years ago by Don-vip

Ticket #11301 has been marked as a duplicate of this ticket.

comment:3 Changed 5 years ago by Don-vip

Cc: wiktorn added

comment:4 Changed 5 years ago by wiktorn

Optimized version doesn't contain org.apache.commons.logging.impl.* though unoptimized has them. Will check that further.

Changed 5 years ago by wiktorn

Attachment: josm.patch added

Corrected build.xml file (Eclipse workspace patch format)

comment:5 Changed 5 years ago by wiktorn

Summary: block by start download - first step after update[patch] block by start download - first step after update

comment:6 Changed 5 years ago by skyper

Ticket #11303 has been marked as a duplicate of this ticket.

comment:7 Changed 5 years ago by stoecker

We don't use build.xml for the release version. When the java compiler does not recognize a reference (i.e. with non-obvious calling conventions) then we need to add a sourcefile by hand. Can this be the case here?

comment:8 Changed 5 years ago by wiktorn

It may exactly be the case here. proguard doesn't recognize reference, as within logging implementation is chosen by reflection, so the same might be for other build system used for releases.

We need to include org.apache.commons.logging.impl.* by hand

comment:9 Changed 5 years ago by skyper

Ticket #11307 has been marked as a duplicate of this ticket.

comment:10 Changed 5 years ago by skyper

Ticket #11308 has been marked as a duplicate of this ticket.

comment:11 Changed 5 years ago by skyper

Ticket #11306 has been marked as a duplicate of this ticket.

comment:12 Changed 5 years ago by skyper

Cc: cschueller jurecka@… giscardveloso@… Atalanttore added

comment:13 Changed 5 years ago by stoecker

Let's see if it works tomorrow.

comment:14 Changed 5 years ago by wiktorn

Still org.apache.commons.logging.impl.* classes are missing.

comment:15 Changed 5 years ago by hjart

I'm sorry to have to say this, but I have the same problem today

comment:16 Changed 5 years ago by stoecker

Resolution: fixed
Status: newclosed

comment:17 Changed 5 years ago by stoecker

Ticket #11309 has been marked as a duplicate of this ticket.

comment:18 Changed 5 years ago by stoecker

Ticket #11311 has been marked as a duplicate of this ticket.

comment:19 Changed 5 years ago by stoecker

Ticket #11313 has been marked as a duplicate of this ticket.

comment:20 Changed 5 years ago by stoecker

The last two reports I don't understand. Works here with the 8175 build.

comment:21 Changed 5 years ago by wiktorn

Is there CDN or any other caching around webpage? I've just talked to the user, that had the same situation with josm-latest.

From my place it works ok.

Last edited 5 years ago by wiktorn (previous) (diff)

comment:22 Changed 5 years ago by skyper

Ticket #11318 has been marked as a duplicate of this ticket.

comment:23 Changed 5 years ago by naoliv

Here fails with josm-latest.jar (8175) too.
Also fails with http://donvip.fr/jenkins/job/JOSM/1996/ (is it exactly the same as josm-latest.jar?)

comment:24 Changed 5 years ago by skyper

Could you please try it with an empty .josm directory by using the command line option --Djosm.home=[PATH] or moving .josm/ out of the way.

Thanks.

Works for me:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-07 08:40:02
Last Changed Author: stoecker
Revision: 8175
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-07 10:18:15 +0200 (Tue, 07 Apr 2015)
Last Changed Rev: 8175

Identification: JOSM/1.5 (8175 de) Linux Debian GNU/Linux 7.8 (wheezy)
Memory Usage: 390 MB / 882 MB (263 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-1~deb7u1
VM arguments: [-Djosm.home=/tmp/.josm-test]
Dataset consistency test: No problems found

terminal output:

# java -Djosm.home=/tmp/.josm-test -jar josm-latest.jar 
INFO: Einstellungsdatei '/tmp/.josm-test/preferences.xml' fehlt. Erstelle Standardeinstellungsdatei.
INFO: GET https://api.openstreetmap.org/api/capabilities... 
INFO: OK
[INFO] CompositeCacheManager - Instance is null, returning unconfigured instance
[INFO] ThreadPoolManager - thread_pool.default PoolConfiguration = useBoundary = [true] boundarySize = [2000] maximumPoolSize = [150] minimumPoolSize = [4] keepAliveTime = [300000] whenBlockedPolicy = [RUN] startUpSize = [4]
[INFO] CompositeCacheConfigurator - Setting default auxiliaries to null
[INFO] CompositeCacheConfigurator - setting defaultCompositeCacheAttributes to [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
[INFO] CompositeCacheConfigurator - setting defaultElementAttributes to [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = false, MaxLifeSeconds = 9223372036854775807, IdleTime = 9223372036854775807, CreateTime = 1428429436364, LastAccessTime = 1428429436364, getTimeToLiveSeconds() = -1, createTime = 1428429436364 ]
[INFO] CompositeCacheConfigurator - Parsed regions []
[INFO] CompositeCacheConfigurator - Finished configuration in 15 ms.
[INFO] CompositeCacheConfigurator - No special ElementAttribute class defined for key [jcs.region.TMS.elementattributes], using default class.
[INFO] AbstractDoubleLinkedListMemoryCache - initialized MemoryCache for TMS
[INFO] CompositeCache - Constructed cache with name [TMS] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
[INFO] IndexedDiskCache - Region [TMS] Cache file root directory: /tmp/.josm-test/cache/tms
[INFO] IndexedDiskCache - Region [TMS] Set maxKeySize to: '25000'
[INFO] IndexedDiskCache - Region [TMS] Indexed Disk Cache is alive.
[INFO] CacheEventQueue - Cache event queue created: CacheEventQueue [listenerId=-1794705946, cacheName=TMS]
[INFO] CacheEventQueue - Cache event queue created: CacheEventQueue [listenerId=-1794705946, cacheName=TMS]
INFO: GET https://api.openstreetmap.org/api/0.6/map?bbox=12.8647327,52.129115,12.8883362,52.1414954
[INFO] ElementEventQueue - Element event queue destroyed: org.apache.commons.jcs.engine.control.event.ElementEventQueue@19d195b6
[INFO] CompositeCache - In DISPOSE, [TMS] fromRemote [false]
[INFO] CompositeCache - In DISPOSE, [TMS] auxiliary [TMS]
[INFO] CompositeCache - In DISPOSE, [TMS] put 123 into auxiliary TMS
[INFO] AbstractDiskCache - No longer waiting for event queue to finish: Cache Event Queue
Working = true
Alive = false
Empty = true
Size = 0
[INFO] AbstractDiskCache - In dispose, destroying event queue.
[INFO] CacheEventQueue - Destroy was called after queue was destroyed.  Doing nothing.  Stats =  Cache Event Queue
Working = true
Alive = false
Empty = true
Size = 0
[INFO] IndexedDiskCache - Region [TMS] Saving keys to: TMS, key count: 123
[INFO] IndexedDiskCache - Region [TMS] Finished saving keys.
[INFO] IndexedDiskCache - Region [TMS] Shutdown complete.
[INFO] CompositeCache - In DISPOSE, [TMS] disposing of memory cache.
[INFO] AbstractMemoryCache - Memory Cache dispose called.

comment:25 in reply to:  24 ; Changed 5 years ago by naoliv

Replying to skyper:

Could you please try it with an empty .josm directory by using the command line option --Djosm.home=[PATH] or moving .josm/ out of the way.

With this it works.
Some cache/database/config that needs to be upgraded or removed by JOSM if migrating from an older version then?

comment:26 in reply to:  25 Changed 5 years ago by skyper

Replying to naoliv:

Some cache/database/config that needs to be upgraded or removed by JOSM if migrating from an older version then?

Still did not have this problem today (did not use latest from yesterday, though). Only special I do with settings is deleting my TMS and WMS cache every day.

comment:27 in reply to:  25 Changed 5 years ago by wiktorn

Replying to naoliv:

Replying to skyper:

Could you please try it with an empty .josm directory by using the command line option --Djosm.home=[PATH] or moving .josm/ out of the way.

With this it works.
Some cache/database/config that needs to be upgraded or removed by JOSM if migrating from an older version then?

Not, if what you're seeing was the same stacktrace/error, that the one reported here. The one reported here was due to missing files within josm-latest.jar.

There might be a different bug though and would be great, if we could solve it too.

Can you restore your .josm directory and if the problem persists, paste the error?

comment:28 Changed 5 years ago by naoliv

The error that I am seeing:

ERROR: java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.imagerycache.ImageryCachePlugin$1.makeTileLoader(Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoaderListener;Ljava/util/Map;)Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoader;
java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.imagerycache.ImageryCachePlugin$1.makeTileLoader(Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoaderListener;Ljava/util/Map;)Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoader;
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:141)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:109)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:208)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:64)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:41)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Problem with ImageryCache plugin it seems.
Just in case:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-07 08:40:02
Last Changed Author: stoecker
Revision: 8175
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-07 10:18:15 +0200 (Tue, 07 Apr 2015)
Last Changed Rev: 8175

Identification: JOSM/1.5 (8175 en) Linux Debian GNU/Linux 8.0 (jessie)
Memory Usage: 247 MB / 10206 MB (123 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-2
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
- Create_grid_of_ways (30892)
- ImageryCache (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- SimplifyArea (30962)
- buildings_tools (30955)
- conflation (0.1.7)
- contourmerge (1012)
- download_along (30892)
- editgpx (30892)
- geotools (31068)
- importvec (30892)
- jts (31002)
- log4j (30892)
- measurement (30892)
- merge-overlap (30988)
- opendata (31050)
- pbf (31010)
- pdfimport (30892)
- poly (31056)
- reverter (30990)
- scripting (30702)
- todo (29154)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31072)

Last errors/warnings:
- E: java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.imagerycache.ImageryCachePlugin$1.makeTileLoader(Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoaderListener;Ljava/util/Map;)Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoader;

Do you want that I open another issue for this?

comment:29 Changed 5 years ago by wiktorn

Please - do open a new issue. Looks like imagerycache needs update. It might actually got obsolete because of recent changes.

comment:30 Changed 5 years ago by wiktorn

actually, there is already #11312

comment:31 Changed 5 years ago by naoliv

Right. Thanks!

comment:32 Changed 5 years ago by skyper

Ticket #11322 has been marked as a duplicate of this ticket.

comment:33 Changed 5 years ago by skyper

Cc: sigfrido@… tomasz@… added
Resolution: fixed
Status: closedreopened
Summary: [patch] block by start download - first step after updateblock by start download - first step after update

If we do not want to get even more duplicates on next release, we need to get the transition completely working.

comment:34 in reply to:  21 Changed 5 years ago by wiktorn

Replying to wiktorn:

Is there CDN or any other caching around webpage? I've just talked to the user, that had the same situation with josm-latest.

From my place it works ok.

Do we have any info about this? All of these errors here complain about missing class in jar file. This was the case for some period of time, but right now.

How can we check, what exactly was the contents of *.jar file user downloaded?

comment:35 Changed 5 years ago by naoliv

If it's an issue with caching (downloading an old file), then how are their JOSMs reporting version 8175?

comment:36 Changed 5 years ago by wiktorn

@sigfrido, @tomasz.nycz, @giscardveloso, @jurecka, @rickmastfan67:

Can one of you please attach a fresh josm-latest.jar that fails for you?

@naoliv:
Does http://josm.openstreetmap.de/josm-latest.jar also fails? If so, please attach the jar file.

comment:37 in reply to:  35 Changed 5 years ago by stoecker

Replying to naoliv:

If it's an issue with caching (downloading an old file), then how are their JOSMs reporting version 8175?

For a short time (10-15 minutes) there was a non-working 8175 when I fixed it, but all the reports came much later. And I broke permissions again which stopped 8176 build (That's why I don't like manually started builds). We'll see if a 8176 is reported for this issue.

comment:38 Changed 5 years ago by skyper

May be , I did reopen to fast as I could not reproduce with a tested -> latest transition, so far.

comment:39 Changed 5 years ago by tomasz@…

I've uploaded jar file from my /usr/share/josm/

http://dev.gis-support.pl/josm/josm-1.5.svn8175.jar

If I remove ~/.josm-latest, bug persists.

comment:40 Changed 5 years ago by tomasz@…

JOSM r8176 works for me :) Thx. Right now need to rebuild WMS database ;)

comment:41 in reply to:  36 ; Changed 5 years ago by rickmastfan67

Replying to wiktorn:

@sigfrido, @tomasz.nycz, @giscardveloso, @jurecka, @rickmastfan67:

Can one of you please attach a fresh josm-latest.jar that fails for you?

@naoliv:
Does http://josm.openstreetmap.de/josm-latest.jar also fails? If so, please attach the jar file.

No can do. JOSM works for me now (as long as I don't have the ImageryCache plugin activated). Plus, I run Windows 7. Everybody else that is having the problem with r8175 was running Linux.

Changed 5 years ago by sigfrido@…

Attachment: josm-latest added

josm-latest giving error in Ubuntu Linux 14.04

comment:42 in reply to:  41 Changed 5 years ago by sigfrido@…

Replying to rickmastfan67:

Replying to wiktorn:

@sigfrido, @tomasz.nycz, @giscardveloso, @jurecka, @rickmastfan67:

Can one of you please attach a fresh josm-latest.jar that fails for you?

@naoliv:
Does http://josm.openstreetmap.de/josm-latest.jar also fails? If so, please attach the jar file.

Just attached the file (sorry for the double attachment, the first one is the shell script).
I downloaded the new jar as suggested, and it works for me now - Ubuntu 14.04. Thanks!

comment:43 Changed 5 years ago by wiktorn

Resolution: fixed
Status: reopenedclosed

I've just checked the apt sources - r8176 runs fine on Ubuntu.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.