Modify

Opened 8 years ago

Closed 8 years ago

#11301 closed defect (duplicate)

Error when trying to add photolayer (Bing etc)

Reported by: hjart Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-06 01:31:03
Last Changed Author: bastiK
Revision: 8168
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-06 01:43:03 +0200 (Mon, 06 Apr 2015)
Last Changed Rev: 8168

Identification: JOSM/1.5 (8168 da) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 508 MB / 1328 MB (368 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:pakken openjdk-7-jre er ikke installeret
Dataset consistency test: No problems found

Plugins:
- DirectUpload (30892)
- InfoMode (30892)
- ShapeTools (1000)
- SimplifyArea (30962)
- buildings_tools (30955)
- geochat (31056)
- graphview (30892)
- junctionchecking (30892)
- mirrored_download (30962)
- reverter (30990)
- scoutsigns (43)
- tagging-preset-tester (30892)
- todo (29154)
- undelete (30892)
- utilsplugin2 (31072)
- wikipedia (31035)

Last errors/warnings:
- E: Kunne ikke finde billedet "maxspeed_icon.svg"
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.
- E: java.lang.ExceptionInInitializerError. Årsag: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl). Årsag: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl
- E: java.lang.NoClassDefFoundError: Could not initialize class org.apache.commons.jcs.engine.control.CompositeCacheManager

java.lang.NoClassDefFoundError: Could not initialize class org.apache.commons.jcs.engine.control.CompositeCacheManager
	at org.openstreetmap.josm.data.cache.JCSCacheManager.initialize(JCSCacheManager.java:86)
	at org.openstreetmap.josm.data.cache.JCSCacheManager.getCache(JCSCacheManager.java:130)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.<init>(TMSCachedTileLoader.java:48)
	at org.openstreetmap.josm.gui.layer.TMSLayer$1.makeTileLoader(TMSLayer.java:139)
	at org.openstreetmap.josm.gui.layer.TMSLayer.initTileSource(TMSLayer.java:386)
	at org.openstreetmap.josm.gui.layer.TMSLayer.<init>(TMSLayer.java:449)
	at org.openstreetmap.josm.gui.layer.ImageryLayer.create(ImageryLayer.java:156)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:82)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11300.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.