Modify

Opened 5 years ago

Closed 5 years ago

#11311 closed defect (duplicate)

Can not download the source map.

Reported by: jurecka@… Owned by: team
Priority: critical Milestone:
Component: Core Version:
Keywords: Cc:

Description

Can not download the source map. Lists errors and can continue to be - "Unexpected error"

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-07 08:26:07
Last Changed Author: stoecker
Revision: 8175
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-07 10:18:15 +0200 (Tue, 07 Apr 2015)
Last Changed Rev: 8175

Identification: JOSM/1.5 (8175 sk) Linux Mint 17.1 Rebecca
Memory Usage: 186 MB / 910 MB (112 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u75-2.5.4-1~trusty1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/xxx/.josm-latest, -Djava.net.useSystemProxies=true]


Last errors/warnings:
- E: java.lang.ExceptionInInitializerError. Príčina: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl). Príčina: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl
- E: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.data.cache.JCSCacheManager

java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.data.cache.JCSCacheManager
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.<init>(TMSCachedTileLoader.java:48)
	at org.openstreetmap.josm.gui.layer.TMSLayer$1.makeTileLoader(TMSLayer.java:139)
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:141)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:109)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:208)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:64)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:41)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11300.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.