Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#11312 closed defect (fixed)

[patch] imagerycache Plugin broken by recent changes in JOSM

Reported by: rickmastfan67 Owned by: akks
Priority: blocker Milestone: 15.04
Component: Plugin imagerycache Version: latest
Keywords: Cc: wiktorn, naoliv

Description

Steps to reproduce:

  1. Install plugin.
  2. Restart JOSM.
  3. Attempt to download some data (Ctrl+Shift+Down).

What happens:
JOSM throws up an error screen and you can't get to the data download window.

What should happen:
Should have the download data window show up with the map allowing me to download some data.

==

Last version of JOSM that works with the plugin is [8167]. Broken starting with [8168]. Guess I'm staying with [8167] till the plugin can be updated to work with the recent changes to the Core.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-07 08:40:02
Last Changed Author: stoecker
Revision: 8175
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-07 10:18:15 +0200 (Tue, 07 Apr 2015)
Last Changed Rev: 8175

Identification: JOSM/1.5 (8175 en) Windows 7 64-Bit
Memory Usage: 354 MB / 1820 MB (226 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- ImageryCache (30892)
- OpeningHoursEditor (30962)
- buildings_tools (30955)
- measurement (30892)
- mirrored_download (30962)
- osmarender (30892)
- reverter (30990)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31072)

Last errors/warnings:
- E: java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.imagerycache.ImageryCachePlugin$1.makeTileLoader(Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoaderListener;Ljava/util/Map;)Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoader;

java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.imagerycache.ImageryCachePlugin$1.makeTileLoader(Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoaderListener;Ljava/util/Map;)Lorg/openstreetmap/gui/jmapviewer/interfaces/TileLoader;
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:141)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:109)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:208)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:64)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:41)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$300(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (2)

jcs_clearcache_source_restore.patch (4.4 KB) - added by wiktorn 5 years ago.
JOSM base patch
imagerycache_jcs_fix.patch (4.4 KB) - added by wiktorn 5 years ago.
Corrected patch. Now performance is OK

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by wiktorn

Cc: wiktorn added

comment:2 Changed 5 years ago by naoliv

Cc: naoliv added

comment:3 Changed 5 years ago by wiktorn

Recent changes to TMS layer caching broke imagerycache. Verify first, if imagerycache is still needed, provided that JOSM caching abilities improved.

comment:4 Changed 5 years ago by wiktorn

In my opinion - imagerycache plugin should be deprecated. It handled only TMS layer.

Now JOSM will store all TMS cached tiles within two files - TMS.data and TMS.key. So separate plugin, that will store imagery in one file is surplus.

comment:5 Changed 5 years ago by rickmastfan67

While yes, it only handled the TMS, it stored the images in separate files for each imagery source, which I liked a lot. That allowed me to delete just one of the imagery caches instead of all of them at once (which is what happens with JOSM now). That way, you could hold onto your Bing Imagery cache for as long as you needed, but could delete the MapBox file whenever you wanted to.

Changed 5 years ago by wiktorn

JOSM base patch

comment:6 Changed 5 years ago by wiktorn

Milestone: 15.04
Summary: imagerycache Plugin broken by recent changes in JOSM[patch] imagerycache Plugin broken by recent changes in JOSM

Attached patch for imagerycache and for base code: restore of TileSource param for clearCache(), it's needed by this plugin.

@rickmastfan67:
For next release (15.05) I plan to add similar feature to JOSM, which is tracked in #11327

comment:7 Changed 5 years ago by wiktorn

imagerycache_jcs_fix.patch needs further work:

  • implement local memory cache

Changed 5 years ago by wiktorn

Attachment: imagerycache_jcs_fix.patch added

Corrected patch. Now performance is OK

comment:8 Changed 5 years ago by bastiK

In 8186/josm:

see #11312 - imagerycache Plugin broken by recent changes in JOSM (patch by wiktorn)

comment:9 Changed 5 years ago by bastiK

In [o31082]:

see ​#11312 - imagerycache Plugin broken by recent changes in JOSM (patch by wiktorn)

comment:10 Changed 5 years ago by bastiK

Resolution: fixed
Status: newclosed

In [o31083]:

see ​#11312 - imagerycache Plugin broken by recent changes in JOSM (patch by wiktorn)

comment:11 Changed 4 years ago by rickmastfan67

Ticket #11612 has been marked as a duplicate of this ticket.

comment:12 Changed 4 years ago by rickmastfan67

Ticket #11613 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain akks.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.