Modify

Opened 8 years ago

Closed 8 years ago

#11303 closed defect (duplicate)

Error on opening map download dialog

Reported by: Atalanttore Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open the map download dialog

=> Error

What is the expected result?

A normal map download dialog should appear.

What happens instead?

Error message.

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-06 01:31:03
Last Changed Author: bastiK
Revision: 8168
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-06 01:43:03 +0200 (Mon, 06 Apr 2015)
Last Changed Rev: 8168

Identification: JOSM/1.5 (8168 de) Windows 7 64-Bit
Memory Usage: 84 MB / 247 MB (38 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) Client VM

Plugins:
- AddrInterpolation (30892)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- OpeningHoursEditor (30962)
- RoadSigns (30977)
- alignways (30892)
- buildings_tools (30955)
- editgpx (30892)
- lakewalker (30892)
- measurement (30892)
- terracer (30892)
- turnlanes (30892)
- turnrestrictions (31034)
- undelete (30892)
- waydownloader (30892)

Last errors/warnings:
- E: java.lang.ExceptionInInitializerError. Ursache: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl). Ursache: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl

java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.data.cache.JCSCacheManager.initialize(JCSCacheManager.java:86)
	at org.openstreetmap.josm.data.cache.JCSCacheManager.getCache(JCSCacheManager.java:130)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.<init>(TMSCachedTileLoader.java:48)
	at org.openstreetmap.josm.gui.layer.TMSLayer$1.makeTileLoader(TMSLayer.java:139)
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:141)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:109)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:208)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:64)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:41)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl)
	at org.apache.commons.logging.LogFactory.createFactory(LogFactory.java:1158)
	at org.apache.commons.logging.LogFactory$2.run(LogFactory.java:960)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.apache.commons.logging.LogFactory.newFactory(LogFactory.java:957)
	at org.apache.commons.logging.LogFactory.getFactory(LogFactory.java:624)
	at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:655)
	at org.apache.commons.jcs.engine.control.CompositeCacheManager.<clinit>(CompositeCacheManager.java:74)
	... 47 more
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at org.apache.commons.logging.LogFactory.createFactory(LogFactory.java:1020)
	... 53 more

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by Atalanttore

Same problem after upgrading to Java 8 Update 40.

Revision: 8168
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: bastiK
Last Changed Date: 2015-04-06 01:43:03 +0200 (Mon, 06 Apr 2015)
Build-Date: 2015-04-06 01:31:03
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8168

Identification: JOSM/1.5 (8168 de) Windows 7 64-Bit
Memory Usage: 343 MB / 892 MB (295 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- AddrInterpolation (30892)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- OpeningHoursEditor (30962)
- RoadSigns (30977)
- alignways (30892)
- buildings_tools (30955)
- editgpx (30892)
- lakewalker (30892)
- measurement (30892)
- terracer (30892)
- turnlanes (30892)
- turnrestrictions (31034)
- undelete (30892)
- waydownloader (30892)

Last errors/warnings:
- E: java.lang.ExceptionInInitializerError. Ursache: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl). Ursache: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl

java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.data.cache.JCSCacheManager.initialize(JCSCacheManager.java:86)
	at org.openstreetmap.josm.data.cache.JCSCacheManager.getCache(JCSCacheManager.java:130)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.<init>(TMSCachedTileLoader.java:48)
	at org.openstreetmap.josm.gui.layer.TMSLayer$1.makeTileLoader(TMSLayer.java:139)
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:141)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:109)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:208)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:64)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:41)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: org.apache.commons.logging.LogConfigurationException: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl (Caused by java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl)
	at org.apache.commons.logging.LogFactory.createFactory(LogFactory.java:1158)
	at org.apache.commons.logging.LogFactory$2.run(LogFactory.java:960)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.apache.commons.logging.LogFactory.newFactory(LogFactory.java:957)
	at org.apache.commons.logging.LogFactory.getFactory(LogFactory.java:624)
	at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:655)
	at org.apache.commons.jcs.engine.control.CompositeCacheManager.<clinit>(CompositeCacheManager.java:74)
	... 47 more
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.impl.LogFactoryImpl
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at org.apache.commons.logging.LogFactory.createFactory(LogFactory.java:1020)
	... 53 more

Last edited 8 years ago by skyper (previous) (diff)

comment:2 Changed 8 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11300.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.