Modify

Opened 4 years ago

Closed 3 months ago

Last modified 7 weeks ago

#10456 closed enhancement (fixed)

Locked layers

Reported by: anonymous Owned by: team
Priority: normal Milestone: 18.02
Component: Core Version:
Keywords: lock layer Cc: josm@…, josm@…, openstreetmap.org-user-d1g

Description

Beeing able to lock layers to prevent them from changes. When I collected data with osmand (which is imho a great tool) I import the .osc file into josm. I also download the area I want to edit into a different layer. This way I dont loose track of all the changes in the first layer and "move" them one by one in the downloaded layer.
When I work on a greater area I download only the surrounding of the object I want to change. This way it sometimes happens that I accidentally download into the first layer – then I loose track. So it would be very nice to be able to prevent this layer for downloading or have an option to download only in the other layer.

Attachments (0)

Change History (21)

comment:1 Changed 4 years ago by Don-vip

Keywords: lock layer added
Priority: minornormal
Summary: Feature Request: locked layersLocked layers

comment:2 in reply to:  description ; Changed 4 years ago by skyper

Replying to anonymous:

So, we need a feature to prevent download + merge.

When I work on a greater area I download only the surrounding of the object I want to change. This way it sometimes happens that I accidentally download into the first layer – then I loose track. So it would be very nice to be able to prevent this layer for downloading or have an option to download only in the other layer.

As workaround you could always set the check box "download to new layer" and then manually merge plus keeping the original file/layer by cloning it.

comment:3 in reply to:  2 Changed 4 years ago by bitnapper

So, we need a feature to prevent download + merge.

Something like that would do.

As workaround you could always set the check box "download to new layer" and then manually merge plus keeping the original file/layer by cloning it.

Did that and it works but the other way would be more comfortable.

comment:4 Changed 4 years ago by Don-vip

Ticket #10525 has been marked as a duplicate of this ticket.

comment:5 Changed 4 years ago by Don-vip

Cc: josm@… added

comment:6 Changed 2 years ago by Don-vip

Ticket #12631 has been marked as a duplicate of this ticket.

comment:7 Changed 2 years ago by Don-vip

Cc: josm@… added

comment:8 Changed 21 months ago by openstreetmap.org-user-d1g

Cc: openstreetmap.org-user-d1g added

comment:9 Changed 21 months ago by openstreetmap.org-user-d1g

I just want to clarify "Prevent modifications" and "prevent them from changes":

prevent modification, but allow data inspection/exploration (at least by default) - this way you could use special layers at tutoring material.

Right now you are able to destroy tutoring materials during trial and error process.

comment:10 Changed 3 months ago by Don-vip

Milestone: 18.02

comment:11 Changed 3 months ago by Don-vip

In 13434/josm:

see #8039, see #10456 - support read-only data layers

comment:12 Changed 3 months ago by Don-vip

In 13435/josm:

see #8039, see #10456 - fix regressions and code style issues

comment:13 Changed 3 months ago by Don-vip

In 13444/josm:

see #8039, see #10456 - fix crash with rendering of virtual nodes

comment:14 Changed 3 months ago by Don-vip

In 13446/josm:

see #8039, see #10456 - disable more actions modifying the dataset

comment:15 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13453/josm:

fix #8039, fix #10456: final fixes for the read-only/locked layers:

  • rename "read-only" to "locked" (in XML and Java classes/interfaces)
  • add a new download policy (true/never) to allow private layers forbidding only to download data, but allowing everything else

This leads to:

  • normal layers: download allowed, modifications allowed, upload allowed
  • private layers: download allowed or not (download=true/never), modifications allowed, upload allowed or not (upload=true/discouraged/never)
  • locked layers: nothing allowed, the data cannot be modified in any way

comment:16 Changed 3 months ago by Don-vip

In 13485/josm:

see #8039, see #10456 - keep layer download/upload/locked flags when saving to .osm file

comment:17 Changed 3 months ago by Don-vip

In 13486/josm:

fix #8039, see #10456 - fix bugs with non-downloadable layers

comment:18 Changed 3 months ago by Don-vip

In 13488/josm:

fix #16039, see #8039, see #10456 - fix upload regression when using individual primitive upload strategy

comment:19 Changed 3 months ago by Don-vip

In 13490/josm:

fix #16045, see #8039, see #10456 - fix NPE when clicking preset link from relation editor

comment:20 Changed 3 months ago by Don-vip

In 13497/josm:

fix #16051, see #8039, see #10456 - more fixes for download/upload policies and locked status (merge of layers)

comment:21 Changed 7 weeks ago by Don-vip

In 13586/josm:

fix #16141, see #8039, see #10456: fix NPE in preset editor

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.