Modify

Opened 9 months ago

Closed 9 months ago

Last modified 7 months ago

#16141 closed defect (fixed)

NPE when Editing Annotation/Name from within a relation

Reported by: anonymous Owned by: team
Priority: normal Milestone: 18.04
Component: Core Version:
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Double-click a relation to open "Edit relation" dialog
  2. Add a field "old_name" to make the "Annotation/Name" template appear
  3. Click the "Annotation/Name" template, edit it, the click "Apply"

What is the expected result?

Changed values are applied to relation.

What happens instead?

Error dialog. Changes NOT applied.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-28 23:24:09 +0200 (Wed, 28 Mar 2018)
Build-Date:2018-03-29 01:32:28
Revision:13582
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13582 en) Linux Ubuntu Bionic Beaver (development branch)
Memory Usage: 378 MB / 1326 MB (102 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
VM arguments: [-Djava.net.preferIPv4Stack=true, -Djosm.prefer.ipv6=false]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.10)
+ OpenStreetCam (114)
+ OpeningHoursEditor (34095)
+ PicLayer (34109)
+ RoadSigns (34109)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34109)
+ public_transport (34109)
+ tageditor (34109)
+ turnlanes (34109)
+ turnlanes-tagging (263)
+ turnrestrictions (34129)
+ undelete (34109)
+ utilsplugin2 (34109)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: Invalid jar file ''<josm.pref>/plugins/turnrestrictions.jar.new'' (exists: false, canRead: false)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.dialogs.properties.PresetListPanel$LabelMouseAdapter.mouseClicked(PresetListPanel.java:43)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
	at java.awt.Component.processMouseEvent(Component.java:6536)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2237)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2295)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4889)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4467)
	at java.awt.Container.dispatchEventImpl(Container.java:2281)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (12)

comment:1 Changed 9 months ago by Klumbumbus

Milestone: 18.04

comment:2 Changed 9 months ago by Don-vip

Keywords: regression added

comment:3 Changed 9 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13586/josm:

fix #16141, see #8039, see #10456: fix NPE in preset editor

comment:4 Changed 8 months ago by Klumbumbus

Ticket #16154 has been marked as a duplicate of this ticket.

comment:5 Changed 8 months ago by Klumbumbus

Ticket #16155 has been marked as a duplicate of this ticket.

comment:6 Changed 8 months ago by Klumbumbus

Ticket #16160 has been marked as a duplicate of this ticket.

comment:7 Changed 8 months ago by Don-vip

Ticket #16187 has been marked as a duplicate of this ticket.

comment:8 Changed 8 months ago by Klumbumbus

Ticket #16200 has been marked as a duplicate of this ticket.

comment:9 Changed 8 months ago by Don-vip

Ticket #16225 has been marked as a duplicate of this ticket.

comment:10 Changed 8 months ago by Don-vip

Summary: Editing Annotation/Name from within a relation throws error on ApplyNPE when Editing Annotation/Name from within a relation

comment:11 Changed 8 months ago by Don-vip

Ticket #16232 has been marked as a duplicate of this ticket.

comment:12 Changed 7 months ago by Don-vip

Ticket #16252 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.