Modify

Opened 4 years ago

Closed 4 years ago

#10525 closed enhancement (duplicate)

Support of "scratchpad" layers

Reported by: josm@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

I'm currently mapping the addresses of my home town. As it has 41k inhabitants this isn't something I can do in one go.
To easily keep track of the "unmapped" areas I'm using a separate data layer as scratchpad: I marked all areas that I haven't mapped yet and as I map the addresses I chop off the finished parts from the marked areas.
There is just a little problem with this: A couple of times it happened that I had the wrong layer selected, downloading OSM-data into the scratchpad layer or pressing the upload button. Fortunately I noticed this everytime before I saved the layer or pressed the upload button in the changeset dialog.

As I couldn't find real support for scratchpad layers in JOSM I propose a scratchpad layer support for JOSM.
In my opinion it should be enough if the upload and/or download of a data layer can be disable to prevent accidents. Maybe this can be selected by right-clicking on the layer in the layer list.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10456.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.