Modify

Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#16039 closed defect (fixed)

DataIntegrityProblemException: Primitive cannot be modified in read-only dataset / OsmServerWriter.uploadChangesIndividually

Reported by: anonymous Owned by: team
Priority: major Milestone: 18.03
Component: Core Version:
Keywords: template_report upload regression Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. upload data and changset will be not closed

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-01 10:08:48 +0100 (Thu, 01 Mar 2018)
Build-Date:2018-03-01 09:12:13
Revision:13478
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13478 de) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 1223 MB / 3641 MB (169 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (33963)
+ HouseNumberTaggingTool (34074)
+ Mapillary (v1.5.10)
+ OpeningHoursEditor (33876)
+ PicLayer (34021)
+ apache-commons (33668)
+ apache-http (32699)
+ continuosDownload (68)
+ ejml (32680)
+ geotools (33958)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ opendata (34072)
+ public_transport (33817)
+ rasterfilters (33893)
+ reverter (34036)
+ tageditor (33806)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ undelete (33980)
+ utilsplugin2 (33991)
+ wikipedia (34079)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ http://osm.michis-pla.net/presets/observatory.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.xml
+ http://www.freietonne.de/ft_icons/josm/FreieTonne_rules_presets_zip.php
+ http://www.openrailwaymap.org/josm-presets/de.zip
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Maxspeed-zones&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Healthcare&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- C:\Daten\gis\OSM_Erfassung\SK_Test.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1

Last errors/warnings:
- E: java.util.concurrent.ExecutionException: [powershell, -Command, $PSVersionTable.PSVersion.Major]
- E: java.util.concurrent.ExecutionException: [powershell, -Command, $PSVersionTable.PSVersion.Major]
- E: Fehler beim Laden des Bildes 'presets/landuse/landuse.png'
- W:  Observatory site: Could not get presets icon presets/landuse/landuse.png
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=4947666589 version=1 MVT lat=52.057139,lon=14.1112245}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=3867620430 version=1 MVT lat=52.1173989,lon=14.1908639}
- E: Error header: Version mismatch: Provided 1, server had: 2 of Node 3867620430
- E: Konflikte gefunden - <html>Hochladen <strong>fehlgeschlagen</strong>, da der Server eine neuere Version<br>von einem Ihrer Punkte, Linien oder Relationen hat.<br>Der Konflikt wird durch ein Objekt vom Typ <strong>Punkt</strong> mit der Kennung <strong>3.867.620.430</strong> ausgelöst.<br>Der Server hat Version 2, Ihre Version ist 1.<br>Wählen Sie <strong>Nur Punkte 3.867.620.430 synchronisieren</strong>, um dieses Objekt zu synchronisieren.<br>Wählen Sie <strong>Ganzen Datensatz synchronisieren</strong>, um den kompletten lokalen Datensatz mit dem Server zu synchronisieren.<br>Wählen Sie <strong>Abbrechen</strong>, um abzubrechen und weiterzuarbeiten.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=3869883413 version=1 MVT lat=52.1289173,lon=14.1617739}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-2 (259)
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Node id=3869883413 version=1 MVT lat=52.1289173,lon=14.1617739}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDatasetNotReadOnly(OsmPrimitive.java:282)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.setOsmId(OsmPrimitive.java:315)
	at org.openstreetmap.josm.io.OsmApi.modifyPrimitive(OsmApi.java:398)
	at org.openstreetmap.josm.io.OsmServerWriter.makeApiRequest(OsmServerWriter.java:234)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesIndividually(OsmServerWriter.java:115)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:214)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:260)
	at org.openstreetmap.josm.gui.io.AsynchronousUploadPrimitivesTask.realRun(AsynchronousUploadPrimitivesTask.java:131)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (8)

comment:1 Changed 10 months ago by Don-vip

Keywords: upload regression added
Milestone: 18.03
Priority: normalmajor

comment:2 Changed 10 months ago by stoecker

Ticket #16041 has been marked as a duplicate of this ticket.

comment:3 Changed 10 months ago by streckenkundler

Hi,

I have reported this Problem.

I can downloaded data, I can change data...

If I want to upload data, I get this error. However, the data is obviously also saved when I ignore the error-message. The changeset is not closed, it must be closed manually.

Then when I want to quit JOSM, I get the message that I need to upload the changes, even though data is already uploaded and change set is manually closed.

I hope this helps a bit more...

streckenkundler

comment:4 in reply to:  3 ; Changed 10 months ago by Hb---

Replying to streckenkundler:

Thanks for reporting this. It is a regression which came in the code due to resolving a Dutch Mapsserver problem in #15992. JOSM code has to cover three MS Windows variants with and without different variants of powershell.

comment:5 in reply to:  4 Changed 10 months ago by Don-vip

Replying to Hb---:

It is a regression which came in the code due to resolving a Dutch Mapsserver problem in #15992. JOSM code has to cover three MS Windows variants with and without different variants of powershell.

Absolutely not! Please don't make such statements about the code. The issues are not related at all.

comment:6 Changed 10 months ago by Don-vip

Description: modified (diff)
Summary: upload data and changset will be not closedDataIntegrityProblemException: Primitive cannot be modified in read-only dataset / OsmServerWriter.uploadChangesIndividually

comment:7 Changed 10 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13488/josm:

fix #16039, see #8039, see #10456 - fix upload regression when using individual primitive upload strategy

comment:8 Changed 10 months ago by streckenkundler

Thanks.

Now it works fine again.

streckenkundler

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.