wiki:Ja:Help/SystemRequirements

Version 7 (modified by anonymous, 4 days ago) (diff)

--

システム要件

JOSMを実行するには Java 8 以降の最新バージョンの実行環境が必要です。

古いJavaしか持っておらず更新もできない場合、古いバージョンのJOSMを使ってください。

  • バージョン 3377 はJava 5で動作します。
  • バージョン 7000 はJava 6で動作します。
  • バージョン 10526 はJava 7で動作します。

MacとWindows用のインストーラを含む古いバージョンのJOSMは download archive から入手できます。ただし、常に最新の安定版を使用することを強くお勧めします。

Java 7の古いバージョン(2013年6月リリースのupdate 25よりも前)しかない場合、JOSMのバージョン10526は動作はするものの以下のJavaのバグを引く可能性があります。回避するにはそれぞれのバグに対応する更新を適用してください。

  • #8182: Mac OS: Cannot open files in directories with swedish characters in them -> Update to Java 7 update 10 or later (see Java bug 7193966)

トラブルシューティング

  • コマンドライン出力でJOSMを起動する
    Exception in thread "main" java.lang.UnsupportedClassVersionError: JOSM : Unsupported major.minor version 52.0
    
    → 上記の説明に従ってJava 8以降をインストールしてください。