Modify

Opened 9 years ago

Closed 15 months ago

#8266 closed defect (needinfo)

validator issues incorrect warning for "route" relation

Reported by: Gilbert54 Owned by: Gilbert54
Priority: normal Milestone:
Component: Core validator Version:
Keywords: public_transport role check Cc: Xapitoun

Description

Role <empty> missing - Role verification problem (1)
org.openstreetmap.josm.data.validation.TestError@1db6fbe
relation: 2592193
I deleted all stop and platform members and the warning won't go away. Eventually restored the relation to it's original state.In my opinion the validator gives incorrect results.
When I test this relation with the OSM relation analyzer everything checks out OK.
http://ra.osmsurround.org/analyzeRelation?relationId=2592193&_noCache=on#

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-29 02:31:07
Last Changed Author: stoecker
Revision: 5608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-28 23:47:46 +0100 (Wed, 28 Nov 2012)
Last Changed Rev: 5608

Identification: JOSM/1.5 (5608 en_GB)
Memory Usage: 439 MB / 494 MB (36 MB allocated, but free)
Java version: 1.7.0_09, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Attachments (0)

Change History (14)

comment:1 Changed 9 years ago by simon04

I agree that this warning is unwanted. Reason: relation is validated also according to new public transport scheme – see also my comment:6:ticket:8255.

comment:2 Changed 9 years ago by Don-vip

Summary: validator issues incorrect warning for relationvalidator issues incorrect warning for "route" relation

comment:3 Changed 8 years ago by Don-vip

Ticket #8769 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by Don-vip

Cc: Xapitoun added

comment:5 Changed 8 years ago by skyper

See also #8422 and #8460

comment:6 Changed 8 years ago by skyper

Keywords: public_transport role check added; incorrect validation result removed

comment:7 Changed 8 years ago by simon04

Owner: changed from team to Gilbert54
Status: newneedinfo

Are you sure that highway=bus_stop with role platform is correct according to the older and/or newer PT mapping scheme. I think either highway=bus_stop with role stop is correct in the older one, or public_transport=platform with role platform according to the newer one.

comment:8 Changed 8 years ago by Don-vip

Milestone: 14.02

comment:9 Changed 8 years ago by simon04

Resolution: needinfo
Status: needinfoclosed

comment:10 Changed 8 years ago by Don-vip

Milestone: 14.02

comment:11 Changed 15 months ago by anonymous

Resolution: needinfo
Status: closedreopened

Wait was this resolved or not? I have same issue in 2020 (version 15937).
Relation 8860865 is type=route_master
Relation 8860864 is a member of 8860865 with empty role, as prescribed by https://wiki.openstreetmap.org/wiki/Relation:route_master#Members
Validator says that 8860864 has "Role verification problem - Role '<empty>' missing"

comment:12 Changed 15 months ago by anonymous

I tried to assign role=<empty>, the above warning still remains but there is another one on top of that: "Role '<empty>' is not in templates"

comment:13 in reply to:  12 Changed 15 months ago by skyper

Replying to anonymous:

I tried to assign role=<empty>, the above warning still remains but there is another one on top of that: "Role '<empty>' is not in templates"

Please, recheck if the role is really "empty". I have found fixed white spaces as role value. So change the role and make sure you add nothing. One way is to use the relation editor and use the role box at the bottom. You should be warned about adding an empty value with default settings.

comment:14 in reply to:  11 Changed 15 months ago by skyper

Resolution: needinfo
Status: reopenedclosed

Replying to anonymous:

Wait was this resolved or not? I have same issue in 2020 (version 15937).
Relation 8860865 is type=route_master
Relation 8860864 is a member of 8860865 with empty role, as prescribed by https://wiki.openstreetmap.org/wiki/Relation:route_master#Members
Validator says that 8860864 has "Role verification problem - Role '<empty>' missing"

Hey, the warning is about the members of the type=route relation (8860864 which does not have any way and no object with <empty> role as member. As public_transport:version=2 is present the warning is correct.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gilbert54.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.