Modify

Opened 9 years ago

Closed 9 years ago

#8267 closed defect (duplicate)

Exception when editing relations

Reported by: Jolter Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?
Have not reproduced.
Tried to set role "stop" on a tram stop node in a tram line relation.

What is the expected result?
node should get role "stop".

What happens instead?
Exception dialog.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-29 02:31:07
Last Changed Author: stoecker
Revision: 5608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-28 23:47:46 +0100 (Wed, 28 Nov 2012)
Last Changed Rev: 5608

Identification: JOSM/1.5 (5608 en)
Memory Usage: 190 MB / 910 MB (34 MB allocated, but free)
Java version: 1.7.0_07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found


java.lang.IndexOutOfBoundsException: Index: 121, Size: 121
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.updateRole(MemberTableModel.java:452)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$SetRoleAction.actionPerformed(GenericRelationEditor.java:1539)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source

Attachments (1)

Capture.PNG (840.5 KB) - added by Jolter 9 years ago.
Screenshot of relation editor

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Jolter

Attachment: Capture.PNG added

Screenshot of relation editor

comment:1 Changed 9 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7885.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.