Modify

Opened 7 years ago

Closed 5 years ago

#7885 closed defect (fixed)

IndexOutOfBoundsException when editing a relation member's role

Reported by: nzara Owned by: team
Priority: normal Milestone: 14.09
Component: Core Version:
Keywords: template_report Cc: Jolter, CaptainCrunch

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Select some ways
  2. Choose: Presets:Relation:Polygon
  3. Click 'Add all Objects selected in the current dataset after the last element'

What is the expected result?

What happens instead?
Bug message opens

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-07-03 01:31:22
Last Changed Author: simon04
Revision: 5315
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-07-02 14:51:19 +0200 (Mon, 02 Jul 2012)
Last Changed Rev: 5315

Identification: JOSM/1.5 (5315 en)
Memory Usage: 427 MB / 455 MB (120 MB allocated, but free)
Java version: 1.7.0_05, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: DirectDownload (28412)
Plugin: DirectUpload (28412)
Plugin: ImportImagePlugin (28412)
Plugin: InfoMode (27981)
Plugin: PicLayer (27883)
Plugin: alignways (28412)
Plugin: buildings_tools (28412)
Plugin: editgpx (28412)
Plugin: imageryadjust (28412)
Plugin: measurement (28412)
Plugin: multipoly-convert (28412)
Plugin: pdfimport (28448)
Plugin: proj4j (28412)
Plugin: public_transport (28412)
Plugin: reltoolbox (28412)
Plugin: tag2link (28412)
Plugin: tageditor (28412)
Plugin: utilsplugin2 (28412)
Plugin: wikipedia (28488)

java.lang.IndexOutOfBoundsException: Index: 39, Size: 39
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.updateRole(MemberTableModel.java:441)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$SetRoleAction.actionPerformed(GenericRelationEditor.java:1537)
	at javax.swing.AbstractButton.fireActionPerform

Attachments (0)

Change History (14)

comment:1 Changed 7 years ago by Don-vip

Owner: changed from team to nzara
Status: newneedinfo

Works for me. Is it always reproducible ? If yes, can you attach your .osm file, please ?

comment:2 Changed 7 years ago by Don-vip

Summary: Bug at create new relationIndexOutOfBoundsException when creating a new relation

comment:3 Changed 7 years ago by stoecker

Resolution: needinfo
Status: needinfoclosed

comment:4 Changed 7 years ago by Don-vip

Resolution: needinfo
Status: closedreopened

comment:5 Changed 7 years ago by Don-vip

Ticket #8267 has been marked as a duplicate of this ticket.

comment:6 Changed 7 years ago by Don-vip

Cc: Jolter added
Summary: IndexOutOfBoundsException when creating a new relationIndexOutOfBoundsException when editing a relation member's role

More info in #8267 description.

comment:7 Changed 7 years ago by Don-vip

Owner: changed from nzara to team
Status: reopenednew

comment:8 Changed 6 years ago by Don-vip

Ticket #9548 has been marked as a duplicate of this ticket.

comment:9 Changed 6 years ago by Don-vip

Cc: CaptainCrunch added
Milestone: 14.01

From #9548:

Steps to reproduce:

  • Select at least one element that is already member of a relation and open relation editor for that relation
  • Click "Insert all objects of the current selection after the last member" (4th button from top)
  • Click no when prompted to insert elements that are already in the relation. (The selection jumps to the last member.)
  • Now enter a role in the "apply role" textbox and click the apply role button.
Last edited 6 years ago by Don-vip (previous) (diff)

comment:10 Changed 6 years ago by Don-vip

I can't reproduce, can you tell me what was your relation and element id ?

comment:11 Changed 6 years ago by Don-vip

Description: modified (diff)
Milestone: 14.01
Owner: changed from team to nzara
Status: newneedinfo

comment:12 Changed 5 years ago by Don-vip

Milestone: 14.09

comment:13 Changed 5 years ago by Don-vip

Owner: changed from nzara to team
Status: needinfonew

comment:14 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7552/josm:

fix #7885 - IndexOutOfBoundsException in relation dialog

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.