Modify

Opened 12 years ago

Closed 10 years ago

#4077 closed defect (fixed)

[patch] Unsaved changes pops up when closing josm after undoing all changes

Reported by: Daeron Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc: dieterdreist, jstein

Description (last modified by skyper)

If there are some modifications made to the data, and all of them are undone, josm still pops up a dialog asking about "unsaved changes" when closing josm. However, if the same layer is deleted, the dialog doesn't appear.

Attachments (2)

4077.patch (740 bytes) - added by sfriedle 10 years ago.
new-layer-modify.patch (443 bytes) - added by sfriedle 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by stoecker

Ticket #6509 has been marked as a duplicate of this ticket.

comment:2 Changed 10 years ago by anonymous

Ticket #5347 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by skyper

Description: modified (diff)
Summary: Usaved changes pops up when closing josm after undoing all changesUnsaved changes pops up when closing josm after undoing all changes

typo

Last edited 10 years ago by skyper (previous) (diff)

comment:4 Changed 10 years ago by skyper

Ticket #6110 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by skyper

Cc: dieterdreist jstein added

Changed 10 years ago by sfriedle

Attachment: 4077.patch added

Changed 10 years ago by sfriedle

Attachment: new-layer-modify.patch added

comment:6 Changed 10 years ago by sfriedle

Summary: Unsaved changes pops up when closing josm after undoing all changes[patch] Unsaved changes pops up when closing josm after undoing all changes

Patch attached (4077.patch), which hides the "Unsaved changes" dialog if JOSM is to be closed and the data of the layer isn't modified. Works like the delete action in the layer dialog. Unfortunately, the issue with the asterisk in the window title still remains.

There was another problem, which I fixed with patch new-layer-modify.patch: if only new primitives were created in a layer, the data in this layer wasn't marked as modified. I changed this, so that the addition of new primitives marks them as modified. Because I'm new to JOSM development, could some long-term dev review this approach, please?

comment:7 Changed 10 years ago by simon04

Resolution: fixed
Status: newclosed

In 5112/josm:

fix #4077 - patch by sfriedle - Unsaved changes pops up when closing JOSM after undoing all changes

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.