Modify

Opened 8 months ago

Closed 3 months ago

Last modified 3 months ago

#15711 closed enhancement (fixed)

[PATCH] Vizualize imagery layers with non-zero offsets

Reported by: skorbut Owned by: team
Priority: normal Milestone: 18.04
Component: Core imagery Version:
Keywords: offset Cc:

Description

When working with multiple imagery layers (Bing, DigitalGlobe, etc.) where some layers need an offset correction, it gets quickly unclear, which layers have a user-defined non-zero offset and which do not.

To enable the user to see this information at a glance in the layer list, this patch writes the names of imagery layers with a non-zero offset in italic letters.

Note: I'm not sure if there is already another meaning defined behind an italic layer name. If yes, I'm open to suggestions to do show this information in another way, e.g. colors, an exclamation mark on a yellow ground, etc.

Attachments (3)

italic_font_for_nonzero_offsets.patch (2.3 KB) - added by skorbut 8 months ago.
offset_icon.patch (8.3 KB) - added by skorbut 7 months ago.
offset.png (731 bytes) - added by skorbut 7 months ago.
Belongs into images/dialogs/layerlist/offset.png . Is derived from images/mapmode/adjustimg.png .

Download all attachments as: .zip

Change History (23)

Changed 8 months ago by skorbut

comment:1 Changed 8 months ago by stoecker

Nobody will understand the meaning of italic font. That would be another "secret JOSM hint" exchanged by some mappers. A small symbol (with mouseover text) would be a better solution. But that again means also other information may result in more images and this again means a way to handle them ;-)

comment:2 Changed 8 months ago by naoliv

We need this #12173 :-)

comment:3 Changed 8 months ago by Don-vip

Keywords: offset added

comment:4 Changed 8 months ago by Klumbumbus

see also #15615

comment:5 Changed 7 months ago by Don-vip

Summary: [PATCH] Italic font for imagery layers with non-zero offsetsVizualize imagery layers with non-zero offsets

I agree, italic font is not the best way to go. A visual indicator (like an icon overlay, or changing the layer name...) in the layer list would be better.

comment:6 Changed 7 months ago by skorbut

I wrote a new patch that introduces a new icon in the LayerListDialog. The icon is shown when the layer has an offset, otherwise the area is blank. By clicking this new icon, the offset of this layer will be reset to zero. This should improve the user experience when working with layer offsets.

The new icon goes into images/dialogs/layerlist/offset.png. It is derived from images/mapmode/adjustimg.png.

There are two more things that are not yet implemented, but maybe should be eventually:

  1. If one clicks the icon to reset the offset by accident, it's not (easily) possible to regain this offset (when not working with bookmarks). Maybe we can store the offset and reapply it, if the offset checkbox is clicked again. (Where should the offset be stored? Maybe as an extension of LayerList in LayerListDialog?)
  1. If one opens the "Adjust imagery offset" menu and types/drags a new offset, the offset icon is shown immediately, even when the menu is still open. If the icon gets clicked, the offset will be reset. However, the offset values in the form will not be reset. Therefore there is a small mismatch between what is shown in the menu and what is effectively displayed.

comment:7 Changed 7 months ago by skorbut

Summary: Vizualize imagery layers with non-zero offsets[PATCH] Vizualize imagery layers with non-zero offsets

Changed 7 months ago by skorbut

Attachment: offset_icon.patch added

Changed 7 months ago by skorbut

Attachment: offset.png added

Belongs into images/dialogs/layerlist/offset.png . Is derived from images/mapmode/adjustimg.png .

comment:8 Changed 6 months ago by skorbut

What do you devs think of this?

comment:9 Changed 5 months ago by stoecker

Milestone: 18.03

comment:10 Changed 5 months ago by Don-vip

Milestone: 18.0318.04

Nice! I will merge it next week as it adds new strings to translate.

comment:11 Changed 4 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13608/josm:

fix #15711 - Vizualize imagery layers with non-zero offsets (patch by skorbut)

comment:12 Changed 4 months ago by Don-vip

Thanks for the patch! and sorry for delay!

comment:13 Changed 3 months ago by Don-vip

Ticket #14829 has been marked as a duplicate of this ticket.

comment:14 Changed 3 months ago by Klumbumbus

Ticket #12173 has been marked as a duplicate of this ticket.

comment:15 Changed 3 months ago by Klumbumbus

Ticket #15615 has been marked as a duplicate of this ticket.

comment:16 Changed 3 months ago by Polarbear-j

Resolution: fixed
Status: closedreopened

This is fine, thanks.

There is a inconsistency remaining: when I reset the offset by clicking the icon, and check the current offset via right-click ->Offset, the tick-mark hangs still at an old offset bookmark.

Furthermore, when the offset was selected via a bookmark, clicking the icon does reset it, but the icon does not (always?) disappear. I also got a situation now with two bookmarks having a tick-mark.

comment:17 Changed 3 months ago by Don-vip

@skorbut: can you please check?

comment:18 Changed 3 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

@Polarbear-j: Can't reproduce, please open a new ticket with status report and screenshot.

comment:19 Changed 3 months ago by Don-vip

Ticket #9477 has been marked as a duplicate of this ticket.

comment:20 Changed 3 months ago by anonymous

Don-vip in a duplicate

Closed as duplicate of #15711.
With #15711 you can now reset an offset to null with a single click.
I won't implement the non-volatility of offset after restart. Like projections, it would be easy for users to forget they changed this parameter, I prefer to be sure the offsets are chosen manually.

Thanks. OK but...
Forgetting that there should be an offset is just as dangerous as forgetting that one is defined.

Italics...

In fact, I see the warning as exactly the same as when a layer is opened for the first time.
("may be wrong" large bar to dismiss at the top of the display)
Instead of "because you use the layer first time", it would say "because you have offsets defined".
Sorry to have just been warned of this discussion.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.