Modify

Opened 3 years ago

Closed 3 years ago

Last modified 7 months ago

#12297 closed enhancement (fixed)

New preset icons in svg - power

Reported by: zermes Owned by: Klumbumbus
Priority: normal Milestone: 16.02
Component: Internal preset Version:
Keywords: icon svg preset power plant generator substation transformer portal busbar switchgear bay switch converter compensator cable distribution cabinet tower pole distribution line Cc: naoliv, Klumbumbus, lists@…

Description (last modified by Klumbumbus)

Before someone begin voting or something I want to know if these icons represent what they mean (e.g. is that a switchgear or a switch?). I tried to find photos not present in https://wiki.openstreetmap.org/wiki/Tag:power%3Dswitchgear and other pages but didn't had lucky in some of them, so I guessed. If it's ok I will attach the files.

Edit:

Proposals for new presets, which came up in this ticket discussion:

Tag (wiki) Decision
Tag:power=portal Added
Tag:building=transformer_tower Added
Tag:power=terminal Not add now only 310 uses. No wiki page.
Tag:man_made=street_cabinet + street_cabinet=power instead of Tag:power=cable_distribution_cabinet Replaced (Although "old" tagging is still used more) see #11507
Proposed_features/Location_transitions instead of Tag:tower=transition and Tag:pole=transition Not replace now wait how the proposal goes and the usage. Currently there is only one hotspot, http://overpass-turbo.eu/s/dHf
Tag:power=catenary_mast Not add now Used nearly only in germany
Tag:power=insulator Added (Although only a few hotspots, http://overpass-turbo.eu/s/dHi)
Tag:power=heliostat Not add now Very specialized tag. Used only at a very limited number of solar power plants.

Tags, which are not added now to the internal preset can be added to Presets/NewTags (the icons are availible, https://trac.openstreetmap.org/browser/subversion/applications/share/map-icons/classic.small/power)

new internal preset guidlines: see DevelopersGuide/DefaultPresets

Attachments (6)

JOSM_icons_power.png (2.1 KB) - added by zermes 3 years ago.
JOSM_icons_power_v2.png (6.8 KB) - added by zermes 3 years ago.
JOSM_svg_icons_power_v2.7z (5.7 KB) - added by zermes 3 years ago.
JOSM_icons_power_v3.png (1.4 KB) - added by zermes 3 years ago.
JOSM_svg_icons_power_CC0_Public_Domain.7z (6.7 KB) - added by zermes 3 years ago.
JOSM_icons_power_v4.png (6.9 KB) - added by zermes 3 years ago.

Download all attachments as: .zip

Change History (50)

Changed 3 years ago by zermes

Attachment: JOSM_icons_power.png added

comment:1 Changed 3 years ago by zermes

Here is a preview:

comment:2 Changed 3 years ago by Don-vip

Milestone: 16.02

comment:3 Changed 3 years ago by Don-vip

Ticket #11207 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Don-vip

Cc: naoliv added

comment:5 Changed 3 years ago by Klumbumbus

Cc: Klumbumbus added

comment:6 Changed 3 years ago by Don-vip

can you please also create an icon for power=portal? (see #12240)

Changed 3 years ago by zermes

Attachment: JOSM_icons_power_v2.png added

Changed 3 years ago by zermes

Attachment: JOSM_svg_icons_power_v2.7z added

comment:7 Changed 3 years ago by zermes

Keywords: plant generator substation transformer portal busbar switchgear bay switch converter compensator cable distribution cabinet tower pole distribution line added

comment:8 in reply to:  6 Changed 3 years ago by zermes

Replying to Don-vip:

can you please also create an icon for power=portal? (see #12240)

Of course. It's a lot easier when I know what to draw.

In case something is wrong it can be changed. Has to be someone who knows what these tags represent.

Released under CC0/Public Domain

comment:9 Changed 3 years ago by francois.lacombe

Hi zermes and thank you for this awsome work

It's ok for merely all of these icons, they are very realistic and understandable
Please note that man_made=street_cabinet + street_cabinet=power is preferred to power=cable_distribution_cabinet
The proposed icon can certainly be used for street_cabinet.

I find the switch icon a bit fuzzy. What does it correspond to exactly ?
This symbol may be simpler https://pixabay.com/static/uploads/photo/2013/07/12/13/19/switch-146821_640.png or in reality : http://img.directindustry.com/images_di/photo-g/13988-2624407.jpg

Two items may be missing :

  • 'location transition' item, pole or tower with location transition

OSM tags : location:transition=yes (see http://wiki.openstreetmap.org/wiki/Proposed_features/Location_transitions)
In picture : http://wiki.openstreetmap.org/wiki/File:French_distribution_line_with_transition.jpg

  • 'power terminal', basically overhead line connected to a wall

OSM tags : power=terminal
In picture : http://wiki.openstreetmap.org/wiki/File:Trafohaus.jpg

These point above are only details and your collection is really a good one.

comment:10 in reply to:  9 ; Changed 3 years ago by Don-vip

Replying to francois.lacombe:

This symbol may be simpler https://pixabay.com/static/uploads/photo/2013/07/12/13/19/switch-146821_640.png

"no hotlinking", we can't see the image

comment:11 in reply to:  10 Changed 3 years ago by francois.lacombe

Replying to Don-vip:

"no hotlinking", we can't see the image

Sorry, don't understand why. Works well on my browser.
It corresponds to the symbol we use to see on any electric diagram for a switch : __/ __

comment:12 Changed 3 years ago by naoliv

If we click at the link then indeed we can't see it. Copying the URL works.
To make it easier:
http://i.imgur.com/zIaOEGs.png

comment:13 Changed 3 years ago by Aun Johnsen <lists@…>

Cc: lists@… added

Changed 3 years ago by zermes

Attachment: JOSM_icons_power_v3.png added

comment:14 Changed 3 years ago by zermes

Thanks for the tips. Much better with pictures! I knew I must have made a mistake somewhere since I don't understand some tags. That "switch icon" I've made was based wrongly in https://en.wikipedia.org/wiki/File:TMW_50981_Schnittmodell_Hochspannung-Leistungschalter_HPF500F.jpg I should had read the description of that picture that says "circuit breaker". In the picture https://wiki.openstreetmap.org/wiki/File:Substation-diagram.png the "switch" is called "disconnector", so I was confused.

power=cable_distribution_cabinet "More information about this feature" in JOSM is pointing to https://wiki.openstreetmap.org/wiki/Tag:power%3Dcable so it seems should be https://wiki.openstreetmap.org/wiki/Tag:man_made%3Dstreet_cabinet and the tag changed to "man_made=street_cabinet + street_cabinet=power" like francois.lacombe said. In the future, if man_made=street_cabinet is added to JOSM for the other tags I can make the other icons similar to this one for gas, water, etc.

I've added "building=transformer_tower" icon too, don't know if everyone agrees adding that to JOSM. In my country we have it almost everywhere and I saw people tagging them with "power=substation" only or in some cases only with "operator/name=EDP" (main company in Portugal). Tagifo shows it's used 3334 times.

Probably we should also add "power=catenary_mast" too (4731 uses). JOSM developers can you give us a hit what should be added to JOSM? Someone must stop us or we will ask to add everything :-)

I have to thank the authors of icons present in Potlatch 2 and JOSM default styles. Although some of them are not optimized for 16x16px they are nice icons and inspired me to make these.

Here they are:

comment:15 Changed 3 years ago by francois.lacombe

Hi zermes,

Actually, there are several type of power switches, each one for different places and use.
According to the picture you provide, you weren't wrong. But it's a circuit breaker and not a simple disconnector (both are power switches).

OSM tags for switches aren't set yet and power=switch is the only one correctly reviewed.
We may improve the description with switch=* (disconnector, cricuit_breaker,...) in the future.
That's why I recommend to use the Switch2 icon in your last post for all power=switch features for now.

Ok to diversify the cable_cabinet according to the street_cabinet=* values ;)

The building=transformer_tower hopefully gets more and more used and your icon for it fits perfectly.

Regarding the location transition cases, the location_transition8 icon best describe the situation with its underground part.

Ok to stop by catenary_mast (2nd icon is better), power=terminal (Terminal2 icon is the best) and transformer_tower. I don't see any other item to add for now.

Thank you so much ;)

comment:16 Changed 3 years ago by francois.lacombe

One more thing...

The last power=feature documented was the power=insulator value
http://wiki.openstreetmap.org/wiki/Tag:power%3Dinsulator

You may find some pictures on the wiki page.
May you add a dedicated icon for it ?

Will all these icons be present on the map itself ?
The yellow background suits perfectly menu integration but it's not really convenient on the map.
Some of described features (switches, terminal, insulator) can be also represented by a simple yellow dot, can't they ?

comment:17 in reply to:  16 ; Changed 3 years ago by stoecker

Replying to francois.lacombe:

The yellow background suits perfectly menu integration but it's not really convenient on the map.

See the leftmost black column. The yellow icons should also look right on the map.

comment:18 in reply to:  17 Changed 3 years ago by francois.lacombe

Replying to stoecker:

Replying to francois.lacombe:

See the leftmost black column. The yellow icons should also look right on the map.

I agree.
Nevertheless the problem isn't the black background but the amount of features in a small space.
16x16 icons are big when space between object is 2 or 3 meters in reality.
That's why I suggest small yellow dot similar to the cyan default one today.

At smaller zoom levels, small dots are mandatory

comment:19 Changed 3 years ago by Klumbumbus

I also think that the square yellow background will not work well for tower and pole, because they appear very often on the map. The icon in the preset menu and on the map should be the same for the same feature. While for the preset menu the square background is fine, it hides often to much on the map and can be obtrusive. (See also ticket:12232#comment:22). The icon on the map should be as small as possible. The square background is just a workaround if the icon would have to low contrast to the background.
Zermes, can you create the icons for tower and pole only with a yellow halo? (similar to the current tower icon, but in yellow instead of white) I think that would be the best compromise.

Changed 3 years ago by zermes

Changed 3 years ago by zermes

Attachment: JOSM_icons_power_v4.png added

comment:20 Changed 3 years ago by zermes

Thanks francois.lacombe for the info and suggestions.

About the size and obtrusion of icons, personally I don't have problem with that since JOSM can zoom in a lot (to millimeters I think). So only if one day we tag tiny things like "screw=philips" we will have problems and zoom had to be extended more. In some areas we will always have many icons obstructing at some zoom levels, shops, amenities, everything, so these should be tiny too... In OpenStreetMap site they choose at certain zoom levels to show some icons, but not others, but it's for a "finished" presentation purpose and for practical reasons in a "fixed medium". In JOSM is different, is for editing and we are constantly zooming in and out while using it. Any way, that's how I use JOSM and I understand not everyone use JOSM the same way and I should take in account the feedback by others while making these icons. I've made the suggestions and improved a bit, I hope, some of them. I've also added other icons like heliostat just in case, if not now, one day those presets are added to JOSM.

Released under CC0/Public Domain. Here is a preview:

comment:21 in reply to:  20 ; Changed 3 years ago by francois.lacombe

Hi Zermes

Replying to zermes:

About the size and obtrusion of icons, personally I don't have problem with that since JOSM can zoom in a lot (to millimeters I think). So only if one day we tag tiny things like "screw=philips" we will have problems and zoom had to be extended more.

I agree with you, we'll always manage to deal with icons on the map
But the advantage of JOSM is to provide a global view with small and comprehensive icons too. What if we obstruct this global view with bigger icons ?
Removing the yellow card as you done around the tower and pole is a good thing. Thank you :)

Nevertheless, it's only details and the new power icon set is really fancy
Ok to push it in the presets

comment:22 in reply to:  21 Changed 3 years ago by Don-vip

Replying to francois.lacombe:

Ok to push it in the presets

+1 this is really great work

comment:23 Changed 3 years ago by Klumbumbus

Owner: changed from team to Klumbumbus

comment:24 Changed 3 years ago by Klumbumbus

In 9423/josm:

see #12297 - add new power icons (by zermes), move old icons to nodist folder; see also [o31980]; fix cable_distribution_cabinet link

comment:25 Changed 3 years ago by Klumbumbus

I uploaded all the icons and replaced those, where we have a preset already. I will make a table in the ticket description for the new preset proposals.

comment:26 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:27 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:28 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:29 Changed 3 years ago by Klumbumbus

Owner: changed from Klumbumbus to team

comment:30 Changed 3 years ago by Klumbumbus

Owner: changed from team to Klumbumbus

comment:31 Changed 3 years ago by Klumbumbus

In 9433/josm:

see #12297 - add power=portal, power=insulator and building=transformer_tower to preset and mappaint style

comment:32 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:33 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:34 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:35 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:36 Changed 3 years ago by Klumbumbus

In 9434/josm:

fix #11507, see #12297 - deprecate power=cable_distribution_cabinet in favor of man_made=street_cabinet + street_cabinet=power

comment:37 Changed 3 years ago by Klumbumbus

Description: modified (diff)
Resolution: fixed
Status: newclosed

comment:38 Changed 3 years ago by francois.lacombe

Location:transition key is now approved at the end of the vote
http://wiki.openstreetmap.org/wiki/Proposed_features/Location_transitions

The wiki page will be created by this weekend but it will take a little time to rise up the amount of use cases.

comment:39 Changed 3 years ago by Don-vip

In 9643/josm:

see #12297 - ignore location:transition=yes

comment:41 Changed 3 years ago by sherpashaky@…

How do i access these new power icons in my preset.
Previously they were available as icon="styles/standard/power/transformer.svg"

This no longer works and the icons don't show my on my Preset list.

Thank you.

comment:42 in reply to:  41 Changed 3 years ago by Klumbumbus

Replying to sherpashaky@…:

Previously they were available as icon="styles/standard/power/transformer.svg"

This should work. Please try JOSM latest. presets, which are included via URL take up to 10 days until they auto update. You can clean the cache to force an update.

comment:43 Changed 3 years ago by stoecker

The last two anonymous edits to the preset breaks our validity tests as they access non-existing icons.

WARNING:  Transformer: Could not get presets icon styles/standard/misc/landmark/power/transformer.png
WARNING:  Transmission Substation: Could not get presets icon styles/standard/misc/landmark/power/tower_small.png
WARNING:  End Pole: Could not get presets icon styles/standard/misc/landmark/power/pole.png

Same for the style:

WARNING: Mappaint style "standard" (Power Mapping Additions) icon "styles/standard/misc/landmark/power/transformer.png" not found.

As these are anonymous edits without comment breaking previous fixes I tend to revert them completely if not cared by someone else.

A NOTE: styles referring to images included inside of JOSM will only work with the JOSM version including these images. JOSM only includes images used by the core itself. Add necessary images to the style itself to support older and newer versions.

comment:44 Changed 3 years ago by Klumbumbus

I reverted resp. fixed them.

comment:45 Changed 7 months ago by Klumbumbus

In 14123/josm:

fix #15769, see #12297, see #12386 - Add power=catenary_mast and power=terminal

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.