Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#8220 closed defect (fixed)

Validator does not detect crossing waysegments (of landuse, natural, barrier)

Reported by: simon04 Owned by: team
Priority: normal Milestone: 14.01
Component: Core validator Version:
Keywords: self_crossing check Cc:

Description

Validator does not detect crossing waysegments of landuse – see example file.

Attachments (1)

validator_does_not_detect.osm (876 bytes) - added by simon04 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by simon04

comment:1 Changed 7 years ago by skyper

See also #8194

comment:2 Changed 6 years ago by skyper

Keywords: self_crossing check added
Summary: Validator does not detect crossing waysegments of landuseValidator does not detect crossing waysegments (of landuse, natural, barrier)

This is also at least true for natural and barrier.

Think this check should be run on all closed way and multipolygons/boundaries

comment:3 Changed 6 years ago by skyper

Ticket #8476 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 6581/josm:

fix #8220 fix #9490 - Validator, crossing ways; detect crossing barrier, landuse, natural, boundary

comment:5 Changed 6 years ago by Don-vip

Milestone: 14.01

comment:6 Changed 6 years ago by Don-vip

Ticket #8194 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.