Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9490 closed enhancement (duplicate)

report crossing boundaries with the same tags

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: Cc:

Description (last modified by mkoniecz)

Currently crossing boundaries are not reported (probably because it is possible to mark unrelated boundaries).

I would suggest to report crossing ways with boundary field if both belong to the same relation (especially self-crossing ways).

I tested it by fetching osm map containing boundary and editing it to make it self crossing, than running validator.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-12-28 02:34:32
Last Changed Author: simon04
Revision: 6554
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-12-28 01:31:47 +0100 (Sat, 28 Dec 2013)
Last Changed Rev: 6554

Identification: JOSM/1.5 (6554 en_GB) Windows 7 32-Bit
Memory Usage: 70 MB / 247 MB (15 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30117)
Plugin: buildings_tools (30057)
Plugin: notes (v0.8)

Attachments (0)

Change History (4)

comment:1 by mkoniecz, 10 years ago

Description: modified (diff)

comment:2 by simon04, 10 years ago

Resolution: fixed
Status: newclosed

In 6581/josm:

fix #8220 fix #9490 - Validator, crossing ways; detect crossing barrier, landuse, natural, boundary

comment:3 by Don-vip, 10 years ago

Milestone: 14.01

comment:4 by Don-vip, 10 years ago

Milestone: 14.01
Resolution: fixedduplicate

Duplicate of #8220.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.