Modify

Opened 8 years ago

Closed 6 years ago

#8194 closed defect (duplicate)

JOSM fails to recognize error

Reported by: eyeofthestorm@… Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: self_crossing check Cc:

Description

I just wanted to point out that JOSM failed to recognize error during validation of boundary relation. It allowed me to pass through validation, even though afterwards, after searching why boundary doesn't appear in nominatim and in OSMInspector, Me and colleague found the error in boundary relation (Y shape on one way which is part of relation - http://i49.tinypic.com/zksd8z.jpg). Hopefully it will not happen to anybody else in the future.

Regards, Alen

Attachments (3)

error.jpg (83.2 KB) - added by anonymous 8 years ago.
error description image
error_raised.osm (693 bytes) - added by anonymous 8 years ago.
Crossing way error raised
error_not_raised.osm (697 bytes) - added by anonymous 8 years ago.
No crossing way error raised (same geometry, but different tagging)

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by anonymous

Attachment: error.jpg added

error description image

comment:1 Changed 8 years ago by anonymous

Confirmed the self-intersecting test does not work on untagged ways or tagged as boundary=*, but does work when tagged as highway=*

comment:2 Changed 8 years ago by Don-vip

Owner: changed from team to eyeofthestorm@…
Status: newneedinfo

The self-intersecting test does not take into account way tags.

Could you please supply a .osm file with this error ? I have run some tests with Y-shaped ways and the warning is correctly raised.

Changed 8 years ago by anonymous

Attachment: error_raised.osm added

Crossing way error raised

Changed 8 years ago by anonymous

Attachment: error_not_raised.osm added

No crossing way error raised (same geometry, but different tagging)

comment:3 Changed 8 years ago by skyper

Component: unspecifiedCore validator
Keywords: self-intersecting added
Owner: changed from eyeofthestorm@… to team
Status: needinfonew

comment:4 Changed 7 years ago by skyper

The check is only run on some major tags like highway, railway, waterway. I did try barrier=wall which does nor raise a warning neither.

Think this check should be run on all ways.

comment:5 Changed 7 years ago by skyper

Keywords: self_crossing check added; self-intersecting removed

comment:6 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8220.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.