Modify

Opened 7 years ago

Closed 7 years ago

#8195 closed defect (duplicate)

ways without nodes (Undelete Plugin)

Reported by: Nakaner Owned by: team
Priority: normal Milestone:
Component: Plugin undelete Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download Dessau-Ziebigk, Germany.
  2. Create a second layer and activate the second layer.
  3. Run the Undelete-Plugin File -> Undelete Object for all objects that were deleted in changeset 13877017
  4. First do this with all nodes, afterwards with all ways that were deleted.
  5. Try to upload. The bug message will occure.

What is the expected result?

The deleted ways and nodes should have been restored. I wanted to upload them.

What happens instead?

The bug message came. JOSM did not crash.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-10 02:31:13
Last Changed Author: bastiK
Revision: 5576
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-09 21:16:38 +0100 (Fri, 09 Nov 2012)
Last Changed Rev: 5576

Identification: JOSM/1.5 (5576 de)
Memory Usage: 379 MB / 1745 MB (98 MB allocated, but free)
Java version: 1.7.0_09, Oracle Corporation, OpenJDK 64-Bit Server VM
Operating system: Linux

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=26008220 version=5 MVT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=119329873 version=2 MVT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=119329933 version=2 MVT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=119329883 version=2 MVT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=119329916 version=2 MVT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=119329879 version=2 MVT nodes=[]} has zero nodes


Plugin: FixAddresses (28807)
Plugin: PicLayer (28807)
Plugin: buildings_tools (28891)
Plugin: download_along (28807)
Plugin: mapdust (28807)
Plugin: measurement (28898)
Plugin: openstreetbugs (28807)
Plugin: pdfimport (28807)
Plugin: print (28807)
Plugin: reverter (28820)
Plugin: undelete (28807)
Plugin: utilsplugin2 (28807)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.validation.tests.WayConnectedToArea.visit(WayConnectedToArea.java:29)
	at org.openstreetmap.josm.data.osm.Way.visit(Way.java:198)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:144)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:61)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:187)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:210)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:258)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:723)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:682)
	at java.awt.EventQueue$3.run(EventQueue.java:680)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:696)
	at java.awt.EventQueue$4.run(EventQueue.java:694)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:693)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)

Attachments (1)

undelete-bug.zip (2.6 KB) - added by Nakaner 7 years ago.
This zip file contains both layers.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Nakaner

Attachment: undelete-bug.zip added

This zip file contains both layers.

comment:1 Changed 7 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7986.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.