Modify

Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#5586 closed enhancement (fixed)

Support *.kmz-files

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin opendata Version:
Keywords: kmz kml Cc: baditaflorin

Description (last modified by skyper)

kmz-files are quiet simple ZIP-files containing JPGs and Coordinates in an XML-File.
Google Earth and Garming Outdoor-Devices support it. I made several files myself, including some relief-topo maps...

Attachments (0)

Change History (11)

comment:1 Changed 10 years ago by skyper

Ticket #7244 has been marked as a duplicate of this ticket.

comment:2 Changed 10 years ago by skyper

Cc: baditaflorin added
Description: modified (diff)
Keywords: kmz kml added

there is an example file: #7244

comment:3 Changed 10 years ago by Don-vip

I'm working on a plugin that deals with KML/KMZ/CSV (and maybe more) file formats quite well. But I don't plan to release such a dangerous tool in hands of everyone before the implementation of #4922... (it would be an open door to both accidental and intentional mass imports of open data not reviewed/checked)

comment:4 Changed 10 years ago by anonymous

#4922 got fixed, any possibility to release your plugin, or to send me a copy per mail?

comment:5 in reply to:  4 Changed 10 years ago by Don-vip

Replying to anonymous:

#4922 got fixed, any possibility to release your plugin, or to send me a copy per mail?

I plan to release a first version quite soon (sometime this month). I can send you a copy for beta testing, but I need your e-mail address for that :)

comment:6 Changed 10 years ago by Don-vip

Resolution: fixed
Status: newclosed

The plugin is live. It is called opendata, you can use it with JOSM 5124 and later.

comment:7 Changed 8 years ago by SK53

Resolution: fixed
Status: closedreopened

KMZ files containing directories and other files are not opened but generate an XML parse error.

I have numerous KMZ files generated using Geosetter containing thumbnails of geolocated images for photo mapping. Being able to read these natively would be very useful, both because I generate them in normal workflow, and because the thumbnail images are much less memory hungry than the originals. Unzipping the KMZ and reading the KML works, but links to files/images are not read in.

comment:8 Changed 8 years ago by Don-vip

Component: CorePlugin opendata

Can you please attach your kmz file ? (with a proper login or anonymous one...)

comment:9 Changed 8 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Reopen and attach the requested file if you really want this feature.

comment:10 Changed 8 years ago by SK53

Why bother making me go to the trouble of getting a login to file a bug report if you more or less immediately close it.

I want JOSM to behave gracefully if a KMZ file is in a format it cannot load, or even better load it!

Not everyone can drop all the other things they have to do to upload stuff to trac at YOUR CONVENIENCE

comment:11 Changed 8 years ago by Don-vip

Tickets aren't meant to stay open forever. When we lack the required information to fix them, they are closed. And from experience, no answer in 3 days generally mean no answer to expect. But if your prefer to whine about Trac in your childish login name or tickets closure in your comments, rather than attach a sample file requested to implement YOUR feature request, well...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.