Modify

Opened 11 years ago

Closed 10 years ago

#5585 closed defect (fixed)

Impossible to reinstall missing plugins

Reported by: heiccq Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

After partial deinstallation of some JOSM plugins during ubuntu upgrade, it's not possible to open the plugins tab anymore.

What steps will reproduce the problem?

  1. upgrade ubuntu 10.10 from beta to rc1 (plugins were automatically removed)
  2. run josm --> error message (missing plugins wmsplugin, validator)
  3. open 'Einstellungen' and klick on the plugin tab --> crash

What is the expected result?
open plugin screen

What happens instead?
error message with the attached stack trace

Please provide any additional information below. Attach a screenshot if
possible.

Debian-Release: 0.0.svn3514-2
Build-Date: 2010-10-07 18:10:01
Revision: 3514
Is-Local-Build: true

Identification: JOSM/1.5 (3514 de)
Memory Usage: 102 MB / 881 MB (63 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

Plugin: validator
Plugin: wmsplugin

java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.PluginInformation.scanManifest(PluginInformation.java:215)
	at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:117)
	at org.openstreetmap.josm.plugins.PluginListParser.createInfo(PluginListParser.java:36)
	at org.openstreetmap.josm.plugins.PluginListParser.parse(PluginListParser.java:87)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.processLocalPluginInformationFile(ReadLocalPluginInformationTask.java:171)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanSiteCacheFiles(ReadLocalPluginInformationTask.java:90)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanLocalPluginRepository(ReadLocalPluginInformationTask.java:158)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.realRun(ReadLocalPluginInformationTask.java:217)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)

Attachments (1)

Screenshot.png (261.1 KB) - added by heiccq 11 years ago.
screenshot

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by heiccq

Attachment: Screenshot.png added

screenshot

comment:1 Changed 11 years ago by bastiK

This is probably caused by an old corrupted cache file. There are 2 ways to get it working again:

(1)

  • repeat the steps you describe. When the crash comes, click cancel.
  • click 'Liste herunterladen'
  • it should work now

(2)

  • delete the cache file in josm preference directory (plugins/site-josm.openstreetmap.de-_plugin.txt)

comment:2 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.