Modify

Opened 10 years ago

Closed 10 years ago

#4593 closed defect (fixed)

conflict list and header not updated right away after undo/redo

Reported by: skyper Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: conflict list header Cc: skyper

Description

The conflict list is not updated right away. After solving a conflict you need to do one more action (select for example) to have the conflict list updated.

The total number in the header does not change at all.

Attachments (1)

test-0000.mpeg (1.9 MB) - added by avarab@… 10 years ago.
Video showing conflict resolution dialog failing to update

Download all attachments as: .zip

Change History (26)

comment:1 Changed 10 years ago by bastiK

What josm version?

I addressed this issue recently; try latest.

comment:2 Changed 10 years ago by bastiK

Keywords: r-2010-01-blocker removed

comment:3 Changed 10 years ago by mjulius

Ticket #4601 has been marked as a duplicate of this ticket.

comment:4 in reply to:  1 Changed 10 years ago by skyper

Replying to bastiK:

What josm version?

version 3029 and 3033

I addressed this issue recently; try latest.

what changeset ?
I will try.

comment:5 Changed 10 years ago by bastiK

in [3016].

If there is still a missing update of the entire dialog, please describe how to reproduce.

(The header issue is not fixed jet.)

comment:6 Changed 10 years ago by skyper

Keywords: header added
Summary: conflict list not updated right awayconflict list header(was: conflict list not updated right away)

Works all for me with sun, have to check openjdk

comment:7 Changed 10 years ago by skyper

version 3040

comment:8 Changed 10 years ago by anonymous

Resolution: fixed
Status: newclosed

@skyper: Please add the josm version for every bug report! It makes live so much easier for us.

comment:9 Changed 10 years ago by bastiK

anonymous is me

comment:10 in reply to:  8 Changed 10 years ago by skyper

Replying to anonymous:

@skyper: Please add the josm version for every bug report! It makes live so much easier for us.

I did this time. - Maybe we should not provide latest in the bug report but the version !!!.

So far I first look at the main page to get to know if there is a new release and then write my bug-report. On the web-interface the report-time is a link that you can see what has been done that day and what version latest really was.

Anyway I was wrong:
Sorry, it did work with conflicts resulting of a merge (downloaded the same area again on same layer). Header list does not update if the conflicts arise after "update data".

still version 3040, sun-java 6 on ubuntu karmic (9.10)

comment:11 Changed 10 years ago by skyper

Resolution: fixed
Status: closedreopened

comment:12 Changed 10 years ago by skyper

Summary: conflict list header(was: conflict list not updated right away)conflict list not updated right away and conflict list header not updated at all

Sorry, the list is not update right away, as I mentioned above the list-update takes one more action in between.

I forgot to mention that I have updated the plugins in between, but I do not know if there were any differences because of #4565.

comment:13 Changed 10 years ago by skyper

Priority: normalmajor

comment:14 Changed 10 years ago by bastiK

Works for me: Update data -> conflicts. Resolve one conflict -> header and content changes.

Please give a step by step description (and maybe an *.osm file to load).

comment:15 Changed 10 years ago by avarab@…

This is still broken on r3056. Here's how I (approx) ran into it:

  1. Edit a day-old country dump
  2. Merge 10 consecutive ways into 1
  3. Change its highway=* tag

Meanwhile on the server someone had done this before me:

  1. Edit a day-old country dump
  2. Don't merge these ways
  3. Change their highway=* tag and add FIXME=*

Any conflict resolution that I do makes the dialog not update when it's changed. I'm attaching a video showing this.

Changed 10 years ago by avarab@…

Attachment: test-0000.mpeg added

Video showing conflict resolution dialog failing to update

comment:16 Changed 10 years ago by avarab@…

Also please add the r-2010-01-blocker keyword back, this is definitely a regression from the previous release and makes any conflict resolution very hard. I don't think a release should go out with this bug.

comment:17 Changed 10 years ago by Ldp

I concur with the header not updating. I just had 2 conflicts, and the header still showed 'Conflicts: 2 unresolved' after resolving those. Then I had another single conflict, and while that showed in the list, the header still showed the 2.

As for the contents: when I get a single conflict, it pops up right away in the list, but if I have 2 or more conflicts, they don't appear in the conflicts list. I have to close and reopen (Alt+C) to see them.

JOSM 3044 + Sun JDK (WinXP)

comment:18 Changed 10 years ago by bastiK

(In [3058]) see #4593 - conflict list not updated right away

comment:19 Changed 10 years ago by bastiK

This might help. (But I still cannot reproduce.) Additionally, it should now print something to the command line each time you resolve a conflict. (If not, something is wrong.)

Anyway, can you attach a osm file where you always get this behaviour? This would help a lot.

comment:20 in reply to:  19 ; Changed 10 years ago by anonymous

Replying to bastiK:

This might help. (But I still cannot reproduce.) Additionally, it should now print something to the command line each time you resolve a conflict. (If not, something is wrong.)

Anyway, can you attach a osm file where you always get this behaviour? This would help a lot.

I can't figure out how to not reproduce this. Anyway here's how (on a version before your fix, I didn't test that out):

  1. Download http://osm.nix.is/archive/2010-02-01/Iceland.osm.bz2
  2. Search for id:48322685
  3. Zoom out and select that entire area
  4. Search for parent(selected type:node) "ofp:highway"=*
  5. This'll give you a bunch of ways with ofp:highway=*
  6. Set tags like foo=bar test=yest blah=blah on the objects
  7. Upload, get conflicts
  8. Sync way X only
  9. Conflict dialog doesn't update
  10. Prod it, now it does
  11. Change some more data, try this again
  12. Conflict count doesn't update until you minimize / maximize the conflict panel

comment:21 in reply to:  20 Changed 10 years ago by avarab@…

Resolution: fixed
Status: reopenedclosed

Replying to anonymous:

I can't figure out how to not reproduce this. Anyway here's how (on a version before your fix, I didn't test that out):

It looks like [3058] fixed this, that test works on HEAD.

comment:22 Changed 10 years ago by skyper

Resolution: fixed
Status: closedreopened
Summary: conflict list not updated right away and conflict list header not updated at allconflict list and header not updated right away after undo/redo

It is not quite done yet.

I solve a conflict and press undo -> conflict list is empty, minimize and maximize gets it back.
I press redo -> the list does not change at all. Again mini- and maximize will do it.

r3057 with openjdk

comment:23 in reply to:  22 Changed 10 years ago by skyper

Replying to skyper:

r3057 with openjdk

sorry r3067

comment:24 Changed 10 years ago by skyper

with r3074 and sun it works

comment:25 Changed 10 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

(In [3078]) fixed #4593 - conflict list and header not updated right away after undo/redo

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.