Modify

Opened 11 years ago

Closed 4 years ago

#4594 closed defect (fixed)

confirmation dialogs block (was: broken <html> text)

Reported by: skyper Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: dialog on top Cc: skyper

Description (last modified by Don-vip)

Confirmation dialog is spreading across the screen and way further.

I attach a screenshot.

Attachments (2)

screenshot.png (427.4 KB) - added by skyper 11 years ago.
josm_bug_4594.osm.bz2 (32.2 KB) - added by skyper 11 years ago.
osm

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by skyper

Attachment: screenshot.png added

comment:1 Changed 11 years ago by bastiK

Cannot reproduce (tried Sun and Openjdk java)

What JOSM version?

Try with latest, my dialog says "Löschbestätigung" and not "Bestätigung", so something has changed in the meantime.

comment:2 in reply to:  1 Changed 11 years ago by skyper

Replying to bastiK:

Cannot reproduce (tried Sun and Openjdk java)

What JOSM version?

was 3033, with sun

Try with latest, my dialog says "Löschbestätigung" and not "Bestätigung", so something has changed in the meantime.

probably [3035]

comment:3 Changed 11 years ago by bastiK

I don't know how you got the string "Bestätigung" and not "Löschbestätigung" in the dialog header, interesting...

Cannot reproduce with 3033 either. There are a lot of other texts that use html (like <br>) for formatting the text. For example the message of the day.

Do these work, or is all html broken?

comment:4 in reply to:  3 Changed 11 years ago by skyper

Replying to bastiK:

I don't know how you got the string "Bestätigung" and not "Löschbestätigung" in the dialog header, interesting...

I appeared auto-repairing "doubled nodes". Right before that I had to change my config on that session, because I had flaged it to keep "do not delete". I removed both, the flag and my previous decision.

Cannot reproduce with 3033 either. There are a lot of other texts that use html (like <br>) for formatting the text. For example the message of the day.

Do these work, or is all html broken?

Sorry, I can not check right know, but I did not see it elsewhere.

comment:5 Changed 11 years ago by skyper

Keywords: repair added
Priority: normalmajor

I checked with version 3040.

The bug still exist !!!
In fact, it is even worse with 3040.
It only appears when repairing as mention above.
With version 3040 you can not even focus the dialog because there is progress-window on top of it.

Last edited 9 years ago by skyper (previous) (diff)

Changed 11 years ago by skyper

Attachment: josm_bug_4594.osm.bz2 added

osm

comment:6 Changed 11 years ago by bastiK

Component: CoreCore validator
Summary: confirmation dialog going out-of boundconfirmation dialogs block (was: broken <html> text)

(In [o20142]) - fixed the long text.

I'm afraid, the blocking of 2 dialogs is anther issue, so I leave the ticket open.

From my experience it happens randomly - sometimes it works and sometimes they block.

comment:7 in reply to:  6 Changed 11 years ago by skyper

Component: Core validatorCore
Keywords: on top added; repair removed

Replying to bastiK:

(In [o20142]) - fixed the long text.

Thanks.


From my experience it happens randomly - sometimes it works and sometimes they block.

My experience is that they always block. Especially offline I get error messages/exceptions because of presets not downloaded or "cannot find .." which are under the progress window. "Abbruch" does not work. The only way to reach the message is to close the progress window.
I think the messages/exceptions window should always be on top !

comment:8 Changed 4 years ago by Don-vip

Description: modified (diff)
Resolution: fixed
Status: newclosed

I assume this has been fixed in the past 7 years.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.