Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3978 closed defect (fixed)

Ways tagged with cycleway=* should not override the highway-style

Reported by: mok0 Owned by: ulfl
Priority: major Milestone:
Component: Internal mappaint style Version: latest
Keywords: cycleways, display Cc:

Description

It gives a lot of extra work when working with cycleways, that ways tagged with cycleway=* are not immediately visible in a distinctive way JOSM's display. Consequently, mappers tend to use parallel ways tagged "highway=cycleway", even in places where this is not warranted.

Attachments (1)

cycleway-examples.osm (501.7 KB) - added by bastiK 11 years ago.
examples for the modified style : see upper left

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by ramilehti

cycleway=lane must not override the more important highway=residential. It makes looking for residential roads among pure cycleways and residential roads with cycleway lanes a BIG headache.

Maybe some sort of striping or something of that nature is called for.

comment:2 Changed 11 years ago by anonymous

Component: CoreInternal mappaint style
Owner: changed from team to ulfl
Priority: normalmajor
Summary: Ways tagged with cycleway=* should be visible somehowWays tagged with cycleway=* should not override the highway-style
Type: enhancementdefect

comment:3 Changed 11 years ago by anonymous

Ticket #4069 has been marked as a duplicate of this ticket.

comment:4 Changed 11 years ago by anonymous

Ticket #4078 has been marked as a duplicate of this ticket.

comment:5 in reply to:  4 Changed 11 years ago by skyper

Replying to anonymous:

Ticket #4078 has been marked as a duplicate of this ticket.

Style also superseeds highway=crossing and highway=traffic_signals when tag with foot=designated or bicycle=designated
-> same bug ?

comment:6 Changed 11 years ago by bastiK

It is a different issue. Please open a new ticket and describe in detail what priority order you would expect on what elements. (You can also try to modify elemstyles.xml directly, if you feel like it...)

comment:7 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [2562]) fix #3978 - Ways tagged with cycleway=* should not override the highway-style

Changed 11 years ago by bastiK

Attachment: cycleway-examples.osm added

examples for the modified style : see upper left

comment:8 Changed 11 years ago by bastiK

Changed the bicycle color a little from pink to purple, to better fit the secondary and tertiary highways.

I also tried to paint "highway=path & bicycle=designated" like a cycleway, but it seems to be impossible in the current setup.

comment:9 Changed 11 years ago by stoecker

bastiK: It is possible to do "combined" checks. You need to add multiple conditions (they are always handled as AND).

comment:10 Changed 11 years ago by bastiK

(In [2829]) draw the combinations highway=path, bicycle=designated & foot=designated correctly (see #3978)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ulfl.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.