Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3977 closed defect (duplicate)

Freeze when splitting outer way of a multipolygon

Reported by: Nop Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When splitting the outer way of a large multipolygon, JOSM crashes with a repeating exception during redraw that makes it freeze and causes total loss of data.

Reproducible: Always

Large multipolygon (1 outer way with 1000 nodes, 57 inner ways) is split into multiple parts at 4 nodes, multipoly now has 4 outer.
One of these ways is deleted. Confirm dialog to delete 1 way from a relation pops up. If you confirm, JOSM crashes.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-11-16 02:31:48
Last Changed Author: stoecker
Revision: 2462
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-11-15 18:24:28 +0100 (Sun, 15 Nov 2009)
Last Changed Rev: 2462

Memory Usage: 99 MB / 1066 MB (35 MB allocated, but free)
Java version: 1.6.0_16

Plugins: multipolyremotecontroltageditorutilspluginwmsplugin
Plugin multipoly Version: 18415
Plugin remotecontrol Version: 18503
Plugin tageditor Version: 18522
Plugin utilsplugin Version: 18621
Plugin wmsplugin Version: 18625

java.lang.NullPointerException

at org.openstreetmap.josm.gui.DefaultNameFormatter.format(DefaultNameFormatter.java:140)
at org.openstreetmap.josm.data.osm.Way.getDisplayName(Way.java:352)
at org.openstreetmap.josm.data.osm.visitor.MapPaintVisitor.joinWays(MapPaintVisitor.java:477)
at org.openstreetmap.josm.data.osm.visitor.MapPaintVisitor.drawMultipolygon(MapPaintVisitor.java:1003)
at org.openstreetmap.josm.data.osm.visitor.MapPaintVisitor.paintUnselectedRelation(MapPaintVisitor.java:527)
at org.openstreetmap.josm.data.osm.visitor.MapPaintVisitor.visitAll(MapPaintVisitor.java:1482)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:247)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:391)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JSplitPane.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JLayeredPane.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paintToOffscreen(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
at javax.swing.BufferStrategyPaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
at java.awt.Container.paint(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 12 years ago by anonymous

Closed as duplicate of #3955.

comment:3 Changed 12 years ago by jttt

Fixed in r2464

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.