Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3955 closed defect (fixed)

NPE when dealing with multipolygons

Reported by: hoertp@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

This happens when I try to create a new multipolygon and sometimes while working with existing ones.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-11-16 02:31:48
Last Changed Author: stoecker
Revision: 2462
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-11-15 18:24:28 +0100 (Sun, 15 Nov 2009)
Last Changed Rev: 2462

Memory Usage: 224 MB / 910 MB (101 MB allocated, but free)
Java version: 1.6.0_16

Plugins: utilsplugin
Plugin utilsplugin Version: 18621

java.lang.NullPointerException

at org.openstreetmap.josm.gui.DefaultNameFormatter.format(DefaultNameFormatter.java:191)
at org.openstreetmap.josm.data.osm.Relation.getDisplayName(Relation.java:310)
at org.openstreetmap.josm.gui.dialogs.relation.RelationTreeCellRenderer.renderValue(RelationTreeCellRenderer.java:48)
at org.openstreetmap.josm.gui.dialogs.relation.RelationTreeCellRenderer.getTreeCellRendererComponent(RelationTreeCellRenderer.java:67)
at javax.swing.plaf.basic.BasicTreeUI$NodeDimensionsHandler.getNodeDimensions(BasicTreeUI.java:2717)
at javax.swing.tree.AbstractLayoutCache.getNodeDimensions(AbstractLayoutCache.java:475)
at javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.updatePreferredSize(VariableHeightLayoutCache.java:1342)
at javax.swing.tree.VariableHeightLayoutCache.rebuild(VariableHeightLayoutCache.java:720)
at javax.swing.tree.VariableHeightLayoutCache.treeStructureChanged(VariableHeightLayoutCache.java:626)
at javax.swing.plaf.basic.BasicTreeUI$Handler.treeStructureChanged(BasicTreeUI.java:3829)
at org.openstreetmap.josm.gui.dialogs.relation.RelationTreeModel.fireRootReplacedEvent(RelationTreeModel.java:164)
at org.openstreetmap.josm.gui.dialogs.relation.RelationTreeModel.populate(RelationTreeModel.java:141)
at org.openstreetmap.josm.gui.dialogs.relation.ChildRelationBrowser.populate(ChildRelationBrowser.java:145)
at org.openstreetmap.josm.gui.dialogs.relation.ChildRelationBrowser.<init>(ChildRelationBrowser.java:136)
at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.<init>(GenericRelationEditor.java:164)
at org.openstreetmap.josm.gui.dialogs.relation.RelationEditor.getEditor(RelationEditor.java:84)
at org.openstreetmap.josm.gui.dialogs.RelationListDialog$NewAction.run(RelationListDialog.java:434)
at org.openstreetmap.josm.gui.dialogs.RelationListDialog$NewAction.actionPerformed(RelationListDialog.java:438)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6263)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:6028)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4630)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by stoecker

Resolution: fixed
Status: newclosed

(In [2463]) fix #3955 - NPE

comment:2 Changed 12 years ago by anonymous

Ticket #3977 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.