Modify

Opened 10 years ago

Closed 10 years ago

#4069 closed defect (fixed)

node: rendering: highway=*, railway=*, barrier=* with tag bicycle=designated or foot=designated

Reported by: skyper Owned by: ulfl
Priority: minor Milestone:
Component: Internal mappaint style Version: latest
Keywords: Cc:

Description

at least highway=residential and highway=secondary with tag cycleway=*
is rendered as cycleway
used to be more highways

version 2555

Attachments (1)

render.osm (512.7 KB) - added by skyper 10 years ago.
osm

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by skyper

rendering is also wrong for traffic_signals and crossing with tag bicycle=*

comment:2 Changed 10 years ago by skyper

Summary: rendering: highway=* with tag cycleway=*rendering: highway=* with tag cycleway=* or bicycle=*

comment:3 in reply to:  2 Changed 10 years ago by skyper

Replying to skyper:
tag foot=* on a node aswell

comment:4 Changed 10 years ago by stoecker

Component: CoreInternal mappaint style
Owner: changed from team to ulfl

comment:5 Changed 10 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:6 Changed 10 years ago by anonymous

Closed as duplicate of #3978.

comment:7 Changed 10 years ago by skyper

Resolution: duplicate
Status: closedreopened
Summary: rendering: highway=* with tag cycleway=* or bicycle=*rendering: highway=* with tag bicycle=* or foot=*

highway=crossing and highway=traffic_signal are superseeded by foot,bicycle=designated. Used to be different.

I think this should be rendered as traffic_signals and crossing and NOT as a round, blue traffic_sign.

comment:8 Changed 10 years ago by skyper

Summary: rendering: highway=* with tag bicycle=* or foot=*node: rendering: highway=*, railway=*, barrier=* with tag bicycle=designated or foot=designated

Yes I might change it myself but I still think it is confusing if the default setting is rendering this nodes in favour of routing and not in favour of objects. (blue round sign <-> traffic_signals)

comment:9 Changed 10 years ago by ulfl

Resolution: wontfix
Status: reopenedclosed

I'm not going to guess what you've meant with your confusing telegram style sentences.

comment:10 Changed 10 years ago by skyper

Resolution: wontfix
Status: closedreopened

Sorry was some days offline

Have attached an osm-file

Just look at the croosings with traffic-lights

chears skyper

Changed 10 years ago by skyper

Attachment: render.osm added

osm

comment:11 Changed 10 years ago by skyper

I think rendering should be:

  1. highway=* and railway=*
  2. bicycle=designated or foot=designated

comment:12 Changed 10 years ago by ulfl

Resolution: fixed
Status: reopenedclosed

(In [2816]) fix #4069: reduce prio of access node rules (e.g. footway=designated), to show more interesting stuff (e.g. highway=traffic_signals)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ulfl.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.