Modify

Opened 13 years ago

Closed 11 years ago

Last modified 9 years ago

#2662 closed enhancement (fixed)

Auto-save

Reported by: anonymous Owned by: jttt
Priority: minor Milestone:
Component: Core Version: latest
Keywords: autosave, auto-save, exception Cc: luttermann@…, Michi, richlv, skyper

Description

Seems that this app is really good at catching exepctions, it would be practical to have it auto-save to a temporary file if it does so. So that no data would be lost.

Attachments (0)

Change History (13)

comment:1 Changed 12 years ago by Roy Wallace

Summary: Auto-safeAuto-save

I like this idea. I find myself uploading more often than I would like, so as to avoid data loss if JOSM crashes. An auto-save function would avoid this. Also, what is the meaning of "Save" in JOSM? The wiki just says "Save the currently active layer", when what I really want to do is save my changes - is this actually the same thing?

comment:2 Changed 12 years ago by Michi

Cc: Michi added

comment:3 Changed 12 years ago by Gubaer

Ticket #3894 has been marked as a duplicate of this ticket.

comment:5 Changed 12 years ago by jttt

Now when OsmPrimitive has reference to the Dataset are two ways of implementing such functionality possible - one is saving complete dataset every few minutes, another option is logging all changes done on primitives. That would allow to replay all changes after crash

comment:6 in reply to:  5 Changed 12 years ago by Gubaer

Replying to jttt:

  • one is saving complete dataset every few minutes,

... in which case we would probably need some mechanism for "locking" a dataset. Timed auto-saving will probably run on its own thread and with respect to the dataset it should have transactional properties. During autosave it should not be possible to modify the dataset itself (adding/removing a primitive), nor one of its primitives (move a primitive, add a primitive, etc.).

comment:7 Changed 12 years ago by PHerison

Keywords: autosave auto-save added; autosafe auto-safe removed

I support this enhancement request. I just lost 1 houre of data after JOSM crashed. Why can't the datalayer(s) be saved every x seconds into a file. This will minimize the lost of new data in case of a crash.

comment:8 Changed 12 years ago by richlv

Cc: richlv added

comment:9 Changed 11 years ago by stoecker

Ticket #4831 has been marked as a duplicate of this ticket.

comment:10 Changed 11 years ago by skyper

Cc: skyper added

comment:11 Changed 11 years ago by anonymous

Owner: changed from team to jttt

comment:12 Changed 11 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3378]) Fix #2662 Auto-save

comment:13 Changed 11 years ago by jttt

Basic implementation of autosave, no gui - only configurable using Einstein preferences. By default on, should save all osm layers every 5 minutes. When josm is restarted after crash, unsaved layers should be restored.

Property autosave.filesPerLayer - number of files kept for one layer. By default 1 can be set to higher number to get snapshots of layer every autosave interval.

comment:14 Changed 9 years ago by Don-vip

Ticket #4495 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.