Modify

Opened 12 years ago

Closed 9 years ago

#4495 closed enhancement (duplicate)

Log editing in JOSM to a temporarily file, and restore

Reported by: cetest Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: crash failsafe backup restart Cc:

Description (last modified by Don-vip)

JOSM stable and dev versions tend to crash now and then. It seems we have to live with that.
However, loosing recent edits is a real PITA.
Frequent uploading helps but needs discipline.

A small edit loggin file, that gets erased on upload, and that may be run automatically
if the user asks so on restart might resolve a lot of frustration.
On startup after a crash JOSM basically needs to reload the current viewport (OSM data) and carry out all logged actions to create a Eureka feeling.

Alternately a automatic save in OSM format every minute would do the same, but needs a lot
of resources on large edits.

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by Gubaer

Type: defectenhancement

comment:2 Changed 9 years ago by Don-vip

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Closed as duplicate of #2662.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.