Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3894 closed defect (duplicate)

Systemcrash - 'Out of memory'

Reported by: AnubisEmail@… Owned by: team
Priority: critical Milestone:
Component: Core Version: tested
Keywords: Crash, 'Out of memory' Cc:

Description

Hi all,

I am really enraged. Now it's the second time I waste hours of time by editing for OSM using JOSM. Based on the fact that JOSM is running out of memory I lost all my data. I didn't even get the chance to save my work. Because running out of memory means in this case, you can't do anything beside shutting down JOSM (by using the task-manager), which led to the effect that you'll lose everything you edited.

In the last case I remember that I did around 820 commands and in the error prompt was something written like "Sorry, strange things may happen.... running out of memory (63MB or 64MB).... please Restart JOSM .... you can set manually more memory by...."

In my opinion there hast to be something like a 'Autosave function' or superiorly JOSM has to have a buffer/reserve of memory that in every case the user has the chance to save or to upload his editing.
For example by reaching 60MB used memory a message appears:
"JOSM is running out of memory... Please save/upload your work"
Maybe the user will also be asked, if JOSM should use 256MB of memory when JOSM starts the next time.

Hopefully I could describe the problem I had and maybe you take this comment as a chance to further improve JOSM.

Kind regards,

Anubis

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by Gubaer

Resolution: duplicate
Status: newclosed

comment:2 Changed 12 years ago by Gubaer

Closed as duplicate of #2662.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.