Modify

Opened 3 months ago

Last modified 2 months ago

#22330 reopened enhancement

StartupPage: Add link to help updating from java 8 (WAS: Wrong requested java version "11" at OSM start page)

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Wiki content Version:
Keywords: template_report StartupPage java version Cc: stoecker, smarties

Description

What steps will reproduce the problem?

  1. start OSM
  2. read first line above the version news.

What is the expected result?

nothing

What happens instead?

There is an announcement, im the first line that my java version soon will not be supported anymore. I should update to version 11 or better...
But my java version 8.341 seems to be the newest version available according to java update function...
So I should ot get any message about too old java version.

Please provide any additional information below. Attach a screenshot if possible.

screen added

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-08-29 16:59:00 +0200 (Mon, 29 Aug 2022)
Build-Date:2022-08-30 01:30:57
Revision:18543
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18543 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19043)
Memory Usage: 139 MB / 247 MB (60 MB allocated, but free)
Java version: 1.8.0_341-b10, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00) \Display1 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: de_DE
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ turnrestrictions (36011)

Attachments (1)

error.JPG (120.2 KB) - added by andy_king50@… 3 months ago.
Screenshot

Download all attachments as: .zip

Change History (14)

Changed 3 months ago by andy_king50@…

Attachment: error.JPG added

Screenshot

comment:1 Changed 3 months ago by skyper

Oracle does not provide a higher java version but other do. You might want to take a look at our windows installer which includes a higher java version, see Download.

Please, always use a 64-bit java version on a 64-bit operating system. This by the way will allocate more memory for JOSM without manual changes. So you might want to uninstall java 8 completely prior to installing the windows installer.

comment:2 Changed 3 months ago by skyper

Component: CoreWiki content
Resolution: invalid
Status: newclosed

comment:3 Changed 3 months ago by anonymous

Now I did look up the favoured "Azul" platform, downloaded and unzipped 64Bit version but did not manage to install. There is a *.msi installer mentioned in their help text but not available in the download. I am no IT professional but not so dumb im this field too... so many other users might have the same problem.

  • using Oracles versions and update program will be in wide spread use (many people will Java still connect with Oracle in their mind, so using this, or just because they only updated again and again)
  • not beeing able to install the prefered other Java versions without precise instruction and/or automatic installer will affect others too. in tehe comment on JOSM Start page there is not even a comment on those preferred versions.

It is simply no topic I want to invest much time into updates where I get no clear instructions. Would rather invest it in mapping...
If you change to Java versions no longer supported by the Oracle java versions, there should be Installation instructions suitable for people who just want to have JOSM work. Of the sofware provider Azul does not, it might be yor task to give this information. Please consider teh knowledge leveel of end users....

comment:4 Changed 3 months ago by anonymous

btw, i always use the windows installer. But if you have the recent JOSM Version installed, the installer starts and then finishes without any message (would expect at least some message "you have the latest version installed), so I have no access to the usual download page and possible links there)

comment:5 in reply to:  4 Changed 3 months ago by skyper

Replying to anonymous:

btw, i always use the windows installer. But if you have the recent JOSM Version installed, the installer starts and then finishes without any message (would expect at least some message "you have the latest version installed), so I have no access to the usual download page and possible links there)

For the missing message, see #22053.
Sorry, I was not aware that you had already used the installer. Sadly, the installer does not update the java version if java 8 is installed. You need to uninstall JOSM plus probably java 8 first and then install JOSM with the up-to-date installer which should provide java 17+, see #21307.
You might want to backup your preferences, just in case, see Help/Preferences and check Help/Action/About for the locations.
That said, I do not have a windows system and can only repeat what others wrote.

comment:6 Changed 3 months ago by andy_king50@…

Thanks for qick answering,

After some new search I managed to find a msi installer at https://www.azul.com/downloads/?package=jdk#download-openjdk and tried it out.
I did not deinstall Oracles 8 version before, it is aorking fine with it still installed, because you are prompted on te next start of JOSM which program to use...
But I have still some problems this his ticket:

  1. the message at JOSM start page still indicates wrongly, FURTHER Versions of JOSM migth not work below Java 11. Instead even THIS recent version of JOSM absolutely WILL not work without version 11.
  2. Then you should add below this information the above mentioned download link and advice to download and execute the 64Bit Windows *.msi installer als a Windows User (as a mapper you do normally not even read the recommendations to use this rather exotic new versions, and if you look up for "Java 11 download" at google you get not much helpful stuff.
  3. the overall philosophy of such updates sould be re-evaluated. The target group of your communication is mainly mappers with very different levels of computing knowledge, from experts to people who can start and use JOSM HMI but not so much more. So If you do a change which will render JOSM de facto useless until some things are done:

I would expect an announcement at least one version before the problem will occure.
I would exect to have a description page prominentely linked with the update announcement with a step-for step instruction for the non-expert group. Would spare alot of work because I will not be the only one with problems. It is not in Your interest to be bombarded with tickets because of missing instruction.

  1. I am used to support tickets are not closed until...
    • a clear instruction about how the problem can be solved by the normal user (bo computing expert) is given
    • the problem is solved for the user (indicated e.g. by users answer) or
    • after some time, if you can assume the user does not track the ticket anymore. Posting a commentary and closing the ticket might be less work but is bad style "customer service".

tx for considering
Andy King

comment:7 Changed 3 months ago by skyper

Cc: stoecker added
Keywords: StartupPage java version added
Resolution: invalid
Status: closedreopened
Summary: Wrong requested java version "11" at OSM start pageStartupPage: Add link to help updating from java 8 (WAS: Wrong requested java version "11" at OSM start page)
Type: defectenhancement

Good to know that you managed the upgrade.
Did you try the installer after de-installing JOSM and Java?

No worry, I mostly reply on comments of tickets which I have closed.
You did not ask for help but report a defect which is invalid in several cases.
I have changed the ticket to ask for a link to a wiki help page. The link needs to be integrated into the macro. Do you recommend any existing wiki page (which could be extended)?

Anyway, you are already welcome to update or extend the wiki.

Last edited 3 months ago by skyper (previous) (diff)

comment:8 in reply to:  6 Changed 3 months ago by taylor.smock

Replying to andy_king50@…:

  1. the message at JOSM start page still indicates wrongly, FURTHER Versions of JOSM migth not work below Java 11. Instead even THIS recent version of JOSM absolutely WILL not work without version 11.

It should still be working, as we are still targeting Java 8 for our builds. I just checked josm-tested.jar and all the classes in it are compiled for Java 8 or earlier. If you have conflicting information, please open a ticket with the problematic jar file.

I would expect an announcement at least one version before the problem will occure.

The warning has been there for months (see wiki:StartupPageSource?action=diff&version=3048 ). We do need better instructions, but we haven't made the move yet (see #17858).

Replying to anonymous:

btw, i always use the windows installer. But if you have the recent JOSM Version installed, the installer starts and then finishes without any message (would expect at least some message "you have the latest version installed), so I have no access to the usual download page and possible links there)

GerdP has also encountered this problem. I don't have a windows machine, so I cannot troubleshoot it. I've got a guess for what will fix the problem (see #22053), but it is just that, a guess. I probably ought to apply the guess to a git branch and have GitHub actions build an installer for testing.

comment:9 Changed 3 months ago by anonymous

After updating to the new java 11 version i do not get the warning anymore and all things are running fine. So I cannot provide any things concerning the topic which I can reproduce myself at this time anymore. All I can say i had the "newest" Oracle 8... version and got the warning and JOSM did not load more than 1 background layer at once. Then I installed the recommended version 11 via msi installer. After that it worked again as usual. Then came a new start page request to update JOSM and I did, since then the version warning did not re-appear. I did not find any information about this new updates content at start page as usual...very strange indeed.
But please put rather something at the start page with some mapper-friendly instructions how to upgrade to the 11 version. Might make is much simple to other users. And prevents the above problem from the beginning. Have the people simply do this update step by step once instead of looking fo probable cause....I do not know if you can see, which versions users have, certainly via uploaded bug reports. I would think, most have the 8.xx versions.No real problem to change over, but needs to be organized and communicated to mappers at a quite simple step-by step advice....
Tx. Andy

comment:10 in reply to:  9 Changed 3 months ago by taylor.smock

Replying to anonymous:

All I can say i had the "newest" Oracle 8... version and got the warning and JOSM did not load more than 1 background layer at once. [...snip...]

This sounds like you were running the x32 version of Java 8 (which makes sense given your status report). The Java x32 version (by default) gives us relatively low memory allocations (~256 MB), and JOSM works best with more than that, especially as users add more background layers. We do recommend in wiki:Download#Java that users use x64 bit versions of Java.

comment:11 Changed 3 months ago by skyper

Ticket #22361 has been marked as a duplicate of this ticket.

comment:12 Changed 3 months ago by skyper

Cc: smarties added

comment:13 Changed 2 months ago by taylor.smock

I've updated the link on the start page, specifically java.com -> azul.com ( wiki:WikiStart?action=diff&version=334 ).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to anonymous
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.