Modify

Opened 11 days ago

Closed 9 days ago

Last modified 4 hours ago

#21307 closed defect (worksforme)

Installer fails under Windows 10

Reported by: pigsonthewing Owned by: team
Priority: normal Milestone:
Component: Installer Windows Version:
Keywords: template_report Cc:

Description

I have v. 18118 under Windows 10. Today it told me I should update.

I downloaded the installer, ran it, and it appeared to execute, but JOSM did not restart.

A manual restart showed I was still on v. 18118 (which, thankfully, appears usable).

I ran the installer again, and it offered to "repair", but the result was the same.

I downloaded the installer again, with the same result.

Attachments (0)

Change History (8)

comment:1 Changed 11 days ago by skyper

Owner: changed from team to pigsonthewing
Status: newneedinfo

Please, we need some more information to help you. First of all your currently working configuration might be useful. Therefor, please, add the first part of the Status Report, see instructions::

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


comment:2 Changed 11 days ago by pigsonthewing

Apologies; I came via Help menu/ Report Bug, but did not see the status report "below the fold". Here it is:

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-08-02 19:44:04 +0200 (Mon, 02 Aug 2021)
Build-Date:2021-08-02 18:26:20
Revision:18118
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18118 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19043)
Memory Usage: 523 MB / 1820 MB (307 MB allocated, but free)
Java version: 1.8.0_301-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: en_GB
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ HouseNumberTaggingTool (35640)
+ Mapillary (2.0.0-alpha.34-dirty)
+ OpeningHoursEditor (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools (35756)
+ javafx-windows (35655)
+ jna (35662)
+ measurement (35640)
+ reverter (35732)
+ terracer (35640)
+ turnrestrictions (35640)
+ undelete (35640)
+ wikipedia (1.1.4)

comment:3 Changed 11 days ago by skyper

Owner: changed from pigsonthewing to team
Status: needinfonew

comment:4 Changed 9 days ago by Don-vip

Resolution: worksforme
Status: newclosed

The installer changed in the last release. Please uninstall JOSM 18118 first and then reinstall the new version.

comment:5 in reply to:  4 ; Changed 9 days ago by pigsonthewing

Replying to Don-vip:

The installer changed in the last release. Please uninstall JOSM 18118 first and then reinstall the new version.

Will this preserve my settings?

If not, how may they be preserved?

Are all users expected to go through this process? If so, that requirement should be made more apparent.

comment:6 in reply to:  5 Changed 9 days ago by Don-vip

Replying to andy@…:

Replying to Don-vip:

The installer changed in the last release. Please uninstall JOSM 18118 first and then reinstall the new version.

Will this preserve my settings?

I think it should, but I'm not 100% sure.

If not, how may they be preserved?

You can do a manual copy of %APPDATA%\JOSM before uninstalling the old version.

Are all users expected to go through this process? If so, that requirement should be made more apparent.

We'll see how many users struggle with the update. If needed, InstallNotes can indeed be improved.

comment:7 Changed 9 days ago by pigsonthewing

Now working, thank you.

This process is nonetheless counter-intuitive and user-unfriendly.

comment:8 Changed 4 hours ago by skyper

Ticket #21352 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.