Modify

Opened 2 weeks ago

Closed 10 days ago

Last modified 10 days ago

#19888 closed defect (fixed)

JosmDecimalFormatSymbolsProviderTest broken on GitHub CI

Reported by: simon04 Owned by: simon04
Priority: normal Milestone: 20.10
Component: Unit tests Version:
Keywords: github-ci Cc: Stereo

Description

The unit test JosmDecimalFormatSymbolsProviderTest.testGroupingSeparator introduced via #19397 is not working on GitHub CI: ​https://github.com/openstreetmap/josm/runs/1216949683

Attachments (0)

Change History (8)

comment:1 Changed 2 weeks ago by simon04

Testing locally:

$ java -version
openjdk version "11.0.8" 2020-07-14
OpenJDK Runtime Environment (build 11.0.8+10)
OpenJDK 64-Bit Server VM (build 11.0.8+10, mixed mode)

$ cat /etc/locale.conf
de_AT.UTF-8 UTF-8
en_GB.UTF-8 UTF-8 
en_IE.UTF-8 UTF-8 
en_US.UTF-8 UTF-8

$ LANG=en_AU.UTF-8 ant test '-Ddefault-junit-includes=**/JosmDecimalFormatSymbolsProviderTest.class'
# OK (0 tests failed)

$ LANG=en_GB.UTF-8 ant test '-Ddefault-junit-includes=**/JosmDecimalFormatSymbolsProviderTest.class'
# BROKEN (1 tests failed)

$ LANG=en_IE.UTF-8 ant test '-Ddefault-junit-includes=**/JosmDecimalFormatSymbolsProviderTest.class'
# BROKEN (1 tests failed)

$ LANG=en_US.UTF-8 ant test '-Ddefault-junit-includes=**/JosmDecimalFormatSymbolsProviderTest.class'
# OK (0 tests failed)

What's going on?

comment:2 Changed 2 weeks ago by simon04

In 17089/josm:

see #19888 - Make PluginHandlerJOSMTooOldTest more robust

comment:3 Changed 12 days ago by simon04

Ticket #19443 has been marked as a duplicate of this ticket.

comment:4 Changed 12 days ago by simon04

Cc: Stereo added

comment:5 Changed 11 days ago by simon04

In 17155/josm:

see #19888, see #19370 - GitHub Actions: specify LANG=en_US.UTF-8

comment:6 Changed 10 days ago by Stereo

I didn't know anyone was actually using these on the JOSM side! I've been vaguely maintaining a fork at https://github.com/thomersch/josm/

Tests get broken about once a month for one reason or another, and it's a bit frustrating. I think it would be more useful and transparent if we could repatriate the infrastructure to build the macOS releases on Github on the 'main' repo.

comment:7 Changed 10 days ago by simon04

Resolution: fixed
Status: assignedclosed

The unit test failure is gone thanks to r17155.

comment:8 Changed 10 days ago by simon04

@Stereo, for the general GitHub CI discussion, please use #19370.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.