Modify

#19443 closed defect (duplicate)

JosmDecimalFormatSymbolsProviderTest fails on Ubuntu with Java 11 and 14

Reported by: Stereo Owned by: team
Priority: normal Milestone:
Component: Unit tests Version:
Keywords: java11 java14 linux Cc:

Description

https://github.com/grischard/josm/runs/814121328?check_suite_focus=true reports an error in the Ubuntu 11 and 14 runs. Windows and macOS are unaffected. The problem doesn't happen on Java 8.

From Java 14 on ubuntu-latest with headless=true:

Tests run: 4, Failures: 3, Skipped: 0, Aborted: 0, Time elapsed: 8 sec(s)
Testcase: org.openstreetmap.josm.tools.JosmDecimalFormatSymbolsProviderTest
Test: testParseDouble took 588 milli sec(s)
Test: testGroupingSeparator took 581 milli sec(s) FAILED: de expected:<123[ ]456> but was:<123[.]456>
org.junit.ComparisonFailure: de expected:<123[ ]456> but was:<123[.]456>
	at org.openstreetmap.josm.tools.JosmDecimalFormatSymbolsProviderTest.checkGroupingSymbol(JosmDecimalFormatSymbolsProviderTest.java:42)
	at org.openstreetmap.josm.tools.JosmDecimalFormatSymbolsProviderTest.testGroupingSeparator(JosmDecimalFormatSymbolsProviderTest.java:36)
	at org.openstreetmap.josm.testutils.JOSMTestRules$TimeoutThread.run(JOSMTestRules.java:765)

Attachments (0)

Change History (1)

comment:1 Changed 14 months ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19888.
Closing this older ticket one as duplicate since the other ticket has accumulated more details…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.